Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: gnome commander  (gelezen 2611 keer)

Offline gijsbertha

  • Lid
    • http://www.hendrikvanboven.nl
  • Steunpunt: Nee
gnome commander
« Gepost op: 2007/11/07, 11:33:46 »
Ik heb Ubuntu 7.10 en gebruik graag de gnome commander. Daar is echter een probleem mee. Mijn externe harde schijf (usb) en mijn usb stick worden wel in het menu van gc weergegeven, maar als ik ze met een dubbelklik wil openen krijg ik de melding: Aankoppelen mislukt: Toegang geweigerd!
 Met het gewone bestandsbeheer van Ubuntu kan ik ze wel goed openen en ze worden ook onmiddellijk herkend.  Hoe kan het dan zijn dat het in gc mislukt en vooral hoe los ik dit op?

Alvast mijn hartelijke dank.

Bertha

Offline J de vries

  • Lid
    • http://ubuntu-bits.blogspot.com/
  • Steunpunt: Nee
gnome commander
« Reactie #1 Gepost op: 2007/11/07, 11:44:44 »
Ik geloof dat Ubuntu supermount gebruikt, dus moet je in Gnome Commander het mounten (aankoppelen) overslaan omdat dit al gedaan wordt, dat doe je in als volgt:
Ik gebruik de Engelse Ubuntu dus mocht je Nederlands gebruiken moet je het voor jezelf even een beetje vertalen:
Citaat
Doe (als gnome commander actief is)
ctrl o
dan popt er een Options blad van Gnome Commander op
kies devices (uiterste rechter tabblad) en vink skip mounting aan.
dan zou het correct moeten werken

Succes.

Offline gijsbertha

  • Lid
    • http://www.hendrikvanboven.nl
  • Steunpunt: Nee
gnome commander
« Reactie #2 Gepost op: 2007/11/07, 22:59:25 »
Citaat van: deFrysk
Ik geloof dat Ubuntu supermount gebruikt, dus moet je in Gnome Commander het mounten (aankoppelen) overslaan omdat dit al gedaan wordt, dat doe je in als volgt:
Ik gebruik de Engelse Ubuntu dus mocht je Nederlands gebruiken moet je het voor jezelf even een beetje vertalen:
Citaat
Doe (als gnome commander actief is)
ctrl o
dan popt er een Options blad van Gnome Commander op
kies devices (uiterste rechter tabblad) en vink skip mounting aan.
dan zou het correct moeten werken

Succes.
Bedankt voor je reactie. Ik heb dit aangevinkt, maar helaas dat helpt niet. Heb je misschien nog andere suggesties?

Bertha

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
gnome commander
« Reactie #3 Gepost op: 2007/11/07, 23:58:25 »
Wellicht werkt het als je een nieuw pictogram aanmaakt:
In Gnome Commander kiezen voor -->Instellingen -->Opties -->Apparaten-->Toevoegen--> uit de mogelijkheden kiezen voor aankoppelpunt etc.
pictogram kiezen, Aankoppelen overslaan aanvinken.
Bij mij stonden alle schijven al vermeld op de werkbalk en waren direct te benaderen.
Ook een later ingestoken USB stick was direct te benaderen.
In principe moeten al je schijven direct te mounten zijn als je ze met de gewone bestandsbladeraar kan benaderen.
Ik heb nog niet uit kunnen zoeken hoe je een pictogram kunt verwijderen.

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

Offline gijsbertha

  • Lid
    • http://www.hendrikvanboven.nl
  • Steunpunt: Nee
gnome commander
« Reactie #4 Gepost op: 2007/11/08, 22:29:08 »
Citaat van: Gijsbert
Wellicht werkt het als je een nieuw pictogram aanmaakt:
In Gnome Commander kiezen voor -->Instellingen -->Opties -->Apparaten-->Toevoegen--> uit de mogelijkheden kiezen voor aankoppelpunt etc.
pictogram kiezen, Aankoppelen overslaan aanvinken.
Bij mij stonden alle schijven al vermeld op de werkbalk en waren direct te benaderen.
Ook een later ingestoken USB stick was direct te benaderen.
In principe moeten al je schijven direct te mounten zijn als je ze met de gewone bestandsbladeraar kan benaderen.
Ik heb nog niet uit kunnen zoeken hoe je een pictogram kunt verwijderen.

Met vriendelijke groet,

Gijs
Ik ben aan het rommelen geweest met het toevoegen van een apparaat. Ik neem aan, dat je bij Alias een eigen naam kunt kiezen! En wat kies je bij Apparaat? Moet je daarde een usb poort kiezen...? Het koppelpunt zou toch voor de externe HD, die op usb zit, /media/Targa (zo heet het apparaat) moeten zijn?

Of maak ik hier denkfouten?
Ik heb ook al GC verwijderd en weer opnieuw geïnstalleerd, maar dat werkt niet. Trouwens het verwijderen lijkt ook niet volledig te zijn, daar hij bij de tweede installatie (na een herstart) dat extra apparaat gewoon zag.

 Zou jammer zijn als het niet lukte, want ik vind het een prettig programma om te gebruiken en juist de externe HD gebruik ik  veel voor backups.

vr.gr.  Bertha

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
gnome commander
« Reactie #5 Gepost op: 2007/11/08, 23:15:09 »
Bij alias zet je gewoon een naam,maakt niet uit wat. Bij apparaat zet je bijvoorbeeld disk of usb stick. Wat betreft je externe hard disk het apparaatnaam kan je bijvoorbeeld bij alias zetten.Voor het mountpunt krijg je bijvoorbeeld /media/disk (zo wordt mijn usb stick gezien). Als je in de map media kijkt zal je externe HD ook een naam hebben, bijvoorbeeld sda1. Dan vul je bij koppelpunt (mountpunt) /media/sda1 in. Succes.

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

Offline gijsbertha

  • Lid
    • http://www.hendrikvanboven.nl
  • Steunpunt: Nee
gnome commander
« Reactie #6 Gepost op: 2007/11/09, 20:16:42 »
Citaat van: Gijsbert
Bij alias zet je gewoon een naam,maakt niet uit wat. Bij apparaat zet je bijvoorbeeld disk of usb stick. Wat betreft je externe hard disk het apparaatnaam kan je bijvoorbeeld bij alias zetten.Voor het mountpunt krijg je bijvoorbeeld /media/disk (zo wordt mijn usb stick gezien). Als je in de map media kijkt zal je externe HD ook een naam hebben, bijvoorbeeld sda1. Dan vul je bij koppelpunt (mountpunt) /media/sda1 in. Succes.

Met vriendelijke groet,

Gijs
Opnieuw gedaan, maar helaas...ik blijf dezelfde foutmelding krijgen. Het is uiteraard ook vreemd, dat GC de usb apparaten wel ziet, maar niet kan koppelen.  Jammer, misschien komt er nog eens een oplossing. Als je nog iets weet hoor ik het graag en anders zeer bedankt voor je hulp, ik heb er in ieder geval weer iets bijgeleerd.

vr.gr. Bertha

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
gnome commander
« Reactie #7 Gepost op: 2007/11/09, 23:13:28 »
Ik geef het niet zo snel op, en misschien zijn er nog anderen op dit forum die meekijken in dit draadje en een oplossing hebben.
Probeer het volgende is:
Heb je de schijfkoppelaar al op je werkbalk staan?Zo ja koppelt die de usb schijf wel aan? Zo nee rechts klikken op de werkbalk--> Toevoegen aan het paneel-->even naar beneden scrollen en dan linksonder Schijfkoppelaar.
Krijg je dan wel je usb schijf te zien en kan je hem aankoppelen?
En hoe ziet je fstab eruit? in de map etc staat deze of dit commando in een terminal: sudo fdisk -l

Met vriendelijke groet,

Gijs

Nog even een aanvulling van: http://article.gmane.org/gmane.linux.ubuntu.user.dutch/4746
Zijn er root rechten voor je usb drive nodig?
Als je met de rechtermuisknop op 'Toepassingen' klikt, verschijnt er een
menuutje met daarin als 2e optie 'Menu's bewerken'.
Klik dan op 'Hulpmiddelen' en klik dan rechts met de rechtermuisknop op
'GNOME Commander'. Kies 'Eigenschappen'. Er verschijnt nu een venster
met de eigenschappen van GNOME Commander. Pas wat achter
'Opdrachtregel:' staat als volgt aan:

gksudo gnome-commander

Als je hierna het venster sluit en GNOME commander opnieuw start, zul je
je wachtwoord moeten invoeren en zal het programma met root-rechten
worden opgestart (wees dus voorzichtig!). Je kunt dit ook zien aan het
feit dat het programma nu als beginmap /root/ heeft in plaats
van /home/[jouwnaam]/.

Je zou hier ook een nieuw item van kunnen maken zodat je GNOME commander
ook nog zonder root-rechten kan starten, maar dit is iets meer werk.
In der Beschränkung zeigt sich der Meister.

Offline gijsbertha

  • Lid
    • http://www.hendrikvanboven.nl
  • Steunpunt: Nee
gnome commander
« Reactie #8 Gepost op: 2007/11/10, 21:56:03 »
Citaat van: Gijsbert
Ik geef het niet zo snel op, en misschien zijn er nog anderen op dit forum die meekijken in dit draadje en een oplossing hebben.
Probeer het volgende is:
Heb je de schijfkoppelaar al op je werkbalk staan?Zo ja koppelt die de usb schijf wel aan? Zo nee rechts klikken op de werkbalk--> Toevoegen aan het paneel-->even naar beneden scrollen en dan linksonder Schijfkoppelaar.
Krijg je dan wel je usb schijf te zien en kan je hem aankoppelen?
En hoe ziet je fstab eruit? in de map etc staat deze of dit commando in een terminal: sudo fdisk -l

Met vriendelijke groet,

Gijs

Nog even een aanvulling van: http://article.gmane.org/gmane.linux.ubuntu.user.dutch/4746
Zijn er root rechten voor je usb drive nodig?
Als je met de rechtermuisknop op 'Toepassingen' klikt, verschijnt er een
menuutje met daarin als 2e optie 'Menu's bewerken'.
Klik dan op 'Hulpmiddelen' en klik dan rechts met de rechtermuisknop op
'GNOME Commander'. Kies 'Eigenschappen'. Er verschijnt nu een venster
met de eigenschappen van GNOME Commander. Pas wat achter
'Opdrachtregel:' staat als volgt aan:

gksudo gnome-commander

Als je hierna het venster sluit en GNOME commander opnieuw start, zul je
je wachtwoord moeten invoeren en zal het programma met root-rechten
worden opgestart (wees dus voorzichtig!). Je kunt dit ook zien aan het
feit dat het programma nu als beginmap /root/ heeft in plaats
van /home/[jouwnaam]/.

Je zou hier ook een nieuw item van kunnen maken zodat je GNOME commander
ook nog zonder root-rechten kan starten, maar dit is iets meer werk.
De schijfkoppelaar koppelt de usb hd gewoon aan.
De fstab ziet er als volgt uit:

# /etc/fstab: static file system information.
#
#  -- This file has been automaticly generated by ntfs-config --
#
#            

proc /proc proc defaults 0 0
# Entry for /dev/sda8 :
UUID=dd959817-3637-43c0-b510-bc58d41a9312 / ext3 defaults,errors=remount-ro 0 1
# Entry for /dev/sda1 :
UUID=E40847FF0847CEEC /media/sda1 ntfs-3g defaults,locale=nl_NL.UTF-8 0 1
# Entry for /dev/sda5 :
UUID=4A4CC3BF4CC3A453 /media/sda5 ntfs-3g defaults,locale=nl_NL.UTF-8 0 1
# Entry for /dev/sda6 :
UUID=DA10C68810C66AD9 /media/sda6 ntfs-3g defaults,locale=nl_NL.UTF-8 0 1
# Entry for /dev/sda7 :
UUID=acdf77dd-4098-4191-a88c-c1e9f4ea8b20 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0

Kun je daar iets mee?

Verder heb ik GC ook met de root-rechten opgestart, zoals hiervoor beschreven. Gek genoeg zie ik dan nog minder, ik zie dan alleen nog maar de home, ook de windows-partities zie ik dan niet meer. sad1,5 en 6 zijn mijn windows-partities.

vr.gr. Bertha

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
gnome commander
« Reactie #9 Gepost op: 2007/11/11, 20:28:35 »
Ik dacht even dat je USB schijf via fstab gemount werd, dan kan je alleen de USB schijf met root rechten mounten.
Nog wat gevonden op de GC side: http://www.nongnu.org/gcmd/tips.html
Using removable devices

If you use removable devices such as cd's, floppies and cameras a lot you can make GC automaticly take care of mounting them by following this guide:

    * Open the options dialog and go to the Devices tab.
    * Add the devices that you are using.( dit is een link kijk maar op de side) This is how the program looks with a few added devices. In the last image the red circle shows the available devices, there is also a button, in the green circle, to press if we want to unmount the floppy, which happened to be mounted. The icons that are used for the devices in the example should be available in the $(prefix)/share/pixmaps/gnome-commander/device-icons folder on your computer.
    * There is also an option to skip mounting in the option device tab, this can be useful for making shortcuts to directories, or if you have some automounting feature that mounts it at its mountpoint when available, or if you use Supermount that does it on access basis.
Dat van een device toevoegen had ik verkeerd uit gelegd:
Alias : bijv CD of in jou geval USB schijf o.id.
Device: /dev/hdc (of hoe je USB schijf heet in de map /dev/) dit had ik eerder verkeerd opgeschreven, mijn excuses hiervoor.
Mountpoint: /mnt/cdrom  of /media/hdc net hoe je USB schijf gemount wordt.
Succes ermee.

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

Offline gijsbertha

  • Lid
    • http://www.hendrikvanboven.nl
  • Steunpunt: Nee
gnome commander
« Reactie #10 Gepost op: 2007/11/12, 11:18:01 »
Citaat van: Gijsbert
Ik dacht even dat je USB schijf via fstab gemount werd, dan kan je alleen de USB schijf met root rechten mounten.
Nog wat gevonden op de GC side: http://www.nongnu.org/gcmd/tips.html
Using removable devices

If you use removable devices such as cd's, floppies and cameras a lot you can make GC automaticly take care of mounting them by following this guide:

    * Open the options dialog and go to the Devices tab.
    * Add the devices that you are using.( dit is een link kijk maar op de side) This is how the program looks with a few added devices. In the last image the red circle shows the available devices, there is also a button, in the green circle, to press if we want to unmount the floppy, which happened to be mounted. The icons that are used for the devices in the example should be available in the $(prefix)/share/pixmaps/gnome-commander/device-icons folder on your computer.
    * There is also an option to skip mounting in the option device tab, this can be useful for making shortcuts to directories, or if you have some automounting feature that mounts it at its mountpoint when available, or if you use Supermount that does it on access basis.
Dat van een device toevoegen had ik verkeerd uit gelegd:
Alias : bijv CD of in jou geval USB schijf o.id.
Device: /dev/hdc (of hoe je USB schijf heet in de map /dev/) dit had ik eerder verkeerd opgeschreven, mijn excuses hiervoor.
Mountpoint: /mnt/cdrom  of /media/hdc net hoe je USB schijf gemount wordt.
Succes ermee.

Met vriendelijke groet,

Gijs
Ik heb opnieuw alles geprobeerd. Onder /dev zitten twee mogelijkheden sdc en sdc1, beide geprobeerd. Ook het mountpoint is duidelijk. Niks helpt. Ik heb het automatisch mounten van verwisselbare schijven uitgezet, maar daar kom ik ook niet verder mee. GC ziet de schijf overigens meteen, hij komt gewoon op het paneel, maar dat aankoppelen...Ik heb ook gekeken in de bugslijst van de GC-site, daar kwam ik geen soortgelijk probleem tegen.

vr.gr. Bertha

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
gnome commander
« Reactie #11 Gepost op: 2007/11/12, 16:29:15 »
Sorry ik had al eerder dit antwoord opgeschreven, alleen zo dom geweest niet op de verzend knop te drukken.
Ik heb ook nog internet gezocht naar deze bug, alleen niets over gevonden.
Wel heb ik dit programma gevonden, Krusader, staat in Synaptic.
Dit is een KDE versie van GC, alleen wat meer "toeters en bellen" zoals een KDE programma betaamd.
Hierin zit MountMan, vreemd genoeg moet je de eerste keer op het pictogram drukken dan sluiten en nog een keer op het pictogram drukken voor je de schijven en partities ziet. Bij mij werden alle partities gelijk gezien.
Misschien is dit wat voor je en kan je de USB schijf wel mounten.
Je kan het altijd deinstalleren als het niet goed werkt of bevalt.

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

Offline gijsbertha

  • Lid
    • http://www.hendrikvanboven.nl
  • Steunpunt: Nee
gnome commander
« Reactie #12 Gepost op: 2007/11/13, 22:04:00 »
Citaat van: Gijsbert
Sorry ik had al eerder dit antwoord opgeschreven, alleen zo dom geweest niet op de verzend knop te drukken.
Ik heb ook nog internet gezocht naar deze bug, alleen niets over gevonden.
Wel heb ik dit programma gevonden, Krusader, staat in Synaptic.
Dit is een KDE versie van GC, alleen wat meer "toeters en bellen" zoals een KDE programma betaamd.
Hierin zit MountMan, vreemd genoeg moet je de eerste keer op het pictogram drukken dan sluiten en nog een keer op het pictogram drukken voor je de schijven en partities ziet. Bij mij werden alle partities gelijk gezien.
Misschien is dit wat voor je en kan je de USB schijf wel mounten.
Je kan het altijd deinstalleren als het niet goed werkt of bevalt.

Met vriendelijke groet,

Gijs
Geweldig! Krusader werkt prima!! Zeer bedankt!
 vr.gr. Bertha