Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Teveel gerotzooid met /etc/X11/xorg.conf  (gelezen 2326 keer)

BartVL

  • Gast
Teveel gerotzooid met /etc/X11/xorg.conf
« Gepost op: 2007/11/06, 21:55:36 »
Ha,

Ben natuurlek een complete beginner anders was deze post niet hier.

Ben tijdje geleden overgestapt naar Ubuntu 7.10.

Kreeg mijn games niet aan de praat omwille van ATI Radeon kaart. Oplossing bleek: Gebruik maken van X ipv Xgl.

xserver-xgl verwijdert, dag Compiz dus.

Spel werkte, nieuwe drivers van ATI, leuk, ff installeren. Daaaag configuratie.

Vensters openen buiten bereik van men desktop nu. dus ik doe een reconfigure van xorg.conf.

Nu kan ik Ubuntu niet meer in. Krijg wel nog aanmeldingsscherm. Dan zwart en dan reboot. Ook kan ik niet meer in CTRL + ALT + F1 en dergelijke, dus aanmelden als root etc kan ik ook vergeten.

Weet iemand raad?

Offline bartek

  • Lid
    • http://bartek.blogsome.com
  • Steunpunt: Nee
Teveel gerotzooid met /etc/X11/xorg.conf
« Reactie #1 Gepost op: 2007/11/06, 22:11:08 »
in je terminal invoeren:
sudo dpkg-reconfigure xserver-xorg

Met alles akkoord gaan.
| Deliberando saepe perit occasio |

"Car la vie est un bien perdu quand on n'a pas vécu comme on l'aurait voulu"

BartVL

  • Gast
Teveel gerotzooid met /etc/X11/xorg.conf
« Reactie #2 Gepost op: 2007/11/06, 22:14:49 »
heb ik gedaan, daar is dit alles nu mee begonnen.

Kan niet meer in Terminal noch in de CTRL+ALT+F1 stuff.

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Teveel gerotzooid met /etc/X11/xorg.conf
« Reactie #3 Gepost op: 2007/11/06, 22:14:59 »
Beste bartvl, start op in de recovery mode, je krijgt van die witte letters, is het opgestart dan intoetsen sudo dpkg-reconfigure xserver-xorg, op de hele vragen riedel ja beantwoorden. TAB toets om keuze te bereiken,OK dus, en dan ENTER toets voor te bevestigen.
Daarna sudo reboot en weer normaal opstarten.
Voor de ATI kaart even op het forum zoeken, ik heb nl. een NVIDIA kaart


Met vriendelijke groet,

Gijs

Edit:@Bartek, heb ik weer te langzaam getypt.
In der Beschränkung zeigt sich der Meister.

BartVL

  • Gast
Teveel gerotzooid met /etc/X11/xorg.conf
« Reactie #4 Gepost op: 2007/11/06, 22:16:56 »
hoe kom ik in recovery mode? ik zie geen grub enzo

Offline bartek

  • Lid
    • http://bartek.blogsome.com
  • Steunpunt: Nee
Teveel gerotzooid met /etc/X11/xorg.conf
« Reactie #5 Gepost op: 2007/11/06, 22:19:23 »
Als je opstart moet je op een gegeven moment op esc duwen
je hebt 2 seconden of zo
| Deliberando saepe perit occasio |

"Car la vie est un bien perdu quand on n'a pas vécu comme on l'aurait voulu"

BartVL

  • Gast
Teveel gerotzooid met /etc/X11/xorg.conf
« Reactie #6 Gepost op: 2007/11/06, 22:24:22 »
Hmm, heb ik root paswoord nodig

BartVL

  • Gast
Teveel gerotzooid met /etc/X11/xorg.conf
« Reactie #7 Gepost op: 2007/11/06, 22:29:02 »
Gelukkig wist ik dat, Heb dat commando dus uitgevoerd als root.

Probleem blijft echter aanwezig. Ik kom de desktop omgeving niet meer in.

Mss ligt het probleem elders?

BartVL

  • Gast
Teveel gerotzooid met /etc/X11/xorg.conf
« Reactie #8 Gepost op: 2007/11/06, 22:32:46 »
Via startx, ben ik als root in de x omgeving gekomen, mss kan ik hier iets oplossen?

BartVL

  • Gast
Teveel gerotzooid met /etc/X11/xorg.conf
« Reactie #9 Gepost op: 2007/11/06, 22:44:16 »
Heb xserver-xgl en de restriced ATI driver terug geinstalleerd via synaptic.

Nu open de windows nogal vreemd en kan ik ze ni verplaatsen met de muis (ook niet met ALT)

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Teveel gerotzooid met /etc/X11/xorg.conf
« Reactie #10 Gepost op: 2007/11/06, 22:48:49 »
Krijg je eerst wel een terminal achtig scherm te zien?
Dan kan je het beste sudo dpkg-reconfigure xserver-xorg uitproberen.
Als je in een x omgeving zit kan je met gksudo nautilus(in eenterminal typen) naar etc/X11 gaan en kijken of je oude  xorg.conf (meestal staat er een getal voor)erin staat en deze hernoemen naar xorg.conf.

Met vriendelijke groet,

Gijs

Edit: Ik wordt steeds langzamer met typen. :(
In der Beschränkung zeigt sich der Meister.

BartVL

  • Gast
Teveel gerotzooid met /etc/X11/xorg.conf
« Reactie #11 Gepost op: 2007/11/07, 08:41:16 »
Heb de oude xorg.conf teruggeplaatst, maar probleem blijft echter.

Kan het zijn dat ik Xgl draai? en dat die niet naar dit bestand kijkt?

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Teveel gerotzooid met /etc/X11/xorg.conf
« Reactie #12 Gepost op: 2007/11/07, 10:24:54 »
Kan je je xorg.conf hier plaatsen.
Om te kijken welke ATI kaart het is kan je in de terminal typen lspci | grep VGA
Als het een moderne ATI kaart is gebruik je best de proprietary fglrx driver
Met dank aan profoX.
Xgl is voor Nvidia kaarten.

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

mickvdv

  • Gast
Teveel gerotzooid met /etc/X11/xorg.conf
« Reactie #13 Gepost op: 2007/11/07, 18:31:27 »
Citaat van: BartVL
Heb de oude xorg.conf teruggeplaatst, maar probleem blijft echter.

Kan het zijn dat ik Xgl draai? en dat die niet naar dit bestand kijkt?
Dan denk ik niet dat het aan je xorg.conf ligt. Misschien mis je bepaalde drivers, kijk eens in je /var/log (s)

BartVL

  • Gast
Teveel gerotzooid met /etc/X11/xorg.conf
« Reactie #14 Gepost op: 2007/11/07, 20:10:27 »
Dit staat in Xorg.0.log:

II) ATI Proprietary Linux Driver Build Information: autobuild-rel-r6-8.37.1.1.2.3-driver-lnx-x86-x86_64-346145
(WW) fglrx: No matching Device section for instance (BusID PCI:1:0:1) found

en verder

WW) fglrx(0): Kernel Module version does *not* match driver.
(EE) fglrx(0): incompatible kernel module detected - HW accelerated OpenGL will not work
(II) fglrx(0): [drm] removed 1 reserved context for kernel
(II) fglrx(0): [drm] unmapping 8192 bytes of SAREA 0x4000 at 0xb733f000
(WW) fglrx(0): ***********************************************
(WW) fglrx(0): * DRI initialization failed!                  *
(WW) fglrx(0): * (maybe driver kernel module missing or bad) *
(WW) fglrx(0): * 2D acceleraton available (MMIO)             *
(WW) fglrx(0): * no 3D acceleration available                *
(WW) fglrx(0): ********************************************* *

en dan

(EE) AIGLX: Screen 0 is not DRI capable

mickvdv

  • Gast
Teveel gerotzooid met /etc/X11/xorg.conf
« Reactie #15 Gepost op: 2007/11/07, 21:21:35 »
Kan je ook je xorg ff post.

BartVL

  • Gast
Teveel gerotzooid met /etc/X11/xorg.conf
« Reactie #16 Gepost op: 2007/11/07, 22:06:19 »
# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
EndSection

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "CoreKeyboard"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc105"
   Option      "XkbLayout"   "belgium"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
   Option      "CorePointer"
   Option      "Device"   "/dev/input/mice"
   Option      "Protocol"   "ImPS/2"
   Option      "ZAxisMapping"   "4 5"
   Option      "Emulate3Buttons"   "true"
EndSection

Section "InputDevice"
   Driver      "wacom"
   Identifier   "stylus"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"   "stylus"
   Option      "ForceDevice"   "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
   Driver      "wacom"
   Identifier   "eraser"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"   "eraser"
   Option      "ForceDevice"   "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
   Driver      "wacom"
   Identifier   "cursor"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"   "cursor"
   Option      "ForceDevice"   "ISDV4"# Tablet PC ONLY
EndSection

Section "Device"
   Identifier   "ATI Technologies Inc Radeon R350 [Radeon 9800 Pro]"
   Driver      "fglrx"
   Option      "VideoOverlay"   "on"
   Option      "OpenGLOverlay"   "off"
   Option      "UseFBDev"   "true"
   Busid      "PCI:1:0:0"
EndSection

Section "Monitor"
   Identifier   "SyncMaster"
   Option      "DPMS"
   Horizsync   30-81
   Vertrefresh   56-75
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Device      "ATI Technologies Inc Radeon R350 [Radeon 9800 Pro]"
   Monitor      "SyncMaster"
   Defaultdepth   24
   SubSection "Display"
      Modes      "1280x1024"   "1280x960"   "1152x864"   "1024x768"   "800x600"   "640x480"
   EndSubSection
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
  screen "Default Screen"
   Inputdevice   "Generic Keyboard"
   Inputdevice   "Configured Mouse"
   
   # Uncomment if you have a wacom tablet
   #   InputDevice     "stylus"   "SendCoreEvents"
   #   InputDevice     "cursor"   "SendCoreEvents"
   #   InputDevice     "eraser"   "SendCoreEvents"
EndSection
Section "Module"
   Load      "fglrx"
   Load      "dri"
   
   Load      "glx"
EndSection

Section "Extensions"
   Option      "Composite"   "Disable"
   Option      "Composite"   "0"
EndSection

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Teveel gerotzooid met /etc/X11/xorg.conf
« Reactie #17 Gepost op: 2007/11/07, 22:54:30 »
Kan je niet het beste met een schone lei beginnen?, niet Ubuntu opnieuw installeren maar je xorg.conf.
Begin met opstarten in de recovery mode, ik neem aan dat je deze weer kan kiezen. Probeer dit dan eens in een terminal:
sudo dpkg-reconfigure -p high xserver-xorg
(even opschrijven tenzij je een fotografisch geheugen hebt ;) )
Kies bij de driver voor ati. Vink de goede resoluties aan met de spatiebalk, tab, de pijltjestoetsen en enter.
Bij andere vragen kan je gewoon op enter drukken als het goed is.
Met dank aan Johanvd
Hier een linkje naar http://forum.ubuntu-nl.org/topic/15670 Ati radeon x700+Gutsy staat een hoop informatie in voor ati kaarten, ook de voorgaande beschrijving komt hieruit.
Hopelijk heb je hier voldoende informatie aan om je kaart weer aan de praat te krijgen en duidelijk genoeg is.


Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

Offline Monkwarrior

  • Lid
  • Steunpunt: Nee
Teveel gerotzooid met /etc/X11/xorg.conf
« Reactie #18 Gepost op: 2007/11/07, 22:59:15 »
En volgende keer gewoon rsnapshot gebruiken.
Nooit meer gezeur met verloren gaan van gewijzigde bestanden.
Desnoods voor de luxe samen met dit tooltje:
http://www.kde-apps.org/content/show.php/RetrospeKt?content=57952

Monk.