Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Nvidia XGL + COMPIZ + DualView  (gelezen 885 keer)

g_ij_s

  • Gast
Nvidia XGL + COMPIZ + DualView
« Gepost op: 2007/11/06, 18:55:41 »
Ik ben nu al een aantal dagen bezig Compiz in te stellen in Ubuntu 7.10

Het is geen probleem om de 2 schermen aan de gang te krijgen en het is ook geen probleem om dualview te krijgen.

Het probleem is dat vensters over 2 monitoren maximaliseren. Wat vreselijk onhandig en irritant werkt.

Wanneer ik XGL tijdelijk uitzet door in .config/xgl-server een bestandje disable aan te maken dan werken de monitoren wel goed (Dat wil zeggen, de vensters maximaliseren op 1 scherm) maar dan werkt Compiz natuurlijk weer niet...

Is er iemand die enig idee heeft hoe je dit instelt?

Alvast bedankt

Gefrustreerde linux gebruiker: G_ij_S

Section "Files"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Device"
Identifier "nVidia Corporation G70 [GeForce 7900]"
Boardname "nv"
Busid "PCI:4:0:0"
Driver "nvidia"
Screen 0
EndSection

Section "Monitor"
Identifier "Generic Monitor"
Vendorname "Plug 'n' Play"
Modelname "Plug 'n' Play"
  modeline  "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
  modeline  "640x480@72" 31.5 640 664 704 832 480 489 491 520 -vsync -hsync
  modeline  "640x480@75" 31.5 640 656 720 840 480 481 484 500 -vsync -hsync
  modeline  "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
  modeline  "800x600@72" 50.0 800 856 976 1040 600 637 643 666 +hsync +vsync
  modeline  "800x600@75" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
  modeline  "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
  modeline  "832x624@75" 57.284 832 864 928 1152 624 625 628 667 -vsync -hsync
  modeline  "1024x768@75" 78.8 1024 1040 1136 1312 768 769 772 800 +hsync +vsync
  modeline  "1024x768@70" 75.0 1024 1048 1184 1328 768 771 777 806 -vsync -hsync
  modeline  "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
  modeline  "1152x864@75" 108.0 1152 1216 1344 1600 864 865 868 900 +hsync +vsync
  modeline  "1280x1024@75" 135.0 1280 1296 1440 1688 1024 1025 1028 1066 +hsync +vsync
  modeline  "1280x960@60" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
  modeline  "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
  modeline  "1280x960@75" 129.86 1280 1368 1504 1728 960 961 964 1002 -hsync +vsync
  modeline  "1400x1050@60" 122.61 1400 1488 1640 1880 1050 1051 1054 1087 -hsync +vsync
  modeline  "1600x1200@65" 175.5 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
  modeline  "1600x1200@60" 162.0 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
Gamma 1.0
EndSection

Section "Screen"
Identifier "Default Screen"
Device "nVidia Corporation G70 [GeForce 7900]"
Monitor "Generic Monitor"
Defaultdepth 24
SubSection "Display"
Depth 24
Virtual 1600 1200
Modes "1600x1200@60" "1600x1200@65" "1400x1050@60" "1280x960@75" "1280x1024@60" "1280x960@60" "1280x1024@75" "1152x864@75" "1024x768@60" "1024x768@70" "1024x768@75" "832x624@75" "800x600@60" "800x600@75" "800x600@72" "800x600@56" "640x480@75" "640x480@72" "640x480@60"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
  screen 0 "Default Screen" 0 0
  screen 1 "screen1" rightof "Default Screen"
Inputdevice "Keyboard0" "CoreKeyboard"
Inputdevice "Mouse0" "CorePointer"
EndSection
Section "Module"
Load "glx"
Load "v4l"
EndSection
Section "device" #  
Identifier "device1"
Boardname "nv"
Busid "PCI:4:0:0"
Driver "nvidia"
Screen 1
EndSection
Section "screen" #  
Identifier "screen1"
Device "device1"
Defaultdepth 24
Monitor "monitor1"
SubSection "Display"
Depth 24
Modes "1280x1024@75" "1280x960@60" "1152x864@75" "1280x1024@60" "1024x768@60" "1280x960@75" "1024x768@70" "1400x1050@60" "1024x768@75" "1600x1200@65" "832x624@75" "1600x1200@60" "800x600@60" "800x600@75" "800x600@72" "800x600@56" "640x480@75" "640x480@72" "640x480@60"
EndSubSection
EndSection
Section "monitor" #  
Identifier "monitor1"
Vendorname "Plug 'n' Play"
Modelname "Plug 'n' Play"
  modeline  "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
  modeline  "640x480@72" 31.5 640 664 704 832 480 489 491 520 -vsync -hsync
  modeline  "640x480@75" 31.5 640 656 720 840 480 481 484 500 -vsync -hsync
  modeline  "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
  modeline  "800x600@72" 50.0 800 856 976 1040 600 637 643 666 +hsync +vsync
  modeline  "800x600@75" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
  modeline  "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
  modeline  "832x624@75" 57.284 832 864 928 1152 624 625 628 667 -vsync -hsync
  modeline  "1024x768@75" 78.8 1024 1040 1136 1312 768 769 772 800 +hsync +vsync
  modeline  "1024x768@70" 75.0 1024 1048 1184 1328 768 771 777 806 -vsync -hsync
  modeline  "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
  modeline  "1152x864@75" 108.0 1152 1216 1344 1600 864 865 868 900 +hsync +vsync
  modeline  "1280x1024@75" 135.0 1280 1296 1440 1688 1024 1025 1028 1066 +hsync +vsync
  modeline  "1280x960@60" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
  modeline  "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
  modeline  "1280x960@75" 129.86 1280 1368 1504 1728 960 961 964 1002 -hsync +vsync
  modeline  "1400x1050@60" 122.61 1400 1488 1640 1880 1050 1051 1054 1087 -hsync +vsync
  modeline  "1600x1200@65" 175.5 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
  modeline  "1600x1200@60" 162.0 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
Gamma 1.0
EndSection
Section "ServerFlags"
Option "Xinerama" "false"
EndSection

Offline BlackBurn

  • Lid
    • http://www.robmaas.eu
  • Steunpunt: Nee
Nvidia XGL + COMPIZ + DualView
« Reactie #1 Gepost op: 2007/11/06, 23:21:59 »
Hetzelfde probleem waar ik ook tegen aan gelopen ben. Ik heb dezelfde kaart, dus dit moet zeker kunnen :).

Wat bij mij de oplossing was is twinview inschakelen.
Eerst de nvidia drivers installeren en dan m.b.v. nvidia-settings de boel instellen. Wel een complete reboot doen, want alleen het herstarten van de X server was bij mij telkens niet genoeg. Zal vast nog wel anders kunnen, maar ben nog niet zolang met Linux bezig.

Hiet mijn xorg.conf bestand, misschien dat je er iets aan hebt?

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildmeister@builder3)  Wed Sep 12 14:30:30 PDT 2007

# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"

# Uncomment if you have a wacom tablet
# InputDevice     "stylus" "SendCoreEvents"
# InputDevice     "cursor" "SendCoreEvents"
# InputDevice     "eraser" "SendCoreEvents"
    Identifier     "Default Layout"
    Screen      0  "Screen0" 0 0
    InputDevice    "Generic Keyboard"
    InputDevice    "Configured Mouse"
EndSection

Section "Files"
EndSection

Section "Module"
    Load           "glx"
EndSection

Section "ServerFlags"
    Option         "Xinerama" "0"
EndSection

Section "InputDevice"
    Identifier     "Generic Keyboard"
    Driver         "kbd"
    Option         "CoreKeyboard"
    Option         "XkbRules" "xorg"
    Option         "XkbModel" "pc105"
    Option         "XkbLayout" "us"
EndSection

Section "InputDevice"
    Identifier     "Configured Mouse"
    Driver         "mouse"
    Option         "CorePointer"
    Option         "Device" "/dev/input/mice"
    Option         "Protocol" "ImPS/2"
    Option         "ZAxisMapping" "4 5"
    Option         "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
    Identifier     "stylus"
    Driver         "wacom"
    Option         "Device" "/dev/input/wacom"
    Option         "Type" "stylus"
    Option         "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
    Identifier     "eraser"
    Driver         "wacom"
    Option         "Device" "/dev/input/wacom"
    Option         "Type" "eraser"
    Option         "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
    Identifier     "cursor"
    Driver         "wacom"
    Option         "Device" "/dev/input/wacom"
    Option         "Type" "cursor"
    Option         "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "Monitor"
    Identifier     "Generic Monitor"
    HorizSync       28.0 - 63.0
    VertRefresh     43.0 - 60.0
    Option         "DPMS"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Acer AL1711"
    HorizSync       30.0 - 83.0
    VertRefresh     55.0 - 75.0
EndSection

Section "Monitor"
    Identifier     "Monitor1"
    VendorName     "Unknown"
    ModelName      "HP P1130"
    HorizSync       30.0 - 130.0
    VertRefresh     48.0 - 170.0
EndSection

Section "Device"
    Identifier     "Generic Video Card"
    Driver         "nvidia"
    Option         "AddARGBVisuals" "True"
    Option         "AddARGBGLXVisuals" "True"
    Option         "NoLogo" "True"
    BusID          "PCI:1:0:0"
EndSection

Section "Device"
    Identifier     "Videocard0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 7600 GS"
EndSection

Section "Device"
    Identifier     "Videocard1"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 7600 GS"
    BusID          "PCI:1:0:0"
    Screen          1
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Device         "Generic Video Card"
    Monitor        "Generic Monitor"
    DefaultDepth    24
    SubSection     "Display"
        Modes      "1272x1272" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
EndSection

Section "Screen"

# Removed Option "TwinView" "0"
# Removed Option "metamodes" "CRT-0: 1024x768 +0+0; CRT-0: 832x624 +0+0; CRT-0: 800x600 +0+0; CRT-0: 640x480 +0+0"
# Removed Option "metamodes" "CRT-0: 1280x1024 +0+0; CRT-0: 800x600 +0+0; CRT-0: 640x480 +0+0"
# Removed Option "metamodes" "CRT-0: 1280x1024 +0+0, CRT-1: NULL; CRT-0: 800x600 +0+0, CRT-1: NULL; CRT-0: 640x480 +0+0, CRT-1: NULL"
    Identifier     "Screen0"
    Device         "Videocard0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "1"
    Option         "metamodes" "CRT-0: 1280x1024 +1280+0, CRT-1: 1280x1024 +0+0; CRT-0: 800x600 +0+0, CRT-1: NULL; CRT-0: 640x480 +0+0, CRT-1: NULL"
EndSection

Section "Screen"
    Identifier     "Screen1"
    Device         "Videocard1"
    Monitor        "Monitor1"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "CRT-1: nvidia-auto-select +0+0"
EndSection
Live to win, dare to lose
http://www.robmaas.eu

P4man

  • Gast
Nvidia XGL + COMPIZ + DualView
« Reactie #2 Gepost op: 2007/11/07, 14:32:46 »
Laatste keer dat ik probeerde de nVidia drivers te installeren (van hun site) op Gutsu, liep alles goed fout.  Nooit een probleem gehad op Feisty, ook niet met twinview.

Maar met Gutsy werd xorg.conf na het installeren van de nvidia drivers een totale mesthoop met talloze "monitors" en "devices", X startte steeds in failsafe, kon het nooit goed zetten in dat failsafe configuratiescherm. Enkel manueel effe omzetten naar vesa hielp om X te starten, maar telkens ik dan iets probeerde te veranderen via ofwel de nVidia control panel, of die van gnome, werden er nieuwe secties toegevoegd an xorg.conf, en liep het nog "fouter". Ik heb van pure ellende uiteindelijk "bulletproof X" uitgeschakeld, en opnieuw begonnen met Vesa drivers, en toen werkte het wel.

Een gewaarschuwd mens is er 2 waard.

Offline BlackBurn

  • Lid
    • http://www.robmaas.eu
  • Steunpunt: Nee
Nvidia XGL + COMPIZ + DualView
« Reactie #3 Gepost op: 2007/11/07, 15:15:23 »
Citaat van: P4man
Laatste keer dat ik probeerde de nVidia drivers te installeren (van hun site) op Gutsu, liep alles goed fout.  Nooit een probleem gehad op Feisty, ook niet met twinview.

Maar met Gutsy werd xorg.conf na het installeren van de nvidia drivers een totale mesthoop met talloze "monitors" en "devices", X startte steeds in failsafe, kon het nooit goed zetten in dat failsafe configuratiescherm. Enkel manueel effe omzetten naar vesa hielp om X te starten, maar telkens ik dan iets probeerde te veranderen via ofwel de nVidia control panel, of die van gnome, werden er nieuwe secties toegevoegd an xorg.conf, en liep het nog "fouter". Ik heb van pure ellende uiteindelijk "bulletproof X" uitgeschakeld, en opnieuw begonnen met Vesa drivers, en toen werkte het wel.

Een gewaarschuwd mens is er 2 waard.
Als ik het goed lees, heb je de drivers van de site van NVidia zelf gehaald, hierbij is het bij mij ook mis gegaan. Zowel onder Gutsy als Feisty. Echter hierna de optie restricted drivers gebruikt en dit ging allemaal goed. Als ik met niet vergis kan dit ook via apt-get.

En moet juist zeggen dat het in 7.10 (Gutsy) zonder problemen is verlopen, behalve dat ik dan compleet moest rebooten een paar keer om de instellingen werkend te krijgen. Het mooie van Linux vind ik persoonlijk dan, dat je de files makkelijk kunt editten als iets niet meer werkt. Sowieso altijd een back-up maken voordat je gaat hobbien. Dan kun je dit soort dingen best veilig proberen. Verder ben je volgens mij verplicht om deze drivers te installeren als je bijv. openGL spellen wilt doen. Maar dat weet ik niet zeker.
Live to win, dare to lose
http://www.robmaas.eu

g_ij_s

  • Gast
Nvidia XGL + COMPIZ + DualView
« Reactie #4 Gepost op: 2007/11/07, 21:28:32 »
Nou het is me eindelijk gelukt...

Ik heb de originele xorg.conf terug gezet. Alles van nvidia verwijderd. Alles van GLX en wat er op lijkt verwijderd.

nvidia-glx geinstalleerd met:

sudo apt-get install nvidia-glx
sudo nvidia-xconfig
sudo nvidia-settings

met nvidia settings twinview aangezet

xorg.conf aangepast door :    
    Option         "AddARGBVisuals" "True"
    Option         "AddARGBGLXVisuals" "True"

toe te voegen onder device.

Het resultaat is een schone xorg.conf die dus blijkbaar werkt:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildmeister@builder26)  Mon Apr 16 20:39:49 PDT 2007

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
    RgbPath         "/usr/X11R6/lib/X11/rgb"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "ServerFlags"
    Option         "Xinerama" "0"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Samsung SyncMaster"
    HorizSync       30.0 - 81.0
    VertRefresh     56.0 - 76.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Videocard0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 7900 GT/GTO"
    Option         "AddARGBVisuals" "True"
    Option         "AddARGBGLXVisuals" "True"
    Option         "NoLogo" "True"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Videocard0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "1"
    Option         "metamodes" "DFP-0: 1280x1024 +0+0, DFP-1: nvidia-auto-select +1280+0; DFP-0: 1280x960 +0+0, DFP-1: nvidia-auto-select +1280+0; DFP-0: 1152x864 +0+0, DFP-1: nvidia-auto-select +1152+0; DFP-0: 1024x768 +0+0, DFP-1: nvidia-auto-select +1024+0; DFP-0: 832x624 +0+0, DFP-1: nvidia-auto-select +832+0; DFP-0: 800x600 +0+0, DFP-1: nvidia-auto-select +800+0; DFP-0: 640x480 +0+0, DFP-1: nvidia-auto-select +640+0"
    SubSection     "Display"
        Depth       24
        Modes      "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection
Helemaal gelukkig :D maar ik wil nog wel weten welke plugin in Compiz Settings Manager regelt dat alle windows in 1 keer in beeld komen.