Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Wie denkt er mee? [Gutsy Gibbon netwerkproblemen]  (gelezen 834 keer)

Wooter

  • Gast
Wie denkt er mee? [Gutsy Gibbon netwerkproblemen]
« Gepost op: 2007/11/04, 15:23:31 »
Hallo!

Ik maak sinds kort gebruik van Ubuntu 7.10, naast Windows XP.

Alles is redelijk vlekkeloos gegaan, maar het instellen van het internet (eigenlijk netwerk) wil maar niet. Dit doet het echter wel onder Windows XP. Ik heb precies alle (static) XP-settings ingevuld in Ubuntu. Inloggen op de router lukt ook niet. Ik maak gebruik van een SMC Router/Modem combo. Ik gebruik een Kobishi USB-adapter. Ik ga nu systematisch de gegeven oplossingen langs en de problemen die ik daarmee ondervond.

Citaat
3.2.1. Check for device recognition

   1. Open Device Manager (System ▸ Administration ▸ Device Manager).
   2. Check to see the hardware is recognised if it is then Section 3.2.2 ― Check for driver
   3. If your device is not displayed then there ma be a hardware problem. Ensure if it is PCMCIA or PCI that it is inserted correctly.
Bij mij stond 'ie onder System --> Voorkeuren en niet onder System --> Beheer.
Klik voor screenshot
Dit was wat ik te zien kreeg. Ik neem aan dat de adapter die ik gebruik de WLAN Interface is? Zoals jullie zien is de Device unkown.
 
Citaat
3.2.2. Check for driver

   1. Open a Terminal (Applications ▸ Accessories ▸ Terminal) and type the command: sudo lshw -C network
   2. If there is a driver listed then see Section 3.2.3 ― Check device is on.
   3. Set up NDISWrapper (Section 3.3 ― Using Windows Wireless Drivers).
wouter@pc-wouter:~$ sudo lshw -C network
[sudo] password for wouter:
  *-network              
       description: Ethernet interface
       product: SiS900 PCI Fast Ethernet
       vendor: Silicon Integrated Systems [SiS]
       physical id: 4
       bus info: pci@0000:00:04.0
       logical name: eth0
       version: 91
       serial: 00:16:ec:xx:xx:xx
       size: 10MB/s
       capacity: 100MB/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=sis900 driverversion=v1.08.10 Apr. 2 2006 duplex=half latency=64 link=no maxlatency=11 mingnt=52 module=sis900 multicast=yes port=MII speed=10MB/s
  *-network
       description: Wireless interface
       physical id: 1
       logical name: wlan0
       serial: 00:06:f4:xx:xx:xx
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=at76_usb driverversion=0.14beta1 firmware=1.101.2-84 ip=192.168.2.101 wireless=IEEE 802.11b
Oke, er staan dus twee dingen. We hebben de Ethernet interface en de Wireless interface. Ik neem toch aan dat ik gebruik maak van de Wireless interface, of in ieder geval gebruik van wil maken. Als ik het goed begrijp zendt 'ie dus wel signalen uit. De driver is ook aanwezig neem ik aan?

Ik vermoedde dat het iets met de drivers te maken had, dus ik ging maar eens met NDISWrapper spelen. ndisgtk stond bij mij helemaal niet bij de Synaptic Package Manager, maar ik heb het onder XP gedownload en het naar Ubuntu gezet.
Klik voor screenshot
Het internet deed het hierna nog steeds niet. :)

Citaat
3.2.4. Check for a connection to the router

   1. Open a Terminal (Applications ▸ Accessories ▸ Terminal) and type the command: iwconfig.
   2. If there is an entry that says ESSID="" then see Setting Up WPA (Section 3.4.1 ― Configuring WPA support.
   3. If the ESSID for our router is shown there may be a problem with ACPI support. Boot the kernel with the pci=noacpi option.
wouter@pc-wouter:~$ iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wlan0     IEEE 802.11b  ESSID:"Draadloos@vanDijke"  Nickname:""
          Mode:Managed  Frequency:2.437 GHz  Access Point: 00:04:E2:xx:xx:xx  
          Bit Rate:11 Mb/s   Tx-Power=15 dBm  
          Retry limit:8   RTS thr=1536 B   Fragment thr=1536 B  
          Power Management:off
          Link Quality=85/100  Signal level=85/100  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
ESSID staat er dus. Ik zie niet in waarom ik nu mijn WPA in moet gaan stellen, want er wordt enkel gebruik gemaakt van WEP. Al goed, ik zou dus graag de kernel willen booten met pci=noacpi. Ik heb echter geen flauw idee hoe dat moet.

Citaat
3.2.5. Check IP assignment

   1. Open a Terminal (Applications ▸ Accessories ▸ Terminal) and type the command: ifconfig.
   2. If there is an IP address shown see Section 3.2.6 ― Check DNS.
   3. From the Terminal enter the command: dhclient if_name where if_name is the connection listed earlier.
   4. If you receive a message that says bound to xxx.xxx.xxx.xxx then see Section 3.2.6 ― Check DNS
   5. If not then reboot the system.
eth0      Link encap:Ethernet  HWaddr 00:16:EC:xx:xx:xx  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:20 Base address:0xe000

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:3698 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3698 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:301352 (294.2 KB)  TX bytes:301352 (294.2 KB)

wlan0     Link encap:Ethernet  HWaddr 00:06:F4:xx:xx:xx  
          inet addr:192.168.2.101  Bcast:192.168.2.255  Mask:255.255.255.0
          inet6 addr: fe80::206:f4ff:fe02:9583/64 Scope:Link
          UP BROADCAST RUNNING  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:586 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:24584 (24.0 KB)
Er wordt dus een IP-adres weergegeven, maar ik ga toch nog even verder met stap 3.
wouter@pc-wouter:~$ dhclient wlan0
Internet Systems Consortium DHCP Client V3.0.5
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

can't create /var/lib/dhcp3/dhclient.leases: Permission denied
Can't create /var/run/dhclient.pid: Permission denied
drop_privileges: could not set group id: Operation not permitted
wouter@pc-wouter:~$ dhclient Draadloos@vanDijke
Draadloos@vanDijke: interface name too long (is 18)
Hier word ik dus niet veel wijzer van, ik weet niet zo goed welke connectie bedoeld wordt. Beide gokken gaven ook nog eens een foutmelding.

Citaat
3.2.6. Check DNS

   1. Open a Terminal (Applications ▸ Accessories ▸ Terminal) and type the command: ping 82.211.81.158.
   2. Now type the command: ping www.ubuntu.com. If you get a response from the both then see Section 3.2.7 ― IPv6 Not Supported.
   3. Type the command: cat /etc/resolv.conf. If there is no nameserver listed then contact your ISP and find out your primary and secondary domain name servers. Once you have this information see Section 3.1 ― Connect to a wireless network.
wouter@pc-wouter:~$ ping 82.211.81.158
PING 82.211.81.158 (82.211.81.158) 56(84) bytes of data.
From 192.168.2.101 icmp_seq=1 Destination Host Unreachable
From 192.168.2.101 icmp_seq=2 Destination Host Unreachable
From 192.168.2.101 icmp_seq=3 Destination Host Unreachable
Zo blijft het doorgaan.

wouter@pc-wouter:~$ ping www.ubuntu.com
ping: unknown host www.ubuntu.com
Dat gaat dus niet veel beter.
De nameserver klopt ook met wat ik ingevuld heb.

Tot zover alles wat ik geprobeerd heb.

Roaming mode heb ik geprobeerd, werkte niet.
DHCP was ook niet de oplossing.

Nog als laatste vraag, wat moet ik als Domain name invullen bij de Network Settings?

Nog een bonusscreenshot!


Wie denkt er met me mee? :)

PS.
Mods, als jullie zien dat ik iets gepost heb wat onverstandig was, wees zo vrij het te deleten.

Offline terelfderure

  • Lid
  • Steunpunt: Nee
Wie denkt er mee? [Gutsy Gibbon netwerkproblemen]
« Reactie #1 Gepost op: 2007/11/05, 23:29:03 »
Ik ben op internet wat gaan zoeken. Je hebt een Atmel chipset  de At76_usb. Er zijn nieuwe drivers op de site van Berlios  http://at76c503a.berlios.de/
Bezoek ook eens een draadje met eengelijksoortig probleem  http://forum.ubuntu-nl.org/message/155866.
Alleszins een oude usb wireless adapter met 802.11 b
Usb wireless adapters geven nog al eens problemen.
Ik hoop dat je er wat aan hebt.

Offline diskmusic

  • Lid
  • Steunpunt: Nee
Wie denkt er mee? [Gutsy Gibbon netwerkproblemen]
« Reactie #2 Gepost op: 2007/11/06, 10:16:11 »
Heb je in het SMC router/modem wellicht allow only trusted wlan stations aan staan?
Zo ja wijzig dat dan in allow all stations en zie of er dan wel een verbinding tot stand komt. :cool:

Wooter

  • Gast
Wie denkt er mee? [Gutsy Gibbon netwerkproblemen]
« Reactie #3 Gepost op: 2007/11/06, 11:48:23 »
Update:

Wegens andere problemen met internet hebben we de hele SMC router een factory reset gegeven. Na de firewall opnieuw ingesteld te hebben bleek mijn internet het niet meer te doen bij de WEP-key. Ik snap niet precies hoe dat kan, aangezien alle settings wel kloppen. Nu weet ik in ieder geval wat het probleem is.

Op dit moment heb ik dus geen hulp meer nodig. terelfderure, bedankt voor de link, die gaat naar de bookmarks!

diskmusic, dat stond wel aan. :)