Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: xkb en "software index is broken" (na update 7.10)  (gelezen 344 keer)

Lambik

  • Gast
xkb en "software index is broken" (na update 7.10)
« Gepost op: 2007/11/04, 13:47:51 »
Hoi

Nadat ik Ubuntu 7.10 op mijn systeem zette, duiken er problemen allerhande op. Ik heb al wat op internet rondgesnuffeld, maar ofwel kijk ik erover, ofwel zijn er niet meteen pasklare oplossingen.

Dit zijn ze:

1) Als ik inlog krijg ik volgende pop-up:

Error activating XKB configuration.
It can happen under various circumstances:
- a bug in libxklavier library
- a bug in X server (xkbcomp, xmodmap utilities)
- X server with incompatible libxkbfile implementation

X server version date:
The X.Org Foundation
10300000

If you report this situation as a bug, please include:
- The result of xprop -root / grep XKB
- The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd

"jan@jan-desktop:~$ xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "trust", "be", "", ""
_XKB_RULES_NAMES(STRING) = "xorg", "trust", "be", "", ""
jan@jan-desktop:~$ gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
 layouts = [us,be]
 model = trust
 options = [grp grp:alts_toggle]
 overrideSettings = true"


edit: oh ja, dit krijg ik ook nog als pop-up:

"The X system keyboard settings differ from your current GNOME keyboard settings.

Expected was model "pc105", layout "us" and no options, but the the following settings were found: model "trust", layout "be" and no options.

Which set would you like to use?" (ik hou het dan bij de Gnome-instellingen, omdat die effectief kloppen, maar ietwat irritant dat ie het elke keer vraagt)

2) Ik heb bovenaan m'n scherm zo'n dingetje:
"This usually means that your installed packages have unmet dependencies."

Doe ik dan "install all updates", dan krijg ik volgende knoert van een foutmelding:

"Software index is broken

It is impossible to install or remove any software. Please use the package manager "Synaptic" or run "sudo apt-get install -f" in a terminal to fix this issue at first."

Uiteraard werkt dat niet. Maar als gevolg kan ik bijvoorbeeld mijn OpenOffice.org-programma's niet gebruiken (een van de zaken die geïnstalleerd of geüpgraded moet worden is iets van OpenOffice.org).

Enfin, als er suggesties zijn: meer dan welkom.

Offline Quinten Verlinden

  • Lid
  • Steunpunt: Nee
xkb en "software index is broken" (na update 7.10)
« Reactie #1 Gepost op: 2007/11/04, 14:10:08 »
Ik denk dat herinstalleren het minste tijd in beslag gaat nemen :/
Als er een nieuwe versie is van Ubuntu, kan je best gewoon een volledige nieuwe installatie doen, dan heb je het minste kans op fouten

Offline bartek

  • Lid
    • http://bartek.blogsome.com
  • Steunpunt: Nee
xkb en "software index is broken" (na update 7.10)
« Reactie #2 Gepost op: 2007/11/04, 14:10:29 »
Heb je toevallig in Feisty andere software bronnen toegevoegd aan je sources.list ?
Ik vermoed dat je upgrade alleen de officiele bronnen van je systeem update en niet de zelf toegevoegde. Hierdoor kan het zijn dat sommige programma's slecht of helemaal niet werken.
| Deliberando saepe perit occasio |

"Car la vie est un bien perdu quand on n'a pas vécu comme on l'aurait voulu"