Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Failed to start X server  (gelezen 468 keer)

Offline SlechteNaam

  • Lid
  • Steunpunt: Nee
Failed to start X server
« Gepost op: 2007/11/02, 10:57:14 »
Ik heb weer een ernstig probleempje: Bij het installeren van Compiz, wat ik niet voor elkaar kreeg, heb ik iets stoms met wat drivers gedaan. Precies wat weet ik niet meer, maar als ik nu opstart krijg ik een lelijk scherm met oa de tekst: 'Failed to start X server. It is likely that it was not set up correctly' en kan ik dus verder niets.

Vervolgens wat op internet opgezocht, en zo vond ik dat ik 'sudo dpkg-reconfigure xserver-xorg' moest gebruiken. Dus heb ik de livecd weer voor de dag gehaald (dan doet ie t wel) en dit in de terminal. Vervolgens allerlei vragen beantwoord (moeilijke vragen, meestal maar 'default' geantwoord) maar daarna deed ie t nog steeds nie.

Ik heb een NVIDIA videocard, en als ik bij restricted drivers kijk, staat de 'NVIDIA accelerated graphics driver' uitgeschakeld, 'not in use'. Wanneer ik deze 'enable' en de computer weer opnieuw opstart, krijg ik nog steeds die ene foutmelding, en als ik dan bij 'restricted drivers' kijk, staat de NVIDIA weer uitgeschakeld.

Vervolgens vond ik dit: 'you can either use "sudo dpkg-reconfigure xserver-xorg" or manualy edit the /etc/X11/xorg.conf (thats case sensitive that X), and change the driver to 'vesa'.' In dit document (/etc/X11/xorg.conf) vind ik oa:

Section "InputDevice"
   Driver      "wacom"
   Identifier   "stylus"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"      "stylus"
   Option      "ForceDevice"   "ISDV4"      # Tablet PC ONLY
EndSection

Ik kan /dev/input/wacom niet vinden, maar vesa zie ik er zo ook niet tussen staan, dus ik durf 'wacom' niet te veranderen in 'vesa'.

Ik draai Ubuntu Feisty Fawn op een Asus laptop met een NVIDIA videocard en ben nog een beginner.

Heeft er iemand tips?

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Failed to start X server
« Reactie #1 Gepost op: 2007/11/02, 11:06:54 »
In de live cd gaat het niet werken met dat commando.
Wat je wel kan doen, als je die melding krijgt dat de X server niet gestart kan worden, is het volgende.
Druk op control-alt-F2 en log in
Voer nu het volgende commando uit:
sudo dpkg-reconfigure -phigh xserver-xorg
Hierna de vragen beantwoorden, en als dat klaar is opnieuw opstarten met:
sudo reboot

Die wacom dingen moet je van af blijven, dat heeft niks met je monitor of videokaart te maken.

Offline Blackdrive

  • Lid
  • Steunpunt: Nee
Failed to start X server
« Reactie #2 Gepost op: 2007/11/02, 11:08:51 »
Citaat van: SlechteNaam
Vervolgens wat op internet opgezocht, en zo vond ik dat ik 'sudo dpkg-reconfigure xserver-xorg' moest gebruiken. Dus heb ik de livecd weer voor de dag gehaald (dan doet ie t wel) en dit in de terminal. Vervolgens allerlei vragen beantwoord (moeilijke vragen, meestal maar 'default' geantwoord) maar daarna deed ie t nog steeds nie.
Niet met de live-cd doen. Gewoon in Grub de safe graphics mode kiezen en hetzelfde doen.

Citaat
Vervolgens vond ik dit: 'you can either use "sudo dpkg-reconfigure xserver-xorg" or manualy edit the /etc/X11/xorg.conf (thats case sensitive that X), and change the driver to 'vesa'.' In dit document (/etc/X11/xorg.conf) vind ik oa:

Section "InputDevice"
   Driver      "wacom"
   Identifier   "stylus"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"      "stylus"
   Option      "ForceDevice"   "ISDV4"      # Tablet PC ONLY
EndSection

Ik kan /dev/input/wacom niet vinden, maar vesa zie ik er zo ook niet tussen staan, dus ik durf 'wacom' niet te veranderen in 'vesa'.
Blijf maar van die wacom af :)
Ken je wacom niet? Dat zijn zo van die Tablet's, echt input devices, zoals er staat.

Doe maar gewoon die dpkg-reconfigure

Offline SlechteNaam

  • Lid
  • Steunpunt: Nee
Failed to start X server
« Reactie #3 Gepost op: 2007/11/02, 12:02:32 »
Ok, het werkt weer! bedankt!