Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Geen geluid Acer Aspire 5310  (gelezen 8908 keer)

Offline Iris

  • Lid
  • Steunpunt: Nee
Geen geluid Acer Aspire 5310
« Gepost op: 2007/10/31, 01:21:45 »
Hi Ubuntu users out there!

Net deze goedkope Acer Aspire 5310 laptop aangeschaft, voorgeinstalleerde Vista eraf, Ubuntu 7.10 erop...
Echter: geen geluid over de laptop speaker en geen geluid op hoofdtelefoon.
Gnome ALSA mixer geïnstalleerd, alles op maximaal volume, zonder effect.
Heeft iemand een idee wat hieraan te doen is?

Alvast bedankt!

Offline glupper68

  • Lid
  • Steunpunt: Nee
Geen geluid Acer Aspire 5310
« Reactie #1 Gepost op: 2007/10/31, 08:44:05 »
bekijk dit eens, bij mij was het raak

Citaat van: raggar
Das jammer, ik hoorde ook van Sephiroth dat het niet heeft mogen baten. Zelf heb ik een andere kaart dus ik kan het niet zelf ff testen. Ik zal nog even kijken en misschien vind ik iets anders. Hou ook vooral zelf de bugbeschrijving in de gaten en als je wilt kun je de bug melden.

Edit: Ik zie nu net dat het ook zou moeten werken met de backports module uit de respositories. In de terminal: " sudo apt-get install linux-backports-modules"
Probeer het eens uit zou ik zeggen. (wel opnieuw opstarten he)
Intel Pentium  Core 2 duo 2.66 ghz, geheugen 4 gig, Grafische kaart  NVidia GeForce 7050, geluid  Realtek High Definition audio, Router Linksys 54 Mbps WRT54GL wireless

Ubuntu 11.04

zambo

  • Gast
Geen geluid Acer Aspire 5310
« Reactie #2 Gepost op: 2007/10/31, 09:12:44 »
Kijk eens bij jouw Gnome-Alsa-Mixer om de schuiver voor Surround af te zetten.  Bij mijn Acer Aspire is dat gelukt en had ik dan wel geluid. (Toepassingen - Audio en video - Gnome Alsa Mixer)

Offline Jan Stedehouder

  • Lid
    • Jan Stedehouder
  • Steunpunt: Nee
Geen geluid Acer Aspire 5310
« Reactie #3 Gepost op: 2007/10/31, 09:19:25 »
Het is een bekend probleem bij een aantal typen laptops. Kijk hier maar eens voor een oplossing:

http://www.opensourcelearning.info/osel/index.php?option=com_fireboard&Itemid=57&func=view&id=3&catid=3

Offline Iris

  • Lid
  • Steunpunt: Nee
Geen geluid Acer Aspire 5310
« Reactie #4 Gepost op: 2007/10/31, 09:39:11 »
Thanks voor jullie reacties!

Resultaten van de mogelijke oplossingen:

1. sudo apt-get install linux-backports-modules
Geen effect.

2. In Gnome-Alsa-Mixer, "Surround" uitzetten
Deze optie is in mijn mixer niet beschikbaar...

3. http://www.opensourcelearning.info/osel … mp;catid=3
Ziet er hoopvol uit! Echter hoe zet ik conform stap 3 alles uit wat met geluid te maken heeft? Vanalles geprobeerd, maar blijf de melding "ERROR: Module snd_hda_intel is in use" krijgen...

Alle draaiende progs gestopt, geluid in paneel gedempt, in systeem-->geluid systeemgeluiden uitgeschakeld.
Wat moet ik nog meer doen om stap 3 (sudo rmmod snd_hda_intel) en 4 (sudo modprobe snd_hda_intel) te kunnen uitvoeren?

Offline Jan Stedehouder

  • Lid
    • Jan Stedehouder
  • Steunpunt: Nee
Geen geluid Acer Aspire 5310
« Reactie #5 Gepost op: 2007/10/31, 09:40:49 »
@ Iris
Geen probleem. Voer de stappen drie en vier gewoon uit en herstart de laptop. Dat moet genoeg zijn.

Offline Iris

  • Lid
  • Steunpunt: Nee
Geen geluid Acer Aspire 5310
« Reactie #6 Gepost op: 2007/10/31, 10:12:40 »
Hi J,

Alle stappen uitgevoerd (ondanks eerder genoemde melding bij stap 3), herstart, maar helaas nog steeds geen geluid...
Als ik aan het volumeknopje draai aan de zijkant van de laptop wordt dit trouwens wel door het syteem herkend.

Offline Iris

  • Lid
  • Steunpunt: Nee
Geen geluid Acer Aspire 5310
« Reactie #7 Gepost op: 2007/10/31, 10:28:45 »
Oplossing gevonden door in stap 2, AUTO te vervangen door ACER! :-)

Daarom is voor de ACER Laptop dit het stappenplan:

Stap 1: Open de terminal en tik daar:
Code: gksu gedit /etc/modprobe.d/alsa-base

Stap 2: Voeg aan het eind van het document de volgende regel toe:
Code: options snd-hda-intel model=acer

Stap 3: Zorg dat alles wat met geluid te maken heeft uit staat, dan:
Code: sudo rmmod snd_hda_intel
Eventuele melding "ERROR: Module snd_hda_intel is in use" stond de oplossing bij mij niet in de weg.

Stap 4:
Code: sudo modprobe snd_hda_intel


Muchos gracias Glupper68, Zambo en JStedehouder!

Offline Jan Stedehouder

  • Lid
    • Jan Stedehouder
  • Steunpunt: Nee
Geen geluid Acer Aspire 5310
« Reactie #8 Gepost op: 2007/10/31, 10:35:38 »
gelukkig ;) Ik was al verder aan het neuzen op het grote boze web naar aanvullende oplossingen

Offline glupper68

  • Lid
  • Steunpunt: Nee
Geen geluid Acer Aspire 5310
« Reactie #9 Gepost op: 2007/10/31, 13:19:24 »
toppie
Intel Pentium  Core 2 duo 2.66 ghz, geheugen 4 gig, Grafische kaart  NVidia GeForce 7050, geluid  Realtek High Definition audio, Router Linksys 54 Mbps WRT54GL wireless

Ubuntu 11.04

rob2u

  • Gast
Geen geluid Acer Aspire 5310
« Reactie #10 Gepost op: 2007/10/31, 21:42:44 »
Glupper68, jij hebt net zoals ik een ASUS laptop (ik heb een A6Vc) met Realtek HD Audio! Werkt bij jou de externe audio (koptelefoon-) aansluiting wel? IK heb alleen geluid over de interne speakers.....

Rob.

flix

  • Gast
Geen geluid Acer Aspire 5310
« Reactie #11 Gepost op: 2007/11/03, 21:19:35 »
Ik had net hetzelfde audio-probleem en kan alleen maar zeggen dat deze fix dus echt werkt voor de acer 5310

thx


nu nog de wireless...

Offline Iris

  • Lid
  • Steunpunt: Nee
Geen geluid Acer Aspire 5310
« Reactie #12 Gepost op: 2007/11/07, 12:49:55 »
Bij herinstallatie kwam ik er achter dat één van de eerder genoemde tips ook essentieel is, dus hierbij voor de volledigheid de complete oplossing:

1:
gksu gedit /etc/modprobe.d/alsa-base

2: Voeg aan het eind van het document de volgende regel toe:
options snd-hda-intel model=acer
(Opslaan en afsluiten)

3: Zorg dat alles wat met geluid te maken heeft uit staat, dan:
sudo rmmod snd_hda_intel
(Eventuele melding "ERROR: Module snd_hda_intel is in use" stond de oplossing bij mij niet in de weg.)

4:
sudo modprobe snd_hda_intel

5:
sudo apt-get install linux-backports-modules

6:
Syteem herstarten

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Geen geluid Acer Aspire 5310
« Reactie #13 Gepost op: 2007/11/07, 13:07:38 »
Citaat van: Iris
Bij herinstallatie kwam ik er achter dat één van de eerder genoemde tips ook essentieel is, dus hierbij voor de volledigheid de complete oplossing:

1:
gksu gedit /etc/modprobe.d/alsa-base

2: Voeg aan het eind van het document de volgende regel toe:
options snd-hda-intel model=acer
(Opslaan en afsluiten)

3: Zorg dat alles wat met geluid te maken heeft uit staat, dan:
sudo rmmod snd_hda_intel
(Eventuele melding "ERROR: Module snd_hda_intel is in use" stond de oplossing bij mij niet in de weg.)

4:
sudo modprobe snd_hda_intel

5:
sudo apt-get install linux-backports-modules

6:
Syteem herstarten
Bedankt voor de tip. Je uitleg heb ik op de documentatiepagina gezet.
http://www.ubuntu-nl.org/documentatie/hardware/geluidskaart/#head-c32ccc5b42321672fe5ef047413379ebab3e7633