Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: nieuwe ati driver  (gelezen 4323 keer)

Offline marc heijerman

  • Lid
  • Steunpunt: Nee
nieuwe ati driver
« Gepost op: 2007/10/26, 08:29:44 »
Ok ik heb die nieuwe ati driver geinstalleerd en die zou ook aiglx moeten ondersteunen en wanneer ik fglrxinfo intik krijg ik dit:

display: :0.0  screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.5.1)

hoort hier geen ati te staan inplaats van mesa glx enzo.
Ik praat niet te snel, je luisterd te langzaam ;-)

Offline marc heijerman

  • Lid
  • Steunpunt: Nee
nieuwe ati driver
« Reactie #1 Gepost op: 2007/10/26, 08:33:08 »
als ik glxinfo intik krijg ik ook te zien direct rendering = no
Ik praat niet te snel, je luisterd te langzaam ;-)

Offline vanadium

  • Lid
  • Steunpunt: Nee
nieuwe ati driver
« Reactie #2 Gepost op: 2007/10/26, 08:49:21 »
Volgens welke instructies heb je die driver geïnstalleerd?

Offline marc heijerman

  • Lid
  • Steunpunt: Nee
nieuwe ati driver
« Reactie #3 Gepost op: 2007/10/26, 09:22:55 »
nou ik heb de driver gedownload en het was een run bestand dus ik heb gedaan ./driver install en toen werd hij geinstalleerd alleen het stomme is dat ik de grafische configurator van catalyst wel in mijn menu lijst heb staan maar hij doet niks als ik hem aanklik.
Ik praat niet te snel, je luisterd te langzaam ;-)

Offline vanadium

  • Lid
  • Steunpunt: Nee
nieuwe ati driver
« Reactie #4 Gepost op: 2007/10/26, 09:29:59 »
Ik voreg het omdat ik onder Feisty (of mogelijk nog Edgy - ben begonnen twee weken vóór het verschijnen van Feisty) mijn ATI kaart, een MOBILITY RADEON X600, geïnstalleerd heb volgens https://help.ubuntu.com/community/BinaryDriverHowto/ATI.  Er was daar een "troubleshooting" sectie die ik heb moeten doen, en die op jou probleem lijkt:

Citaat
$ fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.4.1)

These two commands might fix your installation, try this, reboot, and run fglrxinfo again:

mkdir -p /usr/X11R6/lib/modules/dri  
ln -s /usr/lib/dri/fglrx_dri.so /usr/X11R6/lib/modules/dri
waarna bij mij dan inderdaad de goede "output" verscheen

Citaat
~$ fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: MOBILITY RADEON X600
OpenGL version string: 2.0.6334 (8.34.8)

Offline marc heijerman

  • Lid
  • Steunpunt: Nee
nieuwe ati driver
« Reactie #5 Gepost op: 2007/10/26, 09:31:05 »
Ik ga het meteen proberen, laat het zo wel weten.
Ik praat niet te snel, je luisterd te langzaam ;-)

Offline marc heijerman

  • Lid
  • Steunpunt: Nee
nieuwe ati driver
« Reactie #6 Gepost op: 2007/10/26, 09:38:53 »
nee probleem heb ik nog steeds
Ik praat niet te snel, je luisterd te langzaam ;-)

Offline marc heijerman

  • Lid
  • Steunpunt: Nee
nieuwe ati driver
« Reactie #7 Gepost op: 2007/10/26, 09:40:53 »
Ook enig idee hoe ik die andere commando' s weer even ongedaan kan maken ? :D mkdir die kan ik gewoon weer verwijderen neem ik aan maar wat houd dat 2e commando in ?
Ik praat niet te snel, je luisterd te langzaam ;-)

Offline vanadium

  • Lid
  • Steunpunt: Nee
nieuwe ati driver
« Reactie #8 Gepost op: 2007/10/26, 09:51:16 »
Tweede commando creëert een symbolic link

rm /usr/X11R6/lib/modules/dri/fglrx_dri.so

verwijdert deze.

allartk

  • Gast
nieuwe ati driver
« Reactie #9 Gepost op: 2007/10/26, 12:06:20 »
Citaat van: marcheijerman
nou ik heb de driver gedownload en het was een run bestand dus ik heb gedaan ./driver install en toen werd hij geinstalleerd alleen het stomme is dat ik de grafische configurator van catalyst wel in mijn menu lijst heb staan maar hij doet niks als ik hem aanklik.
hoi,

http://forum.ubuntu-nl.org/topic/16521

Heb je die instructies geprobeerd? Kijk anders in /var/log/Xorg.0.log of er iets staat over een verkeerde kernel module want dat lijkt me hier het probleem (als je gedaan heb wat je hier zegt).

Offline marc heijerman

  • Lid
  • Steunpunt: Nee
nieuwe ati driver
« Reactie #10 Gepost op: 2007/10/26, 12:15:01 »
(OprU)
(II) fglrx(0): driver needs X.org 7.1.x.y with x.y >= 0.0
(II) fglrx(0): detected X.org 7.1.1.0
(EE) fglrx(0): atiddxDriScreenInit failed, GPS not been initialized.
(WW) fglrx(0): ***********************************************
(WW) fglrx(0): * DRI initialization failed!                  *
(WW) fglrx(0): * (maybe driver kernel module missing or bad) *
(WW) fglrx(0): * 2D acceleraton available (MMIO)             *
(WW) fglrx(0): * no 3D acceleration available                *
(WW) fglrx(0): *********************************************


bedoelde je dit ?
Ik praat niet te snel, je luisterd te langzaam ;-)

allartk

  • Gast
nieuwe ati driver
« Reactie #11 Gepost op: 2007/10/26, 12:20:55 »
exact ;)

Je kan proberen of alleen het zetten van fglrx bij disabled modules werkt (staat ergens in de howto hoe, voorkomt dat de oude fglrx kernel module wordt geladen bij opstarten), anders kan je denk ik best opnieuw volgens de howto installeren.

Offline marc heijerman

  • Lid
  • Steunpunt: Nee
nieuwe ati driver
« Reactie #12 Gepost op: 2007/10/26, 13:22:34 »
pff haha nou dat word nog wat dan :) moet eerst maar es kijken hoe ik het normaal kan verwijderen zonder dat ik alles weer ver#$@#%...
Ik praat niet te snel, je luisterd te langzaam ;-)

Offline marc heijerman

  • Lid
  • Steunpunt: Nee
nieuwe ati driver
« Reactie #13 Gepost op: 2007/10/26, 14:32:09 »
Ok ehm ik zat even te kijken maar sommige commando's kan ik nie gebruiken omdat ik debian heb hier. Dat was ik even vergeten te melden, dom dom dom :) maar ok ik wil hem alsnog graag geinstalleerd hebben dus ik weet niet of er mensen zijn met ervaring met debian.
Ik praat niet te snel, je luisterd te langzaam ;-)

Offline marc heijerman

  • Lid
  • Steunpunt: Nee
nieuwe ati driver
« Reactie #14 Gepost op: 2007/10/27, 18:00:30 »
Nou ik kom er echt even niet uit hier..... hij is wel geinstalleerd maar het werkt niet goed, ik weet dat ik geen ubuntu heb maar het lijkt wel erg veel op elkaar debian en ubuntu dus er is toch vast wel iemand die me hiermee kan helpen.

Dit is mijn xorg.conf:


# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
   Identifier     "Default Layout"
   Screen      0  "aticonfig-Screen[0]" 0 0
   InputDevice    "Generic Keyboard"
   InputDevice    "Configured Mouse"
EndSection

Section "Files"

   # path to defoma fonts
   FontPath     "/usr/share/fonts/X11/misc"
   FontPath     "/usr/X11R6/lib/X11/fonts/misc"
   FontPath     "/usr/share/fonts/X11/cyrillic"
   FontPath     "/usr/X11R6/lib/X11/fonts/cyrillic"
   FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
   FontPath     "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
   FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
   FontPath     "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
   FontPath     "/usr/share/fonts/X11/Type1"
   FontPath     "/usr/X11R6/lib/X11/fonts/Type1"
   FontPath     "/usr/share/fonts/X11/100dpi"
   FontPath     "/usr/X11R6/lib/X11/fonts/100dpi"
   FontPath     "/usr/share/fonts/X11/75dpi"
   FontPath     "/usr/X11R6/lib/X11/fonts/75dpi"
   FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
   Load  "i2c"
   Load  "bitmap"
   Load  "ddc"
   Load  "dri"
   Load  "extmod"
   Load  "freetype"
   Load  "glx"
   Load  "int10"
   Load  "vbe"
EndSection

Section "ServerFlags"
   Option       "AIGLX" "on"
EndSection

Section "InputDevice"
   Identifier  "Generic Keyboard"
   Driver      "kbd"
   Option       "CoreKeyboard"
   Option       "XkbRules" "xorg"
   Option       "XkbModel" "pc104"
   Option       "XkbLayout" "us"
EndSection

Section "InputDevice"
   Identifier  "Configured Mouse"
   Driver      "mouse"
   Option       "CorePointer"
   Option       "Device" "/dev/input/mice"
   Option       "Protocol" "ImPS/2"
   Option       "Emulate3Buttons" "true"
EndSection

Section "Monitor"
   Identifier   "MX70"
   Option       "DPMS"
EndSection

Section "Monitor"
   Identifier   "aticonfig-Monitor[0]"
   Option       "VendorName" "ATI Proprietary Driver"
   Option       "ModelName" "Generic Autodetecting Monitor"
   Option       "DPMS" "true"
EndSection

Section "Device"
   Identifier  "ATI Technologies Inc RV350 AP [Radeon 9600]"
   Driver      "ati"
   BusID       "PCI:1:0:0"
EndSection

Section "Device"
   Identifier  "aticonfig-Device[0]"
   Driver      "fglrx"
   Option       "VideoOverlay" "on"
   Option       "OpenGLOverlay" "off"
EndSection

Section "Screen"
   Identifier "Default Screen"
   Device     "ATI Technologies Inc RV350 AP [Radeon 9600]"
   Monitor    "MX70"
   DefaultDepth     24
   SubSection "Display"
      Depth     1
      Modes    "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth     4
      Modes    "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth     8
      Modes    "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth     15
      Modes    "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth     16
      Modes    "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth     24
      Modes    "1024x768" "800x600" "640x480"
   EndSubSection
EndSection

Section "Screen"
   Identifier "aticonfig-Screen[0]"
   Device     "aticonfig-Device[0]"
   Monitor    "aticonfig-Monitor[0]"
   DefaultDepth     24
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection

Section "DRI"
   Mode         0666
EndSection

Section "Extensions"
   Option       "Composite" "Enabled"
EndSection

dit krijg ik bij fglrxinfo:

marc@nancy:~$ fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.5.1

en bij glxinfo | grep rendering dit:

cy:~$ glxinfo | grep rendering
direct rendering: No


en ik heb ook het volgende gevonden:

/var/log/Xorg.0.log hier staat het volgende in dat niet goed is volgens mij.

(OprU)
(II) fglrx(0): driver needs X.org 7.1.x.y with x.y >= 0.0
(II) fglrx(0): detected X.org 7.1.1.0
(EE) fglrx(0): atiddxDriScreenInit failed, GPS not been initialized.
(WW) fglrx(0): ***********************************************
(WW) fglrx(0): * DRI initialization failed!                  *
(WW) fglrx(0): * (maybe driver kernel module missing or bad) *
(WW) fglrx(0): * 2D acceleraton available (MMIO)             *
(WW) fglrx(0): * no 3D acceleration available                *
(WW) fglrx(0): *********************************************

Ik zou het zo graag goed werkende zien hier, en mocht dat niet lukken hoe verwijder ik die driver weer goed zodat ik de oudere fglrx driver weer kan installeren want daar had ik wel mijn 3D rendering bij, dan maar geen aiglx ondersteuning.
Ik praat niet te snel, je luisterd te langzaam ;-)

freynder

  • Gast
nieuwe ati driver
« Reactie #15 Gepost op: 2007/10/28, 11:49:58 »
Ik zou toch herinstalleren volgens de correcte methode zoals ervoor al aangeraden werd.

Je kan met een clean xorg.conf beginnen door:
- maak een backup van je huidige xorg.conf
- genereer een nieuwe door dexconf uit te voeren

Vervolgens kan je de driver installeren zoals het moet via --buildpkg
Voor Debian is dat 1 van de volgende:
        Debian/sarge
        Debian/oldstable
        Debian/sid
        Debian/unstable
        Debian/etch
        Debian/stable
        Debian/lenny
        Debian/testing
        Debian/experimental

Volg de volledige instructies zoals hier voor Debian: http://wiki.cchtml.com/index.php/Debian_Installation_Guide

Er staat ook een kleine troubleshooter specifiek voor dri:
code:
# mkdir -p /usr/X11R6/lib/modules/dri
# ln -s /usr/lib/dri/fglrx_dri.so /usr/X11R6/lib/modules/dri

Succes!

Offline marc heijerman

  • Lid
  • Steunpunt: Nee
nieuwe ati driver
« Reactie #16 Gepost op: 2007/10/28, 12:50:31 »
ok dank je wel, ik heb net dexconf gedaan en ga die wikki nu gebruiken om hem correct te installeren. Dus als alles goed gaat heb ik dan ook meteen die 3D rendering en aiglx enz... ?
Ik praat niet te snel, je luisterd te langzaam ;-)

Offline marc heijerman

  • Lid
  • Steunpunt: Nee
nieuwe ati driver
« Reactie #17 Gepost op: 2007/10/28, 16:19:26 »
./ati-driver-installer-8.42.3-x86.x86_64.run --extract fglrx

ok hier krijg ik een foutmelding van bash en die zegt toegang geweigerd terwijl ik toch echt aangemeld ben als root.
Ik praat niet te snel, je luisterd te langzaam ;-)

freynder

  • Gast
nieuwe ati driver
« Reactie #18 Gepost op: 2007/10/28, 17:05:21 »
Dat is omdat er geen execute permissions zijn. De stappen lijken ook wat omslachtig in het artikel.

Probeer dit (vervang Debian/etch door je eigen distributie):
apt-get update
apt-get install module-assistant build-essential fakeroot dh-make debconf bzip2
bash ati-driver-installer-8.42.3-x86.x86_64.run --buildpkg Debian/etch
dpkg -i xorg-driver-fglrx_8.42.3-1_i386.deb fglrx-kernel-source_8.42.3-1_i386.deb xorg-driver-fglrx-dev_8.42.3-1_i386.deb
module-assistant prepare
module-assistant update
module-assistant a-i fglrx
export DISPLAY=:0
aticonfig --initial
fglrxinfo

(ik kan het spijtig genoeg hier niet testen)

freynder

  • Gast
nieuwe ati driver
« Reactie #19 Gepost op: 2007/10/28, 17:07:49 »
Citaat van: marcheijerman
ok dank je wel, ik heb net dexconf gedaan en ga die wikki nu gebruiken om hem correct te installeren. Dus als alles goed gaat heb ik dan ook meteen die 3D rendering en aiglx enz... ?
Ik vermoed van niet tenzij je dat al geinstalleerd had. Als je het al geinstalleerd had, neem dan de 3 lijnen ivm Composite over van je backup xorg.conf als dat niet automatisch gebeurt.

Offline marc heijerman

  • Lid
  • Steunpunt: Nee
nieuwe ati driver
« Reactie #20 Gepost op: 2007/10/28, 17:45:41 »
nou ik ga weer even kijken of het gaat lukken :)
Ik praat niet te snel, je luisterd te langzaam ;-)

Offline marc heijerman

  • Lid
  • Steunpunt: Nee
nieuwe ati driver
« Reactie #21 Gepost op: 2007/10/28, 17:51:14 »
arc# dpkg -i xorg-driver-fglrx_8.42.3-1_i386.deb fglrx-kernel-source_8.42.3-1_i386.deb xorg-driver-fglrx-dev_8.42.3-1_i386.deb
dpkg: fout bij afhandelen van xorg-driver-fglrx_8.42.3-1_i386.deb (--install):
 kan archief niet benaderen: Onbekend bestand of map

en nu dan ? :D
Ik praat niet te snel, je luisterd te langzaam ;-)

freynder

  • Gast
nieuwe ati driver
« Reactie #22 Gepost op: 2007/10/28, 19:48:11 »
Kijk na of dit wel degelijk de files zijn die gegenereerd zijn...

Offline marc heijerman

  • Lid
  • Steunpunt: Nee
nieuwe ati driver
« Reactie #23 Gepost op: 2007/10/29, 09:14:29 »
na ik word er niet wijzer van...... vind het wel mooi zo en gebruik die oude driver wel weer.
Ik praat niet te snel, je luisterd te langzaam ;-)

freynder

  • Gast
nieuwe ati driver
« Reactie #24 Gepost op: 2007/11/02, 21:11:19 »
Denk ook dat het beter is wat af te wachten.