Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: 7.10 beryl probleem geen sleep balk  (gelezen 1091 keer)

damien79

  • Gast
7.10 beryl probleem geen sleep balk
« Gepost op: 2007/10/23, 12:32:46 »
Ben van het weekend over gestapt op Ubuntu. Ben dus redelijk nieuw in alles wat betreft linux e.d. en commando's doe ik kopie pasten :p

Anyho ik wilde dus op 7.10 beryl aan de praat krijgen en dat had ik op een gegeven moment alleen kreeg ik geen balk meer boven mijn menu waarmee ik een venster kan slepen.

Heb van alles al gelezen over de settings in de xconf waarbij je de display settings bijvoorbeeld op 24 moet zetten of wat andere zaken. Dit alles heb ik allemaal geprobeerd maar zonder resultaat.

Ik heb een laptop met nvidia grafische kaart.

Mijn vraag is kunnen jullie in stappen misschien uitleggen hoe ik het beste te werk kan gaan omtrent het installeren van beryl?

Of is dit een bekend probleem en is er een oplossing voor?

Ik heb allerlei handleidingen al door gelezen maar verder dan wat commando's copy pasten kom ik niet.......ben er nu al 2 dagen mee bezig :'(

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
7.10 beryl probleem geen sleep balk
« Reactie #1 Gepost op: 2007/10/23, 12:53:40 »
Heb je al de restricted drivers geïnstalleerd?en geactiveerd?(NVIDIA)
Systeem=>Beheer=>Beperkt ondersteunde stuurprogramma's
Is Compiz Fusion niet geïnstalleerd i.p.v. Beryl?(Bij mij was Compiz geïnstalleerd en Beryl was niet aanwezig)
Heb je de windows decorater aangevinkt in de Manager van voornoemde programma's?
Heb je Emerald en Emerald theme's geïnstalleerd?Zit in Synaptic.
En dan kunnen we nog kijken naar je xorg.conf kijken, bij mij ziet het er zo uit:
# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "Device"
Identifier "nVidia Corporation NV17 [GeForce4 MX 440]"
Driver "nvidia"
Busid "PCI:1:0:0"
Option "AddARGBVisuals" "True"
Option "AddARGBGLXVisuals" "True"
Option "NoLogo" "True"
EndSection

Section "Monitor"
Identifier "Generieke beeldscherm"
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "nVidia Corporation NV17 [GeForce4 MX 440]"
Monitor "Generieke beeldscherm"
Defaultdepth 24
SubSection "Display"
Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
        Option         "DynamicTwinView"    "FALSE"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
  screen "Default Screen"
Inputdevice "Generic Keyboard"
Inputdevice "Configured Mouse"

# Uncomment if you have a wacom tablet
# InputDevice     "stylus" "SendCoreEvents"
# InputDevice     "cursor" "SendCoreEvents"
# InputDevice     "eraser" "SendCoreEvents"
EndSection
Section "Module"
Load "glx"
EndSection
Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

damien79

  • Gast
7.10 beryl probleem geen sleep balk
« Reactie #2 Gepost op: 2007/10/23, 13:02:59 »
Systeem=>Beheer=>Beperkt ondersteunde stuurprogramma's
Heb ik enabled idd :)

Is Compiz Fusion niet geïnstalleerd i.p.v. Beryl
Compiz Fusion ken ik niet :) Maar Beryl moest ik installeren. Heb geen echte Gusty handleiding gevonden dus heb die van 7.04 geprobeerd en dat werkte aardig :P

Heb je de windows decorater aangevinkt in de Manager van voornoemde programma's?
Deze optie heb ik gezien idd. Heb deze ook aangevinkt staan.

Heb je Emerald en Emerald theme's geïnstalleerd?Zit in Synaptic.
Dit had ik ook werken op een gegeven moment.

xorg.conf
Die van mij ziet er redelijk het zelfde uit. Belangrijke passage:
Section "Module"
    Load        "glx"
Staat er ook bij mij in.

damien79

  • Gast
7.10 beryl probleem geen sleep balk
« Reactie #3 Gepost op: 2007/10/23, 13:21:18 »
Zie dat er hier: http://forum.ubuntu-nl.org/topic/14178/2
Ook het één en ander staat omtrent mijn probleem.

Ik ga vanavond een herinstall doen en dan die stappen nogmaals even door lopen :)

Ik moet het aan de praat krijgen!

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
7.10 beryl probleem geen sleep balk
« Reactie #4 Gepost op: 2007/10/23, 13:43:34 »
Compiz Fusion is de opvolger van Beryl in 7.10 bij mij is die automatisch geïnstalleerd.
Ook belangrijk in xorg.conf:
Option        "AddARGBVisuals"    "True"
    Option        "AddARGBGLXVisuals"    "True"

Ik had het probleem van jou ook is uiteindelijk opgelost met de eindrelease van Gutsy misschien staan er in dat draadje nog tips voor je http://forum.ubuntu-nl.org/topic/14178  en deze
http://forum.ubuntu-nl.org/topic/14740 de oplossing bij Beryl en Nvidia kaart van pjotr123.
En wat geeft glxinfo?
Mocht het niet lukken zoek dan zelf nog eens op het forum op "geen vensters", of Beryl, een hoop leeswerk maar het is voor een goed doel. ;)
Ik blijf het draadje volgen.

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

Offline Nunslaughter

  • Lid
    • timovwb
  • Steunpunt: Nee
7.10 beryl probleem geen sleep balk
« Reactie #5 Gepost op: 2007/10/23, 14:54:46 »
ge hoeft geen beryl te gebruiken in gutsy...compiz fusion doet hetzelfde en is al geinstalleerd...emerald themes hebt ge ook niet nodig...

in de compiz manager (systeem - voorkeuren - edvanced desktop effects settings) window decorations aanvinken...

en deze regels zijn inderdaad belangrijk in uw xorg.conf bij nvidia kaarten:
    Option        "AddARGBVisuals"    "True"
    Option        "AddARGBGLXVisuals"    "True"

damien79

  • Gast
7.10 beryl probleem geen sleep balk
« Reactie #6 Gepost op: 2007/10/23, 15:14:56 »
Top! Ga het allemaal vanavond proberen en beloof plechtig een resultaat te posten :)
Bedankt voor de goede support tot zo ver :)

damien79

  • Gast
7.10 beryl probleem geen sleep balk
« Reactie #7 Gepost op: 2007/10/24, 13:15:45 »
Zoals Nunslaughter zei is het gelukt :)

Kreeg eerst de optie niet in mijn meunu dus heb toen alles gedeïnstalleerd van beryl en emerald en alles wat met Compiz te maken had geherinstalleerd of aangezet.

Toen had ik de functie wel en kon ik er mee aan de slag :) Was effe wel zoeken wat er met de hot-key bedoeld werd maar na wat logisch nadenk werk kwam ik tot de windows key :)

In ieder geval allemaal super bedankt! Ik ga nu verder met wat andere op pimp uitdagingen omtrent mijn desktop omgeving :)

Offline Nunslaughter

  • Lid
    • timovwb
  • Steunpunt: Nee
7.10 beryl probleem geen sleep balk
« Reactie #8 Gepost op: 2007/10/24, 14:13:58 »
tegek! veel plezier :)