Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Foutmelding tijdens automatische update  (gelezen 1093 keer)

Offline janwillembol

  • Lid
  • Steunpunt: Nee
Foutmelding tijdens automatische update
« Gepost op: 2007/10/23, 11:47:38 »
Allereerst, ik heb vrijdag Ubuntu geinstalleerd en ben dus een total newbie.

Dan nu:
Vanmorgen stond naast mijn systeemklok een oranje icoontje met de melding dat er updates beschikbaar waren. Ik braaf geklikt dat die geinstalleerd moesten worden. Dit ging een tijdje goed totdat:

Kon de pakketinformatie niet initialiseren

Tijdens het initialiseren van de pakketinformatie ontstond er een onoplosbaar probleem.

Meld deze fout voor het pakket ‘update-manager’ in een foutrapportage en voeg daarbij de volgende foutmelding:

'W:Encountered status field in a non-version description, E:Problem parsing dependency Depends, E:Fout tijdens verwerken van openoffice.org-l10n-en-za (NewVersion1), E:Problem with MergeList /var/lib/dpkg/status, E:De pakketlijsten of het statusbestand konden of niet ontleed, of niet geopend worden.'


Synaptic Pakketbeheer kon vervolgens ook niet gestart worden en gaf de volgende melding:

Controleren van geïnstalleerde en beschikbare software is mislukt

Dit is een zeer ernstige fout in uw pakketbeheersysteem. Controleer met synaptic op gebroken pakketten, controleer de toegangsrechten en correctheid van het bestand  '/etc/apt/sources.list' en herlaad de pakketinformatie met 'sudo apt-get update' en 'sudo apt-get install -f'.


Vervolgens heb ik in het Terminal venster de bovenstaande sudo's ingevoerd. Dit gaf dezelfde foutmelding als bij de updatemanager al werd weergegeven.

Snapt iemand genoeg van deze code-taal om me te vertellen wat ik nu verder moet doen?

PS: Ik draai Ubuntu 7.10 (gutsy)

Offline wutnubu

  • Lid
  • Steunpunt: Nee
Foutmelding tijdens automatische update
« Reactie #1 Gepost op: 2007/10/23, 12:10:28 »
In synaptic kun je de "gebroken pakketten repareren" kiezen, dat is een menuoptie onder bewerken.

Je kunt ook deze pakketten opnieuw installeren, rechts erop klikken en herinstalleren kiezen.

Maar probeer eerst eens repareren.

Offline janwillembol

  • Lid
  • Steunpunt: Nee
Foutmelding tijdens automatische update
« Reactie #2 Gepost op: 2007/10/23, 12:16:25 »
Hoi w.hellinga! Bedankt voor je snelle reactie!

Helaas kan ik Synaptic niet eens starten, want dan krijg ik de error in beeld:

Er is een fout opgetreden

De volgende details zijn beschikbaar:

E: Problem parsing dependency Depends
E: Fout tijdens verwerken van openoffice.org-l10n-en-za (NewVersion1)
E: Problem with MergeList /var/lib/dpkg/status
E: De pakketlijst of statusbestand kon niet worden ingelezen.
E: _cache->open() failed, please report.

W: Encountered status field in a non-version description


Heb je misschien nog meer tips?

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Foutmelding tijdens automatische update
« Reactie #3 Gepost op: 2007/10/23, 12:18:07 »
sudo apt-get install -f  in de terminal.
verder zou je sudo gedit /var/lib/dpkg/status  kunnen doen. doe een zoekopdracht binnen dit bestand, verwijder alle gebroken openoffice bestanden. daarna sudo apt-get update
                           sudo apt-get upgrade

Offline janwillembol

  • Lid
  • Steunpunt: Nee
Foutmelding tijdens automatische update
« Reactie #4 Gepost op: 2007/10/23, 12:19:34 »
janwillembol@mighty-drive:~$ sudo apt-get install -f
Pakketlijsten worden ingelezen... Fout!
W: Encountered status field in a non-version description
E: Problem parsing dependency Depends
E: Fout tijdens verwerken van openoffice.org-l10n-en-za (NewVersion1)
E: Problem with MergeList /var/lib/dpkg/status
E: De pakketlijsten of het statusbestand konden of niet ontleed, of niet geopend worden.


Jongens, echt bedankt voor deze snelle reacties :)

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Foutmelding tijdens automatische update
« Reactie #5 Gepost op: 2007/10/23, 12:20:11 »
Probeer dit dan eens in een terminal of via alt-F2:
gksudo gedit /var/lib/dpkg/status

Zoek het gedeelte op wat over openoffice.org-l10n-en-za gaat en kijk wat er fout is.
Plaats dat gedeelte anders ook eens hier.

Offline janwillembol

  • Lid
  • Steunpunt: Nee
Foutmelding tijdens automatische update
« Reactie #6 Gepost op: 2007/10/23, 12:24:18 »
Dat bestand staat helemaal in het Japans-achtig lettertype: kan er dus niets wijs uit worden :( Heb nog geprobeerd het te wijzigen in een leesbaar lettertype, maar dit lukte niet.

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Foutmelding tijdens automatische update
« Reactie #7 Gepost op: 2007/10/23, 12:27:11 »
Probeer dit dan eens:
sudo mv /var/lib/dpkg/status /var/lib/dpkg/status.kapot
sudo cp /var/lib/dpkg/status-old /var/lib/dpkg/status

Deze 2 commando's kan je gewooon kopiëren en plakken in een terminalvenster.

Offline janwillembol

  • Lid
  • Steunpunt: Nee
Foutmelding tijdens automatische update
« Reactie #8 Gepost op: 2007/10/23, 13:16:30 »
Fantastisch! Die laatste twee werken. Nu heb ik in het Status-bestand gezocht naar "openoffice.org-l10n-en-za". Dit leverde twee zoekresultaten op:

Package: language-support-en
Status: install ok installed
Priority: optional
Section: translations
Installed-Size: 40
Maintainer: Martin Pitt
Architecture: all
Version: 1:7.04+20070209
Depends: mozilla-firefox-locale-en-gb, myspell-en-gb, myspell-en-us, aspell-en, wamerican, wbritish, openoffice.org-help-en-us, openoffice.org-l10n-en-gb, openoffice.org-l10n-en-us, openoffice.org-l10n-en-za, openoffice.org-thesaurus-en-us, thunderbird-locale-en-gb, myspell-en-za, openoffice.org-hyphenation
Recommends: language-pack-en
Description: metapackage for English language support
 This metapackage depends on all packages that provide native language
 support for applications in Ubuntu (like spell
 checkers, dictionaries, OpenOffice and Mozilla locale packages,
 etc.).
 .
 If you also want your applications and the desktop to be translated,
 please additionally install language-pack-en.
 .
 Language: English



EN



Package: openoffice.org-l10n-en-za
Status: install ok installed
Priority: optional
Section: editors
Installed-Size: 5100
Maintainer: Ubuntu Core Developers
Architecture: all
Source: openoffice.org-l10n
Version: 1:2.3.0-1ubuntu2
Replaces: openoffice.org2-l10n-en-za
Provides: openoffice.org-l10n-2.3, openoffice.org2-l10n-en-za
Depends: openoffice.org-l10n-common (>= 1:2.3.0), openoffice.org-common (>= 1:2.3.0) | language-support-en, openoffice.org-common (<< 1:2.3.0.1) | language-support-en
Recommends: openoffice.org-core (>> 1:2.3.0) | language-support-en
Suggests: hunspell-dictionary-en-za | myspell-dictionary-en-za, openoffice.org-hyphenation-en-za, openoffice.org2-thesaurus-en-za, openoffice.org-help-en-za
Conflicts: openoffice.org-core (<< 1:2.3.0), openoffice.org-core (>= 1:2.3.0.1), openoffice.org2-l10n-en-za
Description: English_southafrican language package for OpenOffice.org
 OpenOffice.org is a full-featured office productivity suite that provides
 a near drop-in replacement for Microsoft(R) Office.
 .
 This package contains the localization of OpenOffice.org in
 English_southafrican.
 It contains the user interface, the templates and the autotext features.
 (please note that not all this is available for all possible languages).
 You can switch user interface language using the locales system.
 .
 Spelling dictionaries, hyphenation patterns, thesauri and help are not
 included in this package. There are some available in separate packages
 (myspell-*, openoffice.org-hyphenation-*, openoffice.org-thesaurus-*,
 openoffice.org-help-*)
 .
 If you just want to be able to spellcheck etc. in other languages, you can
 install extra dictionaries/hyphenation patterns/thesauri independently of
 the language packs.
Original-Maintainer: Debian OpenOffice Team

Offline janwillembol

  • Lid
  • Steunpunt: Nee
Foutmelding tijdens automatische update
« Reactie #9 Gepost op: 2007/10/23, 13:25:32 »
Na dit proces nogmaals doorlopen te hebben voor een ander bestand is het updaten gelukt! Bedankt voor alle hulp!