Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: wireless probleem met D-link DWL-G520+  (gelezen 1825 keer)

Ponti

  • Gast
wireless probleem met D-link DWL-G520+
« Gepost op: 2007/10/22, 23:53:41 »
Hallo iedereen,

ik ben een nieuwe Ubuntu gebruiker die op de release party van afgelopen
weekend heeft mogen kennismaken met Ubuntu. Bij mijn thuiskomst bleek er echter nog een probleem met mijn draadloze netwerkkaart en ik kom er niet uit, ondanks de documentatie.

*in de terminal zie ik na lshw -C network het volgende:

description: Wireless interface
product: ACX 111 54Mbps Wireless Interface
vendor: Texas Instruments
physical id: a
bus info: pci@0000:03:0a.0
logical name: wlan0
version: 00
serial: 00:11:95:6e:2c:79
width: 32 bits
clock 33MHz
capabilities: pm bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=acx_pci ip=192.168.1.3 latency=64 module=acx multicast=yes wireless:IEEE 802.11b+/g+

*lspci geeft:

03:0a.0 Network controller: Texas Instruments ACX 111 54 Mbps Wireless Interface
Subsystem: D-Link System Inc DWL-G520+ Wireless PCI Adapter
Flags: bus master, medium devsel, latency 64, IRQ 21
Memory at feafc000 (32-bit, non-prefetchable) [size=8k]
Memory at feac0000 (32-bit, non-prefetchable) [size=128k]
Capabilities:

*lspci -n: 03:0a.0 0280: 104c:9066

*in de terminal zie ik na iwconfig het volgende:

lo        no wireless extension
eth0    no wireless extension
wlan0  IEEE 802.11b+/g+   ESSID:"STA6E2C79"    Nickname:"acx v0.3.36"
Mode: Managed    Frequency:2.4112 GHz    Acces Point: Not-Associated
Bit Rate: 54 MB/s    Tx-Power=15 dBm    Sensitivity=1/3
Retry min limit:7     RTS thr:off
Power Management:off
Link Quality=37/100     Signal Level=12/100     Noise Level=0/100
Rx invalid nwid:0     Invalid misc:0     Missed beacon:0

*iwlist wlan0 scan:
wlan0   No scan results

*etc/network/interfaces:

auto lo
iface lo inet loopback

iface wlan0 inet static
address 192.168.1.3
netmask 255.255.255.0
gateway 192.168.1.1
wpa-psk "ga ik niet allemaal overtypen :)"
wpa-driver wext
wpa-key-mgmt WPA-PSK
wpa-proto WPA
wpa-ssid "de SSID staat juist"

iface eth0 inet static
address 192.168.1.3
netmask 255.255.255.0
gateway 192.168.1.1

auto wlan0

*end of information*

nu heb ik dus een paar vragen:

Is de netwerkkaart goed geïnstalleerd? Zijn de drivers juist? Zowel de acx driver als de wpa driver? Soms sluit hij de pc niet goed af door de network manager, de exacte melding weet ik niet.

Waarom is het signaal zo laag? In windows haal ik signal level 77/100 en signal quality 80/100. Heeft dit iets te maken met tx-power die op 15 dBm staat? In windows staat die op level 1

Gebruik ik best een NDISwrapper driver en zo ja, welke?

Ik heb ook op een andere post gezien dat er zoiets is als wicd in plaats van network manager. Is dit aan te raden?

Tenslotte blijft hij als hij opstart het systeem checken (allemaal lijntjes met dan ok erachter). Op de release party heeft men mij echter gezegd dat dit verdwijnt na de eerste opstart, maar hij blijft dat dus doen. Heeft dit mogelijk te maken met mijn draadloze kaart of iets anders? Wat kan ik doen om dit te verhelpen?

Ook moet ik NIET telkens ik sudo invoer of een administratieve functie mijn paswoord ingeven, alleen de eerste keer. Is dit normaal? Ik dacht dat je dit altijd moest ingeven?

Alvast hartelijk bedankt,
Ponti

Offline Dominique Ramaekers

  • Lid
  • Steunpunt: Nee
wireless probleem met D-link DWL-G520+
« Reactie #1 Gepost op: 2007/10/24, 20:32:25 »
Citaat van: Ponti
...Bij mijn thuiskomst bleek er echter nog een probleem met mijn draadloze netwerkkaart en ik kom er niet uit, ondanks de documentatie.

nu heb ik dus een paar vragen:

Is de netwerkkaart goed geïnstalleerd? Zijn de drivers juist? Zowel de acx driver als de wpa driver? Soms sluit hij de pc niet goed af door de network manager, de exacte melding weet ik niet.
Mij lijkt de driver wel snor te zitten.
Citaat van: Ponti
Waarom is het signaal zo laag? In windows haal ik signal level 77/100 en signal quality 80/100. Heeft dit iets te maken met tx-power die op 15 dBm staat? In windows staat die op level 1
Bij mij doet Ubuntu dat ook. Het grappige is, dat ik een groter bereik heb dan bij windows :) Da's dus ook OK.
Citaat van: Ponti
Gebruik ik best een NDISwrapper driver en zo ja, welke?
Ik zou nog even wachten met NDISwrapper. We zullen dit doen als we de oplossing niet vinden.
Citaat van: Ponti
Ik heb ook op een andere post gezien dat er zoiets is als wicd in plaats van network manager. Is dit aan te raden?
:/ Nog nooit van wicd gehoord. Ik stel dus voor om daar voorlopig ook van af te blijven tot we er meer van weten.
Citaat van: Ponti
Tenslotte blijft hij als hij opstart het systeem checken (allemaal lijntjes met dan ok erachter). Op de release party heeft men mij echter gezegd dat dit verdwijnt na de eerste opstart, maar hij blijft dat dus doen. Heeft dit mogelijk te maken met mijn draadloze kaart of iets anders? Wat kan ik doen om dit te verhelpen?
Dit is wel raar. Bij elke opstart kijkt hij uw partities van uw harde schijven na. Hij zou dit slechts om de 30 keren opstarten mogen doen.
Daar zullen we eens naar kijken.
Citaat van: Ponti
Ook moet ik NIET telkens ik sudo invoer of een administratieve functie mijn paswoord ingeven, alleen de eerste keer. Is dit normaal? Ik dacht dat je dit altijd moest ingeven?
Het klopt dat je het paswoord niet elke keer moet ingeven. Het systeem onthoud 15 minuten lang dat je het paswoord al ingegeven hebt.

Eerst en vooral:
Met wpa + netwerkproblemen heb ik niet zo veel ervaring. Zullen we even overgaan naar WEP? Als dat werk, dan zullen we terug over gaan op WPA.
Gebruik deze regels om een nieuwe /etc/network/interfaces te maken:
auto lo
iface lo inet loopback
iface wlan0 inet dhcp
wireless-key [i]uw key[/i]
wireless-essid [i]uw ESSID[/i]
auto wlan0
Type dan dit in in de terminal:
sudo /etc/init.d/networking restartIndien het niet werkt, post dan hier de uitvoer...

Ponti

  • Gast
wireless probleem met D-link DWL-G520+
« Reactie #2 Gepost op: 2007/10/24, 23:37:14 »
ok Dadio,

bedankt voor de hulp alvast. Ik heb eerst opnieuw geïnstalleerd (ik had toch wat zitten prutsen met ndiswrapper en wicd van te voren) en dan heb ik gedaan wat je gezegd hebt:

sudo /etc/init.d/networking restart
*reconfiguring network interfaces...
There is already a pid file /var/run/dhclient.wlan0.pid 15097
killed old client process, removed PID file
Internet Systems Consortium DHCP Client V3.0.5
Copyright 2004-2006 Internet Systems Consortium.
All rights Reserved.
For info, please visit http://www.isc.org/dhcp/

Listening on LPF/wlan0/00:11:95:6e:2c:79
Sending on LPF/wlan0/00:11:95:6e:2c:79
Sending on Socket/fallback
There is already a pid file var/run/dhclient.wlan0.pid with pid 134519120
Copyright 2004-2006 Internet Systems Consortium.
All rights Reserved.
For info, please visit http://www.isc.org/dhcp/

Listening on LPF/wlan0/00:11:95:6e:2c:79
Sending on LPF/wlan0/00:11:95:6e:2c:79
Sending on Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 11
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 12
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
grep: /etc/resolv.conf: no such file or directory

*end of information*

en dan werkt het dus niet. Mij lijkt dat hij zijn ip adres gewoon niet goed krijgt.

Offline Dominique Ramaekers

  • Lid
  • Steunpunt: Nee
wireless probleem met D-link DWL-G520+
« Reactie #3 Gepost op: 2007/10/25, 16:59:44 »
Citaat van: Ponti
ok Dadio,
en dan werkt het dus niet. Mij lijkt dat hij zijn ip adres gewoon niet goed krijgt.
Klopt... Eigenlijk vind hij uw router niet. Nu nog uitzoeken waarom.

Heb je uw beveiliging op WEP gezet?

Wat ook te proberen valt is bij systeem>beheer>netwerk op 'draadloze verbinding' klikken en dan op de knop eigenschappen.

Hier Roaming mode (zwevende mode) uit vinken en uw ESSID en sleutel ingeven. Controleer of configuration op 'DHCP' staat.

Post dan nog eens uw /etc/network/interfaces. Controleer ook of het bestand ongeveer de regels bevat die ik in mijn vorige post beschreven had.

Dan nog eens posten wat je krijgt bij 'sudo /etc/init.d/networking restart'

Ponti

  • Gast
wireless probleem met D-link DWL-G520+
« Reactie #4 Gepost op: 2007/10/25, 19:09:56 »
Ok Dadio,

als ik in roaming mode hem de opdracht geef, dan detecteert hij geen netwerk. Ik zeg dan "connect to other network" en geef hem alle informatie. Dan verandert de networkmanager in 4 balkjes (die normaal blauw worden volgens signaalsterkte) en dan plots verdwijnt die dus (ik denk dat die netwerkmanager gewoon crasht). Als ik het doe zoals jij het nu juist zei:

dan wordt de /etc/network/interfaces:
auto lo
iface lo inet loopback

iface wlan0 inet dhcp
wireless-key s:"mijn wireless key"
wireless-essid "mijn wireless essid"

de networking restart geeft dan hetgeen ik vorige keer al gepost heb:
*reconfiguring network interfaces...
There is already a pid file var/run/dhclient.wlan0.pid with pid 134519120
Copyright 2004-2006 Internet Systems Consortium.
All rights Reserved.
For info, please visit http://www.isc.org/dhcp/

Listening on LPF/wlan0/00:11:95:6e:2c:79
Sending on LPF/wlan0/00:11:95:6e:2c:79
Sending on Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 11
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 12
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
grep: /etc/resolv.conf: no such file or directory


ik heb het daarjuist ook nog eens geprobeerd met het verschil tussen een hex en een ascii key, levert dus niets op. Ik vind ook dat de pc zo traag reageert als ik aan mijn settings iets veranderd heb???

nu zie ik ook onder network tools dat ik twee wlan0 verbindingen heb???
wlan0 en wlan0:avahi
alleen bij wlan0:avahi staat alles ingevuld (protocol: IPv4 het ip adres trekt op niks maar soit)
het hardware address en de link speed komen overeen met mijn kaart maar als ik op configure klik zegt hem "the interface does not exist???"

Offline Dominique Ramaekers

  • Lid
  • Steunpunt: Nee
wireless probleem met D-link DWL-G520+
« Reactie #5 Gepost op: 2007/10/25, 21:01:50 »
Hoi,

Ik zou sowieso roaming af zetten. Gebruik manuele configuratie. Ik heb dat ook dat de pc wat traag reageerd als ik netwerkinstellingen verander.
Daarom doe ik altijd sudo /etc/init.d/networking restart
Probeer het nog eens als je roaming af gezet hebt...

Dat die wlan0:avahi er bij staat heb ik nog nooit gezien. Staat die er ook bij bij systeem>beheer>netwerk (in het engels dan bij jou)?

Ponti

  • Gast
wireless probleem met D-link DWL-G520+
« Reactie #6 Gepost op: 2007/10/25, 21:38:07 »
Neen, die staat daar dan niet bij. Staat alleen in netwerk tools. Roaming af heb ik ook al geprobeerd, dan krijg je gewoon dat hij de router niet vindt. Is het normaal dat die netwerkmanager gewoon van mijn bovenste balk verdwijnt? Kunnen we niet eens een avond chatten of zo, dat werkt veel makkelijker. Ik zit hier op een laptop met apart internet met de ubuntu pc naast mij. MSN: sintemafia@hotmail.com

Ponti

  • Gast
wireless probleem met D-link DWL-G520+
« Reactie #7 Gepost op: 2007/10/27, 11:23:21 »
Hallo,

heb gisteren een andere wireless kaart van Belkin geïnstalleerd die ik hier nog had liggen en het draait gewoon out of the box. Hartelijk dank aan iedereen voor het zoeken.

een trotse Ubuntu gebruiker