Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [Wireless] Instellingen niet goed onthouden  (gelezen 2975 keer)

StefSOFT

  • Gast
[Wireless] Instellingen niet goed onthouden
« Gepost op: 2007/10/19, 18:52:03 »
Ik draai nu een tijdje Ubuntu Gutsy, en dit werkt op dit moment redelijk. Draadloze netwerkkaart wordt dit keer netjes herkent dus geen gezeur met ndiswrapper, maar ik nog wel een probleem. Als Ubuntu is opgestart en ik wil internetten dan kan ik niks doen. Kijk ik in mijn Network preferences dan zie ik wel dat alle settings zo staan als ze moeten staan. Voer ik 'sudo /etc/init.d/networking restart' uit dan wordt alles gewoon gedetecteerd en kan ik wel het internet op.
Mijn vraag is nu: Waarom wordt dit tijdens het opstarten niet netjes onthouden?

Hieronder een uitdraai van /etc/network/interfaces:
auto lo
iface lo inet loopback




iface eth0 inet dhcp












iface wlan0 inet dhcp
wireless-key HIERSTAATKEY
wireless-essid Mijnssid

auto wlan0

Offline theokus

  • Lid
  • Steunpunt: Nee
[Wireless] Instellingen niet goed onthouden
« Reactie #1 Gepost op: 2007/10/19, 21:41:52 »
Heb hier iets dergelijks.
Ik werk dus via een router (Belkin).

De netwerksleutel wordt niet onhouden...

Stel dat dit 7 letters en/of cijfers zijn en als ik dan Gutsy terug opstart
dan heb ik ook geen internetverbinding.
De sleutel is plots groter geworden > meer zwarte bolletjes dus i.p.v. die 7.

Ik voer dan de geldige sleutel weer in en ik kan weer internetten.
As good as it gets

StefSOFT

  • Gast
[Wireless] Instellingen niet goed onthouden
« Reactie #2 Gepost op: 2007/10/20, 01:27:25 »
Wat me trouwens opviel ik kreeg tijdens het opstarten het tekstscherm (of hoe je dat ook noemt) te zien, omdat hij een harde schijf moest checken en daar zag ik een melding van een failure van modprobe, kon zo snel niet lezen wat er precies stond, maar het leek of hij een bepaald device niet kon vinden. Kan dat er iets mee te maken hebben?

Offline Dominique Ramaekers

  • Lid
  • Steunpunt: Nee
[Wireless] Instellingen niet goed onthouden
« Reactie #3 Gepost op: 2007/10/20, 06:48:20 »
Kan wel, ik heb dat ook dat mijn ethernetkaartje niet goed ondersteund wordt. Het kaartje werkt wel maar de networkmanager vraagt om de haverklap naar mijn netwerksleutel.

Ik heb de networkmanager om manuele configuratie gezet... Ik kan dan wel niet meer roamen maar ja...

StefSOFT

  • Gast
[Wireless] Instellingen niet goed onthouden
« Reactie #4 Gepost op: 2007/10/20, 10:43:33 »
Citaat van: Dadio
Kan wel, ik heb dat ook dat mijn ethernetkaartje niet goed ondersteund wordt. Het kaartje werkt wel maar de networkmanager vraagt om de haverklap naar mijn netwerksleutel.

Ik heb de networkmanager om manuele configuratie gezet... Ik kan dan wel niet meer roamen maar ja...
Ja dat had ik dus ook, elke keer tijdens het opstarten de netwerksleutel moeten invoeren in nm-applet. Daarom dus ook in Network de settings gewoon ingevoerd en roaming uitgeschakeld, maar toch kan ik pas internetten naar het uitvoeren van 'sudo /etc/init.d/networking restart'

StefSOFT

  • Gast
[Wireless] Instellingen niet goed onthouden
« Reactie #5 Gepost op: 2007/10/22, 16:34:31 »
Heb het nu half opgelost door 'sudo /etc/init.d/networking restart' in mijn sessions te plaatsen. Een beetje een halve oplossing, maar het werkt prima.

Offline oemoeta

  • Lid
  • Steunpunt: Nee
[Wireless] Instellingen niet goed onthouden
« Reactie #6 Gepost op: 2007/10/22, 22:12:21 »
Ik heb net hetzelfde probleem, kan je eens verduidelijken wat je hierboven schrijft om het op te lossen? (... in je sessions plaatsen)?

StefSOFT

  • Gast
[Wireless] Instellingen niet goed onthouden
« Reactie #7 Gepost op: 2007/10/23, 18:41:06 »
Mmm, wil ik net je vraag beantwoorden. Dus ik herstart mijn computer van Windows naar Ubuntu blijkt het niet eens goed te werken. De vorige keer dat ik het teste deed ik het door uit- en weer opnieuw in te loggen met mijn account, maar goed wat ik dus heb gedaan (wat dus niet werkt) is door System --> Preferences --> Sessions te openen. En daar een nieuwe opdracht aan toe te voegen d.m.v Add.
Er verschijnt dan een nieuw venster waar je het volgende kunt invullen:

Name: Netwerk restart (naam kun je zelf verzinnen)
Command: sudo /etc/init.d/networking restart
Comment: (Kun je zelf een opmerking toevoegen)

Op het moment dat jij inlogt zou hij dan het commando tijdens het opstarten uit moeten voeren, maar helaas pakt hij hem niet als je het systeem helemaal opnieuw opstart. Mag je uberhaupt wel sudo-commando's gebruiken in je sessions?

Wat ik nu dus steeds doe als de computer is opgestart de terminal openen en dan het commando uit voeren. Je kunt ook testen of dat bij jou wel werkt, maar goed nu nog zien hoe ik het kan automatiseren.

Offline PeterF

  • Lid
  • Steunpunt: Nee
[Wireless] Instellingen niet goed onthouden
« Reactie #8 Gepost op: 2007/10/23, 20:37:55 »
Citaat van: StefSOFT
Mag je uberhaupt wel sudo-commando's gebruiken in je sessions?
Je moet een wachtwoord invoeren bij sudo, dit werkt in de terminal omdat deze tekst gebaseerd is maar in de grafische X omgeving kun je dan nergens je wachtwoord invoeren. Om het in je opstart te kunnen gebruiken moet je het commando gksudo gebruiken, dit heeft hetzelfde doel maar heeft een grafische invoer.

StefSOFT

  • Gast
[Wireless] Instellingen niet goed onthouden
« Reactie #9 Gepost op: 2007/10/23, 21:55:09 »
OK thanks, zal dat eens proberen.

StefSOFT

  • Gast
[Wireless] Instellingen niet goed onthouden
« Reactie #10 Gepost op: 2007/10/24, 10:59:27 »
Beste oplossing in een ander topic gevonden. Je moet '/etc/init.d/networking restart' plaatsen in het documentje /etc/rc.local. In dit documentje worden tijdens het opstarten je commando's als root uitgevoerd.

Korte handleiding:

Open het documentje als root: sudo /etc/rc.local
Voer wachtwoord in;
Voer net boven exit 0 de volgende code in: /etc/init.d/networking restart

Et voila, nu kun ja nadat de computer is opgestart, direct internetten.