Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: CNet CWP-854 (RT61) werkt niet meer na 7.04 upgrade  (gelezen 1933 keer)

pbb

  • Gast
CNet CWP-854 (RT61) werkt niet meer na 7.04 upgrade
« Gepost op: 2007/09/28, 22:05:03 »
Hallo allemaal!

Kan een van jullie me helpen met de setup van mijn CNet CWP-854 wireless? Ik had het werkende in 6.10, met behulp van een RT61 driver die van ralinktech.com.tw gedownload was en ik zelf moest compileren (zie http://ubuntuforums.org/showthread.php?t=296822). Maar, sinds de update van 7.04 geinstalleerd is, werkt het niet meer.

Ik heb een netwerk met vaste IP adressen (modem: 10.0.0.1, router: 10.0.0.2, ubuntu: 10.0.0.5). Ik had eerst encryptie (werkte onder 6.10), maar heb nu als test de encryptie uitgeschakeld. Netwerk wordt nu op MAC-code gefiltert.

De NetworkManager Applet zegt "No network connection", en met een klik erop "No network devices have been found / Manual configuration". Maar onder Manual Configuration is er geen netwerkkaart om te configureren.

lspci:
00:0a.0 Network controller: RaLink RT2561/RT61 rev B 802.11g

modprobe -l | grep rt61:
/lib/modules/2.6.20-16-generic/kernel/ubuntu/wireless/rt2x00/rt61pci.ko
/lib/modules/2.6.20-16-generic/kernel/drivers/net/rt61.ko

/etc/netwerk/interfaces:
auto ra0
iface ra0 inet static
address 10.0.0.5
netmask 255.255.255.0
gateway 10.0.0.1
wireless-essid pbb

sudo iwlist scan:
lo        Interface doesn't support scanning.
ra0       Scan completed :
          Cell 01 - Address: (...)
                    ESSID:"(...)"
                    Mode:Managed
                    Channel:6
                    Encryption key:on
                    Bit Rates:0 kb/s
          Cell 02 - Address: (...)
                    ESSID:"pbb"
                    Mode:Managed
                    Channel:11
                    Encryption key:off
                    Bit Rates:0 kb/s

(Dat met 0 kb/s lijkt mij niet in orde ?????)

iwconfig:
lo        no wireless extensions.
ra0       RT61 Wireless  ESSID:""  Nickname:""
          Mode:Auto  Frequency:2.412 GHz  Bit Rate=54 Mb/s  
          RTS thr:off   Fragment thr:off
          Encryption key:0123-4567-89

(geen ESSID ?????)

ifconfig ra0 10.0.0.5 netmask 255.255.255.0 up:
SIOCSIFNETMASK: No such device
10.0.0.5: ERROR while getting interface flags: No such device

ping 10.0.0.1:
From 10.0.0.5 icmp_seq=635 Destination Host Unreachable

-------------------

Ik heb ook de 7.4 live CD geprobeerd, en hier gaat het ietsje beter, maar niet veel.

NetworkManager Applet zegt weer "No network connection", maar met een klik erop krijg ik wel een lijst van alle draadloze accesspoints. Als ik het mijne aanklik, komt er een tijdje "Attempting to join the wireless network 'pbb'..." maar daarna stopt het weer. Dit zou kunnen zijn vanwege het vaste IP adres dat nodig is?
Als ik Manual Configuration uitvoer, lijk ik wel een netwerk te hebben (volgens het Applet), maar een ping 10.0.0.1 zegt "connect: Network is unreachable"

lspci:
00:0a.0 Network controller: RaLink RT2561/RT61 rev B 802.11g

modprobe -l | grep rt61:
/lib/modules/2.6.20-15-generic/kernel/ubuntu/wireless/rt2x00/rt61pci.ko
/lib/modules/2.6.20-15-generic/kernel/ubuntu/wireless/rt2x00-legacy/rt61/rt61.ko

/etc/network/interfaces:
iface ra0 inet static
address 10.0.0.5
netmask 255.255.255.0
gateway 10.0.0.1
wireless-essid pbb
auto ra0

sudo iwlist scan:
lo        Interface doesn't support scanning.
ra0       Scan completed :
          Cell 01 - Address: (...)
                    ESSID:"pbb"
                    Mode:Managed
                    Channel:11
                    Encryption key:off
                    Quality:56/100  Signal level:-63 dBm  Noise level:-256 dBm
          Cell 02 - Address: (...)
                    ESSID:"(...)"
                    Mode:Managed
                    Channel:6
                    Encryption key:on
                    Quality:0/100  Signal level:-73 dBm  Noise level:-256 dBm

----

Ik hoop dat iemand mij kan helpen, anders is het domweg weer afgelopen met Linux voor wat mij betreft. Ik had ook op de engelstalige Ubuntu forums gepost, en in 3 maanden tijd diverse keren mijn bericht weer naar boven gepust, maar heb letterlijk geen enkele reactie gekregen!

Groetjes, Peter

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
CNet CWP-854 (RT61) werkt niet meer na 7.04 upgrade
« Reactie #1 Gepost op: 2007/09/28, 22:09:59 »
Ralink chipset? Eenvoudige oplossing:
http://siegie.sin.khk.be/wordpress/2007/04/16/rt2500usb-en-network-manager/

Over drie weken is dat probleem waarschijnlijk verdwenen, want dan komt Ubuntu 7.10 uit, en die heeft (als de berichten kloppen) geen enkele moeite met Ralink chipsets.

Groet, Pjotr.

pbb

  • Gast
CNet CWP-854 (RT61) werkt niet meer na 7.04 upgrade
« Reactie #2 Gepost op: 2007/09/28, 22:32:59 »
Het grootste probleem is, dat ik op de harddisk geen wireless network entry heb onder de manuele configuratie!
Wel op de Live CD, ik zal morgen gelijk eens een sudo /etc/init.d/networking restart proberen na de configuratie.

pbb

  • Gast
CNet CWP-854 (RT61) werkt niet meer na 7.04 upgrade
« Reactie #3 Gepost op: 2007/10/02, 10:17:38 »
Ok, volgend is het antwoord wat ik krijg wanneer ik een sudo /etc/init.d/networking restart doe, op de 7.04 Live CD:

Citaat
ubuntu@ubuntu:~$ sudo /etc/init.d/networking restart
 * Reconfiguring network interfaces...                                          eth0: ERROR while getting interface flags: No such device
There is already a pid file /var/run/dhclient.eth0.pid with pid 134993416
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

SIOCSIFADDR: No such device
eth0: ERROR while getting interface flags: No such device
eth0: ERROR while getting interface flags: No such device
Bind socket to interface: No such device
Failed to bring up eth0.
eth1: ERROR while getting interface flags: No such device
There is already a pid file /var/run/dhclient.eth1.pid with pid 134993416
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

SIOCSIFADDR: No such device
eth1: ERROR while getting interface flags: No such device
eth1: ERROR while getting interface flags: No such device
Bind socket to interface: No such device
Failed to bring up eth1.
eth2: ERROR while getting interface flags: No such device
There is already a pid file /var/run/dhclient.eth2.pid with pid 134993416
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

SIOCSIFADDR: No such device
eth2: ERROR while getting interface flags: No such device
eth2: ERROR while getting interface flags: No such device
Bind socket to interface: No such device
Failed to bring up eth2.
ath0: ERROR while getting interface flags: No such device
There is already a pid file /var/run/dhclient.ath0.pid with pid 134993416
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

SIOCSIFADDR: No such device
ath0: ERROR while getting interface flags: No such device
ath0: ERROR while getting interface flags: No such device
Bind socket to interface: No such device
Failed to bring up ath0.
wlan0: ERROR while getting interface flags: No such device
There is already a pid file /var/run/dhclient.wlan0.pid with pid 134993416
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

SIOCSIFADDR: No such device
wlan0: ERROR while getting interface flags: No such device
wlan0: ERROR while getting interface flags: No such device
Bind socket to interface: No such device
Failed to bring up wlan0.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
CNet CWP-854 (RT61) werkt niet meer na 7.04 upgrade
« Reactie #4 Gepost op: 2007/10/02, 10:37:09 »
En probeer de LiveCD van 7.10 Gutsy Gibbon eens, in de bètaversie? Als het goed is, heb je in de LiveCD-sessie meteen al draadloos internet (klikken op terminalsymbooltje rechtsbovenin, in de werkbalk).

Hier haal je de bèta:
ftp://ftp.tudelft.nl/pub/Linux/releases.ubuntu.com/7.10/ubuntu-7.10-beta-desktop-i386.iso

rossemiel

  • Gast
CNet CWP-854 (RT61) werkt niet meer na 7.04 upgrade
« Reactie #5 Gepost op: 2007/10/02, 13:39:14 »
Zit al maanden met hetzelfde probleem. Ik heb thuis twee desktops met een D-LINK DWL-g510 pci kaart (chipset Ralink RT2561). Met Feisty heb ik wpa een tijdje aan het draaien gekregen maar deze liep dan soms vast. Onder Gutsy Gibbon krijg ik helemaal geen verbinding (kan wel het netwerk zien). Heb al zeker twintig verschillende howto's gevolg, steeds zonder succes. Zelfs met ndiswrapper lukt het niet. Ik heb allerlei distributies geprobeerd (Fedora, Gentoo, PCLinuxos, Debian, Suse, Debian...) niets helpt.

Ik begrijp niet dat men er niet in slaagt om een werkende driver voor deze kaart te maken. Het ergste van alles is dat de FFS (free sofware foundation) deze fabrikant aanbeveeld omdat zij hun drivers als open source releasen. Dat deze drivers absoluut niet deugen en dat de communitie er niet in slaagt een goed alternatief te voorzien vergeten ze te vermelden.

pbb

  • Gast
CNet CWP-854 (RT61) werkt niet meer na 7.04 upgrade
« Reactie #6 Gepost op: 2007/10/02, 17:21:24 »
Goed nieuws (voor mij dan); ik heb de netwerkverbinding eindelijk aan de praat in 7.10 beta!

Nu ga ik studeren hoe ik /home op een aparte partitie kan zetten, en gaan we een clean reinstall doen...

Offline balsat

  • Lid
  • Steunpunt: Nee
CNet CWP-854 (RT61) werkt niet meer na 7.04 upgrade
« Reactie #7 Gepost op: 2007/10/21, 21:30:50 »
ik zit ook met dat rt 2561 probleem onder feisty werkte die dan zou je toch zeggen dat daar een goeie driver in zit maar nu in gatsi gibbon werkt het voor geen meter
het schijnt te werken met windows drivers maar hoe weet ik niet precies
die drivers eb ik niet
ubuntu voor human beings ben ik zeker niet human is wel heel moeilijk

pbb

  • Gast
CNet CWP-854 (RT61) werkt niet meer na 7.04 upgrade
« Reactie #8 Gepost op: 2007/10/21, 23:02:25 »
Ja, en nu heb ik weer het probleem dat de setup van 7.10 hangt bij 15% (detecting file systems, ofzo)!!! :-(