Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: mplayer  (gelezen 1159 keer)

Offline mark_v_p

  • Lid
  • Steunpunt: Nee
mplayer
« Gepost op: 2007/09/18, 16:56:52 »
hoi,
ik heb ubuntu 7.04 opnieuw geistalleerd en tot mijn grote verbazing krijg ik mplayer niet aan de praat. deze weigert om mpg, wmv en alle andere af te spele. w32 codec is toch geistalleerd.

kan iemand me effe helpen aub ...



mvg Mark

Offline Steven Klein Haneveld

  • Lid
  • Steunpunt: Nee
mplayer
« Reactie #1 Gepost op: 2007/09/18, 21:04:37 »
Jawel :-)
Heb je deze handleiding helemaal doorlopen?
https://help.ubuntu.com/community/NlMultimediaapplicaties
met dank aan Pjotr123 :-)

Dat zou een boel moeten helpen!

Offline Typhoner

  • Lid
    • http://typhoner.blogspot.com/
  • Steunpunt: Nee
mplayer
« Reactie #2 Gepost op: 2007/09/18, 21:15:55 »
mplayer is toch onafhankelijk van externe codecs?
Hij heeft toch alles standaard bij?

Offline Steven Klein Haneveld

  • Lid
  • Steunpunt: Nee
mplayer
« Reactie #3 Gepost op: 2007/09/19, 14:17:18 »
Ik dacht het niet, Typhoner.
Maar ik kan me vergissen.

Offline mark_v_p

  • Lid
  • Steunpunt: Nee
mplayer
« Reactie #4 Gepost op: 2007/09/20, 22:58:34 »
heb die hele resum doorlopen en in xine wordt wel alles afgespeeld.
snap er nix van ...

Offline happyhamster

  • Lid
  • Steunpunt: Nee
mplayer
« Reactie #5 Gepost op: 2007/09/20, 23:55:36 »
Na een nieuwe installatie doe ik het als volgt (als de codecs al geinstalleerd zijn kan je stap 1 en 2 overslaan):

1. Zorg dat je alle normale codecs hebt geinstalleerd (gaat meestal automatisch als je totem een avi of mkv file laat openen.

2. Installeer extra codecs (o.a. voor dvd-decryptie):
- Voeg eerst de benodigde repositories toe. In een terminal, tik (of copy & paste):

sudo cp /etc/apt/sources.list /etc/apt/sources.old

- om een backup te maken. Vervolgens:

gksudo gedit /etc/apt/sources.list

- Aan het eind van de tekstfile, copy & paste:

## Medibuntu - Ubuntu 7.04 "feisty fawn"
## Please report any bug on https://launchpad.net/products/medibuntu/+bugs
deb http://packages.medibuntu.org/ feisty free non-free

- Save en verlaat de teksteditor.

- Voeg de sleutel toe om deze repos zonder problemen te kunnen gebruiken. In een terminal:

wget -q http://packages.medibuntu.org/medibuntu-key.gpg -O- | sudo apt-key add -


- Vernieuw de softwarepakketten lijst:

sudo apt-get update

- Installeer de codecs:

sudo apt-get install libdvdcss2 w32codecs

3. Start mplayer (het volgende kan misschien afhangen van het type video- en geluidskaart).
- Klik met de rechtermuisknop en kies Preferences.
- Kies Video en selecteer de xv driver.
- Kies Codecs en selecteer FFmpeg's libavcodec voor video en audio
- Kies Misc. en controleer of de DVD en CD-rom devices juist staan aangegeven (in mijn geval /dev/hda). Je kan dit controleren via:

cat /etc/fstab

- Kies OK en sluit mplayer af.

4. *Alleen* indien je gebruik maakt van een widescreen monitor: voeg zelf de beeldschermverhouding toe (aspect ratio), want mplayer zelf detecteert dit niet (een bug).

gksudo gedit ~/.mplayer/config

- En copy & paste:

monitoraspect = "1.6"

- (of een andere waarde, afhankelijk van de afmetingen van je widescreen).

- Save en exit.

5. Eventueel: mplayer de standaard player maken: right-click een .avi file en kies Properties-->Open With, en vink mplayer aan. Indien mplayer niet in de lijst staat, dan toevoegen via Add. Staat mplayer ook daar niet genoemd, dan toevoegen met "Use a custom command" en tik

gmplayer

Offline mark_v_p

  • Lid
  • Steunpunt: Nee
mplayer
« Reactie #6 Gepost op: 2007/09/23, 22:37:49 »
nu werkt het
thx


Mark