Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: libc6  (gelezen 663 keer)

Offline Eddie

  • Lid
  • Steunpunt: Nee
libc6
« Gepost op: 2007/09/16, 16:50:11 »
Hallo allemaal,

Ik heb gisteren op mijn nieuwe desktop Ubuntu 7.04 geinstalleerd met een realtime kernel (2.6.22) en de Con Kolivas CK-1 patch. Nu heb ik voor een realtime applicatie  'schedtool' nodig, vooraf gegaan door libc6. Als ik de laatste installeer krijg ik de melding: 'already the newest version'. Bij het installeren van schedtool volgt: 'schedtool depends on libc6(>=2.5-5); however: version libc6 on system is 2.5-0ubuntu14'. Daarna heb ik libc6_2.6.1-4_i386.deb opgehaald. Als ik deze open dan volgt: 'broken dependencies, run: "apt-get install -f"'. Daarna lijkt het installeren van beide goed te gaan. ('setting up libc6 (2.6.1-4)' en 'setting up schedtool (1.2.9-4)' zonder verdere meldingen).

Daarna heb ik nog geprobeerd: 'apt-get install cpufrequtils', dan volgt: 'unmet dependencies libc6'. Dit is geen essentieel onderdeel dus heb ik niet verder geprobeerd om dit geinstalleerd te krijgen.

Als ik nu een script run met schedtool, dan volgt: 'ERROR: schedtool: Could not exec sndfile-resample - no such file or directory'.

Op mijn vorige systeem, een laptop werkte dit allemaal probleemloos, geinstalleerd begin juli dit jaar . Op debian.org heb ik iets zien staan over bugs i.v.m. libc6(>=2.5-5). Dit hielp me helaas niet verder. Suggesties?

M.vr.gr.
Eddie

Offline happyhamster

  • Lid
  • Steunpunt: Nee
libc6
« Reactie #1 Gepost op: 2007/09/16, 17:11:30 »
Hoi. Dat lijkt op de soort problemen die optreden bij een half-geupgrade systeem. Feisty (Ubuntu 7.04) werkt met kernel 2.6.20, en Gutsy (7.10, nog in alpha testing) werkt met 2.6.22. Gutsy gebruikt bijv. libc6 versie 2.6.1.

Dus misschien helpt het om te kiezen voor Feisty/2.6.20 of Gutsy/2.6.22. (De beta van Gutsy verschijnt 27 september.)

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
libc6
« Reactie #2 Gepost op: 2007/09/16, 17:15:01 »
Waar heb je die .deb van libc6 vandaan?
libc6 is een essentieel stuk software voor je systeem, en zomaar een andere versie of een versie voor een andere distro gebruiken levert zeer waarschijnlijk problemen op.

De libc6 van Gutsy kan je niet in Feisty gebruiken of andersom.

Offline Eddie

  • Lid
  • Steunpunt: Nee
libc6
« Reactie #3 Gepost op: 2007/09/16, 23:10:54 »
Alvast bedankt voor de aanwijzingen. Ik zal proberen e.e.a. uit te zoeken, helaas lukt dat niet op korte termijn.

Offline Eddie

  • Lid
  • Steunpunt: Nee
libc6
« Reactie #4 Gepost op: 2007/09/18, 21:12:12 »
Kan iemand enig advies geven om dit handig aan te pakken? Die 2.6.22 maar helemaal verwijderen? Ik weet niet hoe dat gaat zonder risico dat ik ook dingen ten onrechte verwijder. En dan overnieuw beginnen en goed opletten dat ik de 2.6.20 neem met bijbehorende lib6c?


M.vr.gr.
Eddie