Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [Sitecom Wireless] Vraag  (gelezen 1473 keer)

Offline Julian

  • Lid
  • Steunpunt: Nee
[Sitecom Wireless] Vraag
« Gepost op: 2007/09/10, 17:01:30 »
Beste mensen,
ik zit nu eigenlijk al een tijd met hetzelfde probleem, en wilde daar nu eigenlijk opheldering over wat en hoe.
Ik heb een Sitecom Wireless netwerk adapter (type WL-115v2) en ik krijg maar geen verbinding met de router/internet.
Ik heb vanalles geprobeerd, van handmatig de instellingen opgeven tot die NDIS wrapper, maar niets helpt.
Nu wil ik nogmaals proberen om (K)ubuntu te installeren, en wilde eigenlijk vragen of er iemand is die stap-voor-stap kan uitleggen wat ik nou moet doen om die netwerkadapter werkende te krijgen.
De router zegt dat mijn PC verbinding heeft, maar ik kan geen enkele site e.d. openen.

Offline PeterF

  • Lid
  • Steunpunt: Nee
[Sitecom Wireless] Vraag
« Reactie #1 Gepost op: 2007/09/10, 20:15:46 »
Ik heb geen idee wat voor kaart dit is en kan dus ook geen echte howto geven.

Een start is uitvinden wat voor chipset de kaart gebruikt met "lspci" (voor on-board en pcmcia kaarten) of "lsusb" voor usb kaarten. Wanneer dit een resultaat geeft kun je op de Ubuntu wiki pagina's verder zoeken naar een Howto.

Offline mcgyver

  • Lid
  • Steunpunt: Nee
[Sitecom Wireless] Vraag
« Reactie #2 Gepost op: 2007/09/11, 13:05:55 »
chipset: rt2500 (tenminste, de wl-115) ik weet niet of de v2 dat ook heeft. bij mij werkt ie out of the box, wordt bij installatie direct herkend.

Offline Julian

  • Lid
  • Steunpunt: Nee
[Sitecom Wireless] Vraag
« Reactie #3 Gepost op: 2007/09/11, 20:20:27 »
De chipset van mijn WLan is een RT2561 (RT61). Hij wordt wel herkent, maar hij blijft steken bij het verbinding maken bij "Configuratie toepassen" of zoiets (bij 28%).
Ik heb die Wiki doorlopen, maar ik krijg foutmeldingen als ik doe wat daar staat, maar ik zal het zo nog eens proberen, en die foutmeldingen posten (zit hier nu aan een draadje te internetten :P)

edit: nogmaals geprobeerd, dit is de uitkomst:

julian@JT-01:~/RT61_Linux_STA_Drv1.1.0.0/Module$ make all
make -C /lib/modules/2.6.20-16-generic/build SUBDIRS=/home/julian/RT61_Linux_STA_Drv1.1.0.0/Module modules
make[1]: Map '/usr/src/linux-headers-2.6.20-16-generic' wordt binnengegaan
  CC [M]  /home/julian/RT61_Linux_STA_Drv1.1.0.0/Module/rtmp_main.o
/home/julian/RT61_Linux_STA_Drv1.1.0.0/Module/rtmp_main.c: In functie ‘RT61_probe’:
/home/julian/RT61_Linux_STA_Drv1.1.0.0/Module/rtmp_main.c:197: fout: ‘struct net_device’ has no member named ‘get_wireless_stats’
/home/julian/RT61_Linux_STA_Drv1.1.0.0/Module/rtmp_main.c: In functie ‘RT61_open’:
/home/julian/RT61_Linux_STA_Drv1.1.0.0/Module/rtmp_main.c:326: let op: passing argument 2 of ‘request_irq’ from incompatible pointer type
make[2]: *** [/home/julian/RT61_Linux_STA_Drv1.1.0.0/Module/rtmp_main.o] Fout 1
make[1]: *** [_module_/home/julian/RT61_Linux_STA_Drv1.1.0.0/Module] Fout 2
make[1]: Map '/usr/src/linux-headers-2.6.20-16-generic' wordt verlaten
make: *** [all] Fout 2

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
[Sitecom Wireless] Vraag
« Reactie #4 Gepost op: 2007/09/11, 21:16:40 »
OK. Een Ralink chipset! Dan is hier de oplossing:
http://forum.ubuntu-nl.org/topic/14451

Offline PeterF

  • Lid
  • Steunpunt: Nee
[Sitecom Wireless] Vraag
« Reactie #5 Gepost op: 2007/09/11, 21:16:43 »
Gebruik je deze WIKI?

De eerste instructie geeft niet aan welke header geinstalleerd moet worden, de volgende wel:
sudo apt-get install linux-headers-$(uname -r) build-essential gccVolgens mij haal je niet de juiste driver voor jouw kaart op maar zou je deze gebruiken moeten (check de site:
wget http://www.ralinktech.com.tw/data/IS_Linux_STA_6x_D_1.1.1.0.tar.gzen dan de readme files in het archief lezen.

Pjotr was me voor en ik zou dat eerst testen.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
[Sitecom Wireless] Vraag
« Reactie #6 Gepost op: 2007/09/11, 21:18:20 »
Nee, gewoon doen wat ik boven jouw bijdrage schreef.
http://forum.ubuntu-nl.org/message/143096#p143096

 Veel makkelijker en helpt direct.

Offline Julian

  • Lid
  • Steunpunt: Nee
[Sitecom Wireless] Vraag
« Reactie #7 Gepost op: 2007/09/11, 21:30:16 »
Ik heb het geprobeerd. Het leek even of het lukte, in ieder geval kreeg ik een IP toegewezen, maar vervolgens werd de verbinding direct weer verbroken of zoiets.

edit: lol. heb dit bericht verzonden via wireless! :)
Probleem is dus opgelost!
Dank jullie wel! :)

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
[Sitecom Wireless] Vraag
« Reactie #8 Gepost op: 2007/09/11, 21:34:02 »
Mooi zo! Graag gedaan.  :-)