Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Grub error 5 na updates voor 7.04 i686 van 4 sept. 2007  (gelezen 865 keer)

Offline radiognome

  • Lid
  • Steunpunt: Nee
Grub error 5 na updates voor 7.04 i686 van 4 sept. 2007
« Gepost op: 2007/09/04, 22:10:33 »
Vandaag kwamen er een paar nieuwe updates binnen. Gewoon op install geklikt en na een tijdje zag ik dat ik de machine moest herstarten. Aangezien het de belangrijkste productie-server op mijn werk betreft, had ik tot 18:00 gewacht. Alles netjes afgesloten en reboot

GRUB error 5: Invalid or corrupted partition table!!!!!
HELP!!!!
Welke optie uit het GRUB menu ik ook kies (Kernel 2.6.15-nogwat of Kernel 2.6.26-20-nogwat), ik blijf de error krijgen.

Als ik opstart van de life-CD mount de drive met het os echter probleemloos, heeft een bootflag en alle GRUB-files lijken normaal. Zowel de bios als fstab en de hele rambam wijst allemaal in de juiste volgorde naar de juiste partities op de stukken hardware die aan de opgegeven aansluitingen van de SATA interface hangen. Parted en een andere disk-tool kunnen geen problemen vinden in de 'partition table', maar booten ho maar... Ben onverrichterzake en veel te laat maar naar huis gegaan om een pizza in de oven te gooien.

Iemand een idee, of een vergelijkbaar probleem? Ik zit echt goed in de rats. Natuurlijk is de laatste backup een paar geniale acties geleden, en zijn de deadlines kort.

vr.gr. Martin

Online Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Grub error 5 na updates voor 7.04 i686 van 4 sept. 2007
« Reactie #1 Gepost op: 2007/09/04, 22:15:47 »
Heb je hier iets aan?
http://forums.suselinuxsupport.de/index.php?showtopic=17507#

Hoe oud (en versleten) is je harde schijf eigenlijk?

Offline radiognome

  • Lid
  • Steunpunt: Nee
Grub error 5 na updates voor 7.04 i686 van 4 sept. 2007
« Reactie #2 Gepost op: 2007/09/04, 22:55:42 »
Citaat van: pjotr123
Heb je hier iets aan?
http://forums.suselinuxsupport.de/index.php?showtopic=17507#

Hoe oud (en versleten) is je harde schijf eigenlijk?
Bedankt voor je reactie. Ik zal morgen aan de slag gaan met het draadje dat je stuurde, al staat me bij dat fdisk ook geen errors vond. Ook heeft deze machine nooit aan windows geroken, en was het tot vandaag een frisse probleemloze 'UbuntuBak'.

Die schijf is amper een maandje oud..... Met deze nieuwe server wil ik proberen wat meer afstand van Redmond te nemen in onze software ontwikkeling. De baas weet nergens van (kan mijn experimenteer-tijd nergens op afboeken) maar het ding begon net onmisbaar te worden en eigenlijk was iedereen er blij mee.

De meeste data (virtual machines) staat op een software-raid van drie andere schijven, maar ik zie niet hoe binnen een dag op een verse schijf een omgeving kan inrichten die daar weer vrolijk gebruik van maakt.

Een collega mailde me net dit:
http://forum.ubuntu-fr.org/viewtopic.php?pid=1046433
Ik zal morgen melden wat het opleverde.

Martin

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Grub error 5 na updates voor 7.04 i686 van 4 sept. 2007
« Reactie #3 Gepost op: 2007/09/05, 02:18:00 »
Start eens op van de live cd, unmount de harde schijf, en voer sudo fsck /dev/hdxx uit.
/dev/hdxx moet je vervangen door de aanduiding van de partitie die je wil controleren.

Hoeveel schijven heb je eigenlijk in de server, en hoe zijn die onderverdeeld in partities?
Staan de master/slave instellingen goed (als dat van toepassing is), en staat de boot volgorde van de schijven goed in de bios?

Wordt er in /boot/grub/menu.lst verwezen naar UUID's of naar devices (/dev/hda, /dev/sda, etc.)? UUID's kunnen veranderd zijn na een verandering van de partitie.
Kan je de inhoud van /boot/grub/menu.lst en van /boot/grub/device.map hier plaatsen?

Offline radiognome

  • Lid
  • Steunpunt: Nee
Grub error 5 na updates voor 7.04 i686 van 4 sept. 2007
« Reactie #4 Gepost op: 2007/09/05, 09:23:26 »
Thanks Johanvd. Ik heb het probleem nog niet opgelost, maar jouw reactie legt wel weer wat dingen bloot.

fsck /dev/sdc1 zegt 'clean, 161709/18743296 files, 5658822/37475620 blocks'.

menu.lst bevat een aantal entry's als

title Ubuntu, kernel 2.6.20-16-generic
root (hd2,0)
kernel /boot/vmlinuz-2.6.20-16-generic root=UUID=aab22b91-4088-489a-b1f4-8add050fe24f ro quiet splash
initrd  /boot/initrd.img-2.6.20-16-generic
quiet
savedefault

Daar zit blijkbaar een UUID in...

device.map is heel simpel
(hd0) /dev/sda
(hd1) /dev/sdb
(hd2) /dev/sdc
(hd3) /dev/sdd

En dat klopt

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Grub error 5 na updates voor 7.04 i686 van 4 sept. 2007
« Reactie #5 Gepost op: 2007/09/05, 10:29:51 »
Met het commando sudo vol_id -u /dev/hdc1 kan je de UUID van die partitie achterhalen en kijken of die nog overeenkomt met wat in menu.lst staat.

Offline radiognome

  • Lid
  • Steunpunt: Nee
Grub error 5 na updates voor 7.04 i686 van 4 sept. 2007
« Reactie #6 Gepost op: 2007/09/05, 10:53:45 »
Net met het commando blkid uitgevonden dat dat UUID gewoon klopt.
Ondertussen hebben we hier met testdisk al een nieuw MBR geschreven en grub opnieuw geïnstalleerd, maar daardoor krijgen we weer precies dezelfde error 5.

Het frustrerende is dat GRUB het enige stukje software is dat problemen zegt te hebben met mijn opstartpartitie. Diverse disktools geven aan dat de partitie geheel in orde is.

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Grub error 5 na updates voor 7.04 i686 van 4 sept. 2007
« Reactie #7 Gepost op: 2007/09/05, 11:23:00 »
Dit stukje komt uit mijn menu.lst:
Citaat
## default grub root device
## e.g. groot=(hd0,0)
# groot=(hd0,0)
Verwijst groot bij jou naar (hd2,0)?

Heb je al geprobeerd om de UUID verwijzing te veranderen in /dev/hdc1?

Offline radiognome

  • Lid
  • Steunpunt: Nee
Grub error 5 na updates voor 7.04 i686 van 4 sept. 2007
« Reactie #8 Gepost op: 2007/09/05, 11:31:21 »
We hebben de schijf in een ander 64 bit's systeem gehangen en die boot door tot een terminal.... (weliswaar vol errormeldingen, aangezien alle hardware anders is...maar toch)

Waarschijnlijk dus een BIOS probleempje of iets met het moederbord van de compu.

Bedankt voor het meedenken

vr.gr. Martin