Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Virtualhost in Apache (Ubuntu Feisty Fawn)  (gelezen 3961 keer)

luktmeniet

  • Gast
Virtualhost in Apache (Ubuntu Feisty Fawn)
« Gepost op: 2007/08/28, 16:26:08 »
Het volgende is het geval.
Ik heb mijn site inclusief database lokaal geinstalleerd.
Ik heb draaien Ubuntu 7.04 met een LAMP-server.
Ik krijg de website alleen niet zichtbaar in mijn localhost omgeving.
Dit heeft te maken met het feit dat alles vanuit de database middels modules wordt ingeladen.
Ik moet dus volgens mij in de map etc/apache2/sites-enabled het default bestand aan moeten passen.

---------------------------------------------------------------------------------------------------------------------

NameVirtualHost *

   ServerAdmin webmaster@localhost
   
   DocumentRoot /var/www/
   
      Options FollowSymLinks
      AllowOverride None
   

   
      Options Indexes FollowSymLinks MultiViews
      AllowOverride None
      Order allow,deny
      allow from all
      # This directive allows us to have apache2's default start page
                # in /apache2-default/, but still have / go to the right place
                #RedirectMatch ^/$ /apache2-default/
   


   ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
   
      AllowOverride None
      Options ExecCGI -MultiViews +SymLinksIfOwnerMatch
      Order allow,deny
      Allow from all
   


   ErrorLog /var/log/apache2/error.log

   # Possible values include: debug, info, notice, warn, error, crit,
   # alert, emerg.
   LogLevel warn

   CustomLog /var/log/apache2/access.log combined
   ServerSignature On

    Alias /doc/ "/usr/share/doc/"
   
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
   




------------------------------------------------------------------------------------------------------------

Het configuratie bestand waar de site eerst stond ziet er als volgt uit:

------------------------------------------------------------------------------------------------------------

# ATTENTION!
# DO NOT MODIFY THIS FILE OR ANY PART OF IT. THIS CAN RESULT IN IMPROPER PLESK
# FUNCTIONING OR FAILURE, CAUSE DAMAGE AND LOSS OF DATA. IF YOU REQUIRE CUSTOM
# MODIFICATIONS TO BE APPLIED TO THE CONFIGURATION, PLEASE, PERFORM THEM IN THE
# FOLLOWING FILE(S):
# /var/www/vhosts/belspel.nl/conf/vhost.conf
# /var/www/vhosts/belspel.nl/subdomains//conf/vhost.conf


   ServerName   belspel.nl:80
   ServerAlias  www.belspel.nl
   UseCanonicalName Off
   ServerAdmin  "niels@belspel.net"
   DocumentRoot /var/www/vhosts/belspel.nl/httpdocs
   CustomLog  /var/www/vhosts/belspel.nl/statistics/logs/access_log plesklog
   ErrorLog   /var/www/vhosts/belspel.nl/statistics/logs/error_log

   UserDir /var/www/vhosts/belspel.nl/web_users

   
      SSLEngine off
   

   
   
      php_admin_flag engine on
      php_admin_value open_basedir "/var/www/vhosts/belspel.nl/httpdocs:/tmp"
   

   
      php_admin_flag engine on
      php_admin_value open_basedir "/var/www/vhosts/belspel.nl/httpdocs:/tmp"
   

      Options -Includes -ExecCGI
   

   
   
      AddType text/plain .php .php4 .php3 .phtml
      php_admin_flag engine off
   

   
      AddType text/plain .php .php5 .php4 .php3 .phtml
      php_admin_flag engine off
   

   

   Include /var/www/vhosts/belspel.nl/conf/vhost.conf



   ServerName   admin.belspel.nl:80
   ServerAdmin  "niels@belspel.net"
   DocumentRoot /var/www/vhosts/belspel.nl/subdomains/admin/httpdocs
   CustomLog  /var/www/vhosts/belspel.nl/statistics/logs/access_log plesklog
   ErrorLog   /var/www/vhosts/belspel.nl/statistics/logs/error_log
   
      SSLEngine off
   

   
   
      php_admin_flag engine on
      php_admin_value open_basedir "/var/www/vhosts/belspel.nl/subdomains/admin/httpdocs:/tmp"
   

   
      php_admin_flag engine on
      php_admin_value open_basedir "/var/www/vhosts/belspel.nl/subdomains/admin/httpdocs:/tmp"
   

      Options -Includes -ExecCGI
   

   Include /var/www/vhosts/belspel.nl/subdomains/admin/conf/vhost.conf



   ServerName   dev.belspel.nl:80
   ServerAdmin  "niels@belspel.net"
   DocumentRoot /var/www/vhosts/belspel.nl/subdomains/dev/httpdocs
   CustomLog  /var/www/vhosts/belspel.nl/statistics/logs/access_log plesklog
   ErrorLog   /var/www/vhosts/belspel.nl/statistics/logs/error_log
   
      SSLEngine off
   

   
   
      php_admin_flag engine on
      php_admin_value open_basedir "/var/www/vhosts/belspel.nl/subdomains/dev/httpdocs:/tmp"
   

   
      php_admin_flag engine on
      php_admin_value open_basedir "/var/www/vhosts/belspel.nl/subdomains/dev/httpdocs:/tmp"
   

      Options -Includes -ExecCGI
   





-------------------------------------------------------------------------------------------------------------

Nu is linux voor mij helemaal nieuw en lukt het mij niet om deze site met subdomains zichtbaar te krijgen in mijn lokale omgeving.

Wat moet ik doen om dit voor elkaar te krijgen.
P.S. ik heb lokaal ook geen plesk draaien.

joepie

  • Gast
Virtualhost in Apache (Ubuntu Feisty Fawn)
« Reactie #1 Gepost op: 2007/08/28, 17:19:28 »
In elk geval *:80 gebruiken bij alle hosts, mixed mode is niet toegestaan (alleen *) als je bij een deel :80 (port 80) toevoegd , dan bij alle hosts poortnummer toevoegen. 80 of 443
NameVirtualHost *

    ServerAdmin webmaster@localhost

luktmeniet

  • Gast
Virtualhost in Apache (Ubuntu Feisty Fawn)
« Reactie #2 Gepost op: 2007/08/28, 17:36:16 »
Goedemiddag Joepie,

Waar ik momenteel dus een IP-adres heb staan van de oude lokatie:



Moet ik van maken :

?

En hoe zit het dan met dat ik nu lokaal wil draaien op IP-adres 127.0.0.1 localhost ?
moet ik verder nog wat met deze regel doen?

CustomLog  /var/www/vhosts/belspel.nl/statistics/logs/access_log plesklog

Aangezien ik lokaal geen Plesk heb draaien.

joepie

  • Gast
Virtualhost in Apache (Ubuntu Feisty Fawn)
« Reactie #3 Gepost op: 2007/08/28, 17:45:15 »
omgekeerd, anders zou je 4 x een gelijke naam geven.

Bovenaan beginnen :

aanpassen in default:

NameVirtualHost *:80


=============
Mijn default ziet er zo uit:

NameVirtualHost *:80

(alles doe ik per host)

joepie

  • Gast
Virtualhost in Apache (Ubuntu Feisty Fawn)
« Reactie #4 Gepost op: 2007/08/28, 17:50:57 »
je hebt wel gelijk, kan bij elke host het ipnummer weghalen
wordt dan

joepie

  • Gast
Virtualhost in Apache (Ubuntu Feisty Fawn)
« Reactie #5 Gepost op: 2007/08/28, 17:56:18 »
heb je voor de virtual hosts een aparte conf file aangemaakt ?

zoals
/etc/apache2/sites-available/ dev.belspel.nl.conf
/etc/apache2/sites-enabled/ dev.belspel.nl.conf

(voor elke host)

sudo nano /etc/apache2/sites-available/dev.belspel.nl.conf

    ServerName   dev.belspel.nl:80
    ServerAdmin  "niels@belspel.net"
    DocumentRoot /var/www/vhosts/belspel.nl/subdomains/dev/httpdocs
#    CustomLog  /var/www/vhosts/belspel.nl/statistics/logs/access_log plesklog
#   ErrorLog   /var/www/vhosts/belspel.nl/statistics/logs/error_log
   
        SSLEngine off
   

   
   
        php_admin_flag engine on
        php_admin_value open_basedir "/var/www/vhosts/belspel.nl/subdomains/dev/httpdocs:/tmp"
   

   
        php_admin_flag engine on
        php_admin_value open_basedir "/var/www/vhosts/belspel.nl/subdomains/dev/httpdocs:/tmp"
   

        Options -Includes -ExecCGI
   



Ctrl-O
Ctrl-X
cp /etc/apache2/sites-available/ dev.belspel.nl.conf /etc/apache2/sites-enabled/ dev.belspel.nl.conf

luktmeniet

  • Gast
Virtualhost in Apache (Ubuntu Feisty Fawn)
« Reactie #6 Gepost op: 2007/08/28, 18:00:07 »
Nee nog niet is dat wel beter dan.
Op de webserver is er wel een aparte map conf met daarin het volgende:

----------------------------------------------------------------------------------

# ATTENTION!
# DO NOT MODIFY THIS FILE OR ANY PART OF IT. THIS CAN RESULT IN IMPROPER PLESK
# FUNCTIONING OR FAILURE, CAUSE DAMAGE AND LOSS OF DATA. IF YOU REQUIRE CUSTOM
# MODIFICATIONS TO BE APPLIED TO THE CONFIGURATION, PLEASE, PERFORM THEM IN THE
# FOLLOWING FILE(S):
# /var/www/vhosts/belspel.nl/conf/vhost.conf
# /var/www/vhosts/belspel.nl/subdomains//conf/vhost.conf


    ServerName   belspel.nl:80
    ServerAlias  www.belspel.nl
    UseCanonicalName Off
    ServerAdmin  "niels@belspel.net"
    DocumentRoot /var/www/vhosts/belspel.nl/httpdocs
    CustomLog  /var/www/vhosts/belspel.nl/statistics/logs/access_log plesklog
    ErrorLog   /var/www/vhosts/belspel.nl/statistics/logs/error_log

    UserDir /var/www/vhosts/belspel.nl/web_users

   
        SSLEngine off
   

   
   
        php_admin_flag engine on
        php_admin_value open_basedir "/var/www/vhosts/belspel.nl/httpdocs:/tmp"
   

   
        php_admin_flag engine on
        php_admin_value open_basedir "/var/www/vhosts/belspel.nl/httpdocs:/tmp"
   

        Options -Includes -ExecCGI
   

   
   
        AddType text/plain .php .php4 .php3 .phtml
        php_admin_flag engine off
   

   
        AddType text/plain .php .php5 .php4 .php3 .phtml
        php_admin_flag engine off
   

   

    Include /var/www/vhosts/belspel.nl/conf/vhost.conf



    ServerName   admin.belspel.nl:80
    ServerAdmin  "niels@belspel.net"
    DocumentRoot /var/www/vhosts/belspel.nl/subdomains/admin/httpdocs
    CustomLog  /var/www/vhosts/belspel.nl/statistics/logs/access_log plesklog
    ErrorLog   /var/www/vhosts/belspel.nl/statistics/logs/error_log
   
        SSLEngine off
   

   
   
        php_admin_flag engine on
        php_admin_value open_basedir "/var/www/vhosts/belspel.nl/subdomains/admin/httpdocs:/tmp"
   

   
        php_admin_flag engine on
        php_admin_value open_basedir "/var/www/vhosts/belspel.nl/subdomains/admin/httpdocs:/tmp"
   

        Options -Includes -ExecCGI
   

    Include /var/www/vhosts/belspel.nl/subdomains/admin/conf/vhost.conf



    ServerName   dev.belspel.nl:80
    ServerAdmin  "niels@belspel.net"
    DocumentRoot /var/www/vhosts/belspel.nl/subdomains/dev/httpdocs
    CustomLog  /var/www/vhosts/belspel.nl/statistics/logs/access_log plesklog
    ErrorLog   /var/www/vhosts/belspel.nl/statistics/logs/error_log
   
        SSLEngine off
   

   
   
        php_admin_flag engine on
        php_admin_value open_basedir "/var/www/vhosts/belspel.nl/subdomains/dev/httpdocs:/tmp"
   

   
        php_admin_flag engine on
        php_admin_value open_basedir "/var/www/vhosts/belspel.nl/subdomains/dev/httpdocs:/tmp"
   

        Options -Includes -ExecCGI
   



---------------------------------------------------------------------------

Dat is dus per subdomain, maar ik zit nu niet meer bij die host.
wil de site dus hier lokaal draaiende zien te krijgen.
moet het dus op een of andere manier draaiende zien te krijgen binnen lokale apache in  samenspraak met reeds gemaakte config bestanden zie 0.a. in deze post.

P.S. die :80 achter de default zetten heeft niet gewerkt of moet ik dan eerst apache opnieuw opstarten?

joepie

  • Gast
Virtualhost in Apache (Ubuntu Feisty Fawn)
« Reactie #7 Gepost op: 2007/08/28, 18:00:09 »
logfiles:
CustomLog  /var/www/vhosts/belspel.nl/statistics/logs/access_log plesklog

De file zelf zal niet aangemaakt zijn op je server, zet er even een # voor.
zoals
#CustomLog  /var/www/vhosts/belspel.nl/statistics/logs/access_log plesklog
#ErrorLog   /var/www/vhosts/belspel.nl/statistics/logs/error_log

Dan wordt alles weer standaard in apache gelogd, wil je dat later weer opsplitsen, nieuwe logfiles aanmaken en dat in de virtualhost aangeven

joepie

  • Gast
Virtualhost in Apache (Ubuntu Feisty Fawn)
« Reactie #8 Gepost op: 2007/08/28, 18:10:02 »
En even opletten dat je document roots gelijk zijn in de nieuwe opstelling. of anders aanpassen.
DocumentRoot /var/www/vhosts/belspel.nl/subdomains/dev/httpdocs

luktmeniet

  • Gast
Virtualhost in Apache (Ubuntu Feisty Fawn)
« Reactie #9 Gepost op: 2007/08/28, 18:11:07 »
Ok heb hiervoor inmiddels # geplaatst.
En in de default bestand van apache :80 geplaatst achter de *.

Maar krijg nog steeds niks zichtbaar, moet ik het IP-adres nog aanpassen?
Aangezien ik nu lokaal alles draaiende wil krijgen op:
127.0.0.1 localhost ?

En moet ik na de aanpassingen de server opnieuw opstarten?

joepie

  • Gast
Virtualhost in Apache (Ubuntu Feisty Fawn)
« Reactie #10 Gepost op: 2007/08/28, 18:13:22 »
in elk geval apache herstarten om de nieuwe instellingen te gebruiken, dan naar de log files om te zien of er problernen zijn

luktmeniet

  • Gast
Virtualhost in Apache (Ubuntu Feisty Fawn)
« Reactie #11 Gepost op: 2007/08/28, 18:14:47 »
ik neem aan dat ik onderstaande aanpassingen in default bestand in apache moet doen ?

DocumentRoot /var/www/vhosts/belspel.nl/subdomains/dev/httpdocs

joepie

  • Gast
Virtualhost in Apache (Ubuntu Feisty Fawn)
« Reactie #12 Gepost op: 2007/08/28, 18:15:38 »
heb je bij de andere hosts het ip nummer weggehaald ?

joepie

  • Gast
Virtualhost in Apache (Ubuntu Feisty Fawn)
« Reactie #13 Gepost op: 2007/08/28, 18:20:16 »
ik neem aan dat ik onderstaande aanpassingen in default bestand in apache moet doen ?

DocumentRoot /var/www/vhosts/belspel.nl/subdomains/dev/httpdocs


in default als je het daar laat staan, als je een aparte conf file gemaakt heb dan daar, voor de duidelijkheid, als je een aparte conf maakt in available/enabled dan het betreffende stuk uit de default file halen, anders wordt 2x dezelfde virtual server gedraaid

luktmeniet

  • Gast
Virtualhost in Apache (Ubuntu Feisty Fawn)
« Reactie #14 Gepost op: 2007/08/28, 18:20:17 »
Nee daar staat dit nog :



P.S. misschien een stomme vraag maar hoe geef ik die server een schop?

Probeerde in de terminal:

sudo /etc/apache2 force-reload

Maar zonder resultaat.

joepie

  • Gast
Virtualhost in Apache (Ubuntu Feisty Fawn)
« Reactie #15 Gepost op: 2007/08/28, 18:21:49 »
ok, alle ip nummers weghalen

 wordt een keer of 4 geloof ik

B. op een stoel klimmen voor de juiste hoogte en dan uithalen.

joepie

  • Gast
Virtualhost in Apache (Ubuntu Feisty Fawn)
« Reactie #16 Gepost op: 2007/08/28, 18:24:16 »
probeer:
/etc/init.d/apache2 start

luktmeniet

  • Gast
Virtualhost in Apache (Ubuntu Feisty Fawn)
« Reactie #17 Gepost op: 2007/08/28, 18:26:01 »
Ook aangepast.

Bedoelde de server opnieuw op te starten via de terminal :)

luktmeniet

  • Gast
Virtualhost in Apache (Ubuntu Feisty Fawn)
« Reactie #18 Gepost op: 2007/08/28, 18:29:38 »
Ok heb de apache webserver opnieuw gestart en krijg dan onderstaande melding:

 * Forcing reload of web server (apache2)...                                    apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
[Tue Aug 28 18:28:27 2007] [warn] NameVirtualHost *:80 has no VirtualHosts
apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
[Tue Aug 28 18:28:37 2007] [warn] NameVirtualHost *:80 has no VirtualHosts

joepie

  • Gast
Virtualhost in Apache (Ubuntu Feisty Fawn)
« Reactie #19 Gepost op: 2007/08/28, 18:31:00 »
/etc/init.d/apache2 force-reload

anders

sudo reboot ?

luktmeniet

  • Gast
Virtualhost in Apache (Ubuntu Feisty Fawn)
« Reactie #20 Gepost op: 2007/08/28, 18:33:51 »
Krijg dan deze melding :

 * Forcing reload of web server (apache2)...                                    Warning: DocumentRoot [/var/www/vhosts/belspel.nl/subdomains/dev/httpdocs] does not exist
Warning: DocumentRoot [/var/www/vhosts/belspel.nl/subdomains/dev/httpdocs] does not exist
apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
[Tue Aug 28 18:31:43 2007] [warn] NameVirtualHost *:80 has no VirtualHosts
Warning: DocumentRoot [/var/www/vhosts/belspel.nl/subdomains/dev/httpdocs] does not exist
Warning: DocumentRoot [/var/www/vhosts/belspel.nl/subdomains/dev/httpdocs] does not exist
apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
[Tue Aug 28 18:31:53 2007] [warn] NameVirtualHost *:80 has no VirtualHosts

joepie

  • Gast
Virtualhost in Apache (Ubuntu Feisty Fawn)
« Reactie #21 Gepost op: 2007/08/28, 18:35:42 »
goed, de eerste is bekend, FQDN staat niet goed ingesteld
/etc/hostname
sudo nano /etc/hostname
en check daar dat de hostname correct staat.
en  
als 2e.
/etc/hosts

joepie

  • Gast
Virtualhost in Apache (Ubuntu Feisty Fawn)
« Reactie #22 Gepost op: 2007/08/28, 18:36:42 »
kan je de inhoud van /etc/hosts even posten ?

luktmeniet

  • Gast
Virtualhost in Apache (Ubuntu Feisty Fawn)
« Reactie #23 Gepost op: 2007/08/28, 18:40:05 »
Bij hostname staat dit:

patrick-desktop

En dit bij hosts:

127.0.0.1       localhost
127.0.1.1       patrick-desktop

# The following lines are desirable for IPv6 capable hosts
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts

joepie

  • Gast
Virtualhost in Apache (Ubuntu Feisty Fawn)
« Reactie #24 Gepost op: 2007/08/28, 18:45:13 »
127.0.0.1 localhost  is goed
de 2e
127.0.1.1 server2.domein.nl  server2.domein.nl
de rest is goed,


server2.domein.nl MOET gelijk zijn aan de naam in /etc/hostname

Verder is het geloof ik niet zo'n punt, als apache de FQDN niet kan vinden pakt ie gewoon de naam van de server. Met googlen kom je er wel uit.