Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: isapnp problemen  (gelezen 1464 keer)

BartvStratum

  • Gast
isapnp problemen
« Gepost op: 2007/08/25, 23:39:43 »
Hallo,

vanavond voor het eerst een linux installatie gedaan (7.04). Netwerkkaart (ISA) werkte niet en na een lange zoektocht op het internet en dit forum aan het experimenteren gegaan. Ik ben eindje vooruit gekomen, maar loop uiteindelijk toch vast. Hopelijk kan iemand me hier verder mee helpen.

Isapnp is geïnstalleerd via het isapnptools.deb bestand en lijkt te werken. (linkje)

bart@BvSLinux704:~$ sudo -i
Password:
root@BvSLinux704:~# sudo isapnp
$Id: isapnp_main.l,v 1.26 2001/04/30 21:54:53 fox Exp $
Release isapnptools-1.26
enzenz.
Als ik daarna de volgende code draai lijkt alles nog te werken, alleen kan ik daarna het output bestand (isapnp.conf) nergens vinden!

root@BvSLinux704:~# sudo pnpdump
# $Id: pnpdump_main.c,v 1.27 2001/04/30 21:54:53 fox Exp $
# Release isapnptools-1.26
#
# This is free software, see the sources for details.
# This software has NO WARRANTY, use at your OWN RISK
#
# For details of the output file format, see isapnp.conf(5)
#
# For latest information and FAQ on isapnp and pnpdump see:
# http://www.roestock.demon.co.uk/isapnptools/
#
# Compiler flags:  -DREALTIME -DHAVE_PROC -DENABLE_PCI -DHAVE_SCHED_SETSCHEDULER -DHAVE_NANOSLEEP -DWANT_TO_VALIDATE
#
# Trying port address 0273
# Board 1 has serial identifier e7 00 19 a4 7c 19 80 8c 4a

# (DEBUG)
(READPORT 0x0273)
(ISOLATE PRESERVE)
(IDENTIFY *)
(VERBOSITY 2)
(CONFLICT (IO FATAL)(IRQ FATAL)(DMA FATAL)(MEM FATAL)) # or WARNING

# Card 1: (serial identifier e7 00 19 a4 7c 19 80 8c 4a)
# Vendor Id RTL8019, Serial Number 1680508, checksum 0xE7.
# Version 1.0, Vendor version 1.0
# ANSI string -->Realtek Plug & Play Ethernet Card<--
#
# Logical device id RTL8019
#     Device supports I/O range check register
#
# Edit the entries below to uncomment out the configuration required.
# Note that only the first value of any range is given, this may be changed if required
# Don't forget to uncomment the activate (ACT Y) when happy

(CONFIGURE RTL8019/1680508 (LD 0
#     Compatible device id PNP80d6
#     Logical device decodes 10 bit IO address lines
#         Minimum IO base address 0x0220
#         Maximum IO base address 0x0380
#         IO base alignment 32 bytes
#         Number of IO addresses required: 32
# (IO 0 (SIZE 32) (BASE 0x0220) (CHECK))
#     IRQ 3, 4, 5, 9, 10, 11, 12 or 15.
#         High true, edge sensitive interrupt
# (INT 0 (IRQ 3 (MODE +E)))
 (NAME "RTL8019/1680508[0]{Realtek Plug & Play Ethernet Card}")
# (ACT Y)
))
# End tag... Checksum 0x00 (OK)

# Returns all cards to the "Wait for Key" state
(WAITFORKEY)
Ik heb al geprobeerd een voorbeeld isapnp.conf bestand (uit het installatiebestand) aan te passen door daar de output data van "pnpdump -c" (zie onderstaand voorbeeld) in te plakken maar hierbij krijg ik wanneer ik vervolgens het bestand oproep met "root@BvSLinux704:~# sudo isapnp /home/bart/isapnp.conf" alsnog errors.

# LD n = Logical device, ie write to reg 7
# IO n = IO descriptor n
# BASE n = IO/Mem address
# INT n = Interrupt req n
# IRQ n = Interrupt level
# MODE = line levels etc
# ACT = Activate

# (DEBUG)
(READPORT 0x0273)
(ISOLATE PRESERVE)
(IDENTIFY *)
(VERBOSITY 2)
(CONFLICT (IO FATAL)(IRQ FATAL)(DMA FATAL)(MEM FATAL)) # or WARNING

# Card 1: (serial identifier e7 00 19 a4 7c 19 80 8c 4a)
# Vendor Id RTL8019, Serial Number 1680508, checksum 0xE7.
# Version 1.0, Vendor version 1.0
# ANSI string -->Realtek Plug & Play Ethernet Card<--
#
# Logical device id RTL8019
#     Device supports I/O range check register
#
# Edit the entries below to uncomment out the configuration required.
# Note that only the first value of any range is given, this may be changed if required
# Don't forget to uncomment the activate (ACT Y) when happy

(CONFIGURE RTL8019/1680508 (LD 0
#     Compatible device id PNP80d6
#     Logical device decodes 10 bit IO address lines
#         Minimum IO base address 0x0220
#         Maximum IO base address 0x0380
#         IO base alignment 32 bytes
#         Number of IO addresses required: 32
#  (IO 0 (BASE 0x0220))
#     IRQ 3, 4, 5, 9, 10, 11, 12 or 15.
#         High true, edge sensitive interrupt
  (INT 0 (IRQ 3 (MODE +E)))
 (NAME "RTL8019/1680508[0]{Realtek Plug & Play Ethernet Card}")
  (ACT Y)
))
# End tag... Checksum 0x00 (OK)

# Returns all cards to the "Wait for Key" state
(WAITFORKEY)
het zou natuurlijk het makkelijkst zijn als ik het vers door isapnp geproduceerde isapnp.conf bestand kon vinden. In de documentatie lees ik dat het in usr/share/pnp/config_scripts/ zou moeten staan, maar in de map usr/share komt bij mij geen map pnp voor.

Als iemand een voorbeeld van zijn/ haar isapnp.conf bestand heeft dan kan ik dat eens vergelijken met de output die ik kreeg van "pnpdump -c". Grootste probleem daarbij is dat ik helaas nog niet weet wat I/O adres is..

Alle hulp is welkom!
Groeten,
Bart

BartvStratum

  • Gast
isapnp problemen
« Reactie #1 Gepost op: 2007/08/26, 13:29:10 »
Weer een klein stukje verder.

bart@BvSLinux704:~$ sudo -i
root@BvSLinux704:~# sudo pnpdump -c
# $Id: pnpdump_main.c,v 1.27 2001/04/30 21:54:53 fox Exp $
# Release isapnptools-1.26
#
# This is free software, see the sources for details.
# This software has NO WARRANTY, use at your OWN RISK
#
# For details of the output file format, see isapnp.conf(5)
#
# For latest information and FAQ on isapnp and pnpdump see:
# http://www.roestock.demon.co.uk/isapnptools/
#
# Compiler flags:  -DREALTIME -DHAVE_PROC -DENABLE_PCI -DHAVE_SCHED_SETSCHEDULER -DHAVE_NANOSLEEP -DWANT_TO_VALIDATE
#
# Trying port address 0273
# Board 1 has serial identifier e7 00 19 a4 7c 19 80 8c 4a

# (DEBUG)
(READPORT 0x0273)
(ISOLATE PRESERVE)
(IDENTIFY *)
(VERBOSITY 2)
(CONFLICT (IO FATAL)(IRQ FATAL)(DMA FATAL)(MEM FATAL)) # or WARNING

# Card 1: (serial identifier e7 00 19 a4 7c 19 80 8c 4a)
# Vendor Id RTL8019, Serial Number 1680508, checksum 0xE7.
# Version 1.0, Vendor version 1.0
# ANSI string -->Realtek Plug & Play Ethernet Card<--
#
# Logical device id RTL8019
#     Device supports I/O range check register
#
# Edit the entries below to uncomment out the configuration required.
# Note that only the first value of any range is given, this may be changed if required
# Don't forget to uncomment the activate (ACT Y) when happy

(CONFIGURE RTL8019/1680508 (LD 0
#     Compatible device id PNP80d6
#     Logical device decodes 10 bit IO address lines
#         Minimum IO base address 0x0220
#         Maximum IO base address 0x0380
#         IO base alignment 32 bytes
#         Number of IO addresses required: 32
  (IO 0 (SIZE 32) (BASE 0x0280) (CHECK))
#     IRQ 3, 4, 5, 9, 10, 11, 12 or 15.
#         High true, edge sensitive interrupt
  (INT 0 (IRQ 4 (MODE +E)))
 (NAME "RTL8019/1680508[0]{Realtek Plug & Play Ethernet Card}")
  (ACT Y)
))
# End tag... Checksum 0x00 (OK)

# Returns all cards to the "Wait for Key" state
(WAITFORKEY)
Hiermee zelf een isapnp1.conf bestand gemaakt:
READPORT 0x0273)
(ISOLATE PRESERVE)
(VERBOSITY 2)
(CONFLICT (IO FATAL))
(CONFIGURE RTL8019/1680508 (LD 0 (IO 0 (SIZE 32) (BASE 0x0280)) (INT 0 (IRQ 4 (MODE +E))) (NAME "RTL8019/1680508[0]{Realtek Plug & Play Ethernet Card}") (ACT Y)))
en vervolgens
root@BvSLinux704:~# sudo isapnp /home/bart/isapnp1.conf
RTL8019/1680508[0]{Realtek Plug & Play Ethernet Card}: Port 0x280; IRQ4 --- Enabled OK
root@BvSLinux704:~# sudo modprobe ne io=0x280 irq=4
Bij network connections zie ik nu naast 'modem connection' wat er vanaf de installatie al stond ook:
'wired connection (eth0), Adress: dhcp' en 'wired connection (eth1), Adress: dhcp'
Bij network settings zijn nu 2 ip-adressen bij gekomen, en bij 'search domains' is nu athome221.wau.nl bijgekomen. Echter nog steeds geen internet.....

Offline vliegje20

  • Lid
  • Steunpunt: Nee
isapnp problemen
« Reactie #2 Gepost op: 2007/08/26, 13:36:41 »
Als ik dit zo zie denk ik even 2 dingen:

Allereerst werk je met een realtek RTL8019 chipset. Daar is op dit forum al veel over te vinden

Als 2e zeg je
'search domains' is nu athome221.wau.nl kan ik hieruit opmaken dat je @home als provider hebt?

BartvStratum

  • Gast
isapnp problemen
« Reactie #3 Gepost op: 2007/08/26, 13:58:54 »
Citaat van: vliegje20
Als ik dit zo zie denk ik even 2 dingen:

Allereerst werk je met een realtek RTL8019 chipset. Daar is op dit forum al veel over te vinden

Als 2e zeg je
'search domains' is nu athome221.wau.nl kan ik hieruit opmaken dat je @home als provider hebt?
Ik zal eens verder gaan zoeken op "Realtek RTL8019".

Het internet hier in huis komt direct van de universiteit (Wageningen). Als ik één van de twee ip-adressen die ik onder network settings zag staan trace dan krijg ik de volgende uitvoer:

Hop   (ms)   (ms)   (ms)      IP Address   Host name
1   0   0   0      66.98.244.1   gphou-66-98-244-1.ev1servers.net
2   0   0   0      66.98.241.16   gphou-66-98-241-16.ev1servers.net
3   1   0   0      66.98.240.12   gphou-66-98-240-12.ev1servers.net
4   2   1   1      129.250.11.129   ge-1-11.r03.hstntx01.us.bb.gin.ntt.net
5   2   1   1      129.250.2.228   xe-0-1-0.r20.hstntx01.us.bb.gin.ntt.net
6   7   6   7      129.250.3.129   as-0.r20.dllstx09.us.bb.gin.ntt.net
7   49   42   42      129.250.5.25   p64-0-1-0.r21.asbnva01.us.bb.gin.ntt.net
8   36   35   35      208.51.6.33   so6-2-0-2488m.ar1.dca3.gblx.net
9   115   115   115      67.17.92.153   te2-1-10g.ar2.ams1.gblx.net
10   116   116   116      208.49.224.22   surfnet-3.ge-3-2-0.nar1.ams1.gblx.net
11   117   117   115      145.145.80.33   tf-500.xsr01.amsterdam2a.surf.net
12   119   119   119      145.145.6.98   wur-router.customer.surf.net
13   117   118   118      137.224.248.141   ict.wur.nl

BartvStratum

  • Gast
isapnp problemen
« Reactie #4 Gepost op: 2007/08/26, 14:39:06 »
Op dit forum vind ik met "realtek RTL8019", "RTL8019", enz geen berichten anders dan die van mezelf.
Op ubuntuforums.org vond ik het volgende draadje: http://ubuntuforums.org/showthread.php?t=140788&highlight=RTL8019
Ergens in dat draadje (bericht #6) komt hij met zijn oplossing. Als ik hetzelfde doe krijg ik:

bart@BvSLinux704:~$ sudo modprobe ne
bart@BvSLinux704:~$ sudo ifconfig -a
eth0      Link encap:Ethernet  HWaddr 52:54:40:25:4E:F6  
          inet addr:127.0.0.1  Bcast:127.255.255.255  Mask:255.0.0.0
          inet6 addr: fe80::5054:40ff:fe25:4ef6/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2038 errors:0 dropped:0 overruns:0 frame:0
          TX packets:139 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:191668 (187.1 KiB)  TX bytes:18662 (18.2 KiB)
          Interrupt:5 Base address:0x220

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:291 errors:0 dropped:0 overruns:0 frame:0
          TX packets:291 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:24276 (23.7 KiB)  TX bytes:24276 (23.7 KiB)
Echter het vervolg van zijn oplossing snap ik niet helemaal. Wat van het bovenstaande moet dan bij het IP-adres e.d. worden ingevuld?

Offline vliegje20

  • Lid
  • Steunpunt: Nee
isapnp problemen
« Reactie #5 Gepost op: 2007/08/26, 15:04:23 »
je bedoelt dit gedeelte:
1 System -> Administration -> Networking
 Appears the "Network settings" window;
2 In Connections Tab -> Select "Ethernet connection" -> Properties
3 On the new window I checked "Enable this connection"
4 I choose static IP address, then I filled up the spaces with necesary data;
5 Click OK
6 Click on DNS tab
7 Click Add and here I typed the 2 DNS what I have;
8 Click OK from the bottom of the window;
9 And, here it is.. the computer is responding at ping on it own IP; it's ping response from default gateway, and of course is ping response from www.yahoo.com
Ik heb het even genummerd

1 kijk bij systeem - beheer - netwerk
2 op tabblad verbindingen kies je connectie en dan eigenschappen
3 daar moet je iets aanvinken static ip pakken en alles invullen met de gegevens die je kreeg bij jouw uitvoer en hier weet ik even niet wat je precies in moet vullen

BartvStratum

  • Gast
isapnp problemen
« Reactie #6 Gepost op: 2007/08/26, 15:11:34 »
Hoi Vliegje,

bedankt voor je antwoord. Ik had de gegevens uit de uitvoer van ifconfig -a al op een aantal manieren ingevuld, maar zonder succes. Ik hoopte dat iemand hier precies wist wat waar moest staan.

BartvStratum

  • Gast
isapnp problemen
« Reactie #7 Gepost op: 2007/08/26, 17:15:25 »
zo ,mijn eerste berichtje vanuit linux! Het is uiteindelijk toch allemaal gelukt, in windows de juiste instellingen opgezocht en deze ingevoerd, werkte zo meteen.