Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Krijg Edirol UA-1EX USB externe geluidskaart niet werkend  (gelezen 4800 keer)

musicfreak

  • Gast
Krijg Edirol UA-1EX USB externe geluidskaart niet werkend
« Gepost op: 2007/08/20, 18:40:26 »
Ik heb een externe geluidskaart van Edirol, de UA-1EX. Op de Edirol/Roland site staan alleen drivers voor Windows en Mac OS.

Van een buurman heb ik de volgende instructie gekregen om de geluidskaart onder linux te laten werken:
***
Doe deze kaart in de computer en vervolgens commando zonder pijltjes om de kerneldriver te laden. (mogelijk laadt de linux kernel deze driver automatisch na het insteken van de kaart, dat kan je controleren met het commando )

Je ziet dan een lijst met geladen kernelmodules, kijk vervolgens of je de module snd_card_usd_audio> ziet
***

Dit gaat goed, ik zie de module.

***
Met het commando kan je nu zien of hij wordt herkend. (kaart erin steken of verwijderen)
***

Na het invoeren van dit commando zie ik een enorme lijst, aan het einde staat het volgende:

[  378.224000] usb 1-1: new full speed USB device using ohci_hcd and address 5
[  378.436000] usb 1-1: configuration #1 chosen from 1 choice
[  382.532000] usb 1-1: USB disconnect, address 5
Echter, in audicity zie ik alleen de OSS: /dev/dsp, de ALSA: HDA ATI SB: SLC883 Analog (hw:0,0) en de (hw:0,2) staan die niet werken. Wat nu?

Offline happyhamster

  • Lid
  • Steunpunt: Nee
Krijg Edirol UA-1EX USB externe geluidskaart niet werkend
« Reactie #1 Gepost op: 2007/08/20, 23:40:14 »
- Je kan zien of de kaart wordt herkend door:

lsusb

- En ook:

cat /proc/asound/cards

- Als de kaart(en) gezien worden, dan:

cat /proc/asound/modules

- om te kijken of de bijbehorende modules zijn geladen. De eerstgenoemde module is de module die standaard wordt gebruikt (index 0). Wordt snd-usb-audio wel geladen, maar is het niet de standaard module, dan zal je dat moeten instellen in alsa-base:

sudo nano /etc/modprobe.d/alsa-base

- Het einde van die file ziet er ongeveer zo uit:


# Prevent abnormal drivers from grabbing index 0
options snd-bt87x index=-2
options cx88-alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388


- Je zal dan de "options snd-usb-audio index=-2" regel moeten verwijderen. Dit doe je door er een # teken voor te zetten. Vervolgens moet je dan aan het einde een regel opnemen voor elke geluidskaart die je hebt (Gebruik de module-namen gevonden via het cat /proc/asound/modules commando, met als bijzonderheid dat je een - streepje moet gebruiken i.p.v. een _ Dus als /proc/asound/modules bijv. als uitvoer "snd_intel8x0" heeft, dan is de module-naam: snd-intel8x0). Ok, voorbeeld van hoe het eruit komt te zien:

# Prevent abnormal drivers from grabbing index 0
options snd-bt87x index=-2
options cx88-alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
# options snd-usb-audio index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388

# schrijf hier wat commentaar
options snd-usb-audio index=0
options naam-van-de-tweede-module index=1
options naam-van-de-derde-module index=2



- Het gaat er dus om dat de snd-usb-audio module een index=0 krijgt, en alle overige modules een index ongelijk aan 0.

- Vervolgens opslaan (ctrl-o) en de editor verlaten (ctrl-x). Reboot. Als het niet lukt, of als er problemen zijn, laat het weten. Succes.


Zie ook:
http://forum.ubuntu-nl.org/topic/13385

musicfreak

  • Gast
Krijg Edirol UA-1EX USB externe geluidskaart niet werkend
« Reactie #2 Gepost op: 2007/08/22, 16:28:54 »
Citaat van: happyhamster
- Je kan zien of de kaart wordt herkend door:
lsusb
Yes: Bus 001 Device 002: ID 0582:0096 Roland Corp.
 
Citaat
- En ook:

cat /proc/asound/cards
Dat is wat minder succesvol, zie alleen een ATI Soundblaster:

 0 [SB             ]: HDA-Intel - HDA ATI SB
                      HDA ATI SB at 0xd0000000 irq 19

Citaat
- Als de kaart(en) gezien worden, dan:

cat /proc/asound/modules
Helaas alleen  0 snd_hda_intel

Citaat
- om te kijken of de bijbehorende modules zijn geladen. De eerstgenoemde module is de module die standaard wordt gebruikt (index 0). Wordt snd-usb-audio wel geladen, maar is het niet de standaard module, dan zal je dat moeten instellen in alsa-base:

sudo nano /etc/modprobe.d/alsa-base

- Het einde van die file ziet er ongeveer zo uit:


# Prevent abnormal drivers from grabbing index 0
Omdat er bij mij alleen die ATI SB wordtgevonden krijg ik geen abnormale drivers. ;-)

Wat nu?

Offline happyhamster

  • Lid
  • Steunpunt: Nee
Krijg Edirol UA-1EX USB externe geluidskaart niet werkend
« Reactie #3 Gepost op: 2007/08/22, 18:08:55 »
Citaat van: musicfreak
Citaat
# Prevent abnormal drivers from grabbing index 0
Omdat er bij mij alleen die ATI SB wordtgevonden krijg ik geen abnormale drivers. ;-)

Wat nu?
- Heb je alsa-base wel aangepast? Want dat zal sowieso moeten gebeuren (en vaak is het het enige wat er moet gebeuren). Dus:

sudo nano /etc/modprobe.d/alsa-base

- en voeg de volgende regels toe aan het einde van de file:

# Toegevoegd door user, augustus 2007.
options snd-usb-audio index=0
options snd-hda-intel index=1

- En verwijder de "options snd-usb-audio index=-2" regel (d.m.v. een # teken). Het einde ziet er dan zo uit:


# Prevent abnormal drivers from grabbing index 0
options snd-bt87x index=-2
options cx88-alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
# options snd-usb-audio index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388

# Toegevoegd door user, augustus 2007.
options snd-usb-audio index=0
options snd-hda-intel index=1

- Saven (ctrl-o), exit (ctrl-x). Reboot.

- Als het dan nog niet werkt, voeg dan de naam van de module toe aan /etc/modules:

sudo nano /etc/modules

- en aan het eind de module toevoegen:

snd-usb-audio

- Saven (ctrl-o), exit (ctrl-x). Reboot.

- Als het dan nog niet werkt, bonk dan enige tijd met je hoofd tegen de muur uit frustratie. Vervolgens:

sudo lsusb -v

- Dat geeft veel meer info over de gedetecteerde usb (misschien wordt de kaart niet als geluidskaart herkend, lijkt me sterk, maar goed, controleren kan geen kwaad.
- Controleer of in alsamixer alle kanalen openstaan, en het volume > 0 is.
- Kijk in het system-->preferences-->sound of de juiste geluidsbron beschikbaar/gekozen is, etc, etc.
- Check of de kabels goed vast zitten :)
- Nog meer info verzamelen:

uname -r

aplay -l

cat /proc/asound/version

cat /proc/asound/cards

cat /proc/asound/modules

lsmod | grep snd -i

Offline ds500ss

  • Lid
  • Steunpunt: Nee
Krijg Edirol UA-1EX USB externe geluidskaart niet werkend
« Reactie #4 Gepost op: 2007/08/22, 20:31:03 »
wacht ook nog eeuw op drivers heb een SB Xi-Fi kaart
die in het najaar (hopelijk) ondersteund wordt,als de deadline niet nog eens verschoven wordt

musicfreak

  • Gast
Krijg Edirol UA-1EX USB externe geluidskaart niet werkend
« Reactie #5 Gepost op: 2007/08/22, 21:05:31 »
Citaat van: happyhamster
- Als het dan nog niet werkt, bonk dan enige tijd met je hoofd tegen de muur uit frustratie. Vervolgens:

sudo lsusb -v

- Dat geeft veel meer info over de gedetecteerde usb (misschien wordt de kaart niet als geluidskaart herkend, lijkt me sterk, maar goed, controleren kan geen kwaad.
Tja,  ben idd in het "bonkstadium" beland.

Bij deze de output;

Bus 001 Device 003: ID 0582:0096 Roland Corp.
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               1.10
  bDeviceClass          255 Vendor Specific Class
  bDeviceSubClass         0
  bDeviceProtocol       255
  bMaxPacketSize0         8
  idVendor           0x0582 Roland Corp.
  idProduct          0x0096
  bcdDevice            1.00
  iManufacturer           1 EDIROL
  iProduct                2 UA-1EX
  iSerial                 0
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength          109
    bNumInterfaces          2
    bConfigurationValue     1
    iConfiguration          0
    bmAttributes         0x80
      (Bus Powered)
    MaxPower              200mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           0
      bInterfaceClass       255 Vendor Specific Class
      bInterfaceSubClass      2
      bInterfaceProtocol      0
      iInterface              0
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       1
      bNumEndpoints           1
      bInterfaceClass       255 Vendor Specific Class
      bInterfaceSubClass      2
      bInterfaceProtocol      0
      iInterface              0
      Class specific interface descriptor for class 255 is unsupported
      Class specific interface descriptor for class 255 is unsupported
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x01  EP 1 OUT
        bmAttributes            9
          Transfer Type            Isochronous
          Synch Type               Adaptive
          Usage Type               Data
        wMaxPacketSize     0x0120  1x 288 bytes
        bInterval               1
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        1
      bAlternateSetting       0
      bNumEndpoints           0
      bInterfaceClass       255 Vendor Specific Class
      bInterfaceSubClass      2
      bInterfaceProtocol      0
      iInterface              0
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        1
      bAlternateSetting       1
      bNumEndpoints           1
      bInterfaceClass       255 Vendor Specific Class
      bInterfaceSubClass      2
      bInterfaceProtocol      0
      iInterface              0
      Class specific interface descriptor for class 255 is unsupported
      Class specific interface descriptor for class 255 is unsupported
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x82  EP 2 IN
        bmAttributes            5
          Transfer Type            Isochronous
          Synch Type               Asynchronous
          Usage Type               Data
        wMaxPacketSize     0x0120  1x 288 bytes
        bInterval               1
Device Status:     0x0000
  (Bus Powered)

Citaat
- Controleer of in alsamixer alle kanalen openstaan, en het volume > 0 is.
- Kijk in het system-->preferences-->sound of de juiste geluidsbron beschikbaar/gekozen is, etc, etc.
Waar kan ik alsamixer vinden? Bij voorkeuren --> geluid staat mijn Edirol niet genoemd. Oo zit er door het ludsprekertje rechtsboven nu een stopbord, De ingebouwde geluidskaart werkt nu ook niet meer (gebeurde na aanpassing in alsa-base, heb het precies zo gedaan zoals door jou aangegeven).

Citaat
- Nog meer info verzamelen:

uname -r
Ok, daar gaan we. Als eerste deze;

2.6.20-16-generic

Citaat
aplay -l
**** List of PLAYBACK Hardware Devices ****
card 1: SB [HDA ATI SB], device 0: ALC883 Analog [ALC883 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Citaat
cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.14rc1 (Tue Jan 09 09:56:17 2007 UTC).

Citaat
cat /proc/asound/cards
1 [SB             ]: HDA-Intel - HDA ATI SB
                      HDA ATI SB at 0xd0000000 irq 19

Citaat
cat /proc/asound/modules
1 snd_hda_intel

Citaat
lsmod | grep snd -i
snd_usb_audio          79744  0
snd_usb_lib            17280  1 snd_usb_audio
snd_hwdep               9988  1 snd_usb_audio
snd_hda_intel          21912  0
snd_hda_codec         205056  1 snd_hda_intel
snd_pcm_oss            44544  0
snd_mixer_oss          17408  1 snd_pcm_oss
snd_pcm                79876  4 snd_usb_audio,snd_hda_intel,snd_hda_codec,snd_pcm_oss
snd_seq_dummy           4740  0
snd_seq_oss            32896  0
snd_seq_midi            9600  0
snd_rawmidi            25472  2 snd_usb_lib,snd_seq_midi
snd_seq_midi_event      8448  2 snd_seq_oss,snd_seq_midi
snd_seq                52592  6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer              23684  2 snd_pcm,snd_seq
snd_seq_device          9100  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
snd                    54020  12 snd_usb_audio,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore               8672  1 snd
snd_page_alloc         10888  2 snd_hda_intel,snd_pcm
usbcore               134280  5 snd_usb_audio,snd_usb_lib,ehci_hcd,ohci_hcd


Ik hoop dat je hier wat an hebt. In ieder geval dank voor alle hulp!!!

Offline happyhamster

  • Lid
  • Steunpunt: Nee
Krijg Edirol UA-1EX USB externe geluidskaart niet werkend
« Reactie #6 Gepost op: 2007/08/23, 01:17:22 »
Hmm, de Edirol wordt blijkbaar slechts gedeeltelijk herkend (niet als een audio apparaat). Toch moet de ua-1ex kunnen werken onder linux, zie:

http://bugtrack.alsa-project.org/main/index.php/Matrix:Vendor-Roland_Edirol

Wat ik alleen niet snap is de "Supported in Standard Mode only". Ik zou eerlijk gezegd niet weten waar je dat in moet stellen.

[edit: Heh, gevonden! Blijkbaar zit er op het fysieke apparaat zelf een knop waarmee je standard/advanced mode kan kiezen. ALSA ondersteunt (op dit moment) alleen nog de standaard instelling.]

musicfreak

  • Gast
Krijg Edirol UA-1EX USB externe geluidskaart niet werkend
« Reactie #7 Gepost op: 2007/08/26, 14:12:44 »
Je hebt helemaal gelijk happyhamster, er zit op het apparaat idd een knop om de "advanced driver' in of uit te schakelen. Toen ik deze uitschakelde werd de module USB audio geladen en werkte de kaart!
Wat echter is gebleven is dat de volumeregeling niet werkt. De rechter speaker van de laptop doet het wel als ik bij voorkeuren - > geleuid de ALC883 analog instel, echter het zou leuk zijn als de linker ook zou werken. Hoe is dit op te lossen?

Wat trouwens ook maf is is dat Amarok bij het shuffelen en crossfaden van nummers het ene nummer afspeelt via de externe geluidskaart, de volgende via de interne (wederom alleen via de rechter speaker), daarna via de externe kaart etc.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Krijg Edirol UA-1EX USB externe geluidskaart niet werkend
« Reactie #8 Gepost op: 2007/08/26, 14:15:20 »
Systeem - Beheer - Synaptic pakketbeheer
zoekterm: alsamixergui
aanvinken en druk op knop Toepassen

Start daarna alsamixergui en kijk eens hoe de schuifjes staan? Post desnoods even een schermafdruk, bijvoorbeeld met behulp van http://imageshack.us

-toevoeging-
twee actieve geluidskaarten geeft meestal problemen. Schakel de aan-boord-kaart op het moederbord, eens uit in het BIOS?

musicfreak

  • Gast
Krijg Edirol UA-1EX USB externe geluidskaart niet werkend
« Reactie #9 Gepost op: 2007/08/26, 15:02:42 »
Helaas kan ik mijn interne geluidskaart niet uitschakelen in het Bios. Ik heb Alsamixer geïnstalleerd, het programma start alleen niet op. Hieronder staat een schermafdruk van de foutmelding die ik krijg als ik de voorkeuren van de volumeregeling wil wijzigen:


Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Krijg Edirol UA-1EX USB externe geluidskaart niet werkend
« Reactie #10 Gepost op: 2007/08/26, 15:26:10 »
Citaat van: musicfreak
Helaas kan ik mijn interne geluidskaart niet uitschakelen in het Bios.
Dat lijkt me stug, want dat kan (in mijn ervaring) altijd. Zoek nog eens goed, in het BIOS? Bijvoorbeeld in de instellingen van de southbridge chipsets. Welk moederbord heb je?

musicfreak

  • Gast
Krijg Edirol UA-1EX USB externe geluidskaart niet werkend
« Reactie #11 Gepost op: 2007/08/26, 16:13:09 »
Ik kan het echt niet vinden, ook de site van Acer en apparaatbeheer geven geen uitsluitsel. Is er ook een soort van SiSoft Sandra voor Linux?

Offline happyhamster

  • Lid
  • Steunpunt: Nee
Krijg Edirol UA-1EX USB externe geluidskaart niet werkend
« Reactie #12 Gepost op: 2007/08/26, 20:13:30 »
Blijkbaar heeft de Edirol geen hardware mixer, en zal er gebruik moeten worden gemaakt van een pure software mixer (dmix). Op deze pagina is een voorbeeld setup te vinden:

http://feeds.feedburner.com/nectarius

musicfreak

  • Gast
Krijg Edirol UA-1EX USB externe geluidskaart niet werkend
« Reactie #13 Gepost op: 2007/09/08, 19:10:06 »
Citaat van: happyhamster
Blijkbaar heeft de Edirol geen hardware mixer, en zal er gebruik moeten worden gemaakt van een pure software mixer (dmix). Op deze pagina is een voorbeeld setup te vinden:

http://feeds.feedburner.com/nectarius
Dank voor deze link! Directe link naar het weblog is overigens http://nectarius.net/2007/08/16/linux-usb-audio-problems/.

Zoals ik hierboven al schreef werkt mijn externe geluidskaart nu prima, het enige probleem is dat als ik de kaart verwijder en de laptop opstart de mixer niet meer werkt voor de interne geluidskaart. Hoe is dit op te lossen? Wellicht moet ik een bepaalde instelling terugzetten die ik eerder had aangepast voor de Edirol?

Offline happyhamster

  • Lid
  • Steunpunt: Nee
Krijg Edirol UA-1EX USB externe geluidskaart niet werkend
« Reactie #14 Gepost op: 2007/09/09, 20:58:40 »
Dubbelklikken op de volumeregeling, en dan kan je via File-->Change Device een mixer kiezen.

musicfreak

  • Gast
Krijg Edirol UA-1EX USB externe geluidskaart niet werkend
« Reactie #15 Gepost op: 2007/09/09, 21:00:40 »
Citaat van: happyhamster
Dubbelklikken op de volumeregeling, en dan kan je via File-->Change Device een mixer kiezen.
Helaas, dat dubbelklikken geeft een foutmelding, zie bericht nummer 10.

Offline happyhamster

  • Lid
  • Steunpunt: Nee
Krijg Edirol UA-1EX USB externe geluidskaart niet werkend
« Reactie #16 Gepost op: 2007/09/09, 21:23:11 »
Werkt de onboard kaart op dit moment? En werkte hij voor de aanpassingen aan alsa-base?

[edit: krijg je dezelfde fout als je recht-klikt op de volumeregeling?]

musicfreak

  • Gast
Krijg Edirol UA-1EX USB externe geluidskaart niet werkend
« Reactie #17 Gepost op: 2007/10/17, 21:54:19 »
Het spijt me het te moeten zeggen maar ik heb Ubuntu van mijn laptop verwijderd. Ik wilde uiteindelijk snel mijn internet radiostation weer online hebben, daarnaast blijkt de Acer laptop niet de meest ideale machine voor een succesvolle Ubuntu installatie. Ik krijg binnenkort een nieuwe PC, daar zal ik als ik tijd heb wel een dualboot Windows / Linuxmachine van maken.

Dank voor alle hulp in ieder geval!