Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Segmentatie fout?  (gelezen 932 keer)

boukehaarsma

  • Gast
Segmentatie fout?
« Gepost op: 2007/08/18, 18:17:12 »
hallo iedereen
ik wou graag een simpel spelletje spelen dus heb ik Open arena geinstalleerd (na ik natuurlijk mijn nvidia drivers had geinstalleerd) maar hij deed niets. Dus ik probeer hem te openen in de terminal. hij geeft dit terug

Current search path:
/root/.openarena/baseoa
/usr/share/games/openarena/baseoa/pak6-misc.pk3 (96 files)
/usr/share/games/openarena/baseoa/pak5-TA.pk3 (7 files)
/usr/share/games/openarena/baseoa/pak4-textures.pk3 (932 files)
/usr/share/games/openarena/baseoa/pak2-players.pk3 (187 files)
/usr/share/games/openarena/baseoa/pak1-maps.pk3 (25 files)
/usr/share/games/openarena/baseoa/pak0.pk3 (748 files)
/usr/share/games/openarena/baseoa
/usr/lib/games/openarena/baseoa

----------------------
1995 files in pk3 files
execing default.cfg
couldn't exec q3config.cfg
couldn't exec autoexec.cfg
Hunk_Clear: reset the hunk ok
----- Client Initialization -----
----- Initializing Renderer ----
-------------------------------
QKEY found.
----- Client Initialization Complete -----
----- R_Init -----

------- Input Initialization -------
Joystick is not active.
------------------------------------
...loading libGL.so.1:
Calling SDL_Init(SDL_INIT_VIDEO)...
SDL_Init(SDL_INIT_VIDEO) passed.
Segmentatiefout

toen heb ik maar alien arena geinstalleerd. Maar die geeft dezelfde segmentatie fout
tenslotte ook Actioncube maar die geeft ook een foutmelding (ook segmentatie fout)
Nu ben ik dus vraagtekens over  mijn nvidia drivers ( die ik via de binary van nvidia.com heb geinstalleerd)
mijn xorg.conf

If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
EndSection

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "CoreKeyboard"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc104"
   Option      "XkbLayout"   "us"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
   Option      "CorePointer"
   Option      "Device"      "/dev/input/mice"
   Option      "Protocol"      "ImPS/2"
   Option      "Emulate3Buttons"   "true"
EndSection



Section "Device"
   Identifier   "nVidia Corporation NV11 [GeForce2 MX/MX 400]"
   Driver      "nvidia"
   BusID      "PCI:01:00:0"
   Option       "TripleBuffer"       "true"
Endsection


Section "Monitor"
   Identifier   "V50"
   Option      "DPMS"
Endsection

Section "Screen"
   Identifier   "Screen1"
   Device      "nVidia Corporation NV11 [GeForce2 MX/MX 400]"
   Monitor      "V50"
   DefaultDepth   24
   SubSection "Display"
      Modes      "1024x768" "800x600" "640x480"
   EndSubSection
   Option       "AddARGBGLXVisuals"    "true"
EndSection



Section "ServerLayout"
   Identifier   "Default Layout"
   Screen      "Screen1"
   InputDevice   "Generic Keyboard"
   InputDevice   "Configured Mouse"
EndSection

Volgens mij is hier niets verkeerd aan..
Kunnen jullie mij misschien helpen?

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Segmentatie fout?
« Reactie #1 Gepost op: 2007/08/18, 19:21:42 »
ik denk dat de GeForce2 MX/MX 400 de legacy drivers nodig heeft. dus niet de glx/new drivers.

heb je direct rendering?
Citaat
glxinfo|grep direct
in de terminal. uitkomst hier posten.

zie ook: http://forum.ubuntu-nl.org/topic/8768

boukehaarsma

  • Gast
Segmentatie fout?
« Reactie #2 Gepost op: 2007/08/18, 20:06:57 »
/home/bouke# glxinfo|grep direct
bash: glxinfo: command not found


?? :S

in terminal as root!

en ik heb volgens mij al de legacy drivers
http://www.nvidia.com/object/linux_display_ia32_1.0-9639.html
deze drivers heb ik

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Segmentatie fout?
« Reactie #3 Gepost op: 2007/08/18, 20:26:40 »
Citaat
/home/bouke#
?

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Segmentatie fout?
« Reactie #4 Gepost op: 2007/08/18, 20:29:55 »
Citaat van: boukehaarsma
/home/bouke# glxinfo|grep direct
bash: glxinfo: command not found


?? :S

in terminal as root!

en ik heb volgens mij al de legacy drivers
http://www.nvidia.com/object/linux_display_ia32_1.0-9639.html
deze drivers heb ik
Voor die kaart moet je de "legacy" drivers installeren.


Om het in te stellen:
Haal de gewone nvidia driver weg als je die hebt geïnstalleerd:
sudo apt-get --purge remove nvidia-glx

Installeren van de legacy driver:
sudo apt-get install nvidia-glx-legacy

de legacy drivers staan in de synaptic
kijk even welke drivers geinstalleerd zijn: zoekopdracht in de synaptic bij nvidia. weet je het zeker....