Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Keyboardprobleem  (gelezen 1052 keer)

prazz

  • Gast
Keyboardprobleem
« Gepost op: 2007/08/17, 12:58:32 »
Al een tijdje krijg ik bij het opstarten een foutmelding ivm m'n toetsenbord, en ik heb vnv geen 'at' teken. Dat is redelijk vervelend, en ik weet niet echt hoe ik dat op moet lossen.
Dat is gekomen doordat ik eens met die xorg mijn scherminstellingen moest aanpassen, dat is wel gelukt, helaas heb ik m'n keyboard dan mooi semi-onbruikbaar gemaakt. Any ideas hoe ik dat terug goed stel?
Via optie 'keyboard' in instellingen lukt ook niet, krijg ik dezelfde error.


Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Keyboardprobleem
« Reactie #1 Gepost op: 2007/08/17, 13:45:22 »
OK. Tijd voor een herconfiguratie van je X (grafische omgeving).....
Doe eens dit:

1. installeer xresprobe
Systeem - Beheer - Synaptic pakketbeheer
zoekterm: xresprobe
aanvinken en druk op knop Toepassen

2. Toepassingen - Hulpmiddelen - Terminalvenster
tik in: sudo dpkg-reconfigure xserver-xorg
Ga direct akkoord met alle voorgestelde antwoorden. Bediening met Tabtoets, spatiebalk, *binnenste* Entertoets en pijltjestoetsen.

3. Herstart je PC.

Helpt dit?

Groet, Pjotr.

prazz

  • Gast
Keyboardprobleem
« Reactie #2 Gepost op: 2007/08/17, 17:47:33 »
Ik heb alle voorgestelde opties gekozen, maar het werkt niet. Nog steeds dezelfde melding bij het heropstarten.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Keyboardprobleem
« Reactie #3 Gepost op: 2007/08/17, 19:45:50 »
OK. Welk toetsenbord heb je: qwerty of azerty?

prazz

  • Gast
Keyboardprobleem
« Reactie #4 Gepost op: 2007/08/17, 20:49:12 »
Azerty heb ik.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Keyboardprobleem
« Reactie #5 Gepost op: 2007/08/17, 22:07:46 »
Goed. Post hier eens de inhoud van /etc/X11/xorg.conf

prazz

  • Gast
Keyboardprobleem
« Reactie #6 Gepost op: 2007/08/19, 00:15:35 »
Okay, hier is het :)

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
   FontPath   "/usr/share/fonts/X11/misc"
   FontPath   "/usr/share/fonts/X11/cyrillic"
   FontPath   "/usr/share/fonts/X11/100dpi/:unscaled"
   FontPath   "/usr/share/fonts/X11/75dpi/:unscaled"
   FontPath   "/usr/share/fonts/X11/Type1"
   FontPath   "/usr/share/fonts/X11/100dpi"
   FontPath   "/usr/share/fonts/X11/75dpi"
   # path to defoma fonts
   FontPath   "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
   Load   "bitmap"
   Load   "ddc"
   Load   "dri"
   Load   "extmod"
   Load   "freetype"
   Load   "glx"
   Load   "int10"
   Load   "vbe"
EndSection

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "CoreKeyboard"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc105"
   Option      "XkbLayout"   "be"
   Option      "XkbVariant"   "be"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
   Option      "CorePointer"
   Option      "Device"      "/dev/input/mice"
   Option      "Protocol"      "ImPS/2"
   Option      "ZAxisMapping"      "4 5"
   Option      "Emulate3Buttons"   "true"
EndSection

Section "InputDevice"
   Driver      "wacom"
   Identifier   "stylus"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"      "stylus"
   Option      "ForceDevice"   "ISDV4"      # Tablet PC ONLY
EndSection

Section "InputDevice"
   Driver      "wacom"
   Identifier   "eraser"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"      "eraser"
   Option      "ForceDevice"   "ISDV4"      # Tablet PC ONLY
EndSection

Section "InputDevice"
   Driver      "wacom"
   Identifier   "cursor"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"      "cursor"
   Option      "ForceDevice"   "ISDV4"      # Tablet PC ONLY
EndSection

Section "Device"
   Identifier   "Ati xpress 300"
   Driver      "ati"
   BusID      "PCI:1:5:0"
   VideoRam   64400
EndSection

Section "Monitor"
   Identifier   "Fujitsu Siemens Scaleoview w19-1"
   Option      "DPMS"
   HorizSync   55.5
   VertRefresh   60
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Device      "Ati xpress 300"
   Monitor      "Fujitsu Siemens Scaleoview w19-1"
   DefaultDepth   24
   SubSection "Display"
      Depth      1
      Modes      "1440x900"
   EndSubSection
   SubSection "Display"
      Depth      4
      Modes      "1440x900"
   EndSubSection
   SubSection "Display"
      Depth      8
      Modes      "1440x900"
   EndSubSection
   SubSection "Display"
      Depth      15
      Modes      "1440x900"
   EndSubSection
   SubSection "Display"
      Depth      16
      Modes      "1440x900"
   EndSubSection
   SubSection "Display"
      Depth      24
      Modes      "1440x900"
   EndSubSection
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
   Screen      "Default Screen"
   InputDevice   "Generic Keyboard"
   InputDevice   "Configured Mouse"
   InputDevice     "stylus"   "SendCoreEvents"
   InputDevice     "cursor"   "SendCoreEvents"
   InputDevice     "eraser"   "SendCoreEvents"
EndSection

Section "DRI"
   Mode   0666
EndSection

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Keyboardprobleem
« Reactie #7 Gepost op: 2007/08/19, 00:28:21 »
OK. Doe eens dit:

sudo gedit /etcX11/xorg.conf

en zet een # voor een bepaalde regel in de
Section "InputDevice"
    Identifier    "Generic Keyboard"

Het gaat hierom:
Option        "XkbVariant"    "be"

Zo moet hij dus worden:
#  Option        "XkbVariant"    "be"

Daarna herstart van je PC.

Helpt dit?