Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: ubuntu gebruikt oude modules init /apache2 /firefox  (gelezen 673 keer)

joepie

  • Gast
ubuntu gebruikt oude modules init /apache2 /firefox
« Gepost op: 2007/08/16, 01:05:16 »
#checkrestart
Found 8 processes using old versions of upgraded files
(3 distinct programs)
(3 distinct packages)

Of these, 0 seem to contain init scripts which can be used to restart them:


Here are the others:
firefox:
22687 /usr/lib/firefox/firefox-bin
upstart:
1 /sbin/init
apache2-mpm-prefork:
5680 /usr/sbin/apache2
5682 /usr/sbin/apache2
5674 /usr/sbin/apache2

op een nieuwe 7.04 server + 7.04 desktop+webmin install.

apache2-mpm-prefork volgens synaptic  2.2.3.3.2ubuntu

Hoe kan ik Ubuntu de nieuwe modules laten gebruiken ?

Groet

Pivotter

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
ubuntu gebruikt oude modules init /apache2 /firefox
« Reactie #1 Gepost op: 2007/08/16, 01:18:46 »
Ik begrijp het niet helemaal...
Waar komen de eerste regels vandaan? Wie/welk programma zegt dat Ubuntu oude modules gebruikt?
Wat werkt er niet?

Als het om een programma gaat welke niet specifiek geschreven is voor Ubuntu, zou het kunnen komen doordat Ubuntu gebruik maakt van upstart, in plaats van sysv-init.
http://upstart.ubuntu.com/

Als je Ubuntu gewoon up-to-date houdt door steeds de updates te installeren, zou je de nieuwste modules moeten gebruiken.

Welkom op het forum :)

joepie

  • Gast
ubuntu gebruikt oude modules init /apache2 /firefox
« Reactie #2 Gepost op: 2007/08/16, 01:37:33 »
nou, ik had vertrouwen in security door updates, tot de box gehacked werd, dus spul plat en een nieuwe benadering, daaronder valt ook de check of er niet per ongeluk oude modules draaien.

Ik ben vrij nieuw op Ubuntu, dus als ik rare vragen stel......

checkrestart, komt uit de package debian goodies.

Dus, hoe pak ik het aan ?

Gr.

Pivotter

joepie

  • Gast
ubuntu gebruikt oude modules init /apache2 /firefox
« Reactie #3 Gepost op: 2007/08/16, 01:49:51 »
ik zal je ook vertellen waarom ik het doe, noob als ik ben dacht ik SSL te upgraden make, make install van versie C naar E. dom, ik kwam er later achter dat er dan 2 versies op de server staan. 1 gaat mee met het upgraden, en de ander blijft de oude versie.

Dus vandaar de wens op versie control.

Gr.

Pivotter

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
ubuntu gebruikt oude modules init /apache2 /firefox
« Reactie #4 Gepost op: 2007/08/16, 02:06:31 »
Vervelend dat je computer gehackt is :( Weet je ook hoe de hackers precies zijn binnengekomen? Was het een security fout (bug), of een fout in je configuratie? Dit lijkt me één van de belangrijkste dingen om uit te zoeken.

Het pakket debian goodies is volgens mij ook bedoeld voor Debian, niet voor Ubuntu. Debian gebruikt nog wel het sysv-init systeem, dus daarom krijg je die meldingen.

Alle bekende bugs worden verholpen door de security updates via apt-get/synaptic. Handmatig dingen binnenhalen en compileren wordt dan ook sterk afgeraden. Versie control zou dan ook overbodig moeten zijn.

Voor meer info over de veiligheid/beveiliging wil ik je aanraden om deze uitgebreide post te lezen op het internationale forum: http://ubuntuforums.org/showthread.php?t=510812
Ik ben nog bezig met de Nederlandse vertaling, dus helaas is dit alleen in het Engels.
Verder ben ik geen veiligheids expert, dus kan ik je niet veel meer advies geven.
Als je er hiermee niet uitkomt, kan je ook je vraag stellen op het internationale forum: http://ubuntuforums.org/forumdisplay.php?f=7 of op tweakers.net: http://gathering.tweakers.net/forum/list_topics/23

joepie

  • Gast
ubuntu gebruikt oude modules init /apache2 /firefox
« Reactie #5 Gepost op: 2007/08/16, 02:44:08 »
ja, pech, er was weinig meer aan te redden, verschillende directories waren op world gezet,   de helft van de logfiles werden niet meer bijgewerkt, en met nessus was aardig te zien dat er extra poorten geopend werden. Het enige wat nog hielp was de firewall op volledig restrictive te zetten, alle benodigde services aan een ip binden en alleen poort 80 open. Sindsdien was het rustig........,

En ik denk dat het komt doordat ik ook de server versie draai, uit de box, en niet de apache beveiligingstips heb doorlopen, wat ik nu wel ga doen (eerst maar even harden installeren).

Verder ga ik nu loggen op een externe machine zodat ik het wel na kan kijken, en split ik de mail en webserver op. ga ik toch maar van 1 naar 3 machines.

Dank voor de links, die eerste had ik al gevonden, de rest morgen even lezen.

Gr.

Pivotter

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
ubuntu gebruikt oude modules init /apache2 /firefox
« Reactie #6 Gepost op: 2007/08/16, 02:49:10 »
Uithuilen, formatteren en overnieuw beginnen dus :/

Kijk ook eens naar de optie van virtualiseren, zodat je niet meerdere computers hoeft te gebruiken.

joepie

  • Gast
ubuntu gebruikt oude modules init /apache2 /firefox
« Reactie #7 Gepost op: 2007/08/16, 02:57:26 »
haha, ja ook een optie, wel 8GB erin en een andere proccessor, met 35 watt zal het niet gaan. En het is leergeld, als ze alle drie naar tevredenheid werken is dat eventueel voor de volgende keer.

Dank voor de hulp.

Groet

Pivotter