Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Windows wachtwoord.  (gelezen 1246 keer)

hanssc

  • Gast
Windows wachtwoord.
« Gepost op: 2007/08/13, 13:10:49 »
Ik heb gisteren Ubuntu 7.04 geïnstalleerd en een compliment voor de software.
Het ging allemaal perfect.
Ik kan met de Ubuntu machine op het netwerk komen en een windows pc benaderen en de gedeelde bestanden openen en bewerken.
Vanuit de windows pc kan ik het icoontje van de Ubuntu machine zien, Als ik op het icoontje dubbelklik krijg ik een popup scherm waar ik moet inloggen. Ik kan de windows gebruikersnaam en wachtwoord invullen of de gebruikersnaam en wachtwoord van de Ubuntu machine maar ik kan niet inloggen. Hij geeft telkens aan dat ik moet inloggen.

Hoe nu verder?

Moet ik de windows pc verder intaleren met samba of iets dergelijks om de Ubuntu machine te benaderen.
Ik weet het echt.

Wie kan mij helpen?

Met vriendelijke groet,
Hans.

Offline bartek

  • Lid
    • http://bartek.blogsome.com
  • Steunpunt: Nee
Windows wachtwoord.
« Reactie #1 Gepost op: 2007/08/13, 13:52:25 »
Ubuntu werkt op het EXT3 bestandsysteem, Windows NTFS.
Windows kan geen EXT3 lezen of schrijven.
Daarvoor moet je een aparte partitie aanmaken in FAT32 voor je gedeelde bestanden.
| Deliberando saepe perit occasio |

"Car la vie est un bien perdu quand on n'a pas v├ęcu comme on l'aurait voulu"

hosti

  • Gast
Windows wachtwoord.
« Reactie #2 Gepost op: 2007/08/13, 14:31:08 »
1) Aan het hierbovenstaande: dat klopt maar dat belet niet dat je die partitie niet zou kunnen benaderen.

2) da's een samba dat je draait en een vereiste hiervoor is dat je accounts aanwezig zijn op je samba server (je linux PC maw.).. daar ligt het conflict. even de samba documenatie nalezen hoe je die accounts moet instellen. op linux was dat smbadduser of zoiets.

hanssc

  • Gast
Windows wachtwoord.
« Reactie #3 Gepost op: 2007/08/13, 15:37:57 »
Heren,  dit is nu zo'n probleem waar menig linux persoon tegen aan loopt. De stelling "even de samba documenatie nalezen hoe je die accounts moet instellen".

Vanuit de linux kan ik alles doen, vanuit de windows pc vraagt ie om gebruikersnaam em wachtwoord.

Als ik op de windows pc kijk zie ik geen verwijzing naar samba instellen.
Waar kan ik dit vinden en is er ergens meer geleide documentatie om dit probleem op te lossen.

Met vriendelijke groet,

Hans.

Offline wutnubu

  • Lid
  • Steunpunt: Nee
Windows wachtwoord.
« Reactie #4 Gepost op: 2007/08/13, 16:11:17 »
Kijk eens op de ubuntu wiki op ubuntu.com, zoek eens hier op samba.

Succes

hosti

  • Gast
Windows wachtwoord.
« Reactie #5 Gepost op: 2007/08/13, 22:13:48 »
Heren,  dit is nu zo'n probleem waar menig linux persoon tegen aan loopt.

> Oh, ik dacht juist dat het ontdekken van hoe je zo'n dingen in moet stellen en hoe samba werkt menig mensen juist aansprak. Althans dat vind ik 't knappe van linux. Je dient normaal gewoon je samba.conf. aan te passen.

De stelling "even de samba documenatie nalezen hoe je die accounts moet instellen".

> eeuh-?

Vanuit de linux kan ik alles doen,

vanuit de windows pc vraagt ie om gebruikersnaam em wachtwoord.

Als ik op de windows pc kijk zie ik geen verwijzing naar samba instellen.

> Natuurlijk niet. Jou linux is de sambaserver en daar moet je (bijna) alles instellen. Je win PC contacteert de server, vraagt je in te loggen, stuurt deze gegevens door naar je linux systeempje die de gebruikersinstellingen nakijkt.

Waar kan ik dit vinden en is er ergens meer geleide documentatie om dit probleem op te lossen.

'k zal eens zoeken.

*edit:

http://www.bartendavid.be/doc/howto/netwerk/servers/samba-config-linux.html  (NL)

http://www.redhat.com/docs/manuals/linux/RHL-8.0-Manual/custom-guide/s1-samba-configuring.html

http://ictfreak.wordpress.com/2007/03/20/how-to-configure-samba-on-ubuntu-610/

..en op de samba site kan je de volledige documentatie downloaden (da's een paper van etterlijke 100 pagina's lang)
Ook moet normaal de smb documentatie reeds op je systeem staan: zoek samba - doc eens op.

Onder /var/log/samba.log kan je zien wat er mis is.

Grz, I.

Offline Dave

  • Lid
  • Steunpunt: Nee
Windows wachtwoord.
« Reactie #6 Gepost op: 2007/08/14, 10:24:42 »
niet om vrolijk van te worden dus.

je maakt een map aan(of kiest een bestaande) en geeft aan dat je die wil delen met rechtsklik.
Ubuntu vraagt je dan om aanvullende bestanden te installeren.
dat wil je dan.
nog even een gebruiker aanmaken met wachtwoord in de terminal en dat is het dan.

hosti

  • Gast
Windows wachtwoord.
« Reactie #7 Gepost op: 2007/08/14, 23:26:39 »
idd. maar door een map te delen ga je dat wachtwoord niet uit de weg, maw kan je nog steeds niet aan je bestanden. Je zult hoe dan ook je samba moeten instellen, met name de autenticatie (hoewel ik de naam verkeerd vind). Voor een niet veilig maar toegankelijk systeem deze parameter veranderen (zie /usr/share/doc/samba-doc/htmldocs/ServerType.html)
""# "security = user" is always a good idea. This will require a Unix account"

####### Authentication #######

# "security = user" is always a good idea. This will require a Unix account
# in this server for every user accessing the server. See
# /usr/share/doc/samba-doc/htmldocs/ServerType.html in the samba-doc
# package for details.
;   security = user

# You may wish to use password encryption.  See the section on
# 'encrypt passwords' in the smb.conf(5) manpage before enabling.
   encrypt passwords = true

# If you are using encrypted passwords, Samba will need to know what
# password database type you are using.  
   passdb backend = tdbsam

   obey pam restrictions = yes

;   guest account = nobody
   invalid users = root

# This boolean parameter controls whether Samba attempts to sync the Unix
# password with the SMB password when the encrypted SMB password in the
# passdb is changed.
;   unix password sync = no

# For Unix password sync to work on a Debian GNU/Linux system, the following
# parameters must be set (thanks to Augustin Luton for
# sending the correct chat script for the passwd program in Debian Potato).
   passwd program = /usr/bin/passwd %u
   passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n .

# This boolean controls whether PAM will be used for password changes
# when requested by an SMB client instead of the program listed in
# 'passwd program'. The default is 'no'.
;   pam password change = no
...maar hiermee is je probleem nog niet opgelost: je moet namelijk nog een parameter veranderen zodat BEIDE machines niet dezelfde user account nodig hebben - dit is de kern van je probleem.