Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: foutje gemaakt met : java non-free  (gelezen 850 keer)

artvds2708

  • Gast
foutje gemaakt met : java non-free
« Gepost op: 2007/08/11, 21:51:20 »
en nu krijg ik steeds dit te zien in Synaptic :

E: /var/cache/apt/archives/flashplugin-nonfree_9.0.48.0.0ubuntu5_i386.deb: subproces nieuw pre-removal script gaf een foutwaarde 2 terug

Wat nu ?
Kan niets meer erbij of eraf halen !
En dat is goed balen.

Wie weet wat nu te doen ?!?!
Graag advies.
BVD

PS opnieuw installeren was geen succes :

artvds2708@artvds2708:~$ sudo apt-get install flashplugin-nonfree
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd      
Reading state information... Klaar
flashplugin-nonfree is reeds de nieuwste versie.
flashplugin-nonfree is ingesteld als handmatig geinstalleerd.
0 pakketten opgewaardeerd, 0 pakketten nieuw geïnstalleerd, 0 te verwijderen en 0 niet opgewaardeerd.
1 pakketten niet volledig geïnstalleerd of verwijderd.
Er moeten 0B/17,3kB aan archieven opgehaald worden.
Na het uitpakken zal er 0B extra schijfruimte gebruikt worden.
Voorconfigureren van pakketten...
(Database inlezen ... 168009 bestanden en mappen geïnstalleerd.)
Voorbereiden om flashplugin-nonfree 9.0.48.0.0ubuntu5 te vervangen (door .../flashplugin-nonfree_9.0.48.0.0ubuntu5_i386.deb) ...
/var/lib/dpkg/info/flashplugin-nonfree.prerm: 28: Syntax error: "do" unexpected (expecting ";;")
dpkg: waarschuwing - verouderd pre-removal script gaf een foutcode 2
dpkg - script uit het nieuwe pakket wordt geprobeerd ...
/var/lib/dpkg/tmp.ci/prerm: 28: Syntax error: "do" unexpected (expecting ";;")
dpkg: fout bij afhandelen van /var/cache/apt/archives/flashplugin-nonfree_9.0.48.0.0ubuntu5_i386.deb (--unpack):
 subproces nieuw pre-removal script gaf een foutwaarde 2 terug
/var/lib/dpkg/info/flashplugin-nonfree.postinst: 107: Syntax error: "do" unexpected (expecting "fi")
dpkg: fout tijdens opruimen:
 subproces post-installation script gaf een foutwaarde 2 terug
Fouten gevonden tijdens behandelen van:
 /var/cache/apt/archives/flashplugin-nonfree_9.0.48.0.0ubuntu5_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

En verwijderen lukte ook al niet :

artvds2708@artvds2708:~$ sudo apt-get remove flashplugin-nonfree
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd      
Reading state information... Klaar
De volgende pakketten zullen VERWIJDERD worden:
  flashplugin-nonfree
0 pakketten opgewaardeerd, 0 pakketten nieuw geïnstalleerd, 1 te verwijderen en 0 niet opgewaardeerd.
1 pakketten niet volledig geïnstalleerd of verwijderd.
Er moeten 0B aan archieven opgehaald worden.
Na het uitpakken zal er 152kB schijfruimte vrijkomen.
Wilt u doorgaan [J/n]? j
dpkg: fout bij afhandelen van flashplugin-nonfree (--remove):
 Pakket is in een ernstige inconsistente status - u moet het opnieuw
 installeren alvorens het te verwijderen.
Fouten gevonden tijdens behandelen van:
 flashplugin-nonfree
E: Sub-process /usr/bin/dpkg returned an error code (1)

Offline Prosper

  • Forumteam
  • Steunpunt: Nee
foutje gemaakt met : java non-free
« Reactie #1 Gepost op: 2007/08/12, 07:49:28 »
Probeer eens met Synaptic: selecteer Custom Filter en dan broken, vervolgens rechtsklikken op elk gevonden pakket. Ik heb nu zelf geen gebroken paketten (gelukkig), maar je krijgt allicht een of meerdere keuzes (Mark for Installation, Mark for ...).  Kies naar eigen inzicht.
Omwille van de besparingen hebben ze het licht aan het eind van de tunnel ook uitgedaan...

artvds2708

  • Gast
foutje gemaakt met : java non-free
« Reactie #2 Gepost op: 2007/08/13, 12:30:56 »
@Prosper
Het heeft zichzelf al opgelost !
Dit kwam dankzij een software-update.
Alles werkt weer prima.