Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Geluid soms wel/soms niet  (gelezen 1530 keer)

Offline shappie

  • Lid
  • Steunpunt: Nee
Geluid soms wel/soms niet
« Gepost op: 2007/08/07, 13:42:37 »
Hallo,

ik heb ubuntu en mijn soundblaster live 5.1 werkt soms perfect! Maar soms heb ik gewoon geen geluid en dat is laatste keer steeds vaker! Als ik herstart is het soms weer terug. Mijn geluid staat gewoon op de live 5.1 (alsamixer) dus dit klopt?

Iemand een idee? Het is namelijk heel vervelend. Met mijn onboard AC97 ook hetzelfde probleem, dus dit helpt niet.

Alvast bedankt, Shappie

Edit: Sorry hij staat verkeerd, hoe moet ik deze verplaatsen?
- Intel i7 860 - ATi HD3580 - 4GB DDR3 - Intel X25-M 80GB - Dual Screen Samsung 206BW - Win7/Kubuntu dualboot -

martensson

  • Gast
Geluid soms wel/soms niet
« Reactie #1 Gepost op: 2007/08/07, 15:25:30 »
Kun je geen (fout)melding vinden nadat je geluid wegvalt?  Kijk eens in de /var/log/syslog  of  /var/log/errorlog.

Offline happyhamster

  • Lid
  • Steunpunt: Nee
Geluid soms wel/soms niet
« Reactie #2 Gepost op: 2007/08/07, 15:35:11 »
Je kan proberen in de bios van de pc de on-board kaart uit te schakelen. Als dat niet werkt, of als je dat niet wilt, dan moet je handmatig instellen welke kaart de standaard kaart wordt.

De volgende commandos geven de benodigde informatie:

cat /proc/asound/cards

cat /proc/asound/modules

cat /etc/modprobe.d/alsa-base

Je kan een commando intikken of copy&pasten in een terminalvenster. Kan je de uitvoer hier laten zien?

Laat het weten als er problemen zijn. Succes!

Offline shappie

  • Lid
  • Steunpunt: Nee
Geluid soms wel/soms niet
« Reactie #3 Gepost op: 2007/08/07, 15:52:54 »
Ik heb alsamixergui geinstalleerd en daar stond bovenin ac97 tewijl ik bij geluid de soundblaster had ingesteld en de ac97 doet het nu goed ook na een herstart.

Ik zal even kijken naar die commando's

edit:
mart@mart-desktop:~$ cat /proc/asound/cards
 0 [ICH5           ]: ICH4 - Intel ICH5
                      Intel ICH5 with AD1888 at 0xfebff800, irq 21
 1 [default        ]: USB-Audio - C-Media USB Audio      
                      C-Media INC. C-Media USB Audio        at usb-0000:00:1d.1-2, full speed
 2 [Live           ]: EMU10K1 - SB Live 5.1
                      SB Live 5.1 (rev.7, serial:0x80641102) at 0xdf80, irq 21

mart@mart-desktop:~$ cat /proc/asound/modules
 0 snd_intel8x0
 1 snd_usb_audio
 2 snd_emu10k1

mart@mart-desktop:~$ cat /etc/modprobe.d/alsa-base
# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-ioctl32 ; : ; }
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --Qb snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-seq-midi ; /sbin/modprobe --quiet snd-seq-oss ; : ; }

# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe -Qb saa7134-alsa ; : ; }

# Load snd-seq for devices that don't have hardware midi;
#   Ubuntu #26283, #43682, #56005; works around Ubuntu #34831 for
#   non-Creative Labs PCI hardware
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-seq ; }
# Prevent abnormal drivers from grabbing index 0
options snd-bt87x index=-2
options cx88-alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
- Intel i7 860 - ATi HD3580 - 4GB DDR3 - Intel X25-M 80GB - Dual Screen Samsung 206BW - Win7/Kubuntu dualboot -

Offline shappie

  • Lid
  • Steunpunt: Nee
Geluid soms wel/soms niet
« Reactie #4 Gepost op: 2007/08/07, 15:57:20 »
Citaat van: martensson
Kun je geen (fout)melding vinden nadat je geluid wegvalt?  Kijk eens in de /var/log/syslog  of  /var/log/errorlog.
Het valt niet weg, de ene keer werkt het als ik mijn pc aanzet en de andere keer gewoon niet. Dus in een sessie blijft het hetzelfde.

Ps. weet iemand of mijn trust USB speakers ondersteund worden??? De driver lijkt te kloppen maar als ik het daarop instel geen geluid, hetzelfde als bij soundblaster. Alleen doen de usb speakers het nooit (tot nu toe).
- Intel i7 860 - ATi HD3580 - 4GB DDR3 - Intel X25-M 80GB - Dual Screen Samsung 206BW - Win7/Kubuntu dualboot -

Offline happyhamster

  • Lid
  • Steunpunt: Nee
Geluid soms wel/soms niet
« Reactie #5 Gepost op: 2007/08/07, 16:05:11 »
Wow! Je hebt 3 geluidskaarten: 1 onboard, 1 behorende bij de usb-speakers, en de soundblaster.

Offline shappie

  • Lid
  • Steunpunt: Nee
Geluid soms wel/soms niet
« Reactie #6 Gepost op: 2007/08/07, 16:07:05 »
Klopt :)

Meestal een voordeel, maar nu denk ik niet :(
- Intel i7 860 - ATi HD3580 - 4GB DDR3 - Intel X25-M 80GB - Dual Screen Samsung 206BW - Win7/Kubuntu dualboot -

Offline happyhamster

  • Lid
  • Steunpunt: Nee
Geluid soms wel/soms niet
« Reactie #7 Gepost op: 2007/08/07, 16:22:17 »
Wat je kan doen is in alsa-base de volgende regels toevoegen:


# Toegevoegd door user, augustus 2007.
options snd_emu10k1 index=0
options snd_intel8x0 index=1


Dat zorgt ervoor dat soundblaster de standaard kaart wordt (index=0). Onboard sound zal nog steeds werken, maar zit lager in de rangorde (index =1). Meestal kan je dan per applicatie uitkiezen welke kaart gebruikt moet worden (maar standaard zal soundblaster gekozen worden).

De reden dat de usb-speakers niet werkten, was omdat er standaard een regel in alsa-base aanwezig is die usb-audio min of meer uitschakelt (index=-2).


- N.B. Editen van alsa-base doe je het best via:

sudo nano /etc/modprobe.d/alsa-base

- En je kan eventueel eerst een copie maken via:

sudo cp /etc/modprobe.d/alsa-base ~/alsa-base.origineel

- Plaats de backup niet in /etc/modprobe.d/ , want er zijn meldingen dat dit problemen kan geven. Om dezelfde reden kan je beter niet de editor gedit gebruiken (i.p.v. nano), want gedit maakt standaard een backup.

- Je kan ook gewoon wat experimenteren, bijv. door de snd-usb-audio module een index 0 te geven i.p.v. soundblaster etc.

[edit: saven in nano = ctrl-o, afsluiten = ctrl-x]

Offline shappie

  • Lid
  • Steunpunt: Nee
Geluid soms wel/soms niet
« Reactie #8 Gepost op: 2007/08/07, 16:56:08 »
Sorry maar ik ben nog aardig noob op het terminal gebied, hoe zet ik mijn usb aan? Want opzich hoeft mijn soundblaster niet op nr. 1 te staan. Die soundblaster zit er in voor zijn gameport en voor windows. Want windows geeft een slecht (krakerig) geluid met mijn onboard sound. Ubuntu heeft hier gelukkig geen problemen mee.

Hoe krijg ik usb speakers goed werkend? (dit is wel nodig om bijv. een film te kijken met vrienden, aangezien dat met speakers moet en niet met headset kan)
- Intel i7 860 - ATi HD3580 - 4GB DDR3 - Intel X25-M 80GB - Dual Screen Samsung 206BW - Win7/Kubuntu dualboot -

Offline happyhamster

  • Lid
  • Steunpunt: Nee
Geluid soms wel/soms niet
« Reactie #9 Gepost op: 2007/08/07, 16:58:08 »
Zou je vreemde foutmeldingen krijgen, probeer dan:

# Toegevoegd door user, augustus 2007.
options snd-emu10k1 index=0
options snd-intel8x0 index=1


(Dus met een "-" streepje  i.p.v. een "_" in de module naam. Excuses voor het ongemak.)

Offline happyhamster

  • Lid
  • Steunpunt: Nee
Geluid soms wel/soms niet
« Reactie #10 Gepost op: 2007/08/07, 17:00:55 »
Usb aanzetten, voeg dan de volgende tekst toe (in plaats van het voorgaande):


# Toegevoegd door user, augustus 2007.
options snd-usb-audio index=0
options snd-emu10k1 index=1
options snd-intel8x0 index=2




- en verwijder de regel:

options snd-usb-audio index=-2

- door er een # teken voor te zetten:

# options snd-usb-audio index=-2


- Save & exit.
- Reboot.

[edit: en dan zal je waarschijnlijk in het Systeem-->Voorkeuren-->Geluid menu de juiste kaart moeten selecteren]

Offline shappie

  • Lid
  • Steunpunt: Nee
Geluid soms wel/soms niet
« Reactie #11 Gepost op: 2007/08/07, 18:08:03 »
Super bedankt!! Het werkt perfect mijn boxjes nu. Ik moest wel even nadenken toen ik opeens het opstartgeluid op mijn boxjes hoorde :)
- Intel i7 860 - ATi HD3580 - 4GB DDR3 - Intel X25-M 80GB - Dual Screen Samsung 206BW - Win7/Kubuntu dualboot -