Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Scherm op zwart en Grub  (gelezen 1465 keer)

Offline Daniel Trapman

  • Lid
  • Steunpunt: Nee
Scherm op zwart en Grub
« Gepost op: 2007/08/05, 20:25:00 »
Hallo allemaal,

Ik ben nieuw hier op het forum en ook nieuw als Ubuntu gebruiker. Ik heb met veel pijn en moeite een Dual Boot kunnen maken tussen XP en Ubuntu.

Als ik Ubuntu opstart, dan gaat het scherm op zwart. De monitor komt dan in een soort stand by modus. Om vervolgens na een minuutje ofzo weer aan te springen met het inlogscherm. Is er een manier om dit te omzeilen?

En nu kan ik kiezen in het Grub? menu voor Ubuntu en Windows. Maar ik moet binnen een bepaalde tijd een keuze maken anders start hij standaard Ubuntu. Is er een manier om het menu in beeld te houden? Dat ik verplicht ben om een keuze te maken?

Met vriendelijke groet,

Daniel

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Scherm op zwart en Grub
« Reactie #1 Gepost op: 2007/08/05, 20:33:38 »
Welkom op het forum!  :-)

Grub menulijst wijzigen:

Windows als standaardkeuze:
https://wiki.ubuntu.com/NlFaq#head-e661e5224e4a9d1c5055a155439a7de302a26758

zwarte scherm: doe eens dit:
Systeem - Beheer - Synaptic pakketbeheer
zoekterm: xresprobe
aanvinken en druk op knop Toepassen

Daarna:
Toepassingen - Hulpmiddelen - Terminalvenster
tik in: sudo ddcprobe  (wachtwoord blijft onzichtbaar)

en post hier eens de uitkomst daarvan? Gewoon kopieren en plakken vanuit de terminal.

Offline Daniel Trapman

  • Lid
  • Steunpunt: Nee
Scherm op zwart en Grub
« Reactie #2 Gepost op: 2007/08/05, 21:16:09 »
De timeout is opgelost. Bedankt hiervoor.

xresprobe stond al aangevinkt.

Dit is de uitkomst van ddcprobe

vbe: VESA 2.0 detected.
oem: Copyright 1998 TRIDENT MICROSYSTEMS INC.
memory: 8064kb
mode: 1280x1024x64k
mode: 1280x1024x32k
mode: 1024x768x16m
mode: 1280x1024x256
mode: 640x480x16m
mode: 800x600x16m
mode: 1024x768x32k
mode: 1024x768x64k
mode: 800x600x32k
mode: 800x600x64k
mode: 640x480x32k
mode: 640x480x64k
mode: 1024x768x256
mode: 1280x1024x16
mode: 640x400x256
mode: 800x600x256
mode: 1024x768x16
mode: 800x600x16
mode: 132x25 (text)
mode: 132x43 (text)
mode: 132x60 (text)
mode: 640x480x256
edid:
edid: 1 0
id: 019b
eisa: STC019b
serial: 00000000
manufacture: 0 1997
input: sync on green, analog signal.
screensize: 27 20
gamma: 1.000000
dpms: RGB, active off, suspend, standby
timing: 720x400@70 Hz (VGA 640x400, IBM)
timing: 640x480@75 Hz (VESA)
timing: 800x600@60 Hz (VESA)
timing: 1024x768@87 Hz Interlaced (8514A)
timing: 1024x768@75 Hz (VESA)
ctiming: 248x155@123
ctiming: 2288x1430@123
ctiming: 2288x1430@123
ctiming: 2288x1430@123
dtiming: 4095x4095@34
dtiming: 4095x4095@34
dtiming: 4095x4095@34
dtiming: 4095x4095@34


PS. Mijn petje af voor jullie. Ik kan hier geen kaas van maken.

Groetjes,

Daniel

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Scherm op zwart en Grub
« Reactie #3 Gepost op: 2007/08/05, 21:19:30 »
alles went.... zelfs Linux!  :-)

Doe eens dit:
Toepassingen - Hulpmiddelen - Terminalvenster
tik in: sudo gedit /etc/X11/xorg.conf  (let op de hoofdletter in X11; wachtwoord blijft onzichtbaar)

Verander in de Section "Screen", de DefaultDepth van 24 in 16
Opslaan, sluiten, herstarten.

Helpt dit?

Uitleg: dat ouwe Trident kaartje met 8 MB video-RAM, wordt te zwaar belast met 24 bits kleurendiepte. Met 16 bits kleurendiepte hoeft hij veel minder hard te ploeteren. Terwijl je geen verschil merkt in de weergavekwaliteit.

Offline Daniel Trapman

  • Lid
  • Steunpunt: Nee
Scherm op zwart en Grub
« Reactie #4 Gepost op: 2007/08/05, 21:37:49 »
Hoi,

Hij valt nog steeds uit, maar hij laat nu sneller beeld zien. Voorheen ging hij pas weer aan bij het inlogscherm, nu zie ik, als het beeld weer terugkomt, een hoop regels voorbij komen.

Mounting dit, starting dat. Dat zal wel standaard zijn. Maar het probleem is nu voor de helft opgelost. Ik dacht, laat ik hem dan eens op 8 zetten. Werkt niet, en het beeld wordt er ook niet beter van. :D

Misschien nog een andere oplossing?

Groetjes,

Daniel

PS. Tof dat jullie zo'n beginnertje willen helpen met wat jullie waarschijnlijk blindelings doen.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Scherm op zwart en Grub
« Reactie #5 Gepost op: 2007/08/05, 21:51:39 »
OK. Doe eens dit:

In terminal (Toepassingen - Hulpmiddelen - Terminalvenster):
sudo dpkg-reconfigure xserver-xorg

Maak in die vragenriedel geen enkele eigen keuze, ga meteen akkoord met alle voorgestelde antwoorden. Behalve de kleurendiepte, zet die weer op 16.
Toetsgebruik: Tabtoets, spatiebalk, *binnenste* entertoets, pijltjestoetsen.

Daarna volledige herstart van je PC (!!).

Helpt dit?

Offline Daniel Trapman

  • Lid
  • Steunpunt: Nee
Scherm op zwart en Grub
« Reactie #6 Gepost op: 2007/08/05, 22:22:52 »
Hoi,

Het heeft helaas niks uitgehaald. Voor de rest lijkt Ubuntu het goed te doen. Ik denk dat ik er maar mee moet leven. Althans, tot ik een andere videokaart heb.

In ieder geval bedankt voor jullie hulp.

Groetjes,

Daniel

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Scherm op zwart en Grub
« Reactie #7 Gepost op: 2007/08/05, 22:25:56 »
Je zou nog 1 ding kunnen proberen:
sudo gedit /etc/X11/xorg.conf

en wis alle resoluties behalve de juiste. Dus 640x480, 800x600 en alles boven de 1024x768 (ik neem aan dat je monitor op 1024x768 staat).

Daarna herstart.

Offline Daniel Trapman

  • Lid
  • Steunpunt: Nee
Scherm op zwart en Grub
« Reactie #8 Gepost op: 2007/08/05, 22:29:38 »
Voordat ik daaraan begin... je bedoeld bij Section "Screen" ?

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Scherm op zwart en Grub
« Reactie #9 Gepost op: 2007/08/05, 22:30:25 »
Juist!  De "modes".

Offline Daniel Trapman

  • Lid
  • Steunpunt: Nee
Scherm op zwart en Grub
« Reactie #10 Gepost op: 2007/08/05, 22:36:12 »
Helaas heeft dat ook niks mogen baten :(

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Scherm op zwart en Grub
« Reactie #11 Gepost op: 2007/08/06, 09:28:51 »
OK. Maar dit zou wel moeten werken:

Terminal:
sudo gedit /boot/grub/menu.lst

Ergens middenin de menulijst vind je het volgende onderdeel:

## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=quiet splash

Verander dat als volgt (laatste regel):

## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
defoptions="vga=791"

Opslaan, sluiten, herstarten.

Helpt dit?

Zo niet, haal dan de aanhalingstekens eens weg in de laatste regel:
defoptions=vga=791

Offline Daniel Trapman

  • Lid
  • Steunpunt: Nee
Scherm op zwart en Grub
« Reactie #12 Gepost op: 2007/08/06, 10:34:56 »
Helaas. Ik heb dat vga=791 tussen de aanhalingstekens gezet zoals in jouw voorbeeld, en daarna zonder. Maar het probleem blijft. Het is ook al zo'n oude videokaart.

Maar in ieder geval bedankt.

Groetjes,

Daniel

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Scherm op zwart en Grub
« Reactie #13 Gepost op: 2007/08/06, 10:41:11 »
Hmmm..... probeer tenslotte dit eens:

sudo /boot/grub/menu.lst

En zet die kreet (vga=791) eens in de eerste kernel-regel.
Voorbeeldje:
kernel /boot/vmlinuz-2.6.20-16-generic root=UUID=919570e9-2ef5-410b-9e27-0ebb77636bda vga=791 ro quiet splashOpslaan, sluiten, herstarten.

Helpt dit?