Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: geen geluid via koptelefoon  (gelezen 2967 keer)

martinm3

  • Gast
geen geluid via koptelefoon
« Gepost op: 2007/08/04, 23:39:03 »
heb 7.04 zowel op desktop als op laptop 7.04 geinstalleerd. op zich werkt het prima maar bij mijn laptop sluit de geluidskaart zich niet meer af als ik de koptelefoon aansluit en hij geeft ook geen geluid via de koptelefoon. bij de desktop werkt het prima. kan hierover niets vinden in het forum of elders.
kortom wie weet hier een oplossing voor?

martin

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
geen geluid via koptelefoon
« Reactie #1 Gepost op: 2007/08/04, 23:40:46 »
Installeer eens alsamixergui (gewoon, via Systeem - Beheer - Synaptic pakketbeheer) en post hier eens een schermafdruk van alle schuifjes in alsamixergui?
Posten kan met behulp van http://imageshack.us

martinm3

  • Gast
geen geluid via koptelefoon
« Reactie #2 Gepost op: 2007/08/04, 23:59:03 »
/home/m/Desktop/Schermafdruk.png

hoop dat je dit kunt zien

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
geen geluid via koptelefoon
« Reactie #3 Gepost op: 2007/08/05, 00:02:02 »

martinm3

  • Gast
geen geluid via koptelefoon
« Reactie #4 Gepost op: 2007/08/05, 23:01:46 »
heb het geprobeert met imageshack maar heb mogelijk een blinde vlek hiervoor.
ben er inmidels w.s. wel achter wat er aan de hand is. mijn laptop heeft een Realtek ALC883 aan boord en ik kan hiervoor geen driver vinden.
kijk mogelijk op de verkeerde plekken maar het enige wat ik hier over tegen ben gekomen is dat realtek hiervoor geen ubuntu driver heeft.
het probleem is wel wat duidelijker geworden.heb 3 jack ingangen zwart, rood en groen.
normaal is het dat de rode jack in de rode ingang ,de groene in de groene ingang etc.
en de koptelefoon werkt naar behoren en de interne speaker is uitgeschakeld.
bij mij werkt het ietwat anders: geluid uit de interne speaker is OK maar als ik de groene jack daar steek waar hij hoort dan sluit de interne speaker niet af en hoor ik niets in de koptelefoon. steek ik echter de groene jack in de zwarte ingang dan komt er goed geluid uit de koptelefoon maar wordt de interne speaker niet afgesloten.. de rode van de microfoon heb ik dus nog niet kunnen testen daar het allemaal niet werkt zoals het zou moeten.
Is er mogelijk een alternatieve driver te vinden ?
martin

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
geen geluid via koptelefoon
« Reactie #5 Gepost op: 2007/08/05, 23:06:57 »
Op imageshack: upload - bladeren - selecteer de schermafdruk

martinm3

  • Gast
geen geluid via koptelefoon
« Reactie #6 Gepost op: 2007/08/05, 23:42:32 »

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
geen geluid via koptelefoon
« Reactie #7 Gepost op: 2007/08/06, 09:15:15 »
Bijna.....!  Nu is de afbeelding nog te klein om de schuifjes te zien. Plaats er eens een grotere versie?

martinm3

  • Gast
geen geluid via koptelefoon
« Reactie #8 Gepost op: 2007/08/06, 12:37:23 »
oefining baart kunst zullen we maar zeggen. hoop dat dit wel goed is.

http://img453.imageshack.us/img453/6473/schermafdrukschermafdruns6.png

Offline happyhamster

  • Lid
  • Steunpunt: Nee
geen geluid via koptelefoon
« Reactie #9 Gepost op: 2007/08/06, 17:21:00 »
Martinm3: slechts de helft van de schuifjes zijn te zien zo :).

Het zou kunnen dat je hier tegenaan loopt:
https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/114053

Je kan controleren welke kaart en module je gebruikt via de commando's*:

cat /proc/asound/cards

cat /proc/asound/modules

(waarschijnlijk gaat het om de ALC883 codec, en de snd_hda_intel module)

- Vervolgens kan je dan proberen in het alsa-configuratiebestand het precieze kaart-model in te stellen:

sudo nano /etc/modprobe.d/alsa-base

- Voeg aan het einde van het bestand de volgende regel toe:

options snd_hda_intel model=6stack-dig

- Save & exit (via ctrl-o en ctrl-x)
- Reboot.
- Werkt dat niet, probeer dan een ander model, de mogelijke opties zijn:

     3stack-dig   3-jack with SPDIF I/O
     6stack-dig   6-jack digital with SPDIF I/O
     3stack-6ch    3-jack 6-channel
     3stack-6ch-dig 3-jack 6-channel with SPDIF I/O
     6stack-dig-demo  6-jack digital for Intel demo board
     acer      Acer laptops (Travelmate 3012WTMi, Aspire 5600, etc)
     auto      auto-config reading BIOS (default)

(Bron: ALSA Configuration guide)

Dus 3stack-dig, 6stack-dig, etc.


- Als het niet lukt, kan je dan een nieuwe screenshot uploaden? (met een volledig 'opgerekte' alsamixergui)
- Kan je hier de uitvoer van:

cat /proc/asound/cards

cat /proc/asound/modules

cat /etc/modprobe.d/alsa-base

- laten zien? Laat het weten als er problemen zijn.

*: invoeren (bijv. met copy&paste) in een terminal (Applications-->Accessories-->Terminal of Toepassingen-->Hulpmiddelen-->Terminalvenster)

Offline jan11000

  • Lid
  • Steunpunt: Nee
geen geluid via koptelefoon
« Reactie #10 Gepost op: 2007/08/06, 18:22:52 »
Probeer dit eens:
in terminal
asoundconf-gtk

martinm3

  • Gast
geen geluid via koptelefoon
« Reactie #11 Gepost op: 2007/08/08, 10:28:25 »
heb alle sugesties uitgeprobeerd. het enig wat het opleverd is dat de geluidskaart helemaal geen geluid meer produceerde. de laatse suggestie (auto) leverde in ieder geval op dat de situatie weer werd zoals hij was.-- dus wel geluid uit de laptop en geluid via de koptelefoon in de zwarte uitgang zonder dat  de speaker afgesloten wordt.  
hieronder wat ik gevonden heb van de rest van de suggesties. hopelijk kun je er wat mee.
vind het wel erg leuk om er mee bezig te zijn  en er van te leren, vind ubuntu erg leuk programma.
martin


http://img456.imageshack.us/img456/4201/schermafdruk1us8.png

m@m-laptop:~$ cat /proc/asound/cards
 0 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xc0000000 irq 22
m@m-laptop:~$ cat /proc/asound/modules
 0 snd_hda_intel
m@m-laptop:~$ cat /etc/modprobe.d/alsa-base
# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-ioctl32 ; : ; }
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --Qb snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-seq-midi ; /sbin/modprobe --quiet snd-seq-oss ; : ; }

# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe -Qb saa7134-alsa ; : ; }

# Load snd-seq for devices that don't have hardware midi;
#   Ubuntu #26283, #43682, #56005; works around Ubuntu #34831 for
#   non-Creative Labs PCI hardware
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-seq ; }
# Prevent abnormal drivers from grabbing index 0
options snd-bt87x index=-2
options cx88-alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
options snd_hda_intel model=auto

martinm3

  • Gast
geen geluid via koptelefoon
« Reactie #12 Gepost op: 2007/08/08, 21:25:34 »
Citaat van: martinm3
heb alle sugesties uitgeprobeerd. het enig wat het opleverd is dat de geluidskaart helemaal geen geluid meer produceerde. de laatse suggestie (auto) leverde in ieder geval op dat de situatie weer werd zoals hij was.-- dus wel geluid uit de laptop en geluid via de koptelefoon in de zwarte uitgang zonder dat  de speaker afgesloten wordt.  
hieronder wat ik gevonden heb van de rest van de suggesties. hopelijk kun je er wat mee.
vind het wel erg leuk om er mee bezig te zijn  en er van te leren, vind ubuntu erg leuk programma.
martin


http://img456.imageshack.us/img456/4201/schermafdruk1us8.png

m@m-laptop:~$ cat /proc/asound/cards
 0 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xc0000000 irq 22
m@m-laptop:~$ cat /proc/asound/modules
 0 snd_hda_intel
m@m-laptop:~$ cat /etc/modprobe.d/alsa-base
# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-ioctl32 ; : ; }
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --Qb snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-seq-midi ; /sbin/modprobe --quiet snd-seq-oss ; : ; }

# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe -Qb saa7134-alsa ; : ; }

# Load snd-seq for devices that don't have hardware midi;
#   Ubuntu #26283, #43682, #56005; works around Ubuntu #34831 for
#   non-Creative Labs PCI hardware
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-seq ; }
# Prevent abnormal drivers from grabbing index 0
options snd-bt87x index=-2
options cx88-alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
options snd_hda_intel model=auto

Offline happyhamster

  • Lid
  • Steunpunt: Nee
geen geluid via koptelefoon
« Reactie #13 Gepost op: 2007/08/09, 03:42:33 »
Kan je misschien de uitvoer van het volgende commando laten zien:

amixer

martinm3

  • Gast
geen geluid via koptelefoon
« Reactie #14 Gepost op: 2007/08/09, 10:35:17 »
bij deze, probeer het te lezen maar het is chinees voor mij.

m@m-laptop:~$ amixer
Simple mixer control 'Headphone',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 31 [100%] [0.00dB] [on]
  Front Right: Playback 31 [100%] [0.00dB] [on]
Simple mixer control 'PCM',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 255 [100%] [0.00dB]
  Front Right: Playback 255 [100%] [0.00dB]
Simple mixer control 'Front',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 27 [87%] [-6.00dB] [on]
  Front Right: Playback 27 [87%] [-6.00dB] [on]
Simple mixer control 'Front Mic',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 23 [74%] [0.00dB] [on]
  Front Right: Playback 23 [74%] [0.00dB] [on]
Simple mixer control 'Line',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 30 [97%] [10.50dB] [on]
  Front Right: Playback 30 [97%] [10.50dB] [on]
Simple mixer control 'Mic',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 23 [74%] [0.00dB] [on]
  Front Right: Playback 14 [45%] [-13.50dB] [on]
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 31
  Front Left: Capture 25 [81%] [25.50dB] [off]
  Front Right: Capture 25 [81%] [25.50dB] [off]
Simple mixer control 'Capture',1
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 31
  Front Left: Capture 26 [84%] [27.00dB] [off]
  Front Right: Capture 26 [84%] [27.00dB] [off]
Simple mixer control 'Caller ID',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'Input Source',0
  Capabilities: enum
  Items: 'Mic' 'Front Mic' 'Line'
  Item0: 'Mic'
Simple mixer control 'Input Source',1
  Capabilities: enum
  Items: 'Mic' 'Front Mic' 'Line'
  Item0: 'Mic'
Simple mixer control 'Off-hook',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
m@m-laptop:~$

martinm3

  • Gast
geen geluid via koptelefoon
« Reactie #15 Gepost op: 2007/08/10, 18:08:00 »
heb het opgegeven en ben weer teruggegaan naar vista, hier werkt het wel en is het goed in te stellen. ga wel door met ubuntu maar op aparte schijf zodat ik kan wisselen.
in ieder geval voorlopig bedankt voor de inspanningen en ik kom zeker terug met nieuwe vragen
martin