Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Hulp bij installatie aub =)  (gelezen 4708 keer)

mauro

  • Gast
Hulp bij installatie aub =)
« Gepost op: 2007/07/31, 17:14:38 »
Hallo, sinds gisteren heb ik Ubuntu op mijn pc naast XP geinstalleerd.

Ik wou het vooral een keertje proberen omdat Linux,Unix,Ubuntu OS vlotter zouden draaien en bvb bij 3d applicaties een beetje meer frame rate zou opleveren.

Maar nu -leek die ik momenteel ben- kan ik niet eens een spel installeren,soms krijg ik een prompt-venster om een programma te 'runnen',klik ik ook aan,maar der gebeurt helemaal niets. Enkel wordt mijn scherm ff zwart(dacht eerst dat het het programma aan het laden was),maar dan kom ik direct terug op mijn bureaublad en is de resolutie ervan plotseling helemaal anders,waardoor mijn ganse bureaublad niet op mijn scherm geraakt o_O ?

Kan iemand een leek in nood helpen aub? Heb al proberen te zoeken op Ubuntu en google,maar telkens niets nuttigs gevonden :(

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Hulp bij installatie aub =)
« Reactie #1 Gepost op: 2007/07/31, 17:17:23 »
Wat is je harde waar? Zo precies mogelijk.

Groet, Pjotr.

mauro

  • Gast
Hulp bij installatie aub =)
« Reactie #2 Gepost op: 2007/07/31, 17:20:30 »
euhm

Intel Celeron 3.0gig
512mb RAM
Intel Extreme Graphics 2
Intel chipset,mobo
120 Harde schijf

verder nog iets?

mauro

  • Gast
Hulp bij installatie aub =)
« Reactie #3 Gepost op: 2007/07/31, 17:24:31 »
Ik denk mss eerder dat het iets te maken heeft met wat ik juist moet doen imo,want het spel draaide op windows perfect

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Hulp bij installatie aub =)
« Reactie #4 Gepost op: 2007/07/31, 17:29:08 »
OK... Je harde waar, daar hoef je niks aan te doen, want Intel videokaartjes hebben automatisch de juiste driver al (open bron, zit al in de Linuxkernel).

Welk spel is het?

Overigens gaat installeren heel anders (makkelijker) dan in Windows: namelijk uit de eigen pakketbronnen van Ubuntu. Via Toepassingen - Installeren/verwijderen (beperkte keuze) en via Systeem - Beheer - Synaptic pakketbeheer (ruimste keuze, uit 21.000 programma's).

mauro

  • Gast
Hulp bij installatie aub =)
« Reactie #5 Gepost op: 2007/07/31, 17:46:50 »
@Pjotr : het spel noemt Warsow ,gebaseerd op de Quake2-engine
  heb er de linux versie van binnengehaald en die ging automatisch naar mijn bureaublad(nu ja,map toch) ,maar ik zal het eens proberen met wat jij suggereert ,ty :)


@Arie:   zoals hierboven staat,gaat het wel degelijk om de linuxversie van het spel die ik gedownload heb.
De resolutie staat al goed,en als ik het terug zet,verandert er niets



Mauro ;)

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Hulp bij installatie aub =)
« Reactie #6 Gepost op: 2007/07/31, 18:00:08 »
warsow=native linux. bron oa: http://linuxappfinder.com/package/warsow
de deb. installeert zich via gdebi pakketmanager.
meer games: http://forum.ubuntu-nl.org/topic/1205

3d games in de synaptic: nexuiz en openarena

mauro

  • Gast
Hulp bij installatie aub =)
« Reactie #7 Gepost op: 2007/07/31, 18:02:38 »
Wat me opeens te binnen schiet: is het ook niet mogelijk om pakketten te installeren die je hebt gedownload?
dus: jij download het bestand ,zet het ergens neer en het programma(synaptic,of dat ene bij apps) zoekt het en installeren maar?

Zou wel enorm makkelijk zijn :) :>

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Hulp bij installatie aub =)
« Reactie #8 Gepost op: 2007/07/31, 18:07:23 »
Citaat van: mauro
Wat me opeens te binnen schiet: is het ook niet mogelijk om pakketten te installeren die je hebt gedownload?
dus: jij download het bestand ,zet het ergens neer en het programma(synaptic,of dat ene bij apps) zoekt het en installeren maar?

Zou wel enorm makkelijk zijn :) :>
liever alles uit synaptic pakketbeheer: veilig en beproefd.
warsow: de deb. laten uitpakken door gdebi: rechtermuisknop op het pakketje. dan gaat alles vanzelf.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Hulp bij installatie aub =)
« Reactie #9 Gepost op: 2007/07/31, 18:09:25 »
Citaat van: mauro
Wat me opeens te binnen schiet: is het ook niet mogelijk om pakketten te installeren die je hebt gedownload?
dus: jij download het bestand ,zet het ergens neer en het programma(synaptic,of dat ene bij apps) zoekt het en installeren maar?

Zou wel enorm makkelijk zijn :) :>
ff voor alle duidelijkheid: als je iets installeert vanuit de pakketbronnen van Ubuntu, dan haal je dat ook binnen via het internet, hoor....  :-)

Wat jij bedoelt is de Windowsmanier: een .exe binnenhalen, dubbelklikken en pats. Dat kan ook in Ubuntu, dan heb je een bestand nodig met de extensie .deb. Sommige programmamakers bieden ook .deb bestanden aan voor installatie, vanaf hun websites.

Maar zo installeren is een slechte gewoonte..... Als je het namelijk (zoveel mogelijk) bij de pakketbronnen houdt, dan weet je zeker dat het veilig spul is, en je systeem niet aantast. Bovendien wordt alles wat je vanuit de pakketbronnen installeert, centraal veilig gehouden met updates, door de update manager van Ubuntu. Geen omkijken meer naar!  :-)

mauro

  • Gast
Hulp bij installatie aub =)
« Reactie #10 Gepost op: 2007/07/31, 18:21:08 »
Daar heb je een dik punt!  Alvast bedankt iedereen voor de snelle (en bovendien uiterst nuttige ) info,ik ga dadelijk aan de slag (y)

mauro

  • Gast
Hulp bij installatie aub =)
« Reactie #11 Gepost op: 2007/07/31, 18:49:19 »
Package gedownload(thx voor de link btw) en als ie opent krijg ik volgende error

Error:Dependency is not satisfiable: libc6


En toen was ik met verstomming geslagen ...:/

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Hulp bij installatie aub =)
« Reactie #12 Gepost op: 2007/07/31, 19:04:53 »
Dat wil alleen maar zeggen, dat je EERST libc6 moet installeren, en die zit (dacht ik) gewoon in de repo's van Ubuntu.
Dus eerst met synaptic libc6 installeren ........
OpenStandaard evangelist, OpenSource promotor, OpenData liefhebber.
Xubuntu gebruiker en voorstander (XFCE).
In Nederland bekend als een dwarsligger.

mauro

  • Gast
Hulp bij installatie aub =)
« Reactie #13 Gepost op: 2007/07/31, 19:08:17 »
ok dankje

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Hulp bij installatie aub =)
« Reactie #14 Gepost op: 2007/07/31, 19:39:21 »
libc6 zit standaard in Ubuntu.
Een andere versie installeren dan degene die meegeleverd wordt levert een kapot systeem op.
Waarschijnlijk is de versie van Warsow die je hebt gedownload bedoeld voor een andere versie van Ubuntu of voor Debian.

Een goede versie die werkt kan je hier vinden:
http://www.getdeb.net/category.php?id=3
Installeer eerst het pakket warsow-data, daarna warsow.
Als je ook een eigen server op wil zetten kan je daarna ook warsow-server installeren.

mauro

  • Gast
Hulp bij installatie aub =)
« Reactie #15 Gepost op: 2007/08/03, 18:11:22 »
Het pakket installeerde deze keer wel goed,maar als ik het wil opstarten krijg ik telkens hetzelfde probleem: even krijg ik een zwart scherm en lijkt het alsof mijn systeem het spel laadt,maar dan kom ik terug opeens op mijn bureaublad terecht en mijn beeld is verschoven naar links en alles is groter geworden.Dan moet ik terug uitloggen,paar keer met de muis bewegen en dan is het beeld weer normaal.Daarna probeerde ik Open Arena ook een keertje te draaien,resultaat: hetzelfde !
Plz help,wa doe ik fout? Ben beetje gehecht aan Warsow soms en op deze pc kán ik het gewoon draaien!


Mauro

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Hulp bij installatie aub =)
« Reactie #16 Gepost op: 2007/08/03, 18:51:09 »
wat geeft:
Citaat
glxgears -printfps
glxinfo | grep direct
in de terminal? het zijn twee commands....

een 3d-spel en 3d-effects zoals beryl en compiz gaan niet zo goed samen.
zet dat eventueel even uit.

mauro

  • Gast
Hulp bij installatie aub =)
« Reactie #17 Gepost op: 2007/08/03, 21:02:25 »
Als ik glxgears -printfps typ bekom ik dit

Usage:
  -display  set the display to run on
  -stereo                 run in stereo mode
  -fullscreen             run in fullscreen mode
  -info                   display OpenGL renderer info

bij glxinfo  grep direct het volgende:
X Error of failed request:  BadAlloc (insufficient resources for operation)
  Major opcode of failed request:  142 (GLX)
  Minor opcode of failed request:  3 (X_GLXCreateContext)
  Serial number of failed request:  16
  Current serial number in output stream:  17

Nu nog iemand vinden die dit kan decoderen xD
srry,ben echt nog een groen-groentje wat Ubuntu betreft.

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Hulp bij installatie aub =)
« Reactie #18 Gepost op: 2007/08/03, 21:32:45 »
glxgears en glxinfo | grep direct geven aan hoe de drivers van de graf.kaart werken.
Citaat
glxinfo | grep direct
zou als uitkomst: direct rendering: Yes
moeten hebben, wanneer je het commando juist hebt ingevoerd doormiddel van copy-paste.

doe eens: sudo gedit /etc/X11/xorg.conf  in de terminal en post de uitkomst hier. (copy-paste)

mauro

  • Gast
Hulp bij installatie aub =)
« Reactie #19 Gepost op: 2007/08/03, 21:43:53 »
sudo: gedit/etc/X11/xorg.conf: command not found

dit krijg ik :s,das precies niet zo goed imo

Jorizzz

  • Gast
Hulp bij installatie aub =)
« Reactie #20 Gepost op: 2007/08/03, 21:45:16 »
Spatie tussen gedit en /etc/X11/xorg.conf, en let erop dat je X11 met hoofdletter doet :) En sudo moet zonder dubbele punt..

mauro

  • Gast
Hulp bij installatie aub =)
« Reactie #21 Gepost op: 2007/08/03, 21:50:20 »
Een hele boterham deze keer :

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
   FontPath   "/usr/share/fonts/X11/misc"
   FontPath   "/usr/share/fonts/X11/cyrillic"
   FontPath   "/usr/share/fonts/X11/100dpi/:unscaled"
   FontPath   "/usr/share/fonts/X11/75dpi/:unscaled"
   FontPath   "/usr/share/fonts/X11/Type1"
   FontPath   "/usr/share/fonts/X11/100dpi"
   FontPath   "/usr/share/fonts/X11/75dpi"
   # path to defoma fonts
   FontPath   "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
   Load   "i2c"
   Load   "bitmap"
   Load   "ddc"
   Load   "dri"
   Load   "extmod"
   Load   "freetype"
   Load   "glx"
   Load   "int10"
   Load   "vbe"
EndSection

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "CoreKeyboard"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc105"
   Option      "XkbLayout"   "be"
   Option      "XkbVariant"   "wang"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
   Option      "CorePointer"
   Option      "Device"      "/dev/input/mice"
   Option      "Protocol"      "ImPS/2"
   Option      "ZAxisMapping"      "4 5"
   Option      "Emulate3Buttons"   "true"
EndSection

Section "InputDevice"
   Driver      "wacom"
   Identifier   "stylus"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"      "stylus"
   Option      "ForceDevice"   "ISDV4"      # Tablet PC ONLY
EndSection

Section "InputDevice"
   Driver      "wacom"
   Identifier   "eraser"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"      "eraser"
   Option      "ForceDevice"   "ISDV4"      # Tablet PC ONLY
EndSection

Section "InputDevice"
   Driver      "wacom"
   Identifier   "cursor"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"      "cursor"
   Option      "ForceDevice"   "ISDV4"      # Tablet PC ONLY
EndSection

Section "Device"
   Identifier   "Generic Video Card"
   Driver      "vesa"
   BusID      "PCI:0:2:0"
EndSection

Section "Monitor"
   Identifier   "PZ456"
   Option      "DPMS"
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Device      "Generic Video Card"
   Monitor      "PZ456"
   DefaultDepth   24
   SubSection "Display"
      Depth      1
      Modes      "1024x768" "832x624" "800x600" "720x400" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      4
      Modes      "1024x768" "832x624" "800x600" "720x400" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      8
      Modes      "1024x768" "832x624" "800x600" "720x400" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      15
      Modes      "1024x768" "832x624" "800x600" "720x400" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      16
      Modes      "1024x768" "832x624" "800x600" "720x400" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      24
      Modes      "1024x768" "832x624" "800x600" "720x400" "640x480"
   EndSubSection
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
   Screen      "Default Screen"
   InputDevice   "Generic Keyboard"
   InputDevice   "Configured Mouse"
   InputDevice     "stylus"   "SendCoreEvents"
   InputDevice     "cursor"   "SendCoreEvents"
   InputDevice     "eraser"   "SendCoreEvents"
EndSection

Section "DRI"
   Mode   0666
EndSection

Hopelijk worden jullie er wijzer uit

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Hulp bij installatie aub =)
« Reactie #22 Gepost op: 2007/08/03, 23:13:33 »
een vesa driver geeft u geen 3d acceleratie en dus geen mogelijkheid om 3d-games te spelen.

mauro

  • Gast
Hulp bij installatie aub =)
« Reactie #23 Gepost op: 2007/08/04, 09:02:07 »
Oei,das raar,want ik kan echt verschillende games draaien.
Op windows draaide ik bvb. Call of Duty,WArsow,RTCW:Enemy Territory ,enz

Offline mcgyver

  • Lid
  • Steunpunt: Nee
Hulp bij installatie aub =)
« Reactie #24 Gepost op: 2007/08/04, 09:39:47 »
De driver niet, de kaart wel. Je hebt dus de verkeerde driver op de goede kaart.