Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Printer op router USR5461  (gelezen 1370 keer)

Offline Prosper

  • Forumteam
  • Steunpunt: Nee
Printer op router USR5461
« Gepost op: 2007/07/27, 20:27:54 »
Ik heb een LexmarkZ640 die ik met succes heb geïnstalleerd op de USB-poort van mijn laptop Fujitsu-Siemens AmiloPi1536 onder Edubuntu 6.10. Stuurprogramma van de Z600 gedownload en zo: dat werkt prima. Nu moet een laptop echter draagbaar zijn en dus wil ik die Lexmark hangen aan de parallelle poort van m'n router voor wireless internet USRobotics 5461. Alles geprobeerd, met de optie Printers via Beheer, localhost:631 en CUPS, tot zelfs het aanpassen van cupsys.config in de xterminal èn via CUPS: de regel "listen 192.168.2.1:631" toegevoegd en dan cupsd herstarten... niets heeft geholpen.  Ik kom niet verder dan de melding "verbonden met 192.168..." of één keer "job held until verification".  Overigens ging dat heropstarten van CUPS niet zoals het hoort: ik krijg wel de melding 'Ok', maar de veranderingen zijn niet zichtbaar (dat was ook al zo toen ik de printerdriver installeerde: die werd pas zichtbaar na een reboot).  Iemand enige ideeën ?
Omwille van de besparingen hebben ze het licht aan het eind van de tunnel ook uitgedaan...

Offline Prosper

  • Forumteam
  • Steunpunt: Nee
Printer op router USR5461
« Reactie #1 Gepost op: 2007/07/30, 11:51:58 »
Bon, iets meer informatie: dit staat er in mijn cupsys.config:
# Show troubleshooting information in error_log.
LogLevel debug
SystemGroup lpadmin
# Allow remote access
Port 631
Listen /var/run/cups/cups.sock
# Enable printer sharing and shared printers.
Browsing On
BrowseOrder allow,deny
BrowseAllow @LOCAL
BrowseAddress @LOCAL
DefaultAuthType Basic

  # Allow shared printing and remote administration...
  Order allow,deny
  Allow @LOCAL


  # Allow remote administration...
  Order allow,deny
  Allow @LOCAL


  AuthType Basic
  Require user @SYSTEM
  # Allow remote access to the configuration files...
  Order allow,deny
  Allow @LOCAL


 
    Require user @OWNER @SYSTEM
    Order deny,allow
 

 
    AuthType Basic
    Require user @SYSTEM
    Order deny,allow
 

 
    Require user @OWNER @SYSTEM
    Order deny,allow
 

 
    Order deny,allow
 

Dat is dus diegene die ik vind bij CUPS via localhost:631.
Ik had via Cups ook aangevinkt om het loglevel te verhogen om te kunnen debuggen, maar er kwam niks bij in /var/cache/cups/error_log. In de systemlog vind ik 'cannot open /var/cache/cups/error_log permission denied.'
De printer deed dus niks. Eerst 'processing page 1', dan 'connected to 192....' en tenslotte '/usr/lib/cups/backend/http failed' bij de eerste poging tot afdrukken van een testpagina.  Bij een tweede poging, zonder iets te veranderen, kwam hij al niet verder meer dan 'connected'.  
Iemand enige ideeën ?  Ikzelf ga nu eerst dat debuggen terug afvinken en hopen dat ik weer niet opnieuw een reboot moet doen.
Omwille van de besparingen hebben ze het licht aan het eind van de tunnel ook uitgedaan...

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Printer op router USR5461
« Reactie #2 Gepost op: 2007/07/30, 14:29:32 »
Heb je deze instructies uitgevoerd die op de site van US Robotics staan?
http://www.usrobotics.com/support/doc-popup-template.asp?url=5461/5461-files/printer_installation_linux/index.html&loc=bene

Zo ja, waar precies gaat het dan fout?

Offline Prosper

  • Forumteam
  • Steunpunt: Nee
Printer op router USR5461
« Reactie #3 Gepost op: 2007/07/31, 10:03:44 »
"/usr/lib/cups/backend/http failed" en dan na het releasen van de job
"Connected to 192.168.2.1..." en vervolgens moet ik ze annuleren.
Ik heb dit al zo'n 25 keer geprobeerd. Het enige verschil is dat ik geen super-user informatie kan invoeren (hoe weet ik die trouwens ?) maar gewoon mijn eigen (en enige) usernaam en paswoord.
Dit staat er in de error_log. Het begin is van bij het opstarten van mijn computer. Ik heb de time-stamps manueel verwijderd met tekstverwerking:
I  Saving job cache file "/var/cache/cups/job.cache"...
I  Listening to :::631 (IPv6)
I  Listening to 0.0.0.0:631 (IPv4)
I  Listening to /var/run/cups/cups.sock (Domain)
I  Loaded configuration file "/etc/cups/cupsd.conf"
I  Using default TempDir of /var/spool/cups/tmp...
I  Cleaning out old temporary files in "/var/spool/cups/tmp"...
I  Configured for up to 100 clients.
I  Allowing up to 100 client connections per host.
I  Using policy "default" as the default!
I  Full reload is required.
I  Loaded MIME database from '/etc/cups': 34 types, 39 filters...
D  Loading printer LaserJet-4000...
D  Loading printer NieuwePoging...
D  Loading printer Rechtstreeks...
I  Loading job cache file "/var/cache/cups/job.cache"...
D  Loading job 17 from cache...
D  Loading job 41 from cache...
D  Loading job 66 from cache...
D  Loading job 67 from cache...
I  Full reload complete.
I  Listening to :::631 on fd 2...
I  Listening to 0.0.0.0:631 on fd 3...
I  Listening to /var/run/cups/cups.sock on fd 4...
D  cupsdAcceptClient: 8 from localhost (Domain)
D  cupsdReadClient: 8 POST / HTTP/1.1
D  cupsdAuthorize: No authentication data provided.
D  CUPS-Get-Printers
D  cupsdProcessIPPRequest: 8 status_code=0 (successful-ok)
D  cupsdReadClient: 8 POST / HTTP/1.1
D  cupsdAuthorize: No authentication data provided.
D  Get-Printer-Attributes ipp://localhost/printers/LaserJet-4000
D  cupsdProcessIPPRequest: 8 status_code=0 (successful-ok)
D  cupsdReadClient: 8 POST / HTTP/1.1
D  cupsdAuthorize: No authentication data provided.
D  Get-Printer-Attributes ipp://localhost/printers/NieuwePoging
D  cupsdProcessIPPRequest: 8 status_code=0 (successful-ok)
D  cupsdReadClient: 8 POST / HTTP/1.1
D  cupsdAuthorize: No authentication data provided.
D  Get-Printer-Attributes ipp://localhost/printers/Rechtstreeks
D  cupsdProcessIPPRequest: 8 status_code=0 (successful-ok)
D  cupsdNetIFUpdate: "lo" = localhost...
D  cupsdNetIFUpdate: "eth1" = 192.168.2.3...
D  cupsdNetIFUpdate: "lo" = localhost...
D  cupsdNetIFUpdate: "eth1" = fe80::213:2ff:fedd:fd28%eth1...
D  cupsdReadClient: 8 POST / HTTP/1.1
D  cupsdAuthorize: No authentication data provided.
Bmerk dat de printers HP-Laserjet en Rechtstreeks geconfigureerd zijn voor gebruik respectievelijk op mijn werkplaats (waar dat draadloos gaat naar een printer op een Windows-machine, zonder problemen) en de printer Rechtstreeks de bewuste Lexmark is wanneer ik die aan de USB-poort van mijn laptop hang en die dus dan wel print.
De laatste cyclus blijft hij eindeloos repeteren. Vanaf een zeker moment heb ik geen toegang meer tot de error_log en ik kan dus niet laten zien wat er gebeurt wanneer ik een testpagina probeer te drukken.  Omdat ik nu dadelijk toch ergens heen moet, vink ik eerst die 'debugging' af en kan ik hem nadien terug opstarten met de hoop dan wel toegang te hebben en in dat geval stuur ik nadien nog wel een aanvulling.
Alvast wreed bedankt dat je dit allemaal wil lezen.
Omwille van de besparingen hebben ze het licht aan het eind van de tunnel ook uitgedaan...