Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Radeon 9250.  (gelezen 2302 keer)

SaabTux

  • Gast
Radeon 9250.
« Gepost op: 2007/07/22, 22:55:49 »
Hallo,

Mijn moederbord is over een week stuk gegaan, en tegelijk ook mijn grafische kaart.
Nu heb ik de pc terug maar met een ATI Radeon 9250 kaart erin, daarvoor zat er een Nvidia kaart in.
Ondertussen heb ik de fglrx driver gëinstalleerd, en de driver voor de andere kaart verwijderd.
Maar als ik opstart start de x-server niet op, en krijg ik enkel de login in tekst mode te zien.

Ik heb ondertussen al verschillende pogingen gedaan zoals:

-De herconfiguratie van het bestand /etc/X11/xorg.conf met dit commando:

sudo dpkg-reconfigure xserver-xorg

Maar nog altijd wil de x-server niet starten als ik startx doe.
Ik krijg dan wel dit te zien:

(WW) fglrx: No matching Device section for instance (BusID PCI:1:0:1) found.
(EE) No devices detected.

Fatal server error:
no screens found

En zo staat het ook in het logbestand.

Kan er iemand helpen ?

Bedankt alvast voor de hulp.

Offline Dominique Ramaekers

  • Lid
  • Steunpunt: Nee
Radeon 9250.
« Reactie #1 Gepost op: 2007/07/22, 23:01:11 »
Wat zegt sudo lshw

SaabTux

  • Gast
Radeon 9250.
« Reactie #2 Gepost op: 2007/07/23, 22:15:24 »
Een lijst van alle hardware beginnende met PCI 03, en gaat dan verder omhoog in cijfers naar het einde van het scherm toe.

Ik begrijp er niets van, en ik zou ook niet weten hoe dit kan helpen. :(

SaabTux

  • Gast
Radeon 9250.
« Reactie #3 Gepost op: 2007/07/27, 18:11:04 »
Hier is dan het resultaat van lshw:

*-pci:0
          description: Host bridge
          product: VT8385 [K8T800 AGP] Host Bridge
          vendor: VIA Technologies, Inc.
          physical id: 100
          bus info: pci@00:00.0
          version: 01
          width: 32 bits
          clock: 66MHz
          configuration: latency=8
        *-pci
             description: PCI bridge
             product: VT8237 PCI bridge [K8T800/K8T890 South]
             vendor: VIA Technologies, Inc.
             physical id: 1
             bus info: pci@00:01.0
             version: 00
             width: 32 bits
             clock: 66MHz
             capabilities: pci normal_decode bus_master cap_list
           *-display:0
                description: VGA compatible controller
                product: RV280 [Radeon 9200 PRO]
                vendor: ATI Technologies Inc
                physical id: 0
                bus info: pci@01:00.0
                version: 01
                size: 128MB
                width: 32 bits
                clock: 66MHz
                capabilities: vga bus_master cap_list
                configuration: latency=64 mingnt=8
                resources: iomemory:e8000000-efffffff ioport:a000-a0ff iomemory:fd600000-fd60ffff irq:11
           *-display:1 UNCLAIMED
                description: Display controller
                product: RV280 [Radeon 9200 PRO] (Secondary)
                vendor: ATI Technologies Inc
                physical id: 0.1
                bus info: pci@01:00.1
                version: 01
                size: 128MB
                width: 32 bits
                clock: 66MHz
                capabilities: bus_master cap_list
                configuration: latency=64 mingnt=8
                resources: iomemory:e0000000-e7ffffff iomemory:fd400000-fd40ffff
Het is wel vreemd dat ik zelfs onder Nvidia in systeeminstellingen altijd twee schermen had, en ik gebruik maar 1 scherm.
Wat ik ook probeerde om dit te veranderen niets hielp.

Groeten.

Offline Dirk Tas

  • Lid
  • Steunpunt: Nee
Radeon 9250.
« Reactie #4 Gepost op: 2007/07/27, 20:11:55 »
Citaat van: SaabTux
Hier is dan het resultaat van lshw:
Het is wel vreemd dat ik zelfs onder Nvidia in systeeminstellingen altijd twee schermen had, en ik gebruik maar 1 scherm.
Wat ik ook probeerde om dit te veranderen niets hielp.
Ik vermoed dat op je Nvidia kaart ook een tv/svideo uitgang zat, je kunt die beiden gebruiken waardoor in de xorg.conf 2 aparaten stonden.

Wat je probleem met de 9250 betreft vermoed ik dat dit niet de makkelijkste ati kaart is die er bestaat, en ati kaarten zijn al niet erg goed ondersteund. Ik heb dit gevonden, probeer misschien één van de tips die hier gegeven worden.

http://ubuntuforums.org/showthread.php?t=418252
Ubuntu User #14670

SaabTux

  • Gast
Radeon 9250.
« Reactie #5 Gepost op: 2007/07/31, 22:16:54 »
Ondertussen gebruik ik de vesa driver en heb ik dus beeld.

Via planet Ubuntu heb ik Envy ontdekt:

http://albertomilone.com/nvidia_scripts1.html

Dit zou dus het probleem met de drivers voor zowel Nvidia als ATI kaarten moeten oplossen.

Aangezien de driver klaagt dat er geen vermelding is voor PCI:1:0:1, ben ik eens gaan zien in windows.
En daar staat dus mijn kaart onder beeldschermadapters twee keer vermeld, deze kaart heeft inderdaad twee aansluitingen.
Kan het zijn dat de Linux versie van deze driver de tweede aansluiting ziet en ook wil gebruiken ?

Ik heb hier dus nog mijn xorg.conf bij mij liggen, van toen er nog SuSe Linux 10.0 op stond.
Voor de zekerheid heb ik die toen afgeprint voordat ik Kubuntu erop heb gezet.
En onder de sectie serverlayout staan deze twee opties:

Option    "Clone" "off"
Option    "Xinerama" "off"
Kan ik door deze twee opties toe te voegen mischien vermijden dat hij de tweede aansluiting wil gebruik ?

Groeten.