Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Horizontale strepen in beeld  (gelezen 2764 keer)

Offline hvb

  • Lid
  • Steunpunt: Nee
Horizontale strepen in beeld
« Gepost op: 2007/07/22, 16:35:50 »
Vanaf april heb ik nu feisty in dualboot met windows 98, en sinds ruim 3 weken heb ik last van grijze horizontale strepen in beeld (1024x768, 85 hz). In absolute zin staan ze ongeveer een millimeter van elkaar af en lijken ze één pixel dik te zijn. Vooral op een witte ondergrond komen ze storend over.
Bovendien gaat er ook iets fout bij het opstarten van ubuntu. Het inlogscherm is in de hoogte kleiner geworden (boven en onder) en in z'n geheel naar links verschoven (rechts een zwart gedeelte). Na het inloggen komt het beeld weer op de normale plaats te staan.
Vreemd genoeg heb ik onder windows geen last van deze strepen, en ook niet met de live cd (wat een prachtig scherp beeld).

Ik heb al het nodige geprobeerd, vooral met de resoluties.  Bij een lagere resolutie verdwijnen de strepen, en bij een hogere blijven ze vrolijk staan. De frequentie kan ik niet veranderen.

Natuurlijk kan ik een nieuwe installatie doen, maar dan verdwijnen ook mijn netwerkinstellingen (is erg ingewikkeld bij upc achter een router).

Wie kan mij helpen?

bvd

hans

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Horizontale strepen in beeld
« Reactie #1 Gepost op: 2007/07/22, 16:57:18 »
Doe eens dit:
Systeem - Beheer - Synaptic pakketbeheer
zoekterm: xresprobe
aanvinken en druk op knop Toepassen

Daarna:
Toepassingen - Hulpmiddelen - Terminalvenster
tik in:
sudo dpkg-reconfigure xserver-xorg

Zeg vervolgens ja en amen op alle voorgestelde antwoorden in de vragenriedel. Bediening soms met Tabtoets, soms met spatiebalk, Entertoets (de binnenste entertoets, dus niet de rechtsbuiten-entertoets) en pijltjestoetsen.

Daarna computer herstarten.

Helpt dit?

Groet, Pjotr.

Offline hvb

  • Lid
  • Steunpunt: Nee
Horizontale strepen in beeld
« Reactie #2 Gepost op: 2007/07/22, 17:30:44 »
Pjotr

Xresprobe was al geïnstalleerd.
Daarna heb ik de hele ongelooflijk lange riedel doorlopen en slechts één keer bij de schermresolutie mijn gebruikelijke waarden "aangevinkt".
Na de herstart ben ik helaas  weer bij de aloude strepen uitgekomen, al lijkt het erop dat nu ook bij 1280x1024 de strepen verdwenen zijn (verbeelding?), waarbij de frequentie naar 60 hz is gezakt.
Uiteraard wil ik op mijn oude 17 inch crt monitor geen hogere (ook geen lagere) frequentie dan 1024x768.

Zijn er nog andere  oplossingen die ik proberen kan?

iig bedankt Pjotr

Hans

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Horizontale strepen in beeld
« Reactie #3 Gepost op: 2007/07/22, 18:00:04 »
Doe eens dit:
Toepassingen - Hulpmiddelen - Terminalvenster
tik in:
gedit /etc/X11/xorg.conf

en post hier eens de inhoud van xorg.conf, bij voorkeur als code: zo dus!en doe ook eens in de terminal: sudo ddcprobe en post de uitkomst daarvan hier ook eens.

Offline hvb

  • Lid
  • Steunpunt: Nee
Horizontale strepen in beeld
« Reactie #4 Gepost op: 2007/07/22, 21:11:18 »
Hier is de tekst die ik in gedit te zien krijg al s ik gedit /etc/X11/xorg.conf intik in de terminal:

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
   FontPath   "/usr/share/fonts/X11/misc"
   FontPath   "/usr/share/fonts/X11/cyrillic"
   FontPath   "/usr/share/fonts/X11/100dpi/:unscaled"
   FontPath   "/usr/share/fonts/X11/75dpi/:unscaled"
   FontPath   "/usr/share/fonts/X11/Type1"
   FontPath   "/usr/share/fonts/X11/100dpi"
   FontPath   "/usr/share/fonts/X11/75dpi"
   # path to defoma fonts
   FontPath   "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
   Load   "bitmap"
   Load   "ddc"
   Load   "dri"
   Load   "extmod"
   Load   "freetype"
   Load   "glx"
   Load   "int10"
   Load   "vbe"
EndSection

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "CoreKeyboard"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc105"
   Option      "XkbLayout"   "us"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
   Option      "CorePointer"
   Option      "Device"      "/dev/input/mice"
   Option      "Protocol"      "ImPS/2"
   Option      "ZAxisMapping"      "4 5"
EndSection

Section "InputDevice"
   Driver      "wacom"
   Identifier   "stylus"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"      "stylus"
   Option      "ForceDevice"   "ISDV4"      # Tablet PC ONLY
EndSection

Section "InputDevice"
   Driver      "wacom"
   Identifier   "eraser"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"      "eraser"
   Option      "ForceDevice"   "ISDV4"      # Tablet PC ONLY
EndSection

Section "InputDevice"
   Driver      "wacom"
   Identifier   "cursor"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"      "cursor"
   Option      "ForceDevice"   "ISDV4"      # Tablet PC ONLY
EndSection

Section "Device"
   Identifier   "Generieke videokaart"
   Driver      "vesa"
   BusID      "PCI:1:0:0"
EndSection

Section "Monitor"
   Identifier   "COMPAQ S720"
   Option      "DPMS"
   HorizSync   30-70
   VertRefresh   50-160
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Device      "Generieke videokaart"
   Monitor      "COMPAQ S720"
   DefaultDepth   24
   SubSection "Display"
      Depth      1
      Modes      "1280x1024" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      4
      Modes      "1280x1024" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      8
      Modes      "1280x1024" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      15
      Modes      "1280x1024" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      16
      Modes      "1280x1024" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      24
      Modes      "1280x1024" "1024x768" "800x600" "640x480"
   EndSubSection
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
   Screen      "Default Screen"
   InputDevice   "Generic Keyboard"
   InputDevice   "Configured Mouse"
   InputDevice     "stylus"   "SendCoreEvents"
   InputDevice     "cursor"   "SendCoreEvents"
   InputDevice     "eraser"   "SendCoreEvents"
EndSection

Section "DRI"
   Mode   0666
EndSection



en hier de tekst van sudo ddcprobe


vbe: VESA 2.0 detected.
oem: SiS
memory: 4096kb
mode: 80x60 (text)
mode: 132x25 (text)
mode: 800x600x16
mode: 1024x768x16
mode: 1280x1024x16
mode: 1600x1200x256
mode: 640x400x256
mode: 640x480x256
mode: 800x600x256
mode: 1024x768x256
mode: 1280x1024x256
mode: 1600x1200x32k
mode: 320x200x32k
mode: 640x480x32k
mode: 800x600x32k
mode: 1024x768x32k
mode: 1280x1024x32k
mode: 320x200x64k
mode: 640x480x64k
mode: 800x600x64k
mode: 1024x768x64k
mode: 1280x1024x64k
mode: 1600x1200x64k
mode: 320x200x16m
mode: 640x480x16m
mode: 800x600x16m
mode: 1024x768x16m
mode: 1280x1024x16m
edid:
edid: 1 3
id: 1399
eisa: CPQ1399
serial: 470f2763
manufacture: 31 2001
input: sync on green, analog signal.
screensize: 32 24
gamma: 1.990000
dpms: RGB, active off, suspend, standby
timing: 720x400@70 Hz (VGA 640x400, IBM)
timing: 640x480@60 Hz (VGA)
timing: 640x480@67 Hz (Mac II, Apple)
timing: 640x480@75 Hz (VESA)
timing: 800x600@60 Hz (VESA)
timing: 800x600@75 Hz (VESA)
timing: 832x624@75 Hz (Mac II)
timing: 1024x768@87 Hz Interlaced (8514A)
timing: 1024x768@70 Hz (VESA)
timing: 1024x768@75 Hz (VESA)
timing: 1280x1024@75 (VESA)
ctiming: 640x480@85
ctiming: 800x600@85
ctiming: 1024x768@85
ctiming: 1280x1024@60
dtiming: 1024x768@104
monitorrange: 30-70, 50-160
monitorname: COMPAQ S720

vbe: VESA 2.0 detected.
oem: SiS
memory: 4096kb
mode: 80x60 (text)
mode: 132x25 (text)
mode: 800x600x16
mode: 1024x768x16
mode: 1280x1024x16
mode: 1600x1200x256
mode: 640x400x256
mode: 640x480x256
mode: 800x600x256
mode: 1024x768x256
mode: 1280x1024x256
mode: 1600x1200x32k
mode: 320x200x32k
mode: 640x480x32k
mode: 800x600x32k
mode: 1024x768x32k
mode: 1280x1024x32k
mode: 320x200x64k
mode: 640x480x64k
mode: 800x600x64k
mode: 1024x768x64k
mode: 1280x1024x64k
mode: 1600x1200x64k
mode: 320x200x16m
mode: 640x480x16m
mode: 800x600x16m
mode: 1024x768x16m
mode: 1280x1024x16m
edid:
edid: 1 3
id: 1399
eisa: CPQ1399
serial: 470f2763
manufacture: 31 2001
input: sync on green, analog signal.
screensize: 32 24
gamma: 1.990000
dpms: RGB, active off, suspend, standby
timing: 720x400@70 Hz (VGA 640x400, IBM)
timing: 640x480@60 Hz (VGA)
timing: 640x480@67 Hz (Mac II, Apple)
timing: 640x480@75 Hz (VESA)
timing: 800x600@60 Hz (VESA)
timing: 800x600@75 Hz (VESA)
timing: 832x624@75 Hz (Mac II)
timing: 1024x768@87 Hz Interlaced (8514A)
timing: 1024x768@70 Hz (VESA)
timing: 1024x768@75 Hz (VESA)
timing: 1280x1024@75 (VESA)
ctiming: 640x480@85
ctiming: 800x600@85
ctiming: 1024x768@85
ctiming: 1280x1024@60
dtiming: 1024x768@104
monitorrange: 30-70, 50-160
monitorname: COMPAQ S720

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Horizontale strepen in beeld
« Reactie #5 Gepost op: 2007/07/22, 21:32:39 »
Doe nog eens dit:
Terminal:
sudo gedit /etc/X11/xorg.conf

en verander in de section "device", de vermelding vesa door sis. Zo dus:

Section "Device"
    Identifier    "Generieke videokaart"
    Driver        "sis"
    BusID        "PCI:1:0:0"
EndSection

Opslaan, sluiten, herstarten.

Helpt dit?

Offline hvb

  • Lid
  • Steunpunt: Nee
Horizontale strepen in beeld
« Reactie #6 Gepost op: 2007/07/22, 21:57:21 »
Citaat van: pjotr123
Doe nog eens dit:
Terminal:
sudo gedit /etc/X11/xorg.conf

en verander in de section "device", de vermelding vesa door sis. Zo dus:

Section "Device"
    Identifier    "Generieke videokaart"
    Driver        "sis"
    BusID        "PCI:1:0:0"
EndSection

Opslaan, sluiten, herstarten.

Helpt dit?
Plotr

Ik weet niet waar je de wijsheid (kennis) vandaan haalt, maar wat ik wel weet is dat het werkt. FANTASTISCH, het beeld is weer vlijmscherp alsof ik een nieuwe installatie heb gedaan. Ook het opstartscherm staat weer op de gewone plaats, ik kan (durf) weer reklame te maken voor ubuntu.

Ik sluit nu de computer af met een tevreden gevoel.

PS: ik meen dat ik enige maanden geleden ook van jou een (geoed) antwoord heb gehad op mijn vraag over streams die niet werkten in de diverse journaals. Op een bepaald ogenblik deden ze het gewoon ook onder windows xp , het is een rare wereld daar.

nogmaals bedankt,

hans

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Horizontale strepen in beeld
« Reactie #7 Gepost op: 2007/07/22, 21:59:03 »
Mooi zo! Graag gedaan  :-)

Offline Dominique Ramaekers

  • Lid
  • Steunpunt: Nee
Horizontale strepen in beeld
« Reactie #8 Gepost op: 2007/07/22, 22:06:42 »
Citaat van: hvb
Citaat van: pjotr123
Doe nog eens dit:
Terminal:
sudo gedit /etc/X11/xorg.conf

en verander in de section "device", de vermelding vesa door sis. Zo dus:

...

Helpt dit?
Plotr

Ik weet niet waar je de wijsheid (kennis) vandaan haalt, maar ...

nogmaals bedankt,

hans
Ja Plotr, wat is die sis-driver? Teach us grasshoppers...

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Horizontale strepen in beeld
« Reactie #9 Gepost op: 2007/07/22, 22:14:54 »
Citaat van: Dadio
Ja Plotr, wat is die sis-driver? Teach us grasshoppers...
De ddcprobe gaf aan, dat het een SiS-videokaartje betrof. Die heeft (uiteraard) de sis-driver nodig. Maar in de xorg.conf stond de Vesa-driver geselecteerd....

Dat was alles  :-)

@hvb: Overigens zou ik met dat oude SiS-videokaartje, ook nog even de kleurendiepte (DefaultDepth) verminderen van 24-bits naar 16-bits. Dat is een enorme taakverlichting voor het oude beestje, en komt dus z'n prestaties ten goede.

Als volgt:
sudo gedit /etc/X11/xorg.conf

In de Section "Screen":

Section "Screen"
    Identifier    "Default Screen"
    Device        "Generieke videokaart"
    Monitor        "COMPAQ S720"
    DefaultDepth    16

Offline hvb

  • Lid
  • Steunpunt: Nee
Horizontale strepen in beeld
« Reactie #10 Gepost op: 2007/07/23, 21:13:22 »
Ik had (en niet heb) bijna te vroeg gejuicht. Nadat mijn beeld weer vlijmscherp was gaf ik aan dat mijn streams het ook deden (terwijl dat in het prille begin niet het geval was).
Opeens bedacht ik gisteravond om dat voor de zekerheid even te proberen en je raadt het al, het was brandhout. Alleen de ingebedde streams werkten, streams waarbij een nieuw browservenster wordt geopend leidden tot een crash van FF (waarom doen die lui zo moeilijk met streams, alles gewoon inbedden, geen problemen).
Gelijk heb ik VLC uitgeprobeerd met ASF bestanden met een idem brandhout resultaat.  

Toen zag ik je laatste bijdrage en leek het me verstandig die kleurdiepte te verkleinen.
Na de herstart bleek alles weer te werken, streams en asf bestanden.
En nu maar hopen dat ik geen volgende beren tegenkom.

Blijft de vraag waarom het probleem met de strepen op een bepaald ogenblik opdook, en waarom windows en de live cd er geen last van hadden.

groeten,

hans

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Horizontale strepen in beeld
« Reactie #11 Gepost op: 2007/07/23, 21:18:45 »
Mooi! Blij dat alles nu werkt.

Verklaring: Windows en LiveCD gebruikten beide waarschijnlijk de sis-driver en niet de Vesa-driver. De Vesa-driver is een zeer beperkt functionerende generieke driver, die je normaliter alleen gebruikt wanneer geen enkele andere driver het wil doen. Vandaar de strepen...  

Met 24 bits kleurendiepte moet je ouwe kaartje (1997 of 1998 of zo?) met slechts 4 MB videogeheugen, boven z'n krachten werken als hij filmpjes moet laten zien. Met 16 bits kleurendiepte spaar je het ouwe beestje en lukt het wel!  :-)

Groet, Pjotr.

Offline hvb

  • Lid
  • Steunpunt: Nee
Horizontale strepen in beeld
« Reactie #12 Gepost op: 2007/07/23, 21:26:57 »
Citaat van: pjotr123
Mooi! Blij dat alles nu werkt.

Verklaring: Windows en LiveCD gebruikten beide waarschijnlijk de sis-driver en niet de Vesa-driver. De Vesa-driver is een zeer beperkt functionerende generieke driver, die je normaliter alleen gebruikt wanneer geen enkele andere driver het wil doen. Vandaar de strepen...  

Met 24 bits kleurendiepte moet je ouwe kaartje (1997 of 1998 of zo?) met slechts 4 MB videogeheugen, boven z'n krachten werken als hij filmpjes moet laten zien. Met 16 bits kleurendiepte spaar je het ouwe beestje en lukt het wel!  :-)

Groet, Pjotr.
bedankt Pjotr,

hans

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Horizontale strepen in beeld
« Reactie #13 Gepost op: 2007/07/23, 21:35:28 »
Graag gedaan!

Offline driesv

  • Lid
  • Steunpunt: Nee
Horizontale strepen in beeld
« Reactie #14 Gepost op: 2008/02/12, 16:35:45 »
Eventjes een oud topicje bovengehaald, maar ik het hetzelfde probleem...

Mijn xorg.conf ziet er zo uit:
# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "be"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizEdgeScroll" "0"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "Device"
Identifier "ATI Technologies Inc M26 [Radeon Mobility X700 XL (PCIE)]"
Driver "fglrx"
Busid "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "Generieke beeldscherm"
Option "DPMS"
Horizsync 30-70
Vertrefresh 50-160
EndSection

Section "Screen"
Identifier "Default Screen"
Device "ATI Technologies Inc M26 [Radeon Mobility X700 XL (PCIE)]"
Monitor "Generieke beeldscherm"
Defaultdepth 24
EndSection

Section "ServerLayout"
Identifier "Default Layout"
  screen "Default Screen"
Inputdevice "Generic Keyboard"
Inputdevice "Configured Mouse"

# Uncomment if you have a wacom tablet
# InputDevice     "stylus" "SendCoreEvents"
# InputDevice     "cursor" "SendCoreEvents"
# InputDevice     "eraser" "SendCoreEvents"
Inputdevice "Synaptics Touchpad"
EndSection
Section "Module"
Load "glx"
EndSection
Section "Extensions"
Option "Composite" "0"
EndSection