Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Intranet  (gelezen 3911 keer)

Offline Sense Hofstede

  • Lid
    • sense
  • Steunpunt: Nee
Intranet
« Gepost op: 2006/04/23, 13:45:34 »
Ik wil graag op ons thuisnetwerkje een intranet beginnen(met websites enzo). Als je dan bijv. nnn.start.WERKGROEP intypt je op een website komt waar HTML, PHP en MySQL gebruikt kunnen worden. Ik ben al wat aan het stuntelen met Apache2, PHP5 en MySQL. Alleen probeerde ik eerst met de pakketten, dat wilde niet, dus ging ik handmatig comileeren(na het verwijderen van de standaar pakketten) dat liep halverwege vast(iets met PHP5-Apache2(libphp5.so, aspx2) en daarna probeerde ik het weer met Synaptic(gecomileerde niet verwijderd). Toen ik httpd.conf had opgezocht kreeg ik het zover dat ik op mijn  IP adres een HTML pagina kon tonen. Alleen als ik met de libphp5.so die ik ip mijn systeem heb gevonden en heb 'toegevoegd' aan httpd.conf en de server herstart(/usr/local/apache2/bin/apachectl restart) zegt hij dat de libphp5.so niet klopt, iets met DSO of dergelijks. Weet iemand hoe dit allemaal op te lossen?
Oja, en ik wil graag een ongebruikte Windows(NTFS) partitie(niet C:) bij mijn ext3 partitie voegen, maar hoe doe je dat?

Alvast bedankt.
Vragen over Ubuntu Nederland of de internationale Ubuntu-gemeenschap? PB of mail me!

budster

  • Gast
Intranet
« Reactie #1 Gepost op: 2006/04/23, 14:29:17 »
Ik zou je toch sterk aanraden om van de debian pakketten gebruik te maken, dan is het installeren van apache, php en mysql (je hebt er nog een nodig php2mysql ofzo) Zo te horen heb je al de deur naar de dependency hel open gezet. Je kan best de errors fixen die je krijgt maar die error's lijden alleen maar weer tot nieuwe en nieuwe. Gewoon die pakages gebruiken van ubuntu.

Ik zou je aanraden je systeem lekker vers te installeren. dan kan je ook meteen je tijdens de installatie bij het partitioneer gedeelte de hele harde schijf voor linux gebruiken.

Offline Sense Hofstede

  • Lid
    • sense
  • Steunpunt: Nee
Intranet
« Reactie #2 Gepost op: 2006/04/23, 19:11:57 »
Herinstalleren is misschien wel het beste, want ik ben nu bezig met mijn webcam(Trust Spacec@am Lite) aan de praat te krijgen en heb daarbij op een of andere manier libesd-alsa0 van mijn systeem af geknikkert. Met gevolg dat ik door dedependency controle van apt NIKS meer kan installeren! Geen .deb, geen binary source, geen apt-get niks! BIj apt-get krijg ik een foutmelding over over een een onbekende groep met de naam fuse in een bestand.
Vragen over Ubuntu Nederland of de internationale Ubuntu-gemeenschap? PB of mail me!

budster

  • Gast
Intranet
« Reactie #3 Gepost op: 2006/04/23, 19:16:40 »
Citaat van: Ytrecq
Herinstalleren is misschien wel het beste, want ik ben nu bezig met mijn webcam(Trust Spacec@am Lite) aan de praat te krijgen en heb daarbij op een of andere manier libesd-alsa0 van mijn systeem af geknikkert. Met gevolg dat ik door dedependency controle van apt NIKS meer kan installeren! Geen .deb, geen binary source, geen apt-get niks! BIj apt-get krijg ik een foutmelding over over een een onbekende groep met de naam fuse in een bestand.
Welkom in dependency hel.

Offline Dennis Kaarsemaker

  • Administrator
    • dennis
    • http://www.kaarsemaker.net
  • Steunpunt: Nee
Intranet
« Reactie #4 Gepost op: 2006/04/23, 19:34:03 »
Niks dependency hel, gewoon een simpele bug in het fuse-utils pakket. Is op het forum al eerder aan bod geweest.

Offline Sense Hofstede

  • Lid
    • sense
  • Steunpunt: Nee
Intranet
« Reactie #5 Gepost op: 2006/04/24, 17:59:28 »
Waar dan?  Ik kan het niet vinden. En moet je dan als oplossing iets installeren? Want ik wou een .deb pakket van libesd-alsa0(van packages.ubuntu.org) installeren en dat wou ook niet.

Oja, ik kan vanwege het ontbreken van die biblotheek ook niet een normale GNOME sessie beginnen, ik heb vanuit het inlogscherm een XTerm veilige modus opgestart, en daarin met het comando firefox forum.ubuntu-nl.org hier terechtgekomen.
Vragen over Ubuntu Nederland of de internationale Ubuntu-gemeenschap? PB of mail me!

Offline Dennis Kaarsemaker

  • Administrator
    • dennis
    • http://www.kaarsemaker.net
  • Steunpunt: Nee
Intranet
« Reactie #6 Gepost op: 2006/04/24, 23:11:09 »
sudo rm -f /var/lib/dpkg/info/fuse-utils.{pre,post}rm

Daarna gaat apt weer werken.

Offline Sense Hofstede

  • Lid
    • sense
  • Steunpunt: Nee
Intranet
« Reactie #7 Gepost op: 2006/04/25, 18:39:46 »
Ik heb beide bestanden verwijdert(fuse-utils.prerm en fuse-utils.postrm), maar apt doet het nog steeds niet. In de foutmelding stond wel iets over in /usr/bin/dpkg . Misschien ligt het probleem daar?

EDIT: Ik denk dat het verstandig is de hele foutmelding te posten. Ik krijg hem na
reading database...dpkg: syntax error: unknown group `fuse'  in statusoverridefile
E: Sub-process /usr/bin/dpkg returned an error code(2)
Nee, de aanhalingstekens om fuse waren echt verschillend.
Vragen over Ubuntu Nederland of de internationale Ubuntu-gemeenschap? PB of mail me!

Offline zappa

  • Lid
    • http://www.c3c.be
  • Steunpunt: Nee
Intranet
« Reactie #8 Gepost op: 2006/04/25, 19:28:21 »
Alweer... Zie eens in mijn thread, maar het komt erop aan die syntax error eruit te halen in de file /var/lib/dpkg/status. Vervang die schuine door '
Dan sudo apt-get autoclean
sudo apt-get install -f
sudo apt-get upgrade
en dan nog eens proberen fuse te installeren.

@ Dennis, dit is toch geen harde-schijf probleem meer :)
Die file zit verder nog vol met fouten, maar dan in description, dus maakt niet uit. Trouwens elke entry wordt toch aangemaakt door de deb die je installeert. (override), ligt naar mijn mening dan toch wel aan de maintainers. Right?

Offline Sense Hofstede

  • Lid
    • sense
  • Steunpunt: Nee
Intranet
« Reactie #9 Gepost op: 2006/04/25, 19:55:41 »
Er stond nergens `fuse'(althans, niet volgens de zoekfunctie van nano). Ik heb wel `fuser' veranderd in 'fuser'(en in de regel eronder `killuser' in 'killuser'), maar dat was in een beschrijving, en toen ik het probeerde(apt-get install -f) kreeg ik weer dezelfde foutmelding. Nou heb ik niet zo zin om het hele bestand uit te kammen op fouten(8000 regels als het er niet meer zijn).

EDIT: Nou zijn de 'waarden' ook niet omgeven door aanhalingstekens dus zou ik nit weten wat er fout zou kunnen zijn.
Vragen over Ubuntu Nederland of de internationale Ubuntu-gemeenschap? PB of mail me!

Offline Dennis Kaarsemaker

  • Administrator
    • dennis
    • http://www.kaarsemaker.net
  • Steunpunt: Nee
Intranet
« Reactie #10 Gepost op: 2006/04/25, 21:25:46 »
Het zit in /var/lib/dpkg/statoverride

Offline zappa

  • Lid
    • http://www.c3c.be
  • Steunpunt: Nee
Intranet
« Reactie #11 Gepost op: 2006/04/25, 22:03:10 »
Ja, let op dat je er niets verkeerd mee doet! Je kan uw hele apt slopen...
(sorry voor de verwarring)
Maar Dennis, dat is toch geen hd probleem?

Offline Sense Hofstede

  • Lid
    • sense
  • Steunpunt: Nee
Intranet
« Reactie #12 Gepost op: 2006/04/26, 15:06:28 »
Er staan ook geen aanhalingstekens in statoverride! Wat moet ik dan aanpassen?

EDIT: De enige regel met fuse erin in statoverride is:
root fuse 4754 /usr/bin/fusermount
Vragen over Ubuntu Nederland of de internationale Ubuntu-gemeenschap? PB of mail me!

Offline zappa

  • Lid
    • http://www.c3c.be
  • Steunpunt: Nee
Intranet
« Reactie #13 Gepost op: 2006/04/26, 15:17:17 »
En met group?

Offline Sense Hofstede

  • Lid
    • sense
  • Steunpunt: Nee
Intranet
« Reactie #14 Gepost op: 2006/04/26, 15:30:40 »
Wat bedoel je precies? Dat was de hele regel als je bedoelt dat er nog een groep bij moet staan, er stond geen groep bij. In het hele bestand kwam het woord group ook niet voor.

EDIT: Ik denk dat ik toch ga herinstalleren, mijn installatie is door mijn proberen toch een rommeltje geworden, ik wil een NTFS partitie bij mij huidige Linux partitie trekken en ik weet niet hoe dit probleem op te lossen.
Ik wil wel graag alle /home directorys behouden. Weet iemand een manier om te herinstalleren zonder /home te verwijderen? Of hoe je in de terminal aan een NTFS partitie mount om de boel te kopieren ernaar?(de Windows partities staan niet in fstab, maar ik kon in GNOME wel mounten.)
Vragen over Ubuntu Nederland of de internationale Ubuntu-gemeenschap? PB of mail me!

Offline zappa

  • Lid
    • http://www.c3c.be
  • Steunpunt: Nee
Intranet
« Reactie #15 Gepost op: 2006/04/26, 16:24:58 »
Als uw home op reeds op een andere partitie staat is het geen probleem, gewoon manueel elke partitie aangeven bij installatie.

Offline Sense Hofstede

  • Lid
    • sense
  • Steunpunt: Nee
Intranet
« Reactie #16 Gepost op: 2006/04/26, 16:38:10 »
Ik ben bezig vanuit Linux met EXT2 IFS de map home naar een NTFS partitie om later(als het systeem geher
Vragen over Ubuntu Nederland of de internationale Ubuntu-gemeenschap? PB of mail me!

Offline Dennis Kaarsemaker

  • Administrator
    • dennis
    • http://www.kaarsemaker.net
  • Steunpunt: Nee
Intranet
« Reactie #17 Gepost op: 2006/04/26, 19:06:11 »
Gewoon die hele regel weghalen...

Offline Sense Hofstede

  • Lid
    • sense
  • Steunpunt: Nee
Intranet
« Reactie #18 Gepost op: 2006/04/27, 19:29:58 »
Ik ben nu bezig met alles opnieuw configureren na een succesvolle installatie. Ik heb op de oude Linux partitie(10,1gig) de /home gezet en op een nieuwe(21.3) de rest. Alleen toen ik de backups maakte heb ik om problemen op te lossen(bij het kopieren) zoweinig mogelijk verborgen(.) mappen meegekopieerd. Alleen ik ben zo stom geweest om .thunderbird NIET mee te kopieren. Ik ben mijn e-mail dus kwijt. Ik heb nog wel een flink oudere thunderbird kopie op Winhoos te staan, maar het is toch jammer.
Vragen over Ubuntu Nederland of de internationale Ubuntu-gemeenschap? PB of mail me!