Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Gksudo command werkt niet  (gelezen 839 keer)

Blazt

  • Gast
Gksudo command werkt niet
« Gepost op: 2007/07/14, 01:30:57 »
Ik heb geprobeerd om met gksudo gedit /etc/X11/xorg.conf in de terminal m'n monitor-instellingen aan te passen.

Alleen als ik na gksudo gedit /etc/X11/xorg.conf Enter klik krijg ik de volgende melding;

(gedit: 18464): GnomeUI-WARNING **: While connecting to session manager: Authentication Rejected, reason: None of the authentication protocols specified are supported and host-based authentication failed.

Als ik na de melding (geprobeerd) gewoon doorga met instellingen aanpassen, loopt de hele handel bij het rebooten vast.

Kan iemand me vertellen wat deze waarschuwing precies inhoud en betekend en hoe het evt. op te lossen is?

Groet
Blazt.

Offline happyhamster

  • Lid
  • Steunpunt: Nee
Gksudo command werkt niet
« Reactie #1 Gepost op: 2007/07/14, 01:38:42 »
Dat is een bug, maar zover ik weet zonder verdere gevolgen. Dus je kan die melding gewoon negeren. Zie bijv:

http://www.psychocats.net/ubuntu/graphicalsudo

Citaat
Als ik na de melding (geprobeerd) gewoon doorga met instellingen aanpassen, loopt de hele handel bij het rebooten vast.
Wat gebeurd er dan precies? Krijg je een xserver error, en kom je daarna in een console? Zo ja, dan is de verandering in xorg.conf de oorzaak.

Blazt

  • Gast
Gksudo command werkt niet
« Reactie #2 Gepost op: 2007/07/14, 01:44:32 »
Hey

Ja ik krijg eerst een zwart scherm en dan, als ik F8 (geloof ik) druk een melding; Het starten van de x-server is mislukt en of ik een log wil bekijken. Maar alles wat ik dan nog kan doen is de pc uit en aanzetten, geen mogelijkheden tot dingen invoeren iig.

De verandering in xorg.conf heb ik vandeweek ook gedaan (ivm strepen op het scherm) en toen ging alles goed.
Nu heb ik FF 7.04 opnieuw geïnstalleerd, dus misschien dat het daaraan ligt?

Blazt

  • Gast
Gksudo command werkt niet
« Reactie #3 Gepost op: 2007/07/14, 01:49:41 »
Citaat van: Blazt
Hey

Ja ik krijg eerst een zwart scherm en dan, als ik F8 (geloof ik) druk een melding; Het starten van de x-server is mislukt en of ik een log wil bekijken. Maar alles wat ik dan nog kan doen is de pc uit en aanzetten, geen mogelijkheden tot dingen invoeren iig.

De verandering in xorg.conf heb ik vandeweek ook gedaan (ivm strepen op het scherm)
http://forum.ubuntu-nl.org/topic/12125/2  en toen ging alles goed.
Nu heb ik FF 7.04 opnieuw geïnstalleerd, dus misschien dat het daaraan ligt?

Offline happyhamster

  • Lid
  • Steunpunt: Nee
Gksudo command werkt niet
« Reactie #4 Gepost op: 2007/07/14, 01:59:54 »
Citaat van: Blazt
Hey

Ja ik krijg eerst een zwart scherm en dan, als ik F8 (geloof ik) druk een melding; Het starten van de x-server is mislukt en of ik een log wil bekijken. Maar alles wat ik dan nog kan doen is de pc uit en aanzetten, geen mogelijkheden tot dingen invoeren iig.
Dan zou je na een paar keer ok accepteren, in een console gedropt moeten worden, en dan moeten kunnen inloggen (met als bijzonderheid dat je tijdens het intikken van je wachtwoord niets op het scherm zal zien verschijnen.)

Zoniet, druk dan op ctrl-alt-F1 (of F2 t/m F6), om een console te forceren. Dan inloggen, en via

sudo nano /etc/X11/xorg.conf

de boel weer herstellen (nano is een tekst-editor, gedit zal niet werken in een console (console = niet-grafische-terminal). ctrl-o = saven, ctrl-x = nano verlaten.
Je kan ook  de backup terugzetten (je hebt een backup gemaakt neem ik aan :))

Citaat
De verandering in xorg.conf heb ik vandeweek ook gedaan (ivm strepen op het scherm) en toen ging alles goed.
Ja, het ging om "DefaultDepth    24" te veranderen in "DefaultDepth    16" (zonder aanhalingstekens).

Citaat
Nu heb ik FF 7.04 opnieuw geïnstalleerd, dus misschien dat het daaraan ligt?
Heb je precies dezelfde versie geinstalleerd? Gebruik bijv. bij voorkeur *niet* de AMD64 versie. Heb je de installatie-cd gecontroleerd op fouten?

Blazt

  • Gast
Gksudo command werkt niet
« Reactie #5 Gepost op: 2007/07/14, 02:08:05 »
Ja, ik heb een backup gemaakt.
Ik had eerst een zelfgebrande Ubuntu FF 7.04 geïnstalleerd, maar ik kreeg vandeweek de originele die ik besteld had, dus die heb ik nu geïnstalleerd.

Offline happyhamster

  • Lid
  • Steunpunt: Nee
Gksudo command werkt niet
« Reactie #6 Gepost op: 2007/07/14, 02:12:40 »
Ik heb even in het vorige topic gekeken; je moet waarschijnlijk ook de refreshrates invoeren (alleen de kleurendiepte veranderen is misschien niet genoeg).

Section "Monitor"
    Identifier    "AL1715"
    Option        "DPMS"
        HorizSync       24.0 - 80.0
        VertRefresh     49.0 - 75.0
EndSection

Blazt

  • Gast
Gksudo command werkt niet
« Reactie #7 Gepost op: 2007/07/14, 02:20:06 »
Dat had ik gedaan en daar was ik ook meteen de mist mee ingegaan, ik had het nl opgeschreven.

Ik had horiz sync en vert refresh gedaan ipv HorizSync en VertRefresh.

*gaat zich in een hoekje staan schamen*

Nu is alles gelukkig weer in orde.

Sorry dat ik je tijd verknoeide, maar toch weer hartelijk dank voor de hulp! :)

Groet
Blazt.

Offline happyhamster

  • Lid
  • Steunpunt: Nee
Gksudo command werkt niet
« Reactie #8 Gepost op: 2007/07/14, 02:33:24 »
Wat ik zelf doe, is alle veranderingen e.d. die ik heb gemaakt in een klein tekstbestandje te schrijven, en deze te bewaren op een usb-stick. De volgende keer dat ik een installatie doe, kan ik alles dan gewoon copy&pasten, zonder bang te hoeven zijn voor tikfouten.

Citaat van: Blazt
Sorry dat ik je tijd verknoeide, maar toch weer hartelijk dank voor de hulp! :)
Geen probleem :)