Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: MythTV installatie problemen door libqt3 dependencies  (gelezen 933 keer)

fwesterop

  • Gast
MythTV installatie problemen door libqt3 dependencies
« Gepost op: 2006/04/22, 17:11:19 »
Hallo,

Ik heb geprobeerd MythTV te installeren (zowel 0.18 uit de Ubuntu repositories als de 0.19 Debian versie uit de officiele MythTV repositories) op een AMD64 bak met Kubuntu Breezy Badger. Dit lukt me niet omdat de MythTV packages dependencies blijken te hebben op de library packages libqt3c102-mt en libqt3c102-mt-mysql. Deze zijn op een up-to-date Breezy systeem  echter vervangen door de packages libqt3-mt en libqt3-mt-mysql, waardoor zowel apt-get als dpkg weigert om MythTV te configureren. De QT3 packages verschillen dus in naam en hebben een iets ander revisie nummer (resp. 3.3.4-3 en 3.3.4-8). Door het kleine verschil verwacht ik dat MythTV ook met de huidige QT3 libs zal werken alleen ik weet niet hoe ik apt-get danwel dpkg hiervan kan overtuigen.

Ik heb ook geprobeerd de QT3 packages te downgraden naar de versie die MythTV kennelijk graag heeft, maar dan stort zo ongeveer mijn hele KDE omgeving in elkaar omdat dan bijna alle KDE apps klagen over failed dependencies. Dat schiet dus niet echt op.

Hoe kan ik dit oplossen? Tips zijn meer dan welkom, want ik weet het niet meer maar wil nu toch eindelijk wel eens TV kunnen kijken op mijn Home Theatre PC...

Groet,
Frank

Offline Dennis Kaarsemaker

  • Administrator
    • dennis
    • http://www.kaarsemaker.net
  • Steunpunt: Nee
MythTV installatie problemen door libqt3 dependencies
« Reactie #1 Gepost op: 2006/04/22, 17:45:53 »
Gebruik een op Ubuntu gerichte repository voor mythTV, http://deb.thehunter.ws bijvoorbeeld :)

fwesterop

  • Gast
MythTV installatie problemen door libqt3 dependencies
« Reactie #2 Gepost op: 2006/04/22, 21:21:16 »
Hmm. Ken je nog meer (K)Ubuntu specific reposities toevallig? TheHunter bevat geen packages voor AMD64.

Offline Dennis Kaarsemaker

  • Administrator
    • dennis
    • http://www.kaarsemaker.net
  • Steunpunt: Nee
MythTV installatie problemen door libqt3 dependencies
« Reactie #3 Gepost op: 2006/04/22, 23:03:18 »
Helaas...

Je kunt wel vrij simpel de packages zelf compileren als je de deb-src regels van TheHunter aan je sources.list toevoegt:

sudo apt-get install build-essential
sudo apt-get build-dep mythtv mythplugins myththemes
apt-get -b source mythtv
apt-get -b source mythplugins
apt-get -b source myththemes

fwesterop

  • Gast
MythTV installatie problemen door libqt3 dependencies
« Reactie #4 Gepost op: 2006/04/24, 13:21:52 »
Thanks, hoewel ik sources compileren probeer te vermijden (bij mij valt er altijd van alles om als ik dat doe). Bleek loud watervrees in dit geval. Ik volgde deze beschrijving die sources uit de orginele Ubuntu repo's gebruikt:

http://s91928265.onlinehome.us/hfamily/mythtv/myth_ubuntu_64.html#myth