Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Java versie 4 vervangen door 5 lukt niet...  (gelezen 421 keer)

saskia

  • Gast
Java versie 4 vervangen door 5 lukt niet...
« Gepost op: 2007/07/09, 16:58:38 »
Hallo,

Al een poos gebruik ik ubuntu en nu heb ik Java versie 5 nodig. Via synaptic kan ik de benodigde pakketten installeren: (als ik t goed heb)
sun-java5-jre
sun-java5-fonts
sun-java5-plugin
Er verschijnen geen errors, en ook wordt in de terminal aangegeven dat ik de sun-licence al geaccepteerd heb.

Echter als ik in de terminal "java -version" intyp blijft hij aangeven dat ik versie 1.4.2 heb, zelfs nadat ik die (j2re1.4) verwijderd heb via synaptic (en het programmaatje waarvoor ik java5 nodig heb draait dus ook niet).

Naast dat volgens alle help-fora bovenstaande 3 bestanden voldoende zouden moeten zijn is er ook nog een "sun-java5-bin" en via sunlabs een .bin file. Ik kan echter niet verzinnen wat ik daarmee moet doen. (.bin bestand heb ik proberen uit te voeren door in te typen, met volledige rechten)

Weet iemand wat het probleem zou kunnen zijn?

Hopelijk ben ik volledig genoeg in mijn probleemstelling. Oja, er draait hier denk ik versie "Ubuntu, Kernel 2.6.15.nogiets..."


vr.gr.
Saskia

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Java versie 4 vervangen door 5 lukt niet...
« Reactie #1 Gepost op: 2007/07/09, 17:14:54 »
Voer in een terminal het volgende commando uit:
 sudo update-alternatives --config java

Nu krijg je een lijstje van alle geïnstalleerde java versies.
Kies nu de goede java versie.

Hierna zal als het goed is de juiste java versie gebruikt worden.

saskia

  • Gast
Java versie 4 vervangen door 5 lukt niet...
« Reactie #2 Gepost op: 2007/07/09, 18:05:47 »
in een keer goed, 1000 maal bedankt!!

(mn systeem opschonen komt later wel, en het ubuntu-begrijpen volgt langzaam, maar alles draait nu iig naar wens : )