Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: SpeedTouch 121G USB en ubuntu 7.04  (gelezen 7303 keer)

smartpc

  • Gast
SpeedTouch 121G USB en ubuntu 7.04
« Gepost op: 2007/07/09, 02:29:08 »
Ik kreeg het eerst niet werkend maar nu heb ik hem draaien.
Met dank aan kevdog:

I think the big Error statement tells you this. No one however has been able to confirm if to me if this matter or not. To solve this problem, you need to backtrack. First uninstall your driver
sudo ndiswrapper -r ***** (put in driver name but do not type the extension .inf)
Then uninstall ndiswrapper -- you likely used Synaptic to install this, so use synaptic to uninstall.

The following is how we are going to install ndiswrapper from source. If this computer does not have a working internet connection (ie a wired connection) then you are going to have to use another computer to help you.

If wired connection, at command line type
sudo aptitude install build-essential

If no wired connection but have installation cd, put cd in drive and type
sudo apt-cdrom add
sudo aptitude update
sudo aptitude install build-essential

Next visit the following site and download the ndiswrapper.tar.gz file (I think the version is 1.47)
http://ndiswrapper.sourceforge.net/j...iki/Itemid,33/

Look for the download section. This should give you a file named ndiswrapper-1.47.tar.gz. Place this in your home directory. You can either do this via command line or GUI using nautilis
Then lets unpack the tar file from command line:
cd ~
tar -zxvf ndisrapper-1.47.tar.gz
cd ndiswrapper -1.47
make distclean
make
sudo make install

Check now if you have the right version of ndiswrapper and everything is correct with this program
ndiswrapper -v
You should get no errors with this statement
Then rewrap driver like you did above
sudo ndiswrapper -i *****.inf <----substitute name of file here with .inf extension. Make sure you have .inf and .sys file in the same directory where you are running this command.

Then load module into kernel
sudo modprobe -r ndiswrapper
sudo depmod -a
sudo modprobe -i ndiswrapper

And then make module load at runtime
sudo ndiswrapper -m

Ndiswrapper makes a default installation on wlan0. This sometimes causes problems for some people because as a default their wirleless connection is setup on eth0, or eth1, etc. We can fix this for you if need be.

Some modifications may need to be done to your /etc/network/interfaces and /etc/iftab files also.

Please do the steps I listed above, and then report back. When you report back please post the results of:
ifconfig
/etc/network/interfaces

Thanks.

Offline Silvester

  • Lid
  • Steunpunt: Nee
SpeedTouch 121G USB en ubuntu 7.04
« Reactie #1 Gepost op: 2007/07/10, 21:51:42 »
Tot en met het uitpakken van ndiswrapper gaat het goed, op de volgende commandline opdracht gaat het mis:
make distclean
make: *** Er is geen regel om doel 'distclean' te maken.  Gestopt.

En nu? Het is de eerste keer dat ik een mak moet maken. Vandaag is het te laat om nog wat te doen. In de loop van de week verder, want nu ik weet dat een speedtouch 121g kan werken, wil ik ook van de losse draad af.
S

Ah, ik zie het al, vergeten de cursor in de map te zetten.
Morgen verder
S

Yggdrasil

  • Gast
SpeedTouch 121G USB en ubuntu 7.04
« Reactie #2 Gepost op: 2007/07/12, 15:17:35 »
Hallo Silvester,

Het is helemaal niet nodig om ndiswrapper te compilen van broncode. Ik heb toevallig afgelopen weekend geprobeerd mijn Speedtouch 121G aan de praat te krijgen op Ubuntu Feisty 7.04 en dat is gelukt.

Ik heb (bij gebrek aan internet toegang) gewoon ndiswrapper-common en ndiswrapper-utils gedownload van http://packages.ubuntu.com/feisty/misc/, daarna geinstalleerd door erop te dubbelklikken. De drivers heb ik gedownload van http://www.thomsontelecompartner.com/getfilefromthomson.php?id=3278.

Met name de combinatie van ndiswrapper en WPA2 vond ik eng maar uiteindelijk was het niet zo moeilijk. Ik heb een combinatie gebruikt van de volgende twee howto's, waarbij ik de laatste twee stappen van de eerste howto heb overgeslagen.

http://ubuntuguide.org/wiki/Ubuntu:Feisty#How_to_install_Windows_Wireless_Drivers_.28Ndiswrapper.29
http://ubuntuguide.org/wiki/Ubuntu:Feisty#How_to_enable_WPA_with_Ndiswrapper_driver

Ik ben de manuele route gegaan na voormalige slechte ervaringen met de automatische methode.
Citaat
How to install Windows Wireless Drivers (Ndiswrapper)

    * Read #General Notes
    * In order to install ndiswrapper you need a copy the windows drivers for your Wireless ethernet device.
    * This is only meant to be installed if your card isn't supported by Ubuntu, check Ubuntu's list of natively supported wireless cards.
    * Check ndiswrapper's list of supported wireless cards if your card isn't supported natively, please visit Ndiswrapper's official supported cards list
    * If your card is supported by ndiswrapper, you can install and configure it via a gui tool (ndisgtk) very easily. Use the Add/Remove Applications tool and search for "Ndiswrapper driver installation tool". Once installed, you can configure the wireless connection by going to System -> Administration -> Windows Wireless Drivers. Some more information on this here.

To Install manually follow the steps below:

    * Find out if you have acx module loaded. Because acx module interferes with windows driver, we need to remove it if it is found.
lsmod | grep acx* Remove the acx module if found. It could also be acx_pci or similar. Please Note: New kernel updates will auto load the acx module again. So repeat the following two commands every time the kernel is updated.
sudo rmmod acx
sudo nano /etc/modprobe.d/blacklist
* Add a new list at the end of the file like this:
# drivers wireless ACX
blacklist acx
* Install ndiswrapper and drivers (due to a bug in Edgy, you need to specify ndiswrapper-utils-1.8)
sudo apt-get install ndiswrapper-utils-1.8
sudo ndiswrapper -i /location_of_your_wireless_driver/your_driver.inf
sudo ndiswrapper -l
sudo modprobe ndiswrapper
* Set ndiswrapper to load on startup
sudo ndiswrapper -m
gksudo gedit /etc/modules
* Add the following module to the list
ndiswrapper* Now you can configure your wireless card with ifconfig and iwconfig.
Hierna kon ik via 'iwlist scan' een lijst krijgen van zichtbare access points.
Verbinding maken met een onbeveiligd access point was makkelijk via iwconfig. Een met WEP beveiligd access point heb ik niet geprobeerd maar zou moeten kunnen met iets als:
sudo iwconfig wlan0 essid "AP" key ababababababababab mode Managed
iwconfig
Ik ben direct doorgegaan met WPA uit de tweede howto:

Citaat
How to enable WPA with Ndiswrapper driver

Make sure on your own that the Ndiswrapper driver works by itself without encryption.

    * Create a file called /etc/wpa_supplicant.conf, and paste in the following. Modify the ssid and psk values.
ctrl_interface=/var/run/wpa_supplicant
 network={
   ssid="YourWiFiSSID"
   psk="YourWiFiPassword"
   key_mgmt=WPA-PSK
   proto=WPA
   pairwise=TKIP
 }
* Run the following code to test it and make sure your router is broadcasting its SSID.
sudo wpa_supplicant -Dwext -iwlan0 -c/etc/wpa_supplicant.conf -d(If your wireless interface is not named "wlan0", replace "-iwlan0" with "-i[name-of-your-wireless-interface]". E.g. "-ieth1")


    * If your WPA works, change your configuration file so Ubuntu automatically connects you to your network. Run:
gksudo gedit /etc/network/interfacesIn the editor, change your wlan0 (or whatever your wireless interface is) section to the following:

If you are using static IP:
auto wlan0
iface wlan0 inet static
address 192.168.1.20
netmask 255.255.255.0
gateway 192.168.1.1
pre-up wpa_supplicant -Bw -Dwext -iwlan0 -c/etc/wpa_supplicant.conf
post-down killall -q wpa_supplicant
or this, if you are using dhcp.
auto wlan0
iface wlan0 inet dhcp
pre-up wpa_supplicant -Bw -Dwext -iwlan0 -c/etc/wpa_supplicant.conf
post-down killall -q wpa_supplicant
* Reload your network configuration:
sudo /etc/init.d/networking restart
Sorry voor de lange post, maar ik wilde je niet zelf aan het zoeken zetten. Met deze handelingen heb ik de Speedtouch 121g samen met WPA2 aan de praat gekregen op Ubuntu Feisty. Negeer de Network Manager voorlopig, want zodra die probeert om een WPA2 verbinding te maken verlies ik mijn verbinding weer.

Offline Silvester

  • Lid
  • Steunpunt: Nee
SpeedTouch 121G USB en ubuntu 7.04
« Reactie #3 Gepost op: 2007/07/12, 19:12:18 »
Hallo Yggdrasil,

Dank voor het uitgebreide antwoord. Hier moet ik maar eens mee aan de slag gaan. Vandaag zal dat wel niet meer lukken. En inderdaad ik heb de network-manager in gebruik. Als die het verstierd moet die uit, maar dan ben ik denk ik ook even de vaste verbinding kwijt, dus moet ik de verschillende stappen maar even in een apart bestandje zetten. Printer heeft mijn dochter weer mee en om het te onthouden zal niet lukken. Ik kom er tzt weer op terug, hopelijk met een juichkreet.
Dank S

Offline Silvester

  • Lid
  • Steunpunt: Nee
SpeedTouch 121G USB en ubuntu 7.04
« Reactie #4 Gepost op: 2007/07/12, 22:31:20 »
acx is niet aanwezig, dus das mooi
Maar daarna kom ik weer niet verder met:

$ sudo apt-get install ndiswrapper-utils-1.8
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd      
Reading state information... Klaar
E: Kon pakket ndiswrapper-utils-1.8 niet vinden

Kortom, daar kom ik dus ook geen steek mee verder. Voorlopig heb ik het wel weer even gehad met linux.

smartpc

  • Gast
SpeedTouch 121G USB en ubuntu 7.04
« Reactie #5 Gepost op: 2007/07/12, 23:20:37 »
hoi sylvester,

Had je alle stappen doorlopen die in mijn stukje staan?
Bij mij werkte het in 1 keer.

[ de .inf en .sys bestanden zijn de windows driver bestanden]

Yggdrasil

  • Gast
SpeedTouch 121G USB en ubuntu 7.04
« Reactie #6 Gepost op: 2007/07/13, 10:07:20 »
Citaat van: Silvester
E: Kon pakket ndiswrapper-utils-1.8 niet vinden
Hallo Silvester,

Bij het installeren van een pakket kun je het versienummer niet op deze manier opgeven, en dat is in het algemeen ook niet nodig. Doe gewoon 'aptitude install ndiswrapper-utils ndiswrapper-common'. Dat zal zeker werken.

Je kunt ook apt-get gebruiken, maar aptitude heeft mijn voorkeur omdat die iets intelligenter is. Kies wat je fijn vindt.

Groeten, Martijn

Offline Silvester

  • Lid
  • Steunpunt: Nee
SpeedTouch 121G USB en ubuntu 7.04
« Reactie #7 Gepost op: 2007/07/14, 08:16:03 »
--> Met Feisty komt ndiswrapper-tools versie 1.9 mee. Die heb ik aangezet met synaptic package manager

--> Vervolgens de stappen doorlopen maar blijf hangen op:
 
/etc$ sudo wpa_supplicant -Dwext -iwlan0 -c/etc/wpa_supplicant.conf -d
Initializing interface 'wlan0' conf '/etc/wpa_supplicant.conf' driver 'wext' ctrl_interface 'N/A' bridge 'N/A'
Configuration file '/etc/wpa_supplicant.conf' -> '/etc/wpa_supplicant.conf'
Reading configuration file '/etc/wpa_supplicant.conf'
ctrl_interface='/var/run/wpa_supplicant'
Line 8: removed CCMP from group cipher list since it was not allowed for pairwise cipher
Priority group 0
   id=0 ssid='SX551D8A612'
Initializing interface (2) 'wlan0'
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: KEY_RX entering state NO_KEY_RECEIVE
EAPOL: SUPP_BE entering state INITIALIZE
EAP: EAP entering state DISABLED
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
SIOCGIWRANGE: WE(compiled)=21 WE(source)=18 enc_capa=0xf
  capabilities: key_mgmt 0xf enc 0xf
WEXT: Operstate: linkmode=1, operstate=5
Own MAC address: 00:12:bf:22:86:c5
wpa_driver_wext_set_wpa
wpa_driver_wext_set_key: alg=0 key_idx=0 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=1 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=2 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=3 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_countermeasures
wpa_driver_wext_set_drop_unencrypted
Setting scan request: 0 sec 100000 usec
Using existing control interface directory.
bind(PF_UNIX): Address already in use
ctrl_iface exists and seems to be in use - cannot override it
Delete '/var/run/wpa_supplicant/wlan0' manually if it is not used anymore
Failed to initialize control interface '/var/run/wpa_supplicant'.
You may have another wpa_supplicant process already running or the file was
left by an unclean termination of wpa_supplicant in which case you will need
to manually remove this file before starting wpa_supplicant again.

Failed to add interface wlan0
State: DISCONNECTED -> DISCONNECTED
Segmentatiefout (core dumped)

--> Als ik vervolgens op zoek ga naar '/var/run/wpa_supplicant/wlan0', dan vind ik die niet. Dus kan die ook niet verwijderen

--> Een zoektocht naar wlan0 levert het volgende op:
/var$ locate wlan0
/var/lib/dhcp3/dhclient.wlan0.leases
/home/wijbenga/.kde/share/config/kwlanrc.wlan0
/home/wijbenga/.kde/share/config/kwlan.wlan0

--> maar heb te weinig kennis om te beoordelen of ik hier iets mee moet.

--> iwconfig geeft wel de wlan0 weer met goede ESSID
--> iwlist scanning geeft 6 cellen, waaronder mijn speedtouch 121g.

--> Interfaces bevat:
auto wlan0
iface wlan0 inet dhcp
pre-up wpa_supplicant -Bw -Dwext -iwlan0 -c/etc/wpa_supplicant.conf
post-down killall -q wpa_supplicant
--> Dat heeft onder Dapper gewerkt

--> Ik heb vervolgens het netwerk opnieuw opgestart en krijg daar onder meer:
Listening on LPF/wlan0/00:12:bf:22:86:c5
Sending on   LPF/wlan0/00:12:bf:22:86:c5
Sending on   Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 3
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 6
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 12
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 10
No DHCPOFFERS received.
No working leases in persistent database - sleeping.

--> Kennelijk gaat er wat mis met de dhcp communicatie. Ik zie in het algemeen wel dat het lampje op de usb volgens een stramien knippert en dan een tijdje aanblijft staan, totdat proces opnieuw begint. Het lijkt erop alsof er wel om verbinding gevraagd wordt vanuit de PC, maar dat de router, die WPA is ingesteld niet de goede code aangeleverd krijgt.

Ik loop er al een maand mee te prutsen. Informatie van hulpvaardige bronnen op verschillende fora krijgen het op verschillende manieren kennelijk wel voor elkaar. Moet bij mij toch ook kunnen, zeker vanuit de wetenschap dat het bij Dapper wel heft gewerkt.
S

Offline Silvester

  • Lid
  • Steunpunt: Nee
SpeedTouch 121G USB en ubuntu 7.04
« Reactie #8 Gepost op: 2007/07/15, 22:29:03 »
Ik heb de vaste verbinding losgemaakt en gekeken welke meldingen worden gedaan:

:~$ sudo dmesg | tail
[   46.236000] Bluetooth: RFCOMM ver 1.8
[ 1173.116000] usb 4-2: USB disconnect, address 2
[ 1173.656000] ndiswrapper: device wlan0 removed
[ 1180.992000] usb 6-4: new high speed USB device using ehci_hcd and address 2
[ 1181.136000] usb 6-4: configuration #1 chosen from 1 choice
[ 1181.252000] usb 6-4: reset high speed USB device using ehci_hcd and address 2
[ 1181.396000] ndiswrapper: driver bt4501g (THOMSON,11/16/2005, 3.3.36.0) loaded
[ 1183.708000] wlan0: ethernet device 00:12:bf:22:86:c5 using NDIS driver: bt4501g, version: 0x30324, NDIS version: 0x501, vendor: 'SpeedTouch 121g Wireless USB Adapter', 06B9:0121.F.conf
[ 1183.708000] wlan0: encryption modes supported: WEP; TKIP with WPA, WPA2, WPA2PSK; AES/CCMP with WPA, WPA2, WPA2PSK
[ 1229.900000] eth0: link down

Iemand nog ideen?

AnHee

  • Gast
SpeedTouch 121G USB en ubuntu 7.04
« Reactie #9 Gepost op: 2007/07/27, 23:37:21 »
Helemaal blij vandaag: na heel lang zoeken en proberen eindelijk de speedtouch 120g werkend gekregen met WPA en Ndiswrapper. Bedankt voor de goede uitleg!:D and =D

AnHee

  • Gast
SpeedTouch 121G USB en ubuntu 7.04
« Reactie #10 Gepost op: 2007/07/28, 11:22:37 »
Hallo Silvester,

Om de speedtouch 120 g werkend te krijgen heb ik eerst de NetworkManager verwijderd en ook ndisgtk. Vervolgens heb ik de stappen gevolgd zoals beschreven door Yggdrasil en smartpc. Ik heb gekozen voor ndiswrapper 1.47. Na installatie van deze versie en na installatie van de driver heb ik letterlijk vanaf   Code:

sudo ndiswrapper -m
gksudo gedit /etc/modules deze stappen gevolgd en toen werkte de 120 g. Ongetwijfeld moet de 121G het ook doen!

Offline Silvester

  • Lid
  • Steunpunt: Nee
SpeedTouch 121G USB en ubuntu 7.04
« Reactie #11 Gepost op: 2007/08/25, 11:37:23 »
Druk druk druk, nog geen tijd gehad om er verder mee te stoeien. Ik hoop echter dat er binnenkort een update komt die alle problemen in een keer vanuit ubuntu oplost.
Ben nog moed aan het verzamelen om weer eens een avond te prutsen, want zo voelt het wel een beetje.

In de tussentijd ligt de vaste kabel gewoon los door het huis. Niet fraai, maar zo werkt het wel. Alternatief is een goedkope andere draadloze stick, maar welke?
Feisty Fawn + experiabox met WPA + welke draadloze stick,

that's the question.

:) S