Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: opstartprobleem na het verwijderen van het bestand "X"  (gelezen 1921 keer)

Gast

  • Gast
opstartprobleem na het verwijderen van het bestand "X"
« Gepost op: 2006/04/19, 16:52:08 »
beste,
mijn probleem:

in de map usr/X11R6/bin/ heb ik de bestandsnaam "X" verwijderd. Na later heropstarten van linux kon de grafische interface niet meer geactiveerd worden, met als fout dat ie het bestand "X" niet kon vinden.
nu heb ik dus enkel een zwart scherm met witte letterkes om te werken. Ik weet niet hoe ik vandaaruit "X" kan terugplaatsen. "X" staat dus normaal wel nog in de prullenbak want die heb ik niet leeggemaakt.
Is het mogelijk om dat bestand dus eigenlijk gewoon weer naar de juiste locatie terug te zetten?

Zelf probeerde ik al via "sudo apt-get install xserver-xorg" de X-server te herinstalleren maar dan zegt ie dat er al een nieuwere versie op de pc staat.

kHoop dat ik linux niet gans moet herinstalleren...

alvast bedankt!
wim

Offline Dennis Kaarsemaker

  • Administrator
    • dennis
    • http://www.kaarsemaker.net
  • Steunpunt: Nee
opstartprobleem na het verwijderen van het bestand "X"
« Reactie #1 Gepost op: 2006/04/19, 17:00:39 »
Waarom heb je die gewist? Als je zomaar willekeurige bestanden gaat wissen kun je rekenen op problemen...

apt-get install --reinstall xserver-xorg

Offline zappa

  • Lid
    • http://www.c3c.be
  • Steunpunt: Nee
opstartprobleem na het verwijderen van het bestand "X"
« Reactie #2 Gepost op: 2006/04/19, 17:01:05 »
Als het nog in de trash zit:
sudo cp /home/'jij'/.Trash /usr/share/bin (ben niet zeker van doelmap!!)

Gast

  • Gast
opstartprobleem na het verwijderen van het bestand "X"
« Reactie #3 Gepost op: 2006/04/19, 17:39:40 »
hey

ik heb nu de xserver-xorg ge reinstalled, maar dat lost het probleem niet op.

"Als het nog in de trash zit:
sudo cp /home/'jij'/.Trash /usr/share/bin (ben niet zeker van doelmap!!)"

wat doet dit juist, want as ik het nu in een verkeerde map terugzet geraakt het alleen maar verder weg.
ik ken de doelmap wel, maar k begrijp het commando niet goe, welk deel is in jouw commando de doelgroep en wat betekent 'jij' ?
kben er vrij zeker van dat "X" in usr/X11R6/bin/ zat.

in elk geval al mercikes voor de snelle respons!

Offline Dennis Kaarsemaker

  • Administrator
    • dennis
    • http://www.kaarsemaker.net
  • Steunpunt: Nee
opstartprobleem na het verwijderen van het bestand "X"
« Reactie #4 Gepost op: 2006/04/19, 17:57:20 »
sudo dpkg -P --force-depends xserver-xorg
sudo apt-get install xserver-xorg

Gast

  • Gast
opstartprobleem na het verwijderen van het bestand "X"
« Reactie #5 Gepost op: 2006/04/19, 20:45:19 »
Citaat van: Dennis
sudo dpkg -P --force-depends xserver-xorg
sudo apt-get install xserver-xorg
ik heb dit ingetypt en het verwijdere en herinstalleren werkte, doch, ik krijg nog altijd dezelfde fout zelfs na het herconfigureren van xserver-xorg. De fout krijg ik in een blauwgrijs scherm en is:

GDM: Xserver. not found: /usr/X11R6/bin/X :O -br -audit .O -auth/var/lib/gdm/:O. Xauth -nolisten tcp vt7
Error: Command could not be executed
Please install the X server or correct .GDM configuration and restart .GDM

kwist nie da zo'n file zo belangrijk was, k had het gedeleted met da k de video driver zo dacht properkes te herinstalleren, maar ja zo leer k linux kenne...

Gast

  • Gast
opstartprobleem na het verwijderen van het bestand "X"
« Reactie #6 Gepost op: 2006/04/19, 20:46:59 »
Citaat van: help
Citaat van: Dennis
sudo dpkg -P --force-depends xserver-xorg
sudo apt-get install xserver-xorg
ik heb dit ingetypt en het verwijdere en herinstalleren werkte, doch, ik krijg nog altijd dezelfde fout zelfs na het herconfigureren van xserver-xorg. De fout krijg ik in een blauwgrijs scherm en is:

GDM: Xserver. not found: /usr/X11R6/bin/X :O -br -audit .O -auth/var/lib/gdm/:O. Xauth -nolisten tcp vt7
Error: Command could not be executed
Please install the X server or correct .GDM configuration and restart .GDM

kwist nie da zo'n file zo belangrijk was, k had het gedeleted met da k de video driver zo dacht properkes te herinstalleren, maar ja zo leer k linux kenne...
oei, die gele ventjes zijn  :O
sorry

Saamelainen

  • Gast
opstartprobleem na het verwijderen van het bestand "X"
« Reactie #7 Gepost op: 2006/04/19, 22:12:48 »
Ik weet het niet hoor, maar soms gebeurt er wel eens wonder als je opnieuw opstart.:o

Gast

  • Gast
opstartprobleem na het verwijderen van het bestand "X"
« Reactie #8 Gepost op: 2006/04/20, 00:15:00 »
Citaat van: zappa
Als het nog in de trash zit:
sudo cp /home/'jij'/.Trash /usr/share/bin (ben niet zeker van doelmap!!)
ik heb 'jij' vervangen door de gebruikersnaam, en hetingetikt, maar krijg nog altijd dezelfde fout.  Weet er nog iemand een oplossing?

groeten,
wim

Offline zappa

  • Lid
    • http://www.c3c.be
  • Steunpunt: Nee
opstartprobleem na het verwijderen van het bestand "X"
« Reactie #9 Gepost op: 2006/04/20, 11:35:20 »
Doe eens wat Dennis schreef. Dan lukt het zeker.

Gast

  • Gast
opstartprobleem na het verwijderen van het bestand "X"
« Reactie #10 Gepost op: 2006/04/20, 12:53:21 »
Citaat van: help
Citaat van: help
Citaat van: Dennis
sudo dpkg -P --force-depends xserver-xorg
sudo apt-get install xserver-xorg
ik heb dit ingetypt en het verwijdere en herinstalleren werkte, doch, ik krijg nog altijd dezelfde fout zelfs na het herconfigureren van xserver-xorg. De fout krijg ik in een blauwgrijs scherm en is:

GDM: Xserver. not found: /usr/X11R6/bin/X :O -br -audit .O -auth/var/lib/gdm/:O. Xauth -nolisten tcp vt7
Error: Command could not be executed
Please install the X server or correct .GDM configuration and restart .GDM

kwist nie da zo'n file zo belangrijk was, k had het gedeleted met da k de video driver zo dacht properkes te herinstalleren, maar ja zo leer k linux kenne...
oei, die gele ventjes zijn  :O
sorry
heb ik al geprobeerd, maar het hielp niet, blijkbaar bevat xserver-xorg het bestandje "X" niet?
wim

Offline Dennis Kaarsemaker

  • Administrator
    • dennis
    • http://www.kaarsemaker.net
  • Steunpunt: Nee
opstartprobleem na het verwijderen van het bestand "X"
« Reactie #11 Gepost op: 2006/04/21, 11:42:16 »
Ah, in breezy zit dat bestand in xserver-common

sudo dpkg -P --force-depends xserver-common
sudo apt-get install xserver-common
sudo apt-get -f install

Gast

  • Gast
opstartprobleem na het verwijderen van het bestand "X"
« Reactie #12 Gepost op: 2006/04/26, 14:09:23 »
Citaat van: Dennis
Ah, in breezy zit dat bestand in xserver-common

sudo dpkg -P --force-depends xserver-common
sudo apt-get install xserver-common
sudo apt-get -f install
bedankt!

ik had de cd nodig, die had ik nie direct bij mij.
Met de  cd lukte het ook nie direct. Maar uiteindelijk lukte het toch met een combinatie van de commando's die je opgaf: eerst typte ik de opgegeven sudo dpkg -P ..... mogelijkheden in met ook nog es zoiets met xserver-xorg-core, en dan alle bijhorende apt-get mogelijkheden en dan sudo apt-get -f install. Enfin het werkte weer.

bedankt!