Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Beryl - Ati - Gnome werkt niet  (gelezen 882 keer)

rx_shorty

  • Gast
Beryl - Ati - Gnome werkt niet
« Gepost op: 2007/07/04, 22:16:33 »
Hallo allemaal,

Na heel wat uurtjes prutsen met ubuntu en de voor mij ondertussen beruchte combinatie van Beryl en Ati, lukt het me niet om Beryl te laten opstarten in Gnome omgeving.

De XGL sessie draait vlekkeloos maar dat ziet er nou eenmaal niet zo strak uit als Gnome.
Als ik in Gnome Beryl wil opstarten gaat het prima, de manager draait ook.
Maar als ik voor Vensterbeheerder kies voor Beryl, Gaat de vensters wat op en neer en schiet hij weer terug naar Metacity.

Wat info over me Ati configuratie:
glxinfo | grep direct
direct rendering: Yes

fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON 9800 Pro
OpenGL version string: 2.0.6334 (8.34.8)

Maar waarom lukt het in XGL wel en niet in Gnome?
Hulp word zeer gewardeerd ;)

Ciao :D

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Beryl - Ati - Gnome werkt niet
« Reactie #1 Gepost op: 2007/07/04, 22:18:44 »
Gebruik je de radeon open source driver + DRI of de closed source fglrx driver? voor de closed source driver moet je Xgl gebruiken, voor de open source driver moet je Aiglx gebruiken (is standaard in Feisty Fawn)

Ik begrijp je opmerking niet goed van "het werkt wel in Xgl maar niet in GNOME".. Xgl is een rendering architectuur, geen vervanging voor GNOME.
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

rx_shorty

  • Gast
Beryl - Ati - Gnome werkt niet
« Reactie #2 Gepost op: 2007/07/04, 23:52:27 »
Citaat van: profoX
Gebruik je de radeon open source driver + DRI of de closed source fglrx driver? voor de closed source driver moet je Xgl gebruiken, voor de open source driver moet je Aiglx gebruiken (is standaard in Feisty Fawn)

Ik begrijp je opmerking niet goed van "het werkt wel in Xgl maar niet in GNOME".. Xgl is een rendering architectuur, geen vervanging voor GNOME.
Als ik bij het aanlogscherm bij opties kies voor XGL sessie, werkt het wel.
Dus als ik kies voor Sessie Gnome, dan start beryl wel op maar krijg ik hem via de manager niet op Beryl gezet.
Ik heb de open source driver gepakt, want het is een ouder Ati kaartje en het is alleen voor de leuke effecten nodig.

Offline moxie

  • Lid
    • JackTummers
  • Steunpunt: Nee
Beryl - Ati - Gnome werkt niet
« Reactie #3 Gepost op: 2007/07/05, 10:11:37 »
Ik heb zelf een ATI X1600 Silent, maar ook mij is het nog niet gelukt. Springt ook steeds terug. Zelfs met een aantal uitgebreide handleidingen heb ik Beryl nog niet aan de praat kunnen krijgen. Als het me lukt is het nog de vraag of ik het wel zal gaan gebruiken (het ziet er ook nogal druk en onrustig uit), maar ik heb graag een keuze ;).
JackTummers.nl

rx_shorty

  • Gast
Beryl - Ati - Gnome werkt niet
« Reactie #4 Gepost op: 2007/07/06, 13:38:29 »
Hmm dus niemand weet hier een oplossing voor?
Ik heb net als moxie al heel wat wiki's en handleidingen doorgenomen...Maar helaas...

:(

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Beryl - Ati - Gnome werkt niet
« Reactie #5 Gepost op: 2007/07/06, 17:19:25 »
Ik raad jullie beide aan om nog een kleine 3 maanden geduld uit te oefenen. Dan komt de volgende versie van Ubuntu uit met de Compiz-Fusion vensterbeheerder (opvolger van Beryl) standaard ingesteld. ;) (je kan natuurlijk hem ook makkelijk uitschakelen als hij niet bevalt)
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

rx_shorty

  • Gast
Beryl - Ati - Gnome werkt niet
« Reactie #6 Gepost op: 2007/07/06, 23:41:42 »
Ik had het al gelezen inderdaad over beryl en compiz...
Beryl is stopgezet en Compiz gaat door toch?

Laten we hopen dat die wel wat soepeler werkt met Ati kaarten... :P
Want op deze pc met een Nvidia werkt het allemaal prima!

Bedankt nog voor je reply!