Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Limewire mist java pakketten  (gelezen 880 keer)

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Limewire mist java pakketten
« Gepost op: 2007/06/26, 13:07:28 »
Ik heb pas limewire geinstalleerd, via toepassingen>internet starte limewire niet op.
Als ik in een terminal limwire opstart krijg ik de volgende fout:
root@gijs-desktop:/home/gijs# limewire
Starting LimeWire...
Java exec found in PATH. Verifying...
OOPS, you don't seem to have a valid JRE. LimeWire works best with Sun JRE available at http://www.java.com
OOPS, unable to locate java exec in  /usr/lib/  hierarchy
You need to upgrade to JRE 1.4.x or newer from http://www.java.com
ls: /usr/java/j*: Bestand of map bestaat niet
OOPS, unable to locate java exec in  /usr/java/  hierarchy
You need to upgrade to JRE 1.4.x or newer from http://www.java.com
ls: /opt/j*: Bestand of map bestaat niet
OOPS, unable to locate java exec in  /opt/  hierarchy
You need to upgrade to JRE 1.4.x or newer from http://www.java.com

Nu heb ik op de side van Java JRE 1.6.0 gedownload en geinstalleerd:
root@gijs-desktop:/home/gijs# chmod a+x jre-6u1-linux-i586-rpm.bin
root@gijs-desktop:/home/gijs# ./jre-6u1-linux-i586-rpm.bin
Vervolgens de hele licensie en dan de volgende foutmelding:Do you agree to the above license terms? [yes or no]
y
Unpacking...
Checksumming...
Extracting...
UnZipSFX 5.50 of 17 February 2002, by Info-ZIP (Zip-Bugs@lists.wku.edu).
  inflating: jre-6u1-linux-i586.rpm  
error: Failed dependencies:
        /bin/basename is needed by jre-1.6.0_01-fcs.i586
        /bin/cat is needed by jre-1.6.0_01-fcs.i586
        /bin/cp is needed by jre-1.6.0_01-fcs.i586
        /bin/gawk is needed by jre-1.6.0_01-fcs.i586
        /bin/grep is needed by jre-1.6.0_01-fcs.i586
        /bin/ln is needed by jre-1.6.0_01-fcs.i586
        /bin/ls is needed by jre-1.6.0_01-fcs.i586
        /bin/mkdir is needed by jre-1.6.0_01-fcs.i586
        /bin/mv is needed by jre-1.6.0_01-fcs.i586
        /bin/pwd is needed by jre-1.6.0_01-fcs.i586
        /bin/rm is needed by jre-1.6.0_01-fcs.i586
        /bin/sed is needed by jre-1.6.0_01-fcs.i586
        /bin/sort is needed by jre-1.6.0_01-fcs.i586
        /bin/touch is needed by jre-1.6.0_01-fcs.i586
        /usr/bin/cut is needed by jre-1.6.0_01-fcs.i586
        /usr/bin/dirname is needed by jre-1.6.0_01-fcs.i586
        /usr/bin/expr is needed by jre-1.6.0_01-fcs.i586
        /usr/bin/find is needed by jre-1.6.0_01-fcs.i586
        /usr/bin/tail is needed by jre-1.6.0_01-fcs.i586
        /usr/bin/tr is needed by jre-1.6.0_01-fcs.i586
        /usr/bin/wc is needed by jre-1.6.0_01-fcs.i586
        /bin/sh is needed by jre-1.6.0_01-fcs.i586

Wat doe ik fout?

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

Offline siegi

  • Lid
  • Steunpunt: Nee
Limewire mist java pakketten
« Reactie #1 Gepost op: 2007/06/26, 13:13:45 »
Je moet java niet handmatig installeren dat zit mooi in de ubuntu repo's.
https://wiki.ubuntu.com/NlJavaHowto
Zorg dat de laatste versie van java geselecteerd word met het commando
sudo update-alternatives --config java

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Limewire mist java pakketten
« Reactie #2 Gepost op: 2007/06/26, 13:17:59 »
Nog eenvoudiger: zie de laatste regel van mijn handtekening:

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Limewire mist java pakketten
« Reactie #3 Gepost op: 2007/06/26, 13:45:31 »
@siegi het commando sudo update-alternatives --config java werkte:
root@gijs-desktop:/home/gijs# sudo update-alternatives --config java

Er zijn 3 alternatieven die 'java' voorzien.

  Selectie    Alternatieven
-----------------------------------------------
          1    /usr/bin/gij-wrapper-4.1
*+        2    /usr/lib/jvm/java-gcj/jre/bin/java
          3    /usr/lib/jvm/java-6-sun/jre/bin/java

druk enter om de standaardwaarde
  • te behouden, of  geef het selectienumber in:

root@gijs-desktop:/home/gijs# sudo update-alternatives --config java

Er zijn 3 alternatieven die 'java' voorzien.

  Selectie    Alternatieven
-----------------------------------------------
          1    /usr/bin/gij-wrapper-4.1
*+        2    /usr/lib/jvm/java-gcj/jre/bin/java
          3    /usr/lib/jvm/java-6-sun/jre/bin/java

druk enter om de standaardwaarde
  • te behouden, of  geef het selectienumber in: 3

'/usr/lib/jvm/java-6-sun/jre/bin/java' wordt gebruikt om in 'java' te voorzien.
Bedankt voor je antwoord.
@pjotr, het zal wel aan mij liggen maar ik begreep niet helemaal de verwijzing naar de multimedia applicaties.

Nu draait limwire tot het moment dat je de knop beëindigen in moet drukken en zie ik alleen nog maar een grijs vlak.
Is daar nog iets aan te doen of kan ik beter wat anders installeren?

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Limewire mist java pakketten
« Reactie #4 Gepost op: 2007/06/26, 13:47:20 »
Citaat van: Gijsbert
@pjotr, het zal wel aan mij liggen maar ik begreep niet helemaal de verwijzing naar de multimedia applicaties.
Als onderdeel van het hele pakket, installeer je gelijk Sun Java mee.

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Limewire mist java pakketten
« Reactie #5 Gepost op: 2007/06/26, 14:16:48 »
Oke pjotr123 nu snap ik het, bedankt voor je antwoord.

Met vriendelijke groet,

Gijs
In der Beschränkung zeigt sich der Meister.