Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: ati video driver / xorg.conf  (gelezen 7531 keer)

Offline Steven Klein Haneveld

  • Lid
  • Steunpunt: Nee
ati video driver / xorg.conf
« Gepost op: 2007/06/23, 16:53:06 »
Mensen,

Ik heb een probleempje.
In dit artikel
https://help.ubuntu.com/community/RadeonDriver
staat e.e.a. over de radeon driver - mijn kaart wordt wel ondersteund (x600).

Heb netjes de gesloten driver verwijderd.
Nu wil ik deze open driver installeren.
Het artikel wil dan, dat ik xorg.conf ga aanpassen.

Goed. Ik heb in de terminal sudo gedit /etc/x11/xorg.conf gedaan.
Maar nu blijkt dat bestand geheel leeg te zijn!

De reden dat ik probeer een driver te installeren, is dat mijn schermresolutie niet hoog genoeg kan. Ik wordt nu toch wel moe van die grote letters en pictogrammen en van het sidescrollen in firefox e.d.

Kan iemand helpen? Alvast dank! Wil per se Ubuntu draaien - vet leuk!

Groeten,

sisosteven

Offline Steven Klein Haneveld

  • Lid
  • Steunpunt: Nee
ati video driver / xorg.conf
« Reactie #1 Gepost op: 2007/06/23, 19:31:39 »
Ubunteri,

Het is niet te geloven, maar ik ben alweer zelf een stap verder gekomen. Via bepaalde comando┼Ť in Terminal heb ik ontdekt, dat die open source driver al wel is ge├»nstalleerd en ook in gebruik.
Grootste probleem opgelost!

Blijf ik nog vaag vinden, dat die xorg.conf blanco is.....

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
ati video driver / xorg.conf
« Reactie #2 Gepost op: 2007/06/23, 19:48:26 »
Je hebt een tikfout gemaakt.... Het is een hoofdletter X. Vandaar het lege bestand.
Het moet dus zijn: sudo gedit /etc/X11/xorg.conf

Groet, Pjotr.

Offline Steven Klein Haneveld

  • Lid
  • Steunpunt: Nee
ati video driver / xorg.conf
« Reactie #3 Gepost op: 2007/06/23, 20:16:46 »
Helaas,
dat is het niet. Ik typ het met grote X, maar nog steeds krijg ik een leeg bestand.
Wat kan het nog meer zijn?

Groet,

Steven

Offline Steven Klein Haneveld

  • Lid
  • Steunpunt: Nee
ati video driver / xorg.conf
« Reactie #4 Gepost op: 2007/06/23, 20:19:08 »
Ow, wacht even.
Ik vergeet volgens mij een slash.....
Moment.....

HOERA!

Pjotr, bedankt!

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
ati video driver / xorg.conf
« Reactie #5 Gepost op: 2007/06/23, 21:05:45 »
PS: als je echt goed werkende 3D acceleratie wilt zal de open source driver momenteel niet de beste keuze zijn, want die is nog niet goed geoptimaliseerd voor de generatie waar de X600 toe behoort (r300) .. het is aan het verbeteren maar als je echt goed werkende (snelle) 3D acceleratie nodig hebt is het misschien beter om voorlopig de fglrx (gesloten fabrieks)driver te gebruiken.. die is in het geval van de X600 zeker driemaal sneller.

let wel op dat je dat dan niet via de site van amd of ati moet doen, maar wel door middel van de fglrx driver te installeren via het pakketbeheer van Ubuntu. Hoewel de restricted manager van Feisty dat allemaal al (volautomatisch) voor je kan doen. Hier meer info: https://help.ubuntu.com/community/BinaryDriverHowto/ATI
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline Steven Klein Haneveld

  • Lid
  • Steunpunt: Nee
ati video driver / xorg.conf
« Reactie #6 Gepost op: 2007/06/23, 22:20:05 »
Dank, profoX! Dat is een goede tip!
Die Howto heb ik gevonden en gebookmarkt. Dat kan niet fout gaan met zo'n document.
Ik ga dat proberen. Maar moet ik dan eerst handmatig de OpenDriver verwijderen? Of gebeurt dat automisch?

Overigens: het ging mij voornamelijk om een hogere beeldschermresolutie..... Dit te wijzigen in xorg.conf haalt niks uit. Of ligt dat aan de driver?

Later,
Steven

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
ati video driver / xorg.conf
« Reactie #7 Gepost op: 2007/06/23, 22:59:24 »
Je hoeft niks te verwijderen. Doordat je een andere driver installeert en selecteert, wordt de oude driver vanzelf gedeselecteerd (is dat een woord?). Die oude driver zit in de Linuxkernel en kan daar rustig op zijn achterwerk blijven zitten.

Resolutie: installeer eerst eens de fabrieksdriver, zoals profoX zegt. Kijk dan eens welke resoluties je kunt instellen.

Offline Steven Klein Haneveld

  • Lid
  • Steunpunt: Nee
ati video driver / xorg.conf
« Reactie #8 Gepost op: 2007/06/23, 23:16:33 »
Super, bedankt!
Ga direct aan de slag.

Offline Steven Klein Haneveld

  • Lid
  • Steunpunt: Nee
ati video driver / xorg.conf
« Reactie #9 Gepost op: 2007/06/23, 23:32:47 »
Goed, tis gedaan.
Na herstart zie ik inderdaad meer resoluties!
Helaas echter niet hoger dan 1024x768
Ik weet zeker dat ik onder Windows een hogere resolutie had..... waarmee ik alleen maar wil zeggen dat mijn hardware het moet aankunnen.
Moet ik nu iets doen met xorg.conf?

groeten,

sisosteven

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
ati video driver / xorg.conf
« Reactie #10 Gepost op: 2007/06/23, 23:47:51 »
Dan kun je je xorg.conf even handmatig bewerken. Post hier eens deze vier zaken:
1. de resolutie die je in Windows had en nu ook wil;
2. het soort scherm wat je hebt (CRT of LCD/TFT);
3. de frequentie die je in Windows had en nu ook wil;
4. de inhoud van het tekstbestand xorg.conf. In terminal: gedit /etc/X11/xorg.conf

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
ati video driver / xorg.conf
« Reactie #11 Gepost op: 2007/06/24, 00:12:53 »
ik wil ook nog ff een hart onder de riem steken: bij de volgende ubuntu release zou dit mogelijk veel eenvoudiger kunnen worden (resoluties enzo) -- zonder xorg.conf ge-edit dus :)
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline Steven Klein Haneveld

  • Lid
  • Steunpunt: Nee
ati video driver / xorg.conf
« Reactie #12 Gepost op: 2007/06/24, 14:19:54 »
Dank voor het hart onder mijn riem :) Maar ik ben nog lang niet wanhopig hoor, ik vind het alleen maar leuk, dit soort gedoe!
Goed, daar gaatie dan!
1. Ik had in Windows 1280x1024 aan staan. Dat is dus ook wat ik nu wil proberen.
2. Ik heb een TFT scherm
3. Frequenty hoort 60 Hz te zijn, en dat staat ook goed ingesteld.
4. De inhoud van xorg.conf volgt hier:

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
   Fontpath   "/usr/share/fonts/X11/misc"
   Fontpath   "/usr/share/fonts/X11/cyrillic"
   Fontpath   "/usr/share/fonts/X11/100dpi/:unscaled"
   Fontpath   "/usr/share/fonts/X11/75dpi/:unscaled"
   Fontpath   "/usr/share/fonts/X11/Type1"
   Fontpath   "/usr/share/fonts/X11/100dpi"
   Fontpath   "/usr/share/fonts/X11/75dpi"
   # path to defoma fonts
   Fontpath   "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
   Load      "i2c"
   Load      "bitmap"
   Load      "ddc"
   Load      "dri"
   Load      "extmod"
   Load      "freetype"
   Load      "glx"
   Load      "int10"
   Load      "vbe"
EndSection

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "CoreKeyboard"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc105"
   Option      "XkbLayout"   "us"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
   Option      "CorePointer"
   Option      "Device"   "/dev/input/mice"
   Option      "Protocol"   "ImPS/2"
   Option      "ZAxisMapping"   "4 5"
   Option      "Emulate3Buttons"   "true"
EndSection

Section "InputDevice"
   Driver      "wacom"
   Identifier   "stylus"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"   "stylus"
   Option      "ForceDevice"   "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
   Driver      "wacom"
   Identifier   "eraser"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"   "eraser"
   Option      "ForceDevice"   "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
   Driver      "wacom"
   Identifier   "cursor"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"   "cursor"
   Option      "ForceDevice"   "ISDV4"# Tablet PC ONLY
EndSection

Section "Device"
   Identifier   "Generieke videokaart"
   Driver      "fglrx"
   Busid      "PCI:4:0:0"
EndSection

Section "Monitor"
   Identifier   "Generieke beeldscherm"
   Option      "DPMS"
   Horizsync   28-51
   Vertrefresh   43-60
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Device      "Generieke videokaart"
   Monitor      "Generieke beeldscherm"
   Defaultdepth   24
   SubSection "Display"
      Depth   1
      Modes      "1024x768"   "800x600"   "640x480"
   EndSubSection
   SubSection "Display"
      Depth   4
      Modes      "1024x768"   "800x600"   "640x480"
   EndSubSection
   SubSection "Display"
      Depth   8
      Modes      "1024x768"   "800x600"   "640x480"
   EndSubSection
   SubSection "Display"
      Depth   15
      Modes      "1024x768"   "800x600"   "640x480"
   EndSubSection
   SubSection "Display"
      Depth   16
      Modes      "1024x768"   "800x600"   "640x480"
   EndSubSection
   SubSection "Display"
      Depth   24
      Modes      "1024x768"   "800x600"   "640x480"
   EndSubSection
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
  screen "Default Screen"
   Inputdevice   "Generic Keyboard"
   Inputdevice   "Configured Mouse"
   Inputdevice   "stylus"   "SendCoreEvents"
   Inputdevice   "cursor"   "SendCoreEvents"
   Inputdevice   "eraser"   "SendCoreEvents"
EndSection

Section "DRI"
   Mode   0666
EndSection
Section "Extensions"
   Option      "Composite"   "0"
EndSection

Kun je hier wat mee?

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
ati video driver / xorg.conf
« Reactie #13 Gepost op: 2007/06/24, 14:25:40 »
Mooi! Waarschijnlijk is het enige wat je hoeft te doen, het handmatig toevoegen van 1280x1024 aan de resolutielijst in de Section "Screen". Bij alle kleurendieptes.
Als volgt (voorbeeldje bij kleurendiepte 1):
SubSection "Display"
        Depth    1
        Modes        "1280x1024"   "1024x768"    "800x600"    "640x480"

Opslaan, sluiten en herstarten. Probeer daarna 1280x1024 in te stellen via Systeem - Voorkeuren - Schermresolutie. Lukt dat?

Offline Steven Klein Haneveld

  • Lid
  • Steunpunt: Nee
ati video driver / xorg.conf
« Reactie #14 Gepost op: 2007/06/24, 16:09:28 »
Ik ga dat nu proberen.
Maar ik heb er alle vertrouwen in!

Laat het zodirect weten (ga nu dus even offline, om straks te herstarten)

Offline Kiwinote

  • Lid
    • Launchpad
  • Steunpunt: Nee
ati video driver / xorg.conf
« Reactie #15 Gepost op: 2007/06/24, 16:11:06 »
je hoeft alleen maar x te herstarten, dus ctrl + alt + backspace .

Offline Steven Klein Haneveld

  • Lid
  • Steunpunt: Nee
ati video driver / xorg.conf
« Reactie #16 Gepost op: 2007/06/24, 16:30:03 »
Humhum, had ik dat maar iets eerder gelezen.....

Het spijt me donders, maar ik heb een foutje gemaakt.....

Ik heb vergeten in systeem/voorkeuren/beeldschermresolutie de resolutie aan te passen. Na aanpassing in xorg.conf heb ik alles afgesloten en de pc herstart.

Maar het probleem is: ik kom die pc niet meer in! Dus ik draai nu vanaf de LiveCD, maar dat is natuurlijk maar een tijdelijke oplossing.....

Ik kreeg een foutmelding van de monitor. Kon ik niets uit opmaken.

De livecd heb ik vervolgens gestart op 1280x1024(x16). Dit ziet er goed uit! Het kan dus zeker wel, alleen heb ik iets niet goed gedaan.....

Help! :S

Offline Kiwinote

  • Lid
    • Launchpad
  • Steunpunt: Nee
ati video driver / xorg.conf
« Reactie #17 Gepost op: 2007/06/24, 16:35:11 »
Je kan gewoon normaal opstraten en dan met ctrl + alt + F2 in een command line komen. Daar met "sudo nano /etc/X11/xorg.conf" je bestand bijwerken en dan met ctrl + alt + F7 terug naar grafische. Nu ctrl + alt + backspace om x te herstarten.

Offline Steven Klein Haneveld

  • Lid
  • Steunpunt: Nee
ati video driver / xorg.conf
« Reactie #18 Gepost op: 2007/06/24, 16:51:44 »
Kiwinote - je bent je gewicht in goud waard!
Ga het direct uitproberen!

Offline Steven Klein Haneveld

  • Lid
  • Steunpunt: Nee
ati video driver / xorg.conf
« Reactie #19 Gepost op: 2007/06/24, 17:13:46 »
Kiwinote:
Bedankt, ik zit weer in het systeem.....
Tjonge, zo leer ik nog eens wat.....

Maar het uiteindelijke doel gaat zo dus niet lukken..... namelijk mijn beeldschermresolutie naar 1280x1024 zetten. Ik moest het nu namelijk weer terugzetten.
Of is er nog een andere manier?

Hier nog de foutmelding:

Signal frequency is out of range
H: 50.8 KHz       V:47.4 Hz
Please change signal timing

Dit kreeg ik dus te zien met 1280x1024. Betekent dat ik nu die resolutie gewoon moet vergeten? Ik ben niet iemand die gauw opgeeft, en eigenlijk gewoon wil bereiken wat ik wil hebben..... :)

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
ati video driver / xorg.conf
« Reactie #20 Gepost op: 2007/06/24, 17:18:29 »
Geen probleem, we komen er wel! Je moet nu bepaalde gegevens te weten komen van je monitor, namelijk de HorizSync en de VertRefresh waarden.

Doe eens dit:
Systeem - Beheer - Synaptic pakketbeheer
zoekterm: xresprobe
progje aanvinken en druk op knop Toepassen

Nu in terminal:
sudo ddcprobe

Nu krijg je een lap gegevens. Post die hier eens?

Offline Kiwinote

  • Lid
    • Launchpad
  • Steunpunt: Nee
ati video driver / xorg.conf
« Reactie #21 Gepost op: 2007/06/24, 17:20:59 »
Als je niet snel opgeeft kan je met "sudo dpkg-reconfigure xserver-xorg" de gewenste resolutie instellen (ongewenste resoluties allemaal uitvinken), de rest als standaard laten, behalve bij onderdeel monitor voor advanced kiezen en daar de juiste hz en vt waardes invullen (staan in je monitor handleiding). Dan x herstarten. Mocht het misgaan dan weer herstellen zoals net.

edit: pjotr was me voor..

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
ati video driver / xorg.conf
« Reactie #22 Gepost op: 2007/06/24, 17:21:56 »
@Kiwinote: laten we eerst even mijn methode proberen....  :-)

Offline Steven Klein Haneveld

  • Lid
  • Steunpunt: Nee
ati video driver / xorg.conf
« Reactie #23 Gepost op: 2007/06/24, 17:22:20 »
Hier is het:

vbe: VESA 2.0 detected.
oem: ATI RV370
memory: 16384kb
mode: 800x600x16
mode: 1024x768x16
mode: 320x200x32k
mode: 320x200x64k
mode: 320x200x16m
mode: 1600x1200x256
mode: 640x400x256
mode: 640x480x256
mode: 640x480x32k
mode: 640x480x64k
mode: 640x480x16m
mode: 1600x1200x32k
mode: 800x600x256
mode: 800x600x32k
mode: 800x600x64k
mode: 800x600x16m
mode: 1600x1200x64k
mode: 1024x768x256
mode: 1024x768x32k
mode: 1024x768x64k
mode: 1024x768x16m
mode: 1280x1024x256
mode: 1280x1024x32k
mode: 1280x1024x64k
mode: 1280x1024x16m
mode: 132x25 (text)
mode: 132x43 (text)
edid:
edid: 1 3
id: 46d6
eisa: IVM46d6
serial: 000013aa
manufacture: 11 2005
input: separate sync, composite sync, sync on green, analog signal.
screensize: 34 27
gamma: 2.200000
dpms: RGB, active off, no suspend, no standby
timing: 720x400@70 Hz (VGA 640x400, IBM)
timing: 720x400@88 Hz (XGA2)
timing: 640x480@60 Hz (VGA)
timing: 640x480@67 Hz (Mac II, Apple)
timing: 640x480@72 Hz (VESA)
timing: 640x480@75 Hz (VESA)
timing: 800x600@60 Hz (VESA)
timing: 800x600@72 Hz (VESA)
timing: 800x600@75 Hz (VESA)
timing: 832x624@75 Hz (Mac II)
timing: 1024x768@87 Hz Interlaced (8514A)
timing: 1024x768@70 Hz (VESA)
timing: 1024x768@75 Hz (VESA)
timing: 1280x1024@75 (VESA)
ctiming: 1280x1024@60
ctiming: 1152x864@75
dtiming: 1280x1024@88
monitorserial: 05492S530503
monitorrange: 24-83, 55-75
monitorname: PLE430/431

Hoe lijkt het?

edit:

moet nu even eten..... Ik lees strak jullie antwoord wel.
Alvast bedankt!

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
ati video driver / xorg.conf
« Reactie #24 Gepost op: 2007/06/24, 17:27:00 »
Heel goed! Het gaat om de monitorrange, helemaal op het einde.

De HorizSync is 24-83 en de VertRefresh is 55-75.

Doe eens dit:
sudo gedit /etc/X11/xorg.conf

Section "Monitor" als volgt wijzigen:

Section "Monitor"
   Identifier   "PLE430/431"
   Option      "DPMS"
   HorizSync   24-83
   VertRefresh    55-75
EndSection

Opslaan, sluiten, herstarten. Nu opnieuw de juiste resolutie proberen in  te stellen.

Helpt dit?