Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Toetsenbord Probleem  (gelezen 616 keer)

jdep

  • Gast
Toetsenbord Probleem
« Gepost op: 2007/06/19, 20:10:21 »
Hallo,

Ik heb een probleem met mijn toetsen bord als ik iets wil veranderen aan mijn toetsenbord instellingen(want die kloppen niet De leestekens en dergelijken zitten op de verkeerde plek) Dan krijg ik deze fout melden

Er is een fout opgetreden bij het activeren van de XKB-Configuratie.
Dit kan onder verschillende opstandigheden voorkomen
- een fout in de libxklavier-bibliotheek
-fout in de X-server (xkbcomp, xmodmaphulpprogramma's)
-X server met incompatibale libxkbfile-implementatie

X-server Versiegegeven:
The X.Org Foundation
70200000

Indien u deze situatie als fout rapporteert. voegt ud an alstublieftoe:
-Het Resultaat van xprop -root | grep XKB
- Het Resultat van gconftool-2 -R (slash)desktop(slash)gnome(slash)peripherals(slash)keyboard(slash)kbd

In de plaats van (slash) moet natuurlijk het slash teken maar kan hem niet vinden.

Wie kan mij helpen?

Offline kennywest

  • Lid
    • http://kennywest.blogspot.com
  • Steunpunt: Nee
Toetsenbord Probleem
« Reactie #1 Gepost op: 2007/06/19, 20:30:11 »
- Hoe probeer je het toetsenbord aan te passen
- Gebruik je gnome of xfce (xubuntu)
- Post eens de inhoud van /etc/X11/corg.conf bestand

jdep

  • Gast
Toetsenbord Probleem
« Reactie #2 Gepost op: 2007/06/21, 11:08:59 »
systeem-voorkeur-toetsenbord zo probeer ik hem aan te passen.
Gebruik Gnome



# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
   Identifier     "Default Layout"
   Screen      0  "aticonfig-Screen[0]" 0 0
   InputDevice    "Generic Keyboard"
   InputDevice    "Configured Mouse"
   InputDevice    "stylus" "SendCoreEvents"
   InputDevice    "cursor" "SendCoreEvents"
   InputDevice    "eraser" "SendCoreEvents"
   InputDevice    "Synaptics Touchpad"
EndSection

Section "Files"

   # path to defoma fonts
   FontPath     "/usr/share/fonts/X11/misc"
   FontPath     "/usr/share/fonts/X11/cyrillic"
   FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
   FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
   FontPath     "/usr/share/fonts/X11/Type1"
   FontPath     "/usr/share/fonts/X11/100dpi"
   FontPath     "/usr/share/fonts/X11/75dpi"
   FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
   Load  "i2c"
   Load  "bitmap"
   Load  "ddc"
   Load  "dri"
   Load  "extmod"
   Load  "freetype"
   Load  "glx"
   Load  "int10"
   Load  "vbe"
EndSection

Section "ServerFlags"
   Option       "AIGLX" "off"
EndSection


Section "InputDevice"
    Identifier    "Generic Keyboard"
    Driver        "kbd"
    Option        "CoreKeyboard"
    Option        "XkbRules"    "xorg"
    Option        "XkbModel"    "pc105"
    Option        "XkbLayout"    "us"
    Option        "XkbOptions"    "lv3:ralt_switch"
    Option        "XkbVariant"    "us_intl"
EndSection

Section "InputDevice"
   Identifier  "Configured Mouse"
   Driver      "mouse"
   Option       "CorePointer"
   Option       "Device" "/dev/input/mice"
   Option       "Protocol" "ImPS/2"
   Option       "ZAxisMapping" "4 5"
   Option       "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
   Identifier  "Synaptics Touchpad"
   Driver      "synaptics"
   Option       "SendCoreEvents" "true"
   Option       "Device" "/dev/psaux"
   Option       "Protocol" "auto-dev"
   Option       "HorizScrollDelta" "0"
EndSection

Section "InputDevice"
   Identifier  "stylus"
   Driver      "wacom"
   Option       "Device" "/dev/input/wacom"
   Option       "Type" "stylus"
   Option       "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
   Identifier  "eraser"
   Driver      "wacom"
   Option       "Device" "/dev/input/wacom"
   Option       "Type" "eraser"
   Option       "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
   Identifier  "cursor"
   Driver      "wacom"
   Option       "Device" "/dev/input/wacom"
   Option       "Type" "cursor"
   Option       "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "Monitor"
   Identifier   "Generic Monitor"
   Option       "DPMS"
EndSection

Section "Monitor"
   Identifier   "aticonfig-Monitor[0]"
   Option       "VendorName" "ATI Proprietary Driver"
   Option       "ModelName" "Generic Autodetecting Monitor"
   Option       "DPMS" "true"
EndSection

Section "Device"
   Identifier  "Generic Video Card"
   Driver      "fglrx"
   Option       "VideoOverlay" "on"
   Option       "OpenGLOverlay" "off"
   BusID       "PCI:1:0:0"
EndSection

Section "Device"
   Identifier  "aticonfig-Device[0]"
   Driver      "fglrx"
   Option       "VideoOverlay" "on"
   Option       "OpenGLOverlay" "off"
EndSection

Section "Screen"
   Identifier "Default Screen"
   Device     "Generic Video Card"
   Monitor    "Generic Monitor"
   DefaultDepth     24
   SubSection "Display"
      Depth     1
      Modes    "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth     4
      Modes    "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth     8
      Modes    "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth     15
      Modes    "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth     16
      Modes    "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth     24
      Modes    "1024x768" "800x600" "640x480"
   EndSubSection
EndSection

Section "Screen"
   Identifier "aticonfig-Screen[0]"
   Device     "aticonfig-Device[0]"
   Monitor    "aticonfig-Monitor[0]"
   DefaultDepth     24
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection

Section "DRI"
   Mode         0666
EndSection

Section "Extensions"
        Option          "Composite"     "0"
EndSection

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Toetsenbord Probleem
« Reactie #3 Gepost op: 2007/06/21, 11:16:01 »
Doe eens dit:
sudo gedit /etc/X11/xorg.conf

En pas de toetsenborddefinitie als volgt aan (in Section Input Device, identifier Generic Keyboard)

Section "InputDevice"
    Identifier    "Generic Keyboard"
    Driver        "kbd"
    Option        "CoreKeyboard"
    Option        "XkbRules"    "xorg"
    Option        "XkbModel"    "pc105"
    Option        "XkbLayout"    "us"
    Option        "XkbVariant"   "intl"
EndSection
Opslaan, sluiten, herstarten.
Helpt dit?

Groet, Pjotr.