Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Problemen met afspelen geluid  (gelezen 2677 keer)

Offline ejfrolich

  • Lid
  • Steunpunt: Nee
Problemen met afspelen geluid
« Gepost op: 2007/06/18, 21:43:01 »
Ik heb 7.02 draaien en heb een wat vreemd probleem. De ene keer werkt het geluid naar wens de andere keer niet. Meestal merk ik al bij opstarten dat er een probleem is, ik krijg dan geen tromgeroffel bij het aanmeldscherm. Als ik naar "Systeem / voorkeuren / geluid ga dan werken alle mogelijkheden normaal. Als ik het tromgeroffel niet hoor bij opstarten is Ubuntu niet in staat om .avi bestanden te laten horen maar wel .wmv bestanden??

Ik weet niet zo goed hoe een en ander werkt in Ubuntu dus hoop dat iemand mij kan helpen dit probleem op te lossen. Het is wat vervelend om steeds maar weer op te starten tot het gaat werken...

Offline happyhamster

  • Lid
  • Steunpunt: Nee
Problemen met afspelen geluid
« Reactie #1 Gepost op: 2007/06/19, 01:55:40 »
Kan je de volgende commando's in een terminal (Applications-Accessories-Terminal) intypen (of via copy & paste), en de uitvoer hier tonen?

uname -r

aplay -l

lspci -v

cat /proc/asound/cards


Ze geven alle 4 specifieke info over je systeem.

[edit: oh, en kan je erbij vermelden of het geluid werkte (of niet) toen je deze commando's hebt uitgevoerd.]

Offline ejfrolich

  • Lid
  • Steunpunt: Nee
Problemen met afspelen geluid
« Reactie #2 Gepost op: 2007/06/19, 21:26:37 »
Nou hier zijn alle antwoorden op je vragen, knap dat je dan begrijpt wat er staat! Ik ben nog niet zover...

oh ene er is wel geluid op de meeste plekken. Het rare blijft dat ik d Ubuntu tune na het inloggen niet meer heb gehoord sinds na de eerste keer 7.02

uname -r
2.6.20-16-generic

 aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: CMI8738MC6 [C-Media PCI CMI8738-MC6], device 0: CMI8738-MC6 [C-Media PCI DAC/ADC]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: CMI8738MC6 [C-Media PCI CMI8738-MC6], device 1: CMI8738-MC6 [C-Media PCI 2nd DAC]

lspci -v
00:00.0 RAM memory: nVidia Corporation MCP55 Memory Controller (rev a1)
        Subsystem: ASUSTeK Computer Inc. Unknown device 8239
        Flags: bus master, 66MHz, fast devsel, latency 0
        Capabilities:

00:01.0 ISA bridge: nVidia Corporation MCP55 LPC Bridge (rev a2)
        Subsystem: ASUSTeK Computer Inc. Unknown device 8239
        Flags: bus master, 66MHz, fast devsel, latency 0

00:01.1 SMBus: nVidia Corporation MCP55 SMBus (rev a2)
        Subsystem: ASUSTeK Computer Inc. Unknown device 8239
        Flags: 66MHz, fast devsel, IRQ 11
        I/O ports at fc00 [size=64]
        I/O ports at 1c00 [size=64]
        I/O ports at 1c40 [size=64]
        Capabilities:

00:01.2 RAM memory: nVidia Corporation MCP55 Memory Controller (rev a2)
        Subsystem: ASUSTeK Computer Inc. Unknown device 8239
        Flags: 66MHz, fast devsel

00:02.0 USB Controller: nVidia Corporation MCP55 USB Controller (rev a1) (prog-if 10 [OHCI])
        Subsystem: ASUSTeK Computer Inc. Unknown device 8239
        Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 16
        Memory at fe02f000 (32-bit, non-prefetchable) [size=4K]
        Capabilities:

00:02.1 USB Controller: nVidia Corporation MCP55 USB Controller (rev a2) (prog-if 20 [EHCI])
        Subsystem: ASUSTeK Computer Inc. Unknown device 8239
        Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 17
        Memory at fe02e000 (32-bit, non-prefetchable) [size=256]
        Capabilities:

00:04.0 IDE interface: nVidia Corporation MCP55 IDE (rev a1) (prog-if 8a [Master SecP PriP])
        Subsystem: ASUSTeK Computer Inc. Unknown device 8239
        Flags: bus master, 66MHz, fast devsel, latency 0
        [virtual] Memory at 000001f0 (32-bit, non-prefetchable) [disabled] [size=8]
        [virtual] Memory at 000003f0 (type 3, non-prefetchable) [disabled]
        [virtual] Memory at 00000170 (32-bit, non-prefetchable) [disabled] [size=8]
        [virtual] Memory at 00000370 (type 3, non-prefetchable) [disabled]
        I/O ports at f000 [size=16]
        Capabilities:

00:05.0 IDE interface: nVidia Corporation MCP55 SATA Controller (rev a2) (prog-if 85 [Master SecO PriO])
        Subsystem: ASUSTeK Computer Inc. Unknown device 8239
        Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 18
        I/O ports at 09f0 [size=8]
        I/O ports at 0bf0
        I/O ports at 0970 [size=8]
        I/O ports at 0b70
        I/O ports at dc00 [size=16]
        Memory at fe02d000 (32-bit, non-prefetchable) [size=4K]
        Capabilities:

00:05.1 IDE interface: nVidia Corporation MCP55 SATA Controller (rev a2) (prog-if 85 [Master SecO PriO])
        Subsystem: ASUSTeK Computer Inc. Unknown device 8239
        Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 19
        I/O ports at 09e0 [size=8]
        I/O ports at 0be0
        I/O ports at 0960 [size=8]
        I/O ports at 0b60
        I/O ports at c800 [size=16]
        Memory at fe02c000 (32-bit, non-prefetchable) [size=4K]
        Capabilities:

00:05.2 IDE interface: nVidia Corporation MCP55 SATA Controller (rev a2) (prog-if 85 [Master SecO PriO])
        Subsystem: ASUSTeK Computer Inc. Unknown device 8239
        Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 16
        I/O ports at c400 [size=8]
        I/O ports at c000
        I/O ports at bc00 [size=8]
        I/O ports at b800
        I/O ports at b400 [size=16]
        Memory at fe02b000 (32-bit, non-prefetchable) [size=4K]
        Capabilities:

00:06.0 PCI bridge: nVidia Corporation MCP55 PCI bridge (rev a2) (prog-if 01 [Subtractive decode])
        Flags: bus master, 66MHz, fast devsel, latency 0
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=32
        I/O behind bridge: 0000a000-0000afff
        Memory behind bridge: fde00000-fdefffff
        Capabilities:

00:06.1 Audio device: nVidia Corporation MCP55 High Definition Audio (rev a2)
        Subsystem: ASUSTeK Computer Inc. Unknown device 81f6
        Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 18
        Memory at fe024000 (32-bit, non-prefetchable) [size=16K]
        Capabilities:

00:08.0 Bridge: nVidia Corporation MCP55 Ethernet (rev a2)
        Subsystem: ASUSTeK Computer Inc. Unknown device 8239
        Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 17
        Memory at fe02a000 (32-bit, non-prefetchable) [size=4K]
        I/O ports at b000 [size=8]
        Memory at fe029000 (32-bit, non-prefetchable) [size=256]
        Memory at fe028000 (32-bit, non-prefetchable) [size=16]
        Capabilities:

00:0a.0 PCI bridge: nVidia Corporation MCP55 PCI Express bridge (rev a2) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0
        Bus: primary=00, secondary=02, subordinate=02, sec-latency=0
        Capabilities:

00:0b.0 PCI bridge: nVidia Corporation MCP55 PCI Express bridge (rev a2) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0
        Bus: primary=00, secondary=03, subordinate=03, sec-latency=0
        Capabilities:

00:0c.0 PCI bridge: nVidia Corporation MCP55 PCI Express bridge (rev a2) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0
        Bus: primary=00, secondary=04, subordinate=04, sec-latency=0
        Capabilities:

00:0d.0 PCI bridge: nVidia Corporation MCP55 PCI Express bridge (rev a2) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0
        Bus: primary=00, secondary=05, subordinate=05, sec-latency=0
        Capabilities:

00:0e.0 PCI bridge: nVidia Corporation MCP55 PCI Express bridge (rev a2) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0
        Bus: primary=00, secondary=06, subordinate=06, sec-latency=0
        Capabilities:

00:0f.0 PCI bridge: nVidia Corporation MCP55 PCI Express bridge (rev a2) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0
        Bus: primary=00, secondary=07, subordinate=07, sec-latency=0
        Memory behind bridge: fa000000-fcffffff
        Prefetchable memory behind bridge: 00000000e0000000-00000000efffffff
        Capabilities:

00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
        Flags: fast devsel
        Capabilities:

00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
        Flags: fast devsel

00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
        Flags: fast devsel

00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
        Flags: fast devsel
        Capabilities:

01:06.0 Multimedia audio controller: C-Media Electronics Inc CM8738 (rev 10)
        Subsystem: C-Media Electronics Inc CMI8738/C3DX PCI Audio Device
        Flags: bus master, stepping, medium devsel, latency 32, IRQ 21
        I/O ports at ac00 [size=256]
        Capabilities:

01:07.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller (rev 80) (prog-if 10 [OHCI])
        Subsystem: VIA Technologies, Inc. IEEE 1394 Host Controller
        Flags: bus master, stepping, medium devsel, latency 32, IRQ 20
        Memory at fdeff000 (32-bit, non-prefetchable) [size=2K]
        I/O ports at a800 [size=128]
        Capabilities:

07:00.0 VGA compatible controller: nVidia Corporation GeForce 7300 LE (rev a1) (prog-if 00 [VGA])
        Subsystem: ASUSTeK Computer Inc. Unknown device 81f4
        Flags: bus master, fast devsel, latency 0, IRQ 21
        Memory at fa000000 (32-bit, non-prefetchable) [size=16M]
        Memory at e0000000 (64-bit, prefetchable) [size=256M]
        Memory at fb000000 (64-bit, non-prefetchable) [size=16M]
        [virtual] Expansion ROM at fcfe0000 [disabled] [size=128K]
        Capabilities:

  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: CMI8738MC6 [C-Media PCI CMI8738-MC6], device 2: CMI8738-MC6 [C-Media PCI IEC958]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 0: AD198x Analog [AD198x Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 1: AD198x Digital [AD198x Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Offline ejfrolich

  • Lid
  • Steunpunt: Nee
Problemen met afspelen geluid
« Reactie #3 Gepost op: 2007/06/19, 21:29:18 »
sorry, deze wilde je ook nog!

cat /proc/asound/cards
 0 [CMI8738MC6     ]: CMI8738-MC6 - C-Media PCI CMI8738-MC6
                      C-Media PCI CMI8738-MC6 (model 55) at 0xac00, irq 21
 1 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xfe024000 irq 18

Offline ejfrolich

  • Lid
  • Steunpunt: Nee
Problemen met afspelen geluid
« Reactie #4 Gepost op: 2007/06/19, 21:30:32 »
Wat misschien intressant is dat ik een extra PCI kaart heb geplaatst. De andere heb ik in de BIOS uitgezet, deze zit op het moederbord.

Offline happyhamster

  • Lid
  • Steunpunt: Nee
Problemen met afspelen geluid
« Reactie #5 Gepost op: 2007/06/20, 02:03:46 »
Ok, ziet er naar uit dat ubuntu de geluidskaart goed herkent (C-Media CMI8738). Wat aplay betreft, is onboard geluid (Nvidia MCP55) inderdaad uitgeschakeld. Maar in /proc/asound/cards wordt de laatste wel genoemd. Probeer het volgende:

1. In een terminal, copy & paste:

cat /proc/asound/modules

- Dit geeft de naam van de gevonden geluidskaart(en). Noteer de precieze naam van de CMI8738 module. Het is waarschijnlijk zoiets als snd-cmipci (het voorafgaande cijfer moet je weglaten, en in plaats van een _ moet je een - gebruiken). Als ik het commando bijvoorbeeld op mijn systeem uitvoer, dan krijg ik het volgende te zien:  0 snd_hda_intel   In mijn geval is de naam van de module dus    snd-hda-intel

- Vervolgens moet je aan het systeem doorgeven dat alleen die module gebruikt moet worden. Maar eerst een backup maken van het configuratiebestand. Copy & paste:

sudo cp /etc/modprobe.d/alsa-base /etc/modprobe.d/alsa-base.origineel

- en vervolgens:

gksudo gedit /etc/modprobe.d/alsa-base

- Voeg aan het eind van deze file de volgende regel toe*:

options naam-van-de-module index=0

- waarin naam-van-de-module  dus de door jou genoteerde naam is. Vervolgens: save en exit.

- reboot en duim dat alles goed werkt** :)



2. Werkt dat niet, dan is er meer info nodig:
 
- Was onboard geluid uitgeschakeld toen je ubuntu installeerde? (of heb je ubuntu geinstalleerd met onboard geluid ingeschakeld, en pas later de andere geluidskaart toegevoegd, etc?)
- Maak je gebruik van bijzondere USB apparatuur? (een speciaal multimedia toetsenbord o.i.d., usb-sticks, etc.)
- Kan je hier de uitvoer van de volgende commando's tonen:

cat /proc/asound/modules

cat /proc/asound/version

cat /etc/modprobe.d/alsa-base

lsmod | grep snd



* Als je op dit punt rare dingen tegenkomt (bijv. een regel die al op index=0 eindigt), of als je denkt dat er iets anders fout is, dan de editor gewoon afsluiten zonder iets te veranderen en doorgaan naar punt 2.

** als er problemen optreden, kan je het originele bestand altijd weer terugzetten met:
sudo cp /etc/modprobe.d/alsa-base.origineel /etc/modprobe.d/alsa-base

Offline ejfrolich

  • Lid
  • Steunpunt: Nee
Problemen met afspelen geluid
« Reactie #6 Gepost op: 2007/06/21, 20:22:12 »
Nou ik ga je even bedanken voor je hulp en het inzicht wat ik eraan heb overgehouden!

Je oplossing werkt consistent lijkt dus ik ben blij!

Ik moest overigens niet de pci module maar de andere blokkeren.

Offline ejfrolich

  • Lid
  • Steunpunt: Nee
Problemen met afspelen geluid
« Reactie #7 Gepost op: 2007/06/21, 23:19:24 »
...Helaas...

Het werkt toch niet. Helaas... Ik zal morgen je vragen nog even invullen.

Offline ejfrolich

  • Lid
  • Steunpunt: Nee
Problemen met afspelen geluid
« Reactie #8 Gepost op: 2007/06/22, 07:33:17 »
Ik zie iets heel apparts...

Als ik in alsa-bash aan het eind het commando " options snd-cmipci index=0" zet dan laat hij daarna bij een cat alleen de snd_hda_intel kaart zien. Als ik er "options snd_hda_intel index=0" voor in de plaats zet laat hij bij een cat beide kaarten zien...?

Wat moet er gebeuren bij het commando options....index=0?

Offline ejfrolich

  • Lid
  • Steunpunt: Nee
Problemen met afspelen geluid
« Reactie #9 Gepost op: 2007/06/22, 08:34:22 »
Nou daar ben ik weer met een uitdraai van de gevraagde gegevens. Ik hoop dat er wat mee kunt? Zoals je kunt zien heb ik de extra regel in alsa-base verwijderd. Het effect is niet wat we hoopten...

Extra info:
als ik het goed weet dan was de kaart er voor dat ik Linux installerde.

Aan de USB poorten hangt een web cam en een printer. Ook heb ik incidenteel een PDA aan hangen. Van beiden heb ik niet het idee dat het iets uithaalt.

Wat ik wel weet is dat alles goed is geweest. Op een gegeven moment was ik het opstart deuntje kwijt en was het elke keer een verassing of ik wel of niet tromgeroffel bij het inlogscherm hoor. Vertder heb ik dus altijd geluid bij WMV bestanden, AVI bestanden laten alleen geluit horen als er ook tromgeroffel heeft geklonken. Nu is mijn Ubuntu dus een beetje als een windows machine...als je geluk hebt werkt het.

Ene fijn dat je wilt meedenken!

cat /proc/asound/modules
 0 snd_cmipci
 1 snd_hda_intel

 cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.14rc1 (Tue Jan 09 09:56:17 2007 UTC).

 cat /etc/modprobe.d/alsa-base
# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-ioctl32 ; : ; }
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --Qb snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-seq-midi ; /sbin/modprobe --quiet snd-seq-oss ; : ; }

# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe -Qb saa7134-alsa ; : ; }

# Load snd-seq for devices that don't have hardware midi;
#   Ubuntu #26283, #43682, #56005; works around Ubuntu #34831 for
#   non-Creative Labs PCI hardware
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-seq ; }
# Prevent abnormal drivers from grabbing index 0
options snd-bt87x index=-2
options cx88-alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388

 lsmod |grep snd
snd_hda_intel          21912  0
snd_hda_codec         205056  1 snd_hda_intel
snd_cmipci             37024  1
snd_pcm_oss            44544  0
snd_mixer_oss          17408  1 snd_pcm_oss
gameport               16520  1 snd_cmipci
snd_opl3_lib           11520  1 snd_cmipci
snd_hwdep               9988  1 snd_opl3_lib
snd_mpu401_uart         9472  1 snd_cmipci
snd_seq_dummy           4740  0
snd_seq_oss            32896  0
snd_seq_midi            9600  0
snd_rawmidi            25472  2 snd_mpu401_uart,snd_seq_midi
snd_seq_midi_event      8448  2 snd_seq_oss,snd_seq_midi
snd_pcm                79876  4 snd_hda_intel,snd_hda_codec,snd_cmipci,snd_pcm_oss
snd_seq                52592  6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer              23684  3 snd_opl3_lib,snd_pcm,snd_seq
snd_seq_device          9100  6 snd_opl3_lib,snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
snd_page_alloc         10888  2 snd_hda_intel,snd_pcm
snd                    54020  16 snd_hda_intel,snd_hda_codec,snd_cmipci,snd_pcm_oss,snd_mixer_oss,snd_opl3_lib,snd_hwdep,snd_mpu401_uart,snd_seq_oss,snd_rawmidi,snd_pcm,snd_seq,snd_timer,snd_seq_device
soundcore               8672  1 snd

Offline happyhamster

  • Lid
  • Steunpunt: Nee
Problemen met afspelen geluid
« Reactie #10 Gepost op: 2007/06/22, 14:36:39 »
Citaat van: ejfrolich
Ik zie iets heel apparts...

Als ik in alsa-bash aan het eind het commando " options snd-cmipci index=0" zet dan laat hij daarna bij een cat alleen de snd_hda_intel kaart zien. Als ik er "options snd_hda_intel index=0" voor in de plaats zet laat hij bij een cat beide kaarten zien...?
Als je dan

cat /proc/asound/modules

doet? Dat is vreemd. Misschien wordt het veroorzaakt omdat er al een regel voor snd-cmipci aanwezig is. Of misschien is er toch een probleem met _ en - ? Gebeurd hetzelfde als je:

options snd-hda-intel index=0

toevoegd i.p.v.      options snd_hda_intel index=0   ?

Citaat
Wat moet er gebeuren bij het commando options....index=0?
De desbetreffende kaart wordt (als het goed is :) ) de default kaart. Maar blijkbaar kan een andere kaart de default kaart toch verdringen. Behalve als elke kaart een vaste index krijgt. Probeer:

gksudo gedit /etc/modprobe.d/alsa-base

En voeg index=0 toe aan de reeds aanwezige snd-cmipci regel aan het eind van de file, en voeg een regel toe voor snd-hda-intel. De laatste 3 regels zien er dan als volgt uit:

# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388 index=0
options snd-hda-intel index=1

- Werkt dat niet, dan kan het geen kwaad wat te experimenteren. Bijv:

# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388 index=0
options snd-hda-intel index=-2

- Of:

# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci index=0
options snd-hda-intel index=1


- Werkt dat allemaal niet, probeer dan de eerste optie:

# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388 index=0
options snd-hda-intel index=1

- en blacklist tevens de intel driver:

gksudo gedit /etc/modprobe.d/blacklist

- en voeg de volgende regels toe:

# Toegevoegd door user (juni 2007)
blacklist snd-hda-intel
blacklist snd_hda_intel


(Vreemd dat /etc/modprobe.d/blacklist blijkbaar de underscore gebruikt, terwijl er vrijwel overal op wordt aangedrongen de - te gebruiken.)

Offline happyhamster

  • Lid
  • Steunpunt: Nee
Problemen met afspelen geluid
« Reactie #11 Gepost op: 2007/06/22, 15:20:31 »
Nog even een aanvulling:

- Vergeet niet een backup te maken voordat je de blacklist edit:

sudo cp /etc/modprobe.d/blacklist /etc/modprobe.d/blacklist.origineel

- Kijk ook eens in System-->Preferences-->Sound. Zorg ervoor dat standaard  ALSA wordt gebruikt. Dus geen autodetect.

- Probeer, als je geen geluid hebt, de module eens handmatig te laden:

sudo modprobe snd-cmipci

- Check of de pci-kaart nog steeds goed vast zit in het pci-slot (je weet maar nooit :) )

Offline ejfrolich

  • Lid
  • Steunpunt: Nee
Problemen met afspelen geluid
« Reactie #12 Gepost op: 2007/06/22, 19:09:07 »
sorry ik zie dat ik iets onduidelijks heb teruggeschreven. In de comando regels gebruik ik alleen maar een gewoon - streepje. Ik heb slechts een regel uit cat gecopieerd en die laat alles zien met een _ streepje.

Offline ejfrolich

  • Lid
  • Steunpunt: Nee
Problemen met afspelen geluid
« Reactie #13 Gepost op: 2007/06/22, 19:23:15 »
Ik heb je voorstellen voor alsa-base en blacklist ingevoerd. Ik krijg geen fouten bij opstarten en ik had de eerste keer rebooten ook meteen geluid. Of dat zo blijft zal de tijd leren. Tot nog toe leek het een random gebeuren...
Ik heb ook gekeken naar de geluidsvoorkeuren. Die stonden altijd op c-media pci iec958 en ik heb ze laten staan. Als ik ze verander in alsa krijg ik foutmeldingen.

Offline ejfrolich

  • Lid
  • Steunpunt: Nee
Problemen met afspelen geluid
« Reactie #14 Gepost op: 2007/06/23, 12:49:52 »
na 4 keer inloggen is het nu elke keer goed. Ik denk dat dit de oplossing is.

Heel erg bedankt voor je moeite!

Offline happyhamster

  • Lid
  • Steunpunt: Nee
Problemen met afspelen geluid
« Reactie #15 Gepost op: 2007/06/23, 15:25:38 »
Hoi. Nog twee tips voor de toekomst: het komt heel af en toe voor dat een update een blacklist overschrijft. Als de symptomen opeens weer beginnen (gesteld dat het probleem nu wel verholpen is) dan is daar het eerste waar je moet kijken. Het is daarom handig om een klein tekstbestandje te maken met daarin een exacte beschrijving van alle aanpassingen die je gemaakt hebt, en deze ergens veilig op te bergen. Groeten, en veel succes.

Offline ejfrolich

  • Lid
  • Steunpunt: Nee
Problemen met afspelen geluid
« Reactie #16 Gepost op: 2007/06/30, 10:37:34 »
dag meneer Hamster,

Nogmaals dank voor je hulp. Alles werkt nu naar behoren en zonder problemen. Ik heb een map gemaakt met tweaks en veranderingen. Ik heb geleerd dat niet op de computer te zetten. Dus het zal, ook in de toekomst, goedkomen wat dit betreft.

Marcvda

  • Gast
Problemen met afspelen geluid
« Reactie #17 Gepost op: 2007/07/18, 17:55:50 »
Beste mentsen op dit topic,
Ook ik had problemen met mijn geluidskaart, en minstens een aantal problemen ontstonden doordat ik back-upbestanden maakte in de directory /etc/modprobe.d/  modprobe leest de hele directory uit, dus als je er een backup-bestand in zet wordt deze gewoon ingelezen. Ook gedit maakt een backup-bestand aan met een ~ aan het eind.
Mischien dat dit bij meer mensen problemen heeft veroorzaakt?
Groetjes, Marc,Nijmegen

Offline happyhamster

  • Lid
  • Steunpunt: Nee
Problemen met afspelen geluid
« Reactie #18 Gepost op: 2007/07/19, 01:10:39 »
Citaat van: Marcvda
Beste mentsen op dit topic,
Ook ik had problemen met mijn geluidskaart, en minstens een aantal problemen ontstonden doordat ik back-upbestanden maakte in de directory /etc/modprobe.d/  modprobe leest de hele directory uit, dus als je er een backup-bestand in zet wordt deze gewoon ingelezen. Ook gedit maakt een backup-bestand aan met een ~ aan het eind.
Mischien dat dit bij meer mensen problemen heeft veroorzaakt?
Groetjes, Marc,Nijmegen
Dat is goed om te weten. Bedankt voor de waarschuwing :)