Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: console inlogscherm lukt niet  (gelezen 1094 keer)

12know

  • Gast
console inlogscherm lukt niet
« Gepost op: 2007/06/17, 23:56:45 »
Ik werk met ubuntu dapper en kom er net achter dat ik met cntr-alt-fxx niet in mijn virtuele console kom. Hij verlaat gewwon niet mijn grafische omgeving.
Met cntr-alt-backspace breek ik x wel af maar dan start die automatisch weer in zijn grafische inlogscherm.
Het is me nog niet opgevallen maar ik moest even x verlaten om in de console iets te doen, en dat lukt niet.
Hoe krijg ik dit voor elkaar? Mijn terminalvenster doet het prima maar ik wil gewoon met cntl-alt-f2 bijvoorbeeld in een console scherm komen.

Marius

Offline Kiwinote

  • Lid
    • Launchpad
  • Steunpunt: Nee
console inlogscherm lukt niet
« Reactie #1 Gepost op: 2007/06/22, 14:25:29 »
Het moet linker ctrl +linker alt + F2 of  linker alt + rechter ctrl +F2 zijn, als dat helpt?

12know

  • Gast
console inlogscherm lukt niet
« Reactie #2 Gepost op: 2007/06/24, 11:56:49 »
Sorry dat ik wat laat reageer, maar welke combinatie ik ook probeer, het lukt niet. Totaal geen reactie.

Grafisch kan ik natuurlijk wel een terminalvenster openen. Maar ik dacht dat ik met ctrl + alt + F? in een viruele console terecht kwam. Maar helaas.

Ik heb namenlijk het pakketje vlock geinstalleerd. Daarmee kan je je systeem blokkeren. Het commando moet je in een VC ingeven anders is het niet secure (zie melding)

marius@ubuntu:~$ vlock -a
 *** This tty is not a VC (virtual console). ***
 *** It may not be securely locked. ***

This TTY is now locked.
Please enter the password to unlock.
marius's Password:
Ben toch benieuwd wat ik verkeerd doe?

grts Marius

12know

  • Gast
console inlogscherm lukt niet
« Reactie #3 Gepost op: 2007/06/24, 13:53:25 »
Ben weer wat verder. Het heeft te maken met "no deadkeys" in xorg.conf. Ik heb dit veranderd in "basic"
Nu werkt het ctrl + alt + f? alleen als ik nu bijvoorbeeld é wil typen lukt dit niet meer door ' + e te typen en dat is ook makkelijk.
Of ik dit nu kan oplossen heb ik geen idee. Zoals het er nu uit ziet is het 't één of 't ander.

Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "kbd"
        Option          "CoreKeyboard"
        Option          "XkbRules"      "xorg"
        Option          "XkbModel"      "pc105"
        Option          "XkbLayout"     "us"
        Option          "XkbVariant"    "basic"
Nog iedeen?

Marius

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
console inlogscherm lukt niet
« Reactie #4 Gepost op: 2007/06/24, 14:40:47 »
Dode toetsen:
Option          "XkbVariant"    "intl"

Niet "basic" dus!

Overigens kun je het ook makkelijker grafisch instellen:
Systeem - Voorkeuren - Toetsenbord - Indelingen - Toevoegen
Klik op driehoekje achter Amerikaans-Engels: er klapt een hele serie keuzes uit. Kies dan voor Internationaal (met dode toetsen).

Daarna oude definitie verwijderen en herstarten.

Groet, Pjotr.

Offline Kiwinote

  • Lid
    • Launchpad
  • Steunpunt: Nee
console inlogscherm lukt niet
« Reactie #5 Gepost op: 2007/06/24, 14:50:46 »
helemaal herstarten hoeft niet, x herstarten is genoeg: ctrl + alt + backspace