Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: geen geluid meer op feisty  (gelezen 3203 keer)

el_nico

  • Gast
geen geluid meer op feisty
« Gepost op: 2007/06/13, 16:20:44 »
naar aanleiding van m'n vorige topic ( http://forum.ubuntu-nl.org/topic/11552 ) , met het geluidsprobleem op de onboard soundcard, heb ik feisty geinstaleert...

maar nu heb ik helemaal geen geluid meer, niet op usb en ook niet op m'n onboard soundcard...

wat kan ik hieraan doen?

Offline vanadium

  • Lid
  • Steunpunt: Nee
geen geluid meer op feisty
« Reactie #1 Gepost op: 2007/06/13, 17:31:58 »
Normaal moet geluid "out of the box" werken. Dat het bij jou niet gaat na een herinstallatie, doet vermoeden dat je een heel specifieke geluidskaart hebt. Als je een schijn van kans wil dat iemand je kan helpen, moet je een beetje informatie geven over je systeem en de geluidskaart.

Vooraleer je te drastische maatregelen neemt, controleer je best eens of je volume wel open staat. Door op het luidsprekertje in de bovenste balk te dubbelklikken, krijg je "volume control" te zien. Zie of het volume aan staat en de betreffende geluidsbron niet afgesloten is (het kleine luidsprekertje onderaan de volumeregelaars: als je daarop klikt, wordt het kanaal afgesloten). Met "File - Change device" switch je van soundcard.

Voor wat betreft je USB kaart is het niet zo zeker of die door Linux ondersteund wordt, hopelijk wel. Je on-board geluidskaart zou je zeker aan de praat moeten krijgen.

el_nico

  • Gast
geen geluid meer op feisty
« Reactie #2 Gepost op: 2007/06/13, 20:10:57 »
moederbordje asus p4s553 MX
die geluidskaart is een onboard kaart, op windows aangedreven door soundmax ofzoiets (sis si7012 staat er in ubuntu)

el_nico

  • Gast
geen geluid meer op feisty
« Reactie #3 Gepost op: 2007/06/21, 12:19:51 »
ok, ik heb feisty eens opnieuw geinstaleerd, maar nog steeds geen geluid, niet op mijn usb boksen, en ook niet op mijn gewone boksen (met een jack aangesloten )

Offline bartek

  • Lid
    • http://bartek.blogsome.com
  • Steunpunt: Nee
geen geluid meer op feisty
« Reactie #4 Gepost op: 2007/06/21, 12:56:13 »
Doe eens alsamixer in je terminal en zet de schuifjes eens op 80% met de pijltjes op je toetsenbord.
| Deliberando saepe perit occasio |

"Car la vie est un bien perdu quand on n'a pas vécu comme on l'aurait voulu"

Offline Kev

  • Lid
  • Steunpunt: Nee
geen geluid meer op feisty
« Reactie #5 Gepost op: 2007/06/21, 13:00:45 »
lsusb om te zien of de usb boxjes herkent worden op de eerste plaats. En ja daarna doen wat Bartek zegt, BTW zoek ook eens op in welke volgorde hij de boxen herkent.
USB en onboard durven wel eens in de clinch te liggen met elkaar en kan zo je geluid storen.
Handige tip je kunt de positie van de drivers afstemmen op welke kaart je wilt gebruiken, maar USB, koppelt die zooi maar af en gebruik die onboard, dan moet je er wel voor zorgen dat hij standaard de onboard gebruikt en dat die ook als eerste geluidsdevice staat aangegeven.
Dit kun je regelen in de geluidsconfig van GNOME.
All Hail Lelouch, The 99th Emperor of Britannia
All Hail Lelouch! All Hail Lelouch!
Iedereen heeft het recht op mijn waarheid, zo wees geprezen.

el_nico

  • Gast
geen geluid meer op feisty
« Reactie #6 Gepost op: 2007/06/21, 13:55:12 »
alles staat op 80%, maar nog steeds geen geluid.
USB'tjes zijn afgekoppeld
 

op Ubuntu 6.06 werkten die usb-boxjes perfect

Offline Kev

  • Lid
  • Steunpunt: Nee
geen geluid meer op feisty
« Reactie #7 Gepost op: 2007/06/21, 21:01:49 »
Citaat van: el_nico
alles staat op 80%, maar nog steeds geen geluid.
USB'tjes zijn afgekoppeld
 

op Ubuntu 6.06 werkten die usb-boxjes perfect
Wel wat word er als default geluidskaart aangeduid, in alsamixer?
All Hail Lelouch, The 99th Emperor of Britannia
All Hail Lelouch! All Hail Lelouch!
Iedereen heeft het recht op mijn waarheid, zo wees geprezen.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
geen geluid meer op feisty
« Reactie #8 Gepost op: 2007/06/21, 21:07:25 »
USB-boxjes zijn vaak een probleem. Investeer eens een tientje in boxjes die een eigen voeding hebben en een draadje hebben dat je gewoon rechtstreeks in de geluidskaart plugt.... Bijkomend voordeel: beter geluid.

el_nico

  • Gast
geen geluid meer op feisty
« Reactie #9 Gepost op: 2007/06/21, 21:40:07 »
Citaat van: Kev
Citaat van: el_nico
alles staat op 80%, maar nog steeds geen geluid.
USB'tjes zijn afgekoppeld
 

op Ubuntu 6.06 werkten die usb-boxjes perfect
Wel wat word er als default geluidskaart aangeduid, in alsamixer?
Card: SiS SI7012

@pjotr123: er zitten ook gewone boksjes op, zo van die interne boksjes in mijn scherm

Offline Kev

  • Lid
  • Steunpunt: Nee
geen geluid meer op feisty
« Reactie #10 Gepost op: 2007/06/22, 17:41:49 »
Citaat van: el_nico
Citaat van: Kev
Citaat van: el_nico
alles staat op 80%, maar nog steeds geen geluid.
USB'tjes zijn afgekoppeld
 

op Ubuntu 6.06 werkten die usb-boxjes perfect
Wel wat word er als default geluidskaart aangeduid, in alsamixer?
Card: SiS SI7012

@pjotr123: er zitten ook gewone boksjes op, zo van die interne boksjes in mijn scherm
hmmm raar dat zou moeten werken, ik zou als ik u was een kijkje nemen op de alsa website. Om te zien of hij herkent word.
http://forum.ubuntu-nl.org/topic/11821
Kijk hier anders eens voor bepaalde info, gaat over dignosecommando's die je kan gebruiken om problemen met audio te troubleshooten.
All Hail Lelouch, The 99th Emperor of Britannia
All Hail Lelouch! All Hail Lelouch!
Iedereen heeft het recht op mijn waarheid, zo wees geprezen.

bermond

  • Gast
geen geluid meer op feisty
« Reactie #11 Gepost op: 2007/06/22, 19:03:04 »
Je hebt dus een onboard geluidskaart!!

Als je daarnaast nog een geluidskaart hebt dan is mijn ervaring dat dat wel eens voor wat problemen kan zorgen.
Zelf zit ik nog wel eens te stoeien met met onboard soundcard en mijn Delta-66 soundcard.
Omdat ik die onboard soundcard verder toch niet gebruik, zet ik in het bios die geluidskaart op "disable".


Ik begrijp dat je Usb-boxen hebt die zoals ik begrijp direkt op een USB poort zitten? Mischien is het best leuk om Boxen op een USB aan te sluiten, maar normaal gaat dat anders.

Ik voorzie toch wat problemen met zulke box-setjes die je direct op je USB aansluit.

el_nico

  • Gast
geen geluid meer op feisty
« Reactie #12 Gepost op: 2007/06/22, 19:29:37 »
die usb boxjes zijn er ondertussen al af

bermond

  • Gast
geen geluid meer op feisty
« Reactie #13 Gepost op: 2007/06/22, 19:32:33 »
Die usb-boxjes die je hebt moet je daar onder Windows aparte drivers voor loaden?

Wat ik eigenlijk bedoel, want ik weet het wat minder goed uit te leggen is:

Hoe kunnen Usb-boxen geluid maken?

Er moet mijns inziens althans onder Windows sprake zijn van een soort geludskaart-emulatie die er voor zorgt dat de Usb-boxen geluid ontvangen.
Via usb worden normaal gesproken gegevens verzonden, en via USB loopt ook spanning, zodat je batterijen kunt opladen van je draadloze muis.

Dit kan ook best met boxen het geval zijn want er zijn boxen die je kunt voeden via een externe spanning.

Ik denk dat jouw systeem gebruik maakt van 2 geluidskaarten, 1 voor je Usb en 1 voor je onboard sound.

Maar kan best zijn dat ik e plank geweldig mis sla!

el_nico

  • Gast
geen geluid meer op feisty
« Reactie #14 Gepost op: 2007/06/22, 20:57:13 »
die usb boxjes werken met C-media in Windows, zit er standaard op.
dus geen extra drivers nodig voor die dingetjes

Offline happyhamster

  • Lid
  • Steunpunt: Nee
geen geluid meer op feisty
« Reactie #15 Gepost op: 2007/06/23, 15:59:38 »
Citaat van: el_nico
moederbordje asus p4s553 MX
die geluidskaart is een onboard kaart, op windows aangedreven door soundmax ofzoiets (sis si7012 staat er in ubuntu)
Citaat van: bermond
Ik denk dat jouw systeem gebruik maakt van 2 geluidskaarten, 1 voor je Usb en 1 voor je onboard sound.
Hallo. Ik vermoed ook dat er een conflict is tussen 2 kaarten. Je zou verwachten dat Ubuntu de onboard kaart zou herkennen als AD1980 (Analog Devices), en dan zal de sis si7012 horen bij de usb-speakers (ingebouwd in de speakers).

Als dat zo is, dan zullen de speakers waarschijnlijk gewoon goed kunnen werken met Ubuntu, maar het zal wel enige moeite gaan kosten :)

El_nico, ik wil graag helpen, maar er moet eerst veel info verzameld worden. Kan je de usb-speakers weer aansluiten, rebooten, en dan de uitvoer van de volgende commando's hier tonen:

uname -r

aplay -l

lspci -v

cat /proc/asound/cards

cat /proc/asound/modules

cat /etc/modprobe.d/alsa-base

(Ze geven info over de aangetroffen hardware en de bijbehorende software modules.)

De commando's moet je invoeren in een terminal (Applications-->Accessories-->Terminal). Gewoon intikken of via copy & paste, en steeds gevolgd door enter. Als er problemen zijn, laat het weten. Het zal trouwens gaan om een flinke lap tekst :)

el_nico

  • Gast
geen geluid meer op feisty
« Reactie #16 Gepost op: 2007/06/23, 16:25:20 »
ok ik start nu m'n pc opnieuw op

el_nico

  • Gast
geen geluid meer op feisty
« Reactie #17 Gepost op: 2007/06/23, 16:34:57 »
2.6.20-16-generic

**** List of PLAYBACK Hardware Devices ****

card 0: SI7012 [SiS SI7012], device 0: Intel ICH [SiS SI7012]

  Subdevices: 1/1

  Subdevice #0: subdevice #0

card 1: Audio [USB Audio], device 0: USB Audio [USB Audio]

  Subdevices: 1/1

  Subdevice #0: subdevice #0


00:00.0 Host bridge: Silicon Integrated Systems [SiS] 651 Host (rev 02)

        Subsystem: ASUSTeK Computer Inc. Unknown device 8081

        Flags: bus master, medium devsel, latency 32

        Memory at e0000000 (32-bit, non-prefetchable) [size=128M]

        Capabilities:



00:01.0 PCI bridge: Silicon Integrated Systems [SiS] Virtual PCI-to-PCI bridge (AGP) (prog-if 00 [Normal decode])

        Flags: bus master, fast devsel, latency 64

        Bus: primary=00, secondary=01, subordinate=01, sec-latency=0

        Memory behind bridge: df000000-dfffffff

        Prefetchable memory behind bridge: eff00000-febfffff



00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS962 [MuTIOL Media IO] (rev 25)

        Flags: bus master, medium devsel, latency 0



00:02.1 SMBus: Silicon Integrated Systems [SiS] SiS961/2 SMBus Controller

        Flags: medium devsel

        I/O ports at e600 [size=32]



00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (prog-if 80 [Master])

        Subsystem: ASUSTeK Computer Inc. Unknown device 807a

        Flags: bus master, medium devsel, latency 128, IRQ 16

        [virtual] Memory at 000001f0 (32-bit, non-prefetchable) [disabled] [size=8]

        [virtual] Memory at 000003f0 (type 3, non-prefetchable) [disabled]

        [virtual] Memory at 00000170 (32-bit, non-prefetchable) [disabled] [size=8]

        [virtual] Memory at 00000370 (type 3, non-prefetchable) [disabled]

        I/O ports at b400 [size=16]



00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] AC'97 Sound Controller (rev a0)

        Subsystem: ASUSTeK Computer Inc. Unknown device 80b0

        Flags: bus master, medium devsel, latency 32, IRQ 21

        I/O ports at a400 [size=256]

        I/O ports at a000 [size=128]

        Capabilities:



00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f) (prog-if 10 [OHCI])

        Subsystem: ASUSTeK Computer Inc. Unknown device 807a

        Flags: bus master, medium devsel, latency 32, IRQ 20

        Memory at de800000 (32-bit, non-prefetchable) [size=4K]



00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f) (prog-if 10 [OHCI])

        Subsystem: ASUSTeK Computer Inc. Unknown device 807a

        Flags: bus master, medium devsel, latency 32, IRQ 17

        Memory at de000000 (32-bit, non-prefetchable) [size=4K]



00:03.3 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller (prog-if 20 [EHCI])

        Subsystem: ASUSTeK Computer Inc. Unknown device 807a

        Flags: bus master, medium devsel, latency 32, IRQ 18

        Memory at dd800000 (32-bit, non-prefetchable) [size=4K]

        Capabilities:



00:04.0 Ethernet controller: Silicon Integrated Systems [SiS] SiS900 PCI Fast Ethernet (rev 91)

        Subsystem: ASUSTeK Computer Inc. Unknown device 80a7

        Flags: bus master, medium devsel, latency 32, IRQ 19

        I/O ports at 9800 [size=256]

        Memory at dd000000 (32-bit, non-prefetchable) [size=4K]

        Expansion ROM at efee0000 [disabled] [size=128K]

        Capabilities:



01:00.0 VGA compatible controller: nVidia Corporation NV11 [GeForce2 MX/MX 400] (rev b2) (prog-if 00 [VGA])

        Flags: bus master, 66MHz, medium devsel, latency 248, IRQ 16

        Memory at df000000 (32-bit, non-prefetchable) [size=16M]

        Memory at f0000000 (32-bit, prefetchable) [size=128M]

        [virtual] Expansion ROM at efff0000 [disabled] [size=64K]

        Capabilities:


 0 [SI7012         ]: ICH - SiS SI7012

                      SiS SI7012 with AD1980 at 0xa400, irq 21

 1 [Audio          ]: USB-Audio - USB Audio

                      C-Media INC. USB Audio at usb-0000:00:03.0-1, full speed


 0 snd_intel8x0

 1 snd_usb_audio


# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-ioctl32 ; : ; }
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --Qb snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-seq-midi ; /sbin/modprobe --quiet snd-seq-oss ; : ; }

# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe -Qb saa7134-alsa ; : ; }

# Load snd-seq for devices that don't have hardware midi;
#   Ubuntu #26283, #43682, #56005; works around Ubuntu #34831 for
#   non-Creative Labs PCI hardware
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-seq ; }
# Prevent abnormal drivers from grabbing index 0
options snd-bt87x index=-2
options cx88-alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388

ziezo, dit is alles (inderdaad een flinke lap tekst)

Offline happyhamster

  • Lid
  • Steunpunt: Nee
geen geluid meer op feisty
« Reactie #18 Gepost op: 2007/06/23, 17:20:28 »
Ok, dus SiS SI7012 is wel degelijk de AD1980 onboard. En usb-sound werkt waarschijnlijk niet vanwege de "index=-2" in /etc/modprobe.d/alsa-base, en misschien is er ook een conflict met snd-intel8x0.

Je hebt op dit moment helemaal geen geluid correct? Wil je alleen de usb-speakers gebruiken? Of wil je ook soms de onboard kaart kunnen gebruiken? (wordt een stuk lastiger).

Wat je alvast kan doen is een kleine verandering aanbrengen in een alsa configuratiebestand. Allereerst een backup maken:

sudo cp /etc/modprobe.d/alsa-base /etc/modprobe.d/alsa-base.origineel

- en vervolgens:

gksudo gedit /etc/modprobe.d/alsa-base

- verwijder de volgende regel geheel:

options snd-usb-audio index=-2

- en voeg aan het einde van de file de volgende regels toe:

# Toegevoegd door user (juni 2007)
# options snd-usb-audio index=-2
options snd-usb-audio index=0
options snd-intel8x0 index=1


- Save & exit
- Reboot, en kijk of usb geluid werkt. Zoniet, ga naar System-->Preferences-->Sound en kijk of de juiste geluidsbronnen zijn gekozen.

el_nico

  • Gast
geen geluid meer op feisty
« Reactie #19 Gepost op: 2007/06/23, 18:07:24 »
het werkt!
bedankt happyhamster :D :D

cmknaap

  • Gast
geen geluid meer op feisty
« Reactie #20 Gepost op: 2008/01/19, 17:37:36 »
Hallo. Nu ik ook aan ubuntu begonnen ben loop ik ook tgen het probleem aan dat het geluid niet werk op mijn laptop Packard Bell (easynote) deze heeft een geluid chip: SIS SI7012 verder heb ik nog wat gegevens achterhaald: snd_intel8x0 en verder AD1888. Ik zou graag geluid willen hebben op de laptop zelf.
Ik ubuntu 7.10 i386 (alternate install cd) geinstalleerd op een externe hd, omdat de interne ide van de harde schijf kapot was (alleen een nieuw moederboard kon dit verhelpen).
Verder ben in een beginner en hoop dat iemand me kan helpen.