Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: e-tech webcam  (gelezen 3921 keer)

Offline clement

  • Lid
  • Steunpunt: Nee
e-tech webcam
« Gepost op: 2007/06/11, 22:06:20 »
ik heb een schone installatie naar Feisty gedaan en nu werkt mijn e-tech webcam niet meer
hij wordt wel herkent bij de usb poort
krijg foutmelding could not connect to video device(/dev/video0)
hij heeft wel gewerkt in de vorge versie
heb alle mogelijke usb poorten geprobeert

iemand enig idee hoe dit op te lossen

groetje`s clement

Offline raggar

  • Lid
    • fietsen naar Tibet
  • Steunpunt: Ja
e-tech webcam
« Reactie #1 Gepost op: 2007/06/16, 00:25:54 »
Er is hier al een tijd niet op gereageerd, dus ik probeer je gewoon te helpen. Ik begrijp dat hij het in edgy wel deed, heb je geupdate naar de nieuwste kernel in feisty 2.6.20-16?

Probeer eerst het volgende commando, misschien dat dit iets oplost:
sudo apt-get install build-essential linux-headers-$(uname -r)

Kun je anders eens de precieze uitkomst van lsusb hier posten. Evenals het type en de gebruikte chips.

Offline clement

  • Lid
  • Steunpunt: Nee
e-tech webcam
« Reactie #2 Gepost op: 2007/06/16, 22:21:34 »
ik krijg het volgende bericht

clement@clement-desktop:~$ sudo apt-get install build-essential linux-headers-$
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd
Reading state information... Klaar
build-essential is reeds de nieuwste versie.
E: Kon pakket linux-headers-$ niet vinden

easy cam geeft de volgende melding
ID 0ac8:301b Z-Star Microelectronics Corp. ZC0301 WebCam

 kan je hier wat mee
hoe krijg ik de chipset in beeld

Offline raggar

  • Lid
    • fietsen naar Tibet
  • Steunpunt: Ja
e-tech webcam
« Reactie #3 Gepost op: 2007/06/16, 23:12:07 »
Alle camera's met dezelfde vendor en product id werken met de Spca5xx webcam driver (0ac8 is je vendors id 301b en is je product id). De Spca5xx worden nu standaard in Ubuntu geladen, dus het zou out of the box moeten werken. Misschien dat dit bij jouw nog niet werkt.

Doe eens:
sudo apt-get install spca5xx-source

Als hij dan nog niet werkt de volgende driver die Z-star ondersteund
sudo apt-get install gspca-source

Als dat ook niet werkt geef dan eens de uitkomst van: $lsvideo

Ps. Welk programma gebruik je om te testen? Camorama heb ik zelf goede ervaringen mee.

Offline clement

  • Lid
  • Steunpunt: Nee
e-tech webcam
« Reactie #4 Gepost op: 2007/06/17, 09:55:18 »
even nog een antwoord op je eerste vraag ik heb een schone installatie met de live cd van feisty fawn gedaan weet niet welke kernel dit is
waar kan ik dat zien

als test prog gebruik ik ook camorama
ik heb de paketten die je aangaf beiden  geinstalleerd
de camera doet het nog steets niet

als ik : $lsvideo in de monitor tik gebeurt niks

Offline raggar

  • Lid
    • fietsen naar Tibet
  • Steunpunt: Ja
e-tech webcam
« Reactie #5 Gepost op: 2007/06/17, 14:54:01 »
sorry, je moet "lsvideo" intikken. Dit staat voor list (ls) video, dus geeft alles weer wat aan video is verbonden. $ staat voor een terminal command, dat had ik beter moeten aangeven.

De kernel versie kun je vinden door in de terminal "uname -r" te typen. De nieuwste versie is: 2.6.20-16

Probeer ook eens, modprobe gebruik je om modules te laden:
sudo modprobe spca5xx
sudo modprobe gspca

Doe dan "lsvideo" als daar iets uitkomt, zou het moeten werken in Camorama.

Ik hoop dat het werkt, hier houden namelijk mijn ideeen op :s

Offline clement

  • Lid
  • Steunpunt: Nee
e-tech webcam
« Reactie #6 Gepost op: 2007/06/18, 22:13:21 »
bij invoer kreeg ik deze meldingen

clement@clement-desktop:~$ lsvideo
bash: lsvideo: opdracht niet gevonden
clement@clement-desktop:~$ "lsvideo"
bash: lsvideo: opdracht niet gevonden
clement@clement-desktop:~$


clement@clement-desktop:~$ sudo modprobe spca5xx
Password:
FATAL: Module spca5xx not found.
clement@clement-desktop:~$

De kernel versie is inderdaad de nieuwste 2.6.20-16

ben ook nog even terug gegaan naar vorge opdrachten zie onder

clement@clement-desktop:~$ sudo apt-get install spca5xx-source
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd      
Reading state information... Klaar
spca5xx-source is reeds de nieuwste versie.
De volgende NIEUWE pakketten zullen geïnstalleerd worden:
  id3v2 python2.4-minimal python2.4
Gebruik 'apt-get autoremove' om deze te verwijderen.
0 pakketten opgewaardeerd, 0 nieuwe pakketten geïnstalleerd, 0 verwijderen en 0 niet opgewaardeerd.


clement@clement-desktop:~$ sudo apt-get install gspca-source
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd      
Reading state information... Klaar
gspca-source is reeds de nieuwste versie.
De volgende NIEUWE pakketten zullen geïnstalleerd worden:
  id3v2 python2.4-minimal python2.4
Gebruik 'apt-get autoremove' om deze te verwijderen.
0 pakketten opgewaardeerd, 0 nieuwe pakketten geïnstalleerd, 0 verwijderen en 0 niet opgewaardeerd.

camera werkt helaas nog steeds niet
heb nog een camera van de buurman geleend een philips
deze werkt ook niet

nog een idee ?

Offline raggar

  • Lid
    • fietsen naar Tibet
  • Steunpunt: Ja
e-tech webcam
« Reactie #7 Gepost op: 2007/06/19, 15:20:41 »
Ik heb een fout gemaakt. Stom van mij, je moet "ls /dev/video*" doen. Maar verder heb ik geen ideeen sorry, iemand anders misschien?

Offline clement

  • Lid
  • Steunpunt: Nee
e-tech webcam
« Reactie #8 Gepost op: 2007/06/20, 19:14:30 »
uitslag van ls /dev/video*

clement@clement-desktop:~$ ls /dev/video*
/dev/video  /dev/video0  /dev/video1

in ieder geval bedank voor je hulp raggar

iemand anders nog een idee om mijn probleem  met de webcam op te lossen

Offline clement

  • Lid
  • Steunpunt: Nee
e-tech webcam
« Reactie #9 Gepost op: 2007/06/21, 22:09:37 »
ik heb maar een nieuwe installatie gedaan en nu werkt de cam weer

artvds2708

  • Gast
e-tech webcam
« Reactie #10 Gepost op: 2007/09/19, 16:21:45 »
Ik heb exact de zelfde problemen als clement.
Een nieuwe install is iets te heavy
Wie kan me helpen ?