Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: nvidia  (gelezen 1133 keer)

christine

  • Gast
nvidia
« Gepost op: 2007/06/10, 22:10:56 »
Beste, ik ben een abolute newbie met ubuntu. Heb wat zitten rommelen, en breuabladeffecten willen inschakelen. pc vroeg toen om nvidiadrivers te installeren, deede dat, en opnieuw opstarte. Sindsdien blijft mijn beeld zwart, en kan ik niks meer doen... is daar een manier om daar uit te geraken zonder ubuntu weer helemaal opnieuw te installeren? dank! Christine

Offline BailHope

  • Lid
    • Techneut
  • Steunpunt: Nee
nvidia
« Reactie #1 Gepost op: 2007/06/10, 22:17:03 »
Kan je ons wat meer vertellen over je systeem?

In elk geval kan je terug beeld krijgen door in veilige modus op te starten (dat is recovery mode in het engels voor Ubuntu.) Het zou de tweede optie moeten zijn wanneer je de keuze krijgt tussen Windows en Ubuntu.

Daar geef je het volgende commando in:
sudo dpkg-reconfigure xserver-xorg

Je krijgt nu een heleboel vragen, en ik raad je aan om het meeste op standaard te laten staan. Je kan echter wel de driver veranderen van nvidia, naar nv (opensource nvidia driver) of vesa.
Ik dacht dat dat de tweede vraag was. Mocht nv ook niet werken of als die niet in de lijst staat, probeer dan de vesa driver. Deze zou zeker moeten werken!

Zo heb je dan al terug beeld.

Wat we zeker nodig hebben om dit probleem op te lossen is je videokaart. De specificaties hiervan vind je door:
lspci | grep VGA
in te geven in een terminal.
Ubuntu user #12046
Mijn blog voor techneuten: http://techneut.wordpress.com
Voor de professionele IT'er: http://it-potato.blogspot.com

christine

  • Gast
nvidia
« Reactie #2 Gepost op: 2007/06/10, 22:17:54 »
Uk zie nog wel de opstartbalk die vol loopt, maar dan wordt het beeld zwart, dus gebruikersnaam en paswoord kan ik niet meer intikken. Christine

The_Necrocide

  • Gast
nvidia
« Reactie #3 Gepost op: 2007/06/10, 22:18:09 »
Welke Nvidia kaart heb je juist?

Start ubuntu in recovery modus, log in met je username en paswoord en typ:

sudo nano /etc/X11/xorg.confZoek het onderdeel "Device", het zou iets in de trend van het volgende moeten weergeven:


Section "Device"
    Identifier     "NVIDIA Corporation NVIDIA Default Card"
    Driver         "nvidia"
EndSection
Indien het dit al weergeeft en de X server geeft nog steeds een zwart scherm, verander dan "nvidia" in "nv".
Als dit werkt en je Ubuntu desktop wordt correct weergegeven kunnen we verder van daar...

Antwoord al gegeven blijkbaar :), deze alternatieve methode zou ook moeten werken...

Offline BailHope

  • Lid
    • Techneut
  • Steunpunt: Nee
nvidia
« Reactie #4 Gepost op: 2007/06/10, 22:21:25 »
Citaat van: christine
Uk zie nog wel de opstartbalk die vol loopt, maar dan wordt het beeld zwart, dus gebruikersnaam en paswoord kan ik niet meer intikken. Christine
Daarom moet je in recovery opstarten om dit probleem op te lossen. Recovery modus werkt sowieso zonder grafische modus, dus je krijgt een soort dos venster om commando's in te geven.

Even een kleine correctie op wat The_Necrocide zei:
het is:
sudo, niet sudu.
Ubuntu user #12046
Mijn blog voor techneuten: http://techneut.wordpress.com
Voor de professionele IT'er: http://it-potato.blogspot.com

The_Necrocide

  • Gast
nvidia
« Reactie #5 Gepost op: 2007/06/10, 22:22:36 »
Citaat van: Bail Hope
Citaat van: christine
Uk zie nog wel de opstartbalk die vol loopt, maar dan wordt het beeld zwart, dus gebruikersnaam en paswoord kan ik niet meer intikken. Christine
Daarom moet je in recovery opstarten om dit probleem op te lossen. Recovery modus werkt sowieso zonder grafische modus, dus je krijgt een soort dos venster om commando's in te geven.

Even een kleine correctie op wat The_Necrocide zei:
het is:
sudo, niet sudu.
Sorry typfoutje, aangepast in orginele post, dankje Bail

Offline BailHope

  • Lid
    • Techneut
  • Steunpunt: Nee
nvidia
« Reactie #6 Gepost op: 2007/06/10, 22:23:47 »
Citaat
Sorry typfoutje, aangepast in orginele post, dankje Bail
Kan gebeuren :)
Ik dacht, ik schrijf het er maar even bij voor ze foutmeldingen ofzo begint te krijgen.
Ubuntu user #12046
Mijn blog voor techneuten: http://techneut.wordpress.com
Voor de professionele IT'er: http://it-potato.blogspot.com

christine

  • Gast
nvidia
« Reactie #7 Gepost op: 2007/06/10, 22:33:06 »
Bedankt Bail Hope! Beeld heb ik al terug, nu de juiste instellingen nog terugplaatsen, maar daar ga ik wel eens naar op zoek! Bedankt!

Offline BailHope

  • Lid
    • Techneut
  • Steunpunt: Nee
nvidia
« Reactie #8 Gepost op: 2007/06/10, 22:37:30 »
Graag gedaan.

Als je nog problemen of zo tegen komt, laat het gerust weten. Wij zijn hier om te helpen :)
Ubuntu user #12046
Mijn blog voor techneuten: http://techneut.wordpress.com
Voor de professionele IT'er: http://it-potato.blogspot.com

christine

  • Gast
nvidia
« Reactie #9 Gepost op: 2007/06/10, 23:05:55 »
Alles schijnt weer ok te zijn! Linux is helemaal nieuw voor mij. Met DOS was ik goed bekend... geef les over programmeren, onder windows natuurlijk... :-), zal eens moeten beginnen studeren. En dan eens gaan programmeren onder linux?
Moet eens op zoek gaan naar een goed ontwikkelingspakket. Voor windows gebruikte ik in de les de Borland C++ Builder. Alleszins al bedankt voor de steun! Is wel fijn.
Christine

Offline BailHope

  • Lid
    • Techneut
  • Steunpunt: Nee
nvidia
« Reactie #10 Gepost op: 2007/06/11, 14:01:42 »
Onder Ubuntu kan je gebruik maken van Eclipse IDE.
Dat is een volledige ontwikkelomgeving voor welke programmeertaal jij maar wil. (java, c, c++, ...)
Er zijn er nog maar daar heb ik geen ervaring mee :)
Ubuntu user #12046
Mijn blog voor techneuten: http://techneut.wordpress.com
Voor de professionele IT'er: http://it-potato.blogspot.com