Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Krijg TV-OUT niet werkend. Feisty. Ati X1250. 8.37.6-1  (gelezen 718 keer)

faze

  • Gast
Krijg TV-OUT niet werkend. Feisty. Ati X1250. 8.37.6-1
« Gepost op: 2007/06/10, 12:26:55 »
Draait nu Kubuntu Feisty. Na veel geklooi draait opzich de ATI driver goed. Kubuntu werkt lekker en bij OpenGL pakt hij de ATI driver.
Als ik echter nu mijn tv-out inplug (of het nu s-video of composite is), dan zie ik de tv een paar keer knipperen, en vervolgens start KDE niet op.

Stuk van de melding uit Xorg.0.log:
(II) Loading sub module "fglrxdrm"
(II) LoadModule: "fglrxdrm"
(II) Loading /usr/lib/xorg/modules/linux//libfglrxdrm.so
(II) Module fglrxdrm: vendor="FireGL - ATI Technologies Inc."
        compiled for 7.1.0, module version = 8.37.6
        ABI class: X.Org Server Extension, version 0.3
(--) fglrx(0): VideoRAM: 131072 kByte, Type: DDR2
(II) fglrx(0): PCIE card detected
(WW) fglrx(0): board is an unknown third party board, chipset is supported
(WW) fglrx(0): MonitorLayout is no longer supported.
               Please use DesktopSetup and ForceMonitors options
(II) Loading sub module "ddc"
(II) LoadModule: "ddc"
(II) Reloading /usr/lib/xorg/modules//libddc.so
(II) fglrx(0): Connected Display1: CRT on primary DAC [crt1]
(II) fglrx(0): Display1 EDID data ---------------------------
(II) fglrx(0): Manufacturer: ACR  Model: ad12  Serial#: 0
(II) fglrx(0): Year: 2004  Week: 49
(II) fglrx(0): EDID Version: 1.3
(II) fglrx(0): Analog Display Input,  Input Voltage Level: 0.700/0.300 V
(II) fglrx(0): Sync:  Separate
(II) fglrx(0): Max H-Image Size [cm]: horiz.: 34  vert.: 27
(II) fglrx(0): Gamma: 2.20
(II) fglrx(0): DPMS capabilities: StandBy Suspend Off; RGB/Color Display
(II) fglrx(0): First detailed timing not preferred mode in violation of standard!(II) fglrx(0): redX: 0.637 redY: 0.344   greenX: 0.310 greenY: 0.582
(II) fglrx(0): blueX: 0.143 blueY: 0.100   whiteX: 0.313 whiteY: 0.329
(II) fglrx(0): Supported VESA Video Modes:
(II) fglrx(0): 720x400@70Hz
(II) fglrx(0): 640x480@60Hz
(II) fglrx(0): 640x480@67Hz
(II) fglrx(0): 640x480@72Hz
(II) fglrx(0): 640x480@75Hz
(II) fglrx(0): 800x600@56Hz
(II) fglrx(0): 800x600@60Hz
(II) fglrx(0): 800x600@72Hz
(II) fglrx(0): 800x600@75Hz
(II) fglrx(0): 832x624@75Hz
(II) fglrx(0): 1024x768@60Hz
(II) fglrx(0): 1024x768@70Hz
(II) fglrx(0): 1024x768@75Hz
(II) fglrx(0): 1280x1024@75Hz
(II) fglrx(0): Manufacturer's mask: 0
(II) fglrx(0): Supported additional Video Mode:
(II) fglrx(0): clock: 108.0 MHz   Image Size:  338 x 270 mm
(II) fglrx(0): h_active: 1280  h_sync: 1328  h_sync_end 1440 h_blank_end 1688 h_border: 0
(II) fglrx(0): v_active: 1024  v_sync: 1025  v_sync_end 1028 v_blanking: 1066 v_border: 0
(II) fglrx(0): Ranges: V min: 55  V max: 75 Hz, H min: 30  H max: 83 kHz, PixClock max 140 MHz
(II) fglrx(0): Serial No: 4490089DPY02
(II) fglrx(0): Monitor name: AL1711
(II) fglrx(0): EDID (in hex):
(II) fglrx(0):  00ffffffffffff00047212ad00000000
(II) fglrx(0):  310e010308221b78e804a5a3584f9524
(II) fglrx(0):  195054bfef0001010101010101010101
(II) fglrx(0):  010101010101302a009851002a403070
(II) fglrx(0):  1300520e1100001e000000fd00374b1e
(II) fglrx(0):  530e000a202020202020000000ff0034
(II) fglrx(0):  34393030383944505930320a000000fc
(II) fglrx(0):  00414c313731310a2020202020200024
(II) fglrx(0): End of Display1 EDID data --------------------
(II) fglrx(0): Connected Display2: TV on TVDAC [tv]
(II) fglrx(0):  Display2: No EDID information from DDC.
(II) fglrx(0): Derived EDID from BIOS and internal tables for Display2:
(II) fglrx(0): Display2 EDID data ---------------------------
(II) fglrx(0): Manufacturer: PNP  Model: 9fe  Serial#: 0
(II) fglrx(0): Year: 1990  Week: 0
(II) fglrx(0): EDID Version: 1.3
(II) fglrx(0): Analog Display Input,  Input Voltage Level: 0.700/0.300 V
(II) fglrx(0): Sync:
(II) fglrx(0): Max H-Image Size [cm]: H-Size may change,  V-Size may change
(II) fglrx(0): Gamma: 1.00
(II) fglrx(0): DPMS capabilities: StandBy Suspend Off; Non RGB Multicolor Display
(II) fglrx(0): First detailed timing not preferred mode in violation of standard!(II) fglrx(0): redX: 0.000 redY: 0.000   greenX: 0.000 greenY: 0.000
(II) fglrx(0): blueX: 0.000 blueY: 0.000   whiteX: 0.000 whiteY: 0.000
(II) fglrx(0): Supported VESA Video Modes:
(II) fglrx(0): 640x480@60Hz
(II) fglrx(0): 800x600@60Hz
(II) fglrx(0): 1024x768@60Hz
(II) fglrx(0): Manufacturer's mask: 0
(II) fglrx(0): EDID (in hex):
(II) fglrx(0):  00ffffffffffff0041d0fe0900000000
(II) fglrx(0):  0000010300000000f000000000000000
(II) fglrx(0):  00000021080000000000000000000000
(II) fglrx(0):  00000000000000000000000000000000
(II) fglrx(0):  00000000000000000000000000000000
(II) fglrx(0):  00000000000000000000000000000000
(II) fglrx(0):  00000000000000000000000000000000
(II) fglrx(0):  000000000000000000000000000000d1
(II) fglrx(0): End of Display2 EDID data --------------------
(WW) fglrx(0): More than one displays are connected,so clone mode is enabled
(WW) fglrx(0): DALEnableDriverInstance on secondary failed: 9
(EE) fglrx(0): PreInitDAL failed
(EE) fglrx(0): PreInit failed
(II) fglrx(0): === [atiddxPreInit] === end
(II) UnloadModule: "fglrx"
(II) UnloadModule: "ddc"
(II) UnloadModule: "fglrxdrm"
(II) Unloading /usr/lib/xorg/modules/linux//libfglrxdrm.so
(II) UnloadModule: "vbe"
(II) UnloadModule: "vm86"
(II) Unloading /usr/lib/xorg/modules//libvm86.so
(II) UnloadModule: "int10"
(II) UnloadModule: "vgahw"
(II) Unloading /usr/lib/xorg/modules//libvgahw.so
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found
Bij mijn xorg.conf heb ik al het een en ander geprobeerd.  Hier met de laatste aanpassingen relevant stuk uit xorg.conf:
Section "Device"
        Identifier      "Generic Video Card"
        Driver          "fglrx"
        Busid           "PCI:1:5:0"
        Option "MonitorLayout" "AUTO, NONE"
        Option "TVOutput" "PAL"
        Option "VideoOverlay" "on"
        Option "OpenGLOverlay" "off"
EndSection

Section "Monitor"
        Identifier      "AL1711"
        Option          "DPMS"
EndSection

Section "Screen"
        Identifier      "Default Screen"
        Device          "Generic Video Card"
        Monitor         "AL1711"
        Defaultdepth    24
        SubSection "Display"
                Depth   1
                Modes           "1280x1024"     "1024x768"      "832x624"       "800x600"       "720x400"       "640x480"
        EndSubSection
        SubSection "Display"
                Depth   4
                Modes           "1280x1024"     "1024x768"      "832x624"       "800x600"       "720x400"       "640x480"
        EndSubSection
        SubSection "Display"
                Depth   8
                Modes           "1280x1024"     "1024x768"      "832x624"       "800x600"       "720x400"       "640x480"
        EndSubSection
        SubSection "Display"
                Depth   15
                Modes           "1280x1024"     "1024x768"      "832x624"       "800x600"       "720x400"       "640x480"
        EndSubSection
        SubSection "Display"
                Depth   16
                Modes           "1280x1024"     "1024x768"      "832x624"       "800x600"       "720x400"       "640x480"
        EndSubSection
        SubSection "Display"
                Depth   24
                Modes           "1280x1024"     "1024x768"      "832x624"       "800x600"       "720x400"       "640x480"
        EndSubSection
EndSection

Section "ServerLayout"
        Identifier      "Default Layout"
  screen "Default Screen"
        Inputdevice     "Generic Keyboard"
        Inputdevice     "Configured Mouse"
        #       InputDevice     "stylus"        "SendCoreEvents"
        #       InputDevice     "cursor"        "SendCoreEvents"
        #       InputDevice     "eraser"        "SendCoreEvents"
EndSection

Section "DRI"
        Mode    0666
EndSection
Section "Extensions"
        Option          "Composite"     "0"
EndSection

Section "ServerFlags"
        Option          "AIGLX" "off"
EndSection
Doe ik nu iets totaal fout? Tot nu toe heb ik al genoeg gedoe met de Ati driver gehad... wist o.a. niet bij de aanschaf dat alphablending e.d. niet werkt. Ik hoop toch dat de tv-out wel mogelijk moet zijn. Als iemand kan helpen, graaaag :) ben nu al een paar dagen aan het klooien om een media-center op te zetten...