Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: geluid doet het niet in Xubuntu  (gelezen 801 keer)

Offline tryer

  • Lid
  • Steunpunt: Nee
geluid doet het niet in Xubuntu
« Gepost op: 2007/06/08, 18:18:43 »
Het geluis doet het niet na installatie. Welke terminal opdracht moet ik doen ? de geluidskaart is (als ik het goed heb begrepen in Puppy -Linux) Intel8x0  00;1f.5Class 0401 8086:2415 (rev02)

Offline tryer

  • Lid
  • Steunpunt: Nee
geluid doet het niet in Xubuntu
« Reactie #1 Gepost op: 2007/06/08, 18:49:44 »
Ik zie dat ik hierboven een fout heb gemaakt. Ik heb Xubuntu op een andere computer ge"installeerd, dus de geluidskaart die ik hierboven beschreef klopt niet. 1. Met welk programma kan ik de hardware vinden. 2. als ik weet welke geluidskaart erin zit, hoe kan ik die vinden en installeren ?

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
geluid doet het niet in Xubuntu
« Reactie #2 Gepost op: 2007/06/08, 19:07:54 »
doe maar eens lspci in de terminal, dan zie je een lijst (ls) van alle pci-kaarten (pci).

Voor de trema's op de ë ö ä:
http://forum.ubuntu-nl.org/message/24118#p24118

sudo mousepad /etc/X11/xorg.conf
(let op de hoofdletter X in X11).

Offline tryer

  • Lid
  • Steunpunt: Nee
geluid doet het niet in Xubuntu
« Reactie #3 Gepost op: 2007/06/08, 22:03:32 »
O.K. ik weet nu de soudcard:

00:1f.5 Multimedia audio controller: Intel Corporation 82801AA AC'97 Audio (rev 02)

en nu de driver ???

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
   FontPath   "/usr/share/fonts/X11/misc"
   FontPath   "/usr/share/fonts/X11/cyrillic"
   FontPath   "/usr/share/fonts/X11/100dpi/:unscaled"
   FontPath   "/usr/share/fonts/X11/75dpi/:unscaled"
   FontPath   "/usr/share/fonts/X11/Type1"
   FontPath   "/usr/share/fonts/X11/100dpi"
   FontPath   "/usr/share/fonts/X11/75dpi"
   # path to defoma fonts
   FontPath   "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
   Load   "bitmap"
   Load   "ddc"
   Load   "dri"
   Load   "extmod"
   Load   "freetype"
   Load   "glx"
   Load   "int10"
   Load   "vbe"
EndSection

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "CoreKeyboard"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc105"
   Option      "XkbLayout"   "us"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
   Option      "CorePointer"
   Option      "Device"      "/dev/input/mice"
   Option      "Protocol"      "ImPS/2"
   Option      "ZAxisMapping"      "4 5"
   Option      "Emulate3Buttons"   "true"
EndSection

Section "InputDevice"
   Driver      "wacom"
   Identifier   "stylus"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"      "stylus"
   Option      "ForceDevice"   "ISDV4"      # Tablet PC ONLY
EndSection

Section "InputDevice"
   Driver      "wacom"
   Identifier   "eraser"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"      "eraser"
   Option      "ForceDevice"   "ISDV4"      # Tablet PC ONLY
EndSection

Section "InputDevice"
   Driver      "wacom"
   Identifier   "cursor"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"      "cursor"
   Option      "ForceDevice"   "ISDV4"      # Tablet PC ONLY
EndSection

Section "Device"
   Identifier   "Intel Corporation 82810E DC-133 CGC [Chipset Graphics Controller]"
   Driver      "i810"
   BusID      "PCI:0:1:0"
   Option      "UseFBDev"      "true"
EndSection

Section "Monitor"
   Identifier   "SONY SDM-N50"
   Option      "DPMS"
   HorizSync   28-49
   VertRefresh   43-72
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Device      "Intel Corporation 82810E DC-133 CGC [Chipset Graphics Controller]"
   Monitor      "SONY SDM-N50"
   DefaultDepth   16
   SubSection "Display"
      Depth      1
      Modes      "1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1200x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      4
      Modes      "1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1200x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      8
      Modes      "1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1200x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      15
      Modes      "1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1200x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      16
      Modes      "1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1200x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      24
      Modes      "1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1200x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
   EndSubSection
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
   Screen      "Default Screen"
   InputDevice   "Generic Keyboard"
   InputDevice   "Configured Mouse"
   InputDevice     "stylus"   "SendCoreEvents"
   InputDevice     "cursor"   "SendCoreEvents"
   InputDevice     "eraser"   "SendCoreEvents"
EndSection

Section "DRI"
   Mode   0666
EndSection

wat moet ik nu doen ??

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
geluid doet het niet in Xubuntu
« Reactie #4 Gepost op: 2007/06/08, 22:08:26 »
xorg.conf heb ik genoemd voor de trema's op je letters, dus niet voor je geluidskaart.....
In xorg.conf dit wijzigen:
Section "InputDevice"
    Identifier    "Generic Keyboard"
    Driver        "kbd"
    Option        "CoreKeyboard"
    Option        "XkbRules"    "xorg"
    Option        "XkbModel"    "pc105"
    Option        "XkbLayout"    "us"
    Option        "XkbVariant"    "intl"
EndSection

De toevoeging van de laatste Option zorgt ervoor, dat je weer netjes trema's kunt zetten op letters: ë ö ä. Je hebt nu de US toetsenborddefinitie en dan heb je US International met dode toetsen.

Voor je geluidskaart:
installeer eens alsamixergui (gewoon, via Systeem - Beheer - Synaptic pakketbeheer). Zet daarna in alsamixergui eens een paar schuifjes open (niet allemaal tegelijk, en geen enkele voor meer dan 80 %).

Offline tryer

  • Lid
  • Steunpunt: Nee
geluid doet het niet in Xubuntu
« Reactie #5 Gepost op: 2007/06/08, 22:21:59 »
bedankt zover  voor je antwoorden

XMMS player doet het wel, echter de Gxine niet. Wat is een goede mediaplayer, die op alles goed werkt ?

En moet ik nog een driver installeren voor Multimedia audio controller: Intel Corporation 82801AA AC'97 Audio (rev 02)

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
geluid doet het niet in Xubuntu
« Reactie #6 Gepost op: 2007/06/08, 22:37:56 »
Graag gedaan!
Drivers zitten normaliter al in de Linuxkernel ingebakken. Dus gewoonlijk doet alles het meteen. Zo niet, dan wordt het lastig (althans, als het probleem het ontbreken van een driver is). Zeker bij Intel hoef je je geen zorgen te maken, Intel en Linux gaan heel goed samen.

Je hebt nu al geluid? XMMS is een prima spelertje, een kloon van Winamp (veel gebruikt in Windows).

Installeer trouwens gelijk eens wat meer multimedia codecs en zo:
Toepassingen - Installeren/verwijderen (weet zo snel ff niet, waar dat staat in Xubuntu):
zoekterm: mp3
aanvinken:
- vlc
- mplayer
- gstreamer plugins
- ubuntu restricted extra's
- Xine extra plugins

Daarna in Synaptic pakketbeheer de volgende plugins:
zoekterm: vlc
aanvinken: mozilla plugin

zoekterm: mplayer
aanvinken: mozilla plugin

Offline tryer

  • Lid
  • Steunpunt: Nee
geluid doet het niet in Xubuntu
« Reactie #7 Gepost op: 2007/06/08, 22:47:16 »
o.k., ga ik morgen proberen. Deze computer staat op de kamer van mijn dochter. Ze gaat nu naar bed, dus ik ga er nu mee stoppen. Alvast bedankt

Offline tryer

  • Lid
  • Steunpunt: Nee
geluid doet het niet in Xubuntu
« Reactie #8 Gepost op: 2007/06/09, 14:10:34 »
O.k. alle bovenstaande programma's gedownload. Ook gxine doet het nu. Alles opgelost

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
geluid doet het niet in Xubuntu
« Reactie #9 Gepost op: 2007/06/09, 17:14:25 »
Mooi zo!  Graag gedaan.  :-)