Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: dBase IV werkend onder ubuntu  (gelezen 1049 keer)

Offline hadez

  • Lid
  • Steunpunt: Nee
dBase IV werkend onder ubuntu
« Gepost op: 2007/06/08, 00:51:51 »
hallo,

ik wil graag helemaal over naar ubuntu, maar dan wil ik mijn werkzaamheden daar ook op afstemmen. Maar nu is het zo, dat ik een applicatie schrijf welke de database dBase IV gebruikt. Ik schrijf in Multi-Edit, en dat programma krijg ik gelukkig gewoon aan de praat met wine. Alleen de database zelf, en het programma dat ik geschreven heb, krijg ik niet aan de praat.

Citaat
fokke@fokke-desktop:~$ cd /media/sda2/dBase/
fokke@fokke-desktop:/media/sda2/dBase$ wine DBASE.EXE
Xlib:  extension "XFree86-DRI" missing on display ":0.0".
Warning: unprotecting memory to allow real-mode calls.
         NULL pointer accesses will no longer be caught.
fokke@fokke-desktop:/media/sda2/dBase$
Dit is de foutmelding die ik krijg. In de appDB van winehq.org kan ik niets vinden over dBase IV, wel over dBase III (dBase PLus) maar daar heb ik helaas niets aan.

Ik weet niet of dit het goede forum is om dit soort vragen te stellen, maar waar wel? En, als dit wel de goede plek is, hoe krijg ik die DB aan de gang, of wat is het alternatief, welke compatibel is met dBase IV??

mvg,

Hadez

Offline woteb

  • Lid
  • Steunpunt: Nee
dBase IV werkend onder ubuntu
« Reactie #1 Gepost op: 2007/06/08, 07:31:48 »
Een antwoord op jouw problemen heb ik niet, maar u bent hier wel op het goede forum. Dit ter geruststelling.
Laptop, HP 550, Dual Core 1 GB RAM/2 Ghz:: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie) Fluxbox / IceWM / XFCE4 / Openbox / LXDE.
3 Werkstations + 1 laptop: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie Gnome/XFCE/IceWM)
Server: Debian 5.0 Stable (Lenny)

Azalin

  • Gast
dBase IV werkend onder ubuntu
« Reactie #2 Gepost op: 2007/06/08, 08:27:05 »
Citaat van: hadez
hallo,

ik wil graag helemaal over naar ubuntu, maar dan wil ik mijn werkzaamheden daar ook op afstemmen. Maar nu is het zo, dat ik een applicatie schrijf welke de database dBase IV gebruikt. Ik schrijf in Multi-Edit, en dat programma krijg ik gelukkig gewoon aan de praat met wine. Alleen de database zelf, en het programma dat ik geschreven heb, krijg ik niet aan de praat.

Citaat
fokke@fokke-desktop:~$ cd /media/sda2/dBase/
fokke@fokke-desktop:/media/sda2/dBase$ wine DBASE.EXE
Xlib:  extension "XFree86-DRI" missing on display ":0.0".
Warning: unprotecting memory to allow real-mode calls.
         NULL pointer accesses will no longer be caught.
fokke@fokke-desktop:/media/sda2/dBase$
Dit is de foutmelding die ik krijg. In de appDB van winehq.org kan ik niets vinden over dBase IV, wel over dBase III (dBase PLus) maar daar heb ik helaas niets aan.

Ik weet niet of dit het goede forum is om dit soort vragen te stellen, maar waar wel? En, als dit wel de goede plek is, hoe krijg ik die DB aan de gang, of wat is het alternatief, welke compatibel is met dBase IV??

mvg,

Hadez
Misschien de trial van CrossOver Office eens proberen?
http://www.codeweavers.com

Dit is een Wine fork die gespecialiseerd is in het draaien van, ja hoe kan het ook anders, Windows office applicaties onder Linux. Ik heb er bijvoorbeeld Microsoft Access mee aan de praat gekregen. Niet de 2003 maar de XP versie. Misschien dat ditvoor dBase IV ook werkt. Eventueel, ik heb zelf een gekochte CrossOver Office en ben beta tester, kan ik dBase IV wel voor je testen maar het programma heb ik niet. Het zal denk ik niet vrij te krijgen zijn, maar een trial ofzo???

Offline joop13

  • Lid
  • Steunpunt: Nee
dBase IV werkend onder ubuntu
« Reactie #3 Gepost op: 2007/06/08, 13:14:02 »
Heb je iets aan het programma Harbour (in synaptic!). Een compiler om XBase language te compilen?

In welke taal schrijf je je programma? Als dat Clipper is dan is Harbour dé oplossing.
Door gebrek aan visie gaat het volk ten onder, een keur van raadgevers brengt het tot bloei.

Laptop Lenovo Thinkpad T420 met 12.04, Hoofdcomputer 10.04 en nog een veel  jaar ongebruikte W98SE.

Offline vanadium

  • Lid
  • Steunpunt: Nee
dBase IV werkend onder ubuntu
« Reactie #4 Gepost op: 2007/06/08, 18:03:11 »
DBase IV is voor zover ik mij herinner een good old DOS programma. Installeer dosbox eens: ik ben 97% zeker dat dBase IV hier perfect onder zal draaien. Standaard start het op in een venstertje op je Gnome desktop, maar na Ctrl+enter ben je net teruggecatapulteerd in 1986, met een 25 regel text scherm en een C:> dos prompt.